Anzeige:
Ergebnis 1 bis 6 von 6

Thema: [apache2] xmlTextReaderSchemaValidate

  1. #1
    olli2k
    Gast

    [apache2] xmlTextReaderSchemaValidate

    Hallo,

    ich habe dummerweise auf meinem Web Server (Debian Etch) ein wenig mit Lenny Packages rumprobiert. Leider ist bei dem rumprobieren auch ein apt-get upgrade dabei gewesen. War alles kein Thema, nur Spammassasin hat es mir dabei irgendwie zerschossen. Da dadurch der Spam erheblich zugenommen hat, hab ich wieder alle installierten Packages auf Etch zurück gesetzt. Spamassin läuft wieder, aber der Apache nicht mehr:

    apache2: Syntax error on line 116 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/php5.load: Cannot load /usr/lib/apache2/modules/libphp5.so into server: /usr/lib/apache2/modules/libphp5.so: undefined symbol: xmlTextReaderSchemaValidate

    Apache2, PHP5, libxml2 etc alles schon x-fach in diveresen Versionen neuinstalliert, hilft alles nichts. Google hat bisher leider auch nicht weitergeolfen, hier vlt nch einige nützliche Hinweise:

    ldd libphp5.so
    linux-gate.so.1 => (0xffffe000)
    libcrypt.so.1 => /lib/libcrypt.so.1 (0xb7a65000)
    libz.so.1 => /usr/lib/libz.so.1 (0xb7a50000)
    libssl.so.0.9.8 => /usr/lib/i686/cmov/libssl.so.0.9.8 (0xb7a09000)
    libpcre.so.3 => /usr/lib/libpcre.so.3 (0xb79e0000)
    libdb-4.4.so => /usr/lib/libdb-4.4.so (0xb78e5000)
    libbz2.so.1.0 => /lib/libbz2.so.1.0 (0xb78d5000)
    libresolv.so.2 => /lib/libresolv.so.2 (0xb78c2000)
    libm.so.6 => /lib/libm.so.6 (0xb789c000)
    libdl.so.2 => /lib/libdl.so.2 (0xb7897000)
    libnsl.so.1 => /lib/libnsl.so.1 (0xb7880000)
    libgssapi_krb5.so.2 => /usr/lib/libgssapi_krb5.so.2 (0xb7856000)
    libkrb5.so.3 => /usr/lib/libkrb5.so.3 (0xb77c2000)
    libk5crypto.so.3 => /usr/lib/libk5crypto.so.3 (0xb779e000)
    libcom_err.so.2 => /lib/libcom_err.so.2 (0xb779b000)
    libxml2.so.2 => /usr/local/lib/libxml2.so.2 (0xb769f000)
    libc.so.6 => /lib/libc.so.6 (0xb7561000)
    libcrypto.so.0.9.8 => /usr/lib/i686/cmov/libcrypto.so.0.9.8 (0xb740e000)
    /lib/ld-linux.so.2 (0x80000000)
    libkrb5support.so.0 => /usr/lib/libkrb5support.so.0 (0xb7406000)
    libkeyutils.so.1 => /lib/libkeyutils.so.1 (0xb7403000)
    libpthread.so.0 => /lib/libpthread.so.0 (0xb73ea000)
    /usr/lib# nm libxml2.so.2
    nm: libxml2.so.2: no symbols
    Bin für jeden Tipp sehr dankbar.

  2. #2
    Registrierter Benutzer
    Registriert seit
    Dec 2003
    Ort
    Dettenhausen
    Beiträge
    21.209
    schon mal probiert, den Apache zuerst komplett zu löschen (inkl. Konfigs - AFAIK purge) und neu zu installieren?

    "Webserver" und "herumgespielt" - hoffentlich kein Live-Sever in einem RZ?
    Ich bin root - ich darf das.

  3. #3
    olli2k
    Gast
    Zitat Zitat von marce Beitrag anzeigen
    schon mal probiert, den Apache zuerst komplett zu löschen (inkl. Konfigs - AFAIK purge) und neu zu installieren?
    Ich habe mehrfach alles komplett deinstalliert und neu aufgespielt. Das einzige was ich dabei nicht gelöscht ahbe, sind meine Confixx conf Dateien. Gepurgt auch. Nach Reinstall aber der gleiche Fehler.

    [QUOTE="Webserver" und "herumgespielt" - hoffentlich kein Live-Sever in einem RZ?[/QUOTE]

    Leider schon, ist 5 Jahre so gut gegangen, aber jetzt sieht es schlecht aus :/

    meien google bemühungen weisen allerdings bisher auch die libxml2 hin. Hier scheint irgendwas nicht ok zu sein.

    nm: libxml2.so.2: no symbols

    Hier sollte wohl eine ziemlich lange Liste vorhanden sein.

  4. #4
    Registrierter Benutzer
    Registriert seit
    Dec 2003
    Ort
    Dettenhausen
    Beiträge
    21.209
    Da das Mischen von Versionen nie eine gute Idee ist - evtl. einfach, um das System sauber zu bekommen doch mal den guten alten Weg gehen und die Kiste komplett neu aufsetzen...

    Es gibt bestimmt eine andere Lösung - ob die aber dann 100% sauber ist und weniger Zeit beansprucht wage ich mal zu bezweifeln.

    Spielsysteme gehören übrigens nicht ein ein RZ :-)
    Ich bin root - ich darf das.

  5. #5
    olli2k
    Gast
    Neu aufsetzen ist absolut keine Option für mich, da auf dem Webserver nach etlichen Jahren mittlerweile zu große Datenmengen liegen.

  6. #6

Ähnliche Themen

  1. [Apache2] Subdomain
    Von .:DENNIS:. im Forum Linux als Server
    Antworten: 1
    Letzter Beitrag: 09.04.06, 10:27
  2. [Apache2] Zugriff verweigert! was nu?
    Von .:DENNIS:. im Forum Linux als Server
    Antworten: 3
    Letzter Beitrag: 01.04.06, 17:33
  3. [Apache2] .htaccess funzt net!!
    Von .:DENNIS:. im Forum Linux als Server
    Antworten: 6
    Letzter Beitrag: 12.02.06, 22:41
  4. [Apache2] ProxyPass für mod_userdir
    Von ~Gh05t~ im Forum Linux als Server
    Antworten: 8
    Letzter Beitrag: 06.02.06, 17:06
  5. [Apache2] Rewrite Frage zu [P] Flag
    Von michael.sprick im Forum Linux als Server
    Antworten: 1
    Letzter Beitrag: 05.10.05, 13:19

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •