Anzeige:
Ergebnis 1 bis 7 von 7

Thema: OpenSuse42.3 neu installieren

  1. #1
    eddie2 Avatar von eddie2
    Registriert seit
    Jun 2001
    Ort
    Sorg 27
    Beiträge
    174

    Angry OpenSuse42.3 neu installieren

    Hallo,
    Versuche Leap 42.3 zu installieren.
    Musste neues Motherboard wegen Defekt einbauen.
    Will Linux auf 128 GB SSD installieren.
    SSD 256 GB mit Windows 10 habe ich abgesteckt.
    Start der Installation mit DVD:
    Partitionierung:
    1 GB FAT32 für grub-efi formatieren
    107 mit ext4 formatieren für /
    9 GB Swap formatieren
    /home mit 1TB Festplatte habe ich gemounted.
    Nur UEFI im BIOS eingestellt und Netzwerk wollte ich nachher installieren.
    Läuft alles wunderbar durch.
    Danach kommt aber beim Neustart nur Error: not a valid root device
    Was läuft schief?
    Schon mehrmals mal mit Secure-Boot und ohne probiert.
    Vorher hatte ich windows 7 und Leap42.3 schon auf der 128 GB SSD
    Danach die zweite SSD und Windows 10 zugelegt. Windows funktioniert auch einwandfrei!
    Suse-Linux Leap 42.3
    Computer: AMD A10-68000KAPU Processor Radeon HD Graphics
    8GB RAM
    128 GB SSD und 256GB SSD und 1 HDD 1TB, 2 HDD je 500GB, 1DVD-Brenner

  2. #2
    Registrierter Benutzer
    Registriert seit
    Aug 2007
    Ort
    Sauerland
    Beiträge
    915
    Hast du auch in der Installationsübersicht (bevor die eigentliche Installation mit Formatieren beginnt) nachgeschaut, was dort als Bootloader eingestellt ist und welche Partition?

  3. #3
    eddie2 Avatar von eddie2
    Registriert seit
    Jun 2001
    Ort
    Sorg 27
    Beiträge
    174
    Im Systemabschnitt vor dem Formatieren der Festplatte steht:
    Grub2 für EFI
    und in Kernelparameter:
    resume=dev/sda3 splash=silent quiet showopts
    wobei sda3 swap ist
    secureboot ist gesetzt.
    Suse-Linux Leap 42.3
    Computer: AMD A10-68000KAPU Processor Radeon HD Graphics
    8GB RAM
    128 GB SSD und 256GB SSD und 1 HDD 1TB, 2 HDD je 500GB, 1DVD-Brenner

  4. #4
    eddie2 Avatar von eddie2
    Registriert seit
    Jun 2001
    Ort
    Sorg 27
    Beiträge
    174
    Habe jetzt von nur UEFI auf nur Legacy im BIOS umgestellt.
    Jetzt gehts. Mal sehen was kommt.
    Suse-Linux Leap 42.3
    Computer: AMD A10-68000KAPU Processor Radeon HD Graphics
    8GB RAM
    128 GB SSD und 256GB SSD und 1 HDD 1TB, 2 HDD je 500GB, 1DVD-Brenner

  5. #5
    eddie2 Avatar von eddie2
    Registriert seit
    Jun 2001
    Ort
    Sorg 27
    Beiträge
    174
    Wenn ich die Windows-SSD abgesteckt lasse, funktioniert soweit alles.
    Sobald ich sie aber anstecke kann ich zwar durch drücken der F12-Taste mit der Linux SSD ins Startmenü kommen,
    aber egal wie ich starte, uch bekomme schlußendlich nur in der Textkonsole Give Root-Password
    dann kann ich zwar mit startx in Grafik wechseln, aber kann den Bootloader nicht in YAST starten.
    Suse-Linux Leap 42.3
    Computer: AMD A10-68000KAPU Processor Radeon HD Graphics
    8GB RAM
    128 GB SSD und 256GB SSD und 1 HDD 1TB, 2 HDD je 500GB, 1DVD-Brenner

  6. #6
    eddie2 Avatar von eddie2
    Registriert seit
    Jun 2001
    Ort
    Sorg 27
    Beiträge
    174
    Stecke ich die Windows-SSD wieder ab, geht Linux wieder zu starten!!!
    Beim erneuten Anstecken kommt wieder nur Textkonsole und Give root-Password.
    Warum?
    Geändert von eddie2 (06.11.17 um 10:12 Uhr)
    Suse-Linux Leap 42.3
    Computer: AMD A10-68000KAPU Processor Radeon HD Graphics
    8GB RAM
    128 GB SSD und 256GB SSD und 1 HDD 1TB, 2 HDD je 500GB, 1DVD-Brenner

  7. #7
    Registrierter Benutzer
    Registriert seit
    Dec 2003
    Ort
    Dettenhausen
    Beiträge
    20.481
    Vermutlich ändert sich durch die angesteckte Win-SSD der Devicename der Linux-SSD und damit - wenn die Dinger wirklich mit /dev/sdax und so angesprochen werden in fstab, grub.cfg und anderem - findet er das System nicht mehr.

    Du solltest auf UUIDs wechseln - oder eben mal schauen, wie die Devicenamen mit angesteckter Windows-SSD aussehen und alle relevanten Konfig-Files anpassen.
    Ich bin root - ich darf das.

Ähnliche Themen

  1. DVD brennen, Benutzernamen installieren, Programme installieren
    Von scara im Forum System installieren und konfigurieren
    Antworten: 46
    Letzter Beitrag: 11.11.10, 09:27
  2. Linux ohne Tastatur installieren (remote installieren)
    Von xforze im Forum System installieren und konfigurieren
    Antworten: 0
    Letzter Beitrag: 02.12.03, 22:08
  3. KDE installieren
    Von tomachter im Forum Windowmanager
    Antworten: 3
    Letzter Beitrag: 11.08.03, 20:11
  4. Mandrake 9 installieren & SCSI-Treiber beim installieren mitgeben
    Von Tiroler im Forum System installieren und konfigurieren
    Antworten: 4
    Letzter Beitrag: 19.02.03, 16:11
  5. kde 3.0 installieren
    Von leifg im Forum System installieren und konfigurieren
    Antworten: 4
    Letzter Beitrag: 15.02.02, 01:34

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •