Anzeige:
Ergebnis 1 bis 7 von 7

Thema: k3b bricht mit underrun error ab, auch bei CD und 4x Speed

  1. #1
    Registrierter Benutzer
    Registriert seit
    Sep 2006
    Beiträge
    1.121

    Unhappy k3b bricht mit underrun error ab, auch bei CD und 4x Speed

    Ich habe einen USB-Brenner:

    CD-ROM PIONEER BD-RW BDR-TD04A 1.00 PQ: 0 ANSI: 0
    [sr0] scsi3-mmc drive: 62x/62x writer dvd-ram cd/rw xa/form2 cdda tray

    unter Ubuntu 16.04, auf einem neuen PC mit einem i7 6700k, X11SAE und 64 GiB RAM aber Brennversuche werden beendet durch underrun error, auch bei CD und 4x Speed

    Das automatisch von k3b gewählte Temporär-Verzeichnis ist vorhanden und beschreibbar.
    Testweise habe ich k3b auch als root gestartet, aber das gleiche Ergebnis:

    Code:
    Devices
    -----------------------
    PIONEER BD-RW  BDR-TD04A 1.00 (/dev/sr0, CD-R, CD-RW, CD-ROM, DVD-ROM, DVD-R, DVD-RW, DVD-R DL, BD-ROM, BD-R, BD-RE, DVD+R, DVD+RW, DVD+R DL) [DVD-ROM, DVD-R Sequential, DVD-R Dual Layer Sequential, DVD-RAM, DVD-RW Restricted Overwrite, DVD-RW Sequential, DVD+RW, DVD+R, DVD+R Dual Layer, CD-ROM, CD-R, CD-RW, BD-ROM, BD-R Sequential (SRM), BD-R Random (RRM), BD-RE] [SAO, TAO, RAW, SAO/R96P, SAO/R96R, RAW/R16, RAW/R96P, RAW/R96R, Restricted Overwrite, Random Recording, Sequential Recording, Sequential Recording + POW] [%7]
    
    System
    -----------------------
    K3b Version: 2.0.3
    KDE Version: 4.14.16
    QT Version:  4.8.7
    Kernel:      4.6.5-040605-lowlatency
    
    Used versions
    -----------------------
    cdrecord: 1.1.11
    
    cdrecord
    -----------------------
    scsidev: '/dev/sr0'
    devname: '/dev/sr0'
    scsibus: -2 target: -2 lun: -2
    Linux sg driver version: 3.5.27
    Wodim version: 1.1.11
    SCSI buffer size: 64512
    Beginning DMA speed test. Set CDR_NODMATEST environment variable if device
    communication breaks or freezes immediately after that.
    TOC Type: 1 = CD-ROM
    Driveropts: 'burnfree'
    Device type    : Removable CD-ROM
    Version        : 0
    Response Format: 2
    Capabilities   : 
    Vendor_info    : 'PIONEER '
    Identification : 'BD-RW  BDR-TD04A'
    Revision       : '1.00'
    Device seems to be: Generic mmc2 DVD-R/DVD-RW.
    Current: 0x0009 (CD-R)
    Profile: 0x0043 (BD-RE) 
    Profile: 0x0042 (BD-R random recording) 
    Profile: 0x0041 (BD-R sequential recording) 
    Profile: 0x0040 (BD-ROM) 
    Profile: 0x002B (DVD+R/DL) 
    Profile: 0x001A (DVD+RW) 
    Profile: 0x001B (DVD+R) 
    Profile: 0x0015 (DVD-R/DL sequential recording) 
    Profile: 0x0013 (DVD-RW restricted overwrite) 
    Profile: 0x0014 (DVD-RW sequential recording) 
    Profile: 0x0011 (DVD-R sequential recording) 
    Profile: 0x0012 (DVD-RAM) 
    Profile: 0x0002 (Removable disk) 
    Profile: 0x0010 (DVD-ROM) 
    Profile: 0x000A (CD-RW) 
    Profile: 0x0009 (CD-R) (current)
    Profile: 0x0008 (CD-ROM) 
    Profile: 0xFFFF () 
    Using generic SCSI-3/mmc   CD-R/CD-RW driver (mmc_cdr).
    Driver flags   : MMC-3 SWABAUDIO BURNFREE 
    Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R RAW/R16 RAW/R96P RAW/R96R
    Drive buf size : 1206272 = 1178 KB
    FIFO size      : 12582912 = 12288 KB
    resid: 60
    Speed set to 706 KB/s
    Track 01: data   700 MB        
    Total size:      804 MB (79:44.81) = 358861 sectors
    Lout start:      805 MB (79:46/61) = 358861 sectors
    Current Secsize: 2048
    ATIP info from disk:
      Indicated writing power: 5
      Is not unrestricted
      Is not erasable
      Disk sub type: Medium Type B, low Beta category (B-) (4)
      ATIP start of lead in:  -11607 (97:27/18)
      ATIP start of lead out: 359849 (79:59/74)
    Disk type:    Short strategy type (Phthalocyanine or similar)
    Manuf. index: 18
    Manufacturer: Plasmon Data systems Ltd.
    Blocks total: 359849 Blocks current: 359849 Blocks remaining: 988
    Starting to write CD/DVD at speed   4.0 in real SAO mode for single session.
    Last chance to quit, starting real write in    2 seconds.
       1 seconds.
       0 seconds. Operation starts.
    Waiting for reader process to fill input buffer ... resid: 60
    resid: 60
    input buffer ready.
    Performing OPC...
    Sending CUE sheet...
    Errno: 5 (Input/output error), write_g1 scsi sendcmd: no error
    CDB:  2A 00 FF FF FF 6A 00 00 1F 00
    status: 0x2 (CHECK CONDITION)
    Sense Bytes: 70 00 05 00 00 00 00 0E 00 00 00 00 21 02 00 00
    Sense Key: 0x5 Illegal Request, Segment 0
    Sense Code: 0x21 Qual 0x02 (invalid address for write) Fru 0x0
    Sense flags: Blk 0 (not valid) 
    resid: 63488
    cmd finished after 0.001s timeout 200s
    Writing pregap for track 1 at -150
    write track pad data: error after 0 bytes
    BFree: 1114 K BSize: 1178 K
    Starting new track at sector: 0
    Track 01:    0 of  700 MB written.
    Errno: 5 (Input/output error), write_g1 scsi sendcmd: no error
    CDB:  2A 00 00 00 00 00 00 00 1F 00
    status: 0x2 (CHECK CONDITION)
    Sense Bytes: 70 00 05 00 00 00 00 0E 00 00 00 00 21 02 00 00
    Sense Key: 0x5 Illegal Request, Segment 0
    Sense Code: 0x21 Qual 0x02 (invalid address for write) Fru 0x0
    Sense flags: Blk 0 (not valid) 
    resid: 63488
    cmd finished after 0.001s timeout 200s
    /usr/bin/wodim: The current problem looks like a buffer underrun.
    /usr/bin/wodim: It looks like 'driveropts=burnfree' does not work for this drive.
    /usr/bin/wodim: Please report.
    /usr/bin/wodim: Make sure that you are root, enable DMA and check your HW/OS set up.
    write track data: error after 0 bytes
    Writing  time:   15.272s
    Average write speed 952.9x.
    Fixating...
    Errno: 5 (Input/output error), flush cache scsi sendcmd: no error
    CDB:  35 00 00 00 00 00 00 00 00 00
    status: 0x2 (CHECK CONDITION)
    Sense Bytes: 70 00 03 00 00 00 00 0E 00 00 00 00 0C 00 00 00
    Sense Key: 0x3 Medium Error, Segment 0
    Sense Code: 0x0C Qual 0x00 (write error) Fru 0x0
    Sense flags: Blk 0 (not valid) 
    cmd finished after 39.914s timeout 200s
    Trouble flushing the cache
    Fixating time:   40.152s
    /usr/bin/wodim: fifo had 191 puts and 1 gets.
    /usr/bin/wodim: fifo was 0 times empty and 0 times full, min fill was 100%.
    
    cdrecord command:
    -----------------------
    /usr/bin/wodim -v gracetime=2 dev=/dev/sr0 speed=4 -sao driveropts=burnfree -data -tsize=358861s -
    An einer USB3-Buchse funktioniert der Brenner nicht, mit Fehlermeldungen wie:
    scsi 8:0:0:0: rejecting I/O to offline device
    scsi 8:0:0:0: killing request
    can't restore configuration #1 (error=-71)
    can't set config #1, error -71

    Er funktioniert aber ohne solche Fehlermeldungen an USB2-Buchsen.
    Die Hardware ist intakt, zumindest wenn ich den Brenner über USB2 anschließe: Auslesen von DVDs ist problemlos und unter Win7 kann ich DVDs und CDs brennen mit CDBurnerXP.
    Wieso bricht das Brennen mit k3b ab?

  2. #2
    Elefantenversteher Avatar von florian0285
    Registriert seit
    Jun 2016
    Beiträge
    1.054
    Schon alle USB Ports mal durch probiert? BIOS geupdatet? Original USB Kabel vom Hersteller verwendet bzw. kein 1€ Kabel verwendet?
    Matthäus 7:3 Was siehst du aber den Splitter in deines Bruders Auge, und wirst nicht gewahr des Balkens in deinem Auge?

  3. #3
    Registrierter Benutzer
    Registriert seit
    Dec 2003
    Ort
    Dettenhausen
    Beiträge
    21.477
    Google meint bei
    Code:
    /usr/bin/wodim: It looks like 'driveropts=burnfree' does not work for this drive.
    u.a., dass man evtl. mal probieren könnte, statt wodim cdrecord als Backend zu verwenden. Andere meinen, es könnte auch schon reichen, einen anderen Brennmodus zu verwenden.
    Geändert von marce (03.08.16 um 06:47 Uhr)
    Ich bin root - ich darf das.

  4. #4
    Registrierter Benutzer
    Registriert seit
    Sep 2006
    Beiträge
    1.121
    Zitat Zitat von florian0285 Beitrag anzeigen
    Schon alle USB Ports mal durch probiert? BIOS geupdatet? Original USB Kabel vom Hersteller verwendet bzw. kein 1€ Kabel verwendet?
    Ja, mehrere USB3-Ports ohne Erfolg und einen USB2-Port mit.
    Das BIOS ist noch das neueste und ich verwende die originalen Kabel.

  5. #5
    Registrierter Benutzer
    Registriert seit
    Sep 2006
    Beiträge
    1.121
    Zitat Zitat von marce Beitrag anzeigen
    Google meint bei
    Code:
    /usr/bin/wodim: It looks like 'driveropts=burnfree' does not work for this drive.
    u.a., dass man evtl. mal probieren könnte, statt wodim cdrecord als Backend zu verwenden. Andere meinen, es könnte auch schon reichen, einen anderen Brennmodus zu verwenden.
    Das cdrecord kann ich nicht einstellen, denn das
    "Einstellungen -> K3b einrichten -> Erweitert -> Manuelle Auswahl des Brennprogramms"
    ist nicht vorhanden.
    Bei der Suche habe ich mal den Schreibpuffer erhöht auf 12345 MB, denn ich habe noch mehr frei.

  6. #6
    Elefantenversteher Avatar von florian0285
    Registriert seit
    Jun 2016
    Beiträge
    1.054
    Zitat Zitat von Noether Beitrag anzeigen
    Ja, mehrere USB3-Ports ohne Erfolg und einen USB2-Port mit.
    Das BIOS ist noch das neueste und ich verwende die originalen Kabel.
    Manche USB Ports, oft billige, sind intern "schlampig verdrahtet". Ich habe den selben Effekt mit USB TTL Adaptern am Laptop. Bei mir geht da auch nur ein Port.

    Da ein Port funktioniert kannst du dich mit diesem abfinden. Alternativ kannst du auf dem Mainboard nach Erweiterungen für USB suchen oder einen separaten Controller kaufen und betreiben.

    Manchmal können Fehler durch das BIOS oder Treiber kompensiert werden.

    Du kannst alternative LiveCD's mit unterschiedlichen Kernel versionen testen, ob es Änderungen in den Versionen gab.

    Im Zweifelsfall nen Bugreport erstellen.

    Funktionieren denn alle Ports unter Windows?
    Matthäus 7:3 Was siehst du aber den Splitter in deines Bruders Auge, und wirst nicht gewahr des Balkens in deinem Auge?

  7. #7
    Registrierter Benutzer
    Registriert seit
    Sep 2006
    Beiträge
    1.121
    Das USB an meinem X11SAE war bisher problemlos, aber seit dem Update auf Kernel 4.6.5 sind die beiden Buchsen mit USB 3.1 tot, denn auch ein neuer USB3-Stick wird an keiner Buchse erkannt und auch sonst wird da nichts mehr erkannt!
    Weder lsblk noch lsusb zeigen an den 3.1er Buchsen irgendetwas, auch wenn das an Buchsen mit 2 oder 3.0 problemlos läuft.

    An USB2 funktionierte der externe Brenner, aber nicht immer, wegen Problemen wie "Cannot enable. Maybe the USB cable is bad?" vom Kernel.

    Deshalb habe ich gewechselt, das Slimline-Laufwerk aus der USB-Box per Schiebeschalter ausgeworfen und angeschlossen an das Mainboard per eSATApd (http://www.delock.de/produkte/G_61797/merkmale.html, http://www.delock.de/produkte/S_84402/merkmale.html), mit einem Adapter zu dem smallSATA vom Slimline-Laufwerk und darauf das nackte Laufwerk gesteckt.

    Das funktioniert nun, aber nicht als User, weil mir urplötzlich die Rechte fehlten, nach 50 gebrannten MB, siehe Anhang.

    Also habe ich, nach xhost +, als Root gestartet und das lief endlich problemlos durch, mit zu 99 bis 100 % gefülltem Puffer.

    Also das USB ist ziemlich marode, weiterhin nur eine Notlösung für besseres wie eSATApd, mit dem ich noch nie Probleme hatte.

    Übrigens habe ich auch versucht statt Wodim das Cdrecord zu installieren, nach
    http://linuxg.net/how-to-install-cdr...ative-systems/
    aber das funktionierte nicht, wohl weil das Repository zu alt ist für Ubuntu 16.04.
    Angehängte Grafiken Angehängte Grafiken
    Geändert von Noether (03.08.16 um 21:27 Uhr)

Ähnliche Themen

  1. Ubuntu: Grub bricht ab Error 16
    Von STEVMASTER im Forum System installieren und konfigurieren
    Antworten: 0
    Letzter Beitrag: 21.11.05, 21:18
  2. Pine bricht um - Ich brech auch gleich...
    Von sellem im Forum Anwendungen Allgemein, Software
    Antworten: 5
    Letzter Beitrag: 25.08.05, 14:08
  3. Highspeed CD-RW auch beschreibbar von low speed writer?
    Von Mr.Nobody im Forum Anwendungen Allgemein, Software
    Antworten: 2
    Letzter Beitrag: 28.01.03, 22:33
  4. Gentoo-1.3b bootstrap bricht mit make-Error ab
    Von Ypsilon im Forum Kompilieren von Kernel und Sourcen
    Antworten: 10
    Letzter Beitrag: 23.07.02, 10:13
  5. Brennvorgang bricht ab mit Input/output error
    Von heikoG im Forum stationäre Hardware
    Antworten: 3
    Letzter Beitrag: 05.04.02, 11:51

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •