Anzeige:
Ergebnis 1 bis 15 von 15

Thema: wine f. R.H 9.0

  1. #1
    Der nicht weiß was er tut
    Registriert seit
    Jan 2003
    Beiträge
    173

    wine f. R.H 9.0

    hallo,
    welche wine version soll ich für r.h. 9.0 verwenden von diesen:
    http://www.winehq.com/site/download

    r.h. 9.0 verfügt über eine glibc-2.3

    passt diese version von wine für r.h. 9.0 ?
    http://prdownloads.sourceforge.net/w...6.rpm?download
    lG AUTHacker

  2. #2
    Mod. FAQ/Howto/Emulation
    Registriert seit
    Sep 2000
    Beiträge
    17.344
    Im Dateinamen steht doch rh9, also sollte es klappen. Probiers einfach aus, kaputtmachen kannst du nichts damit.

  3. #3
    The AngeL
    Gast
    Also die aktuelleste Version von Wine ist die 20030709 (YYMMDD) und ich kann bestätigen, dass sie ohne Probleme auf RH9 läuft. Du findest sie wie immer standartmässig auf WineHQ .

    Einfach runterladen compilieren und dann testen. Ich persönlich bin endlich mal damti zufrieden, denn seitdem RH9 mit dem glibc 2.3 draussen ist hat Wine erst nach zwei Updates korrekt auf RH9 gearbeitet.

  4. #4
    Der nicht weiß was er tut
    Registriert seit
    Jan 2003
    Beiträge
    173
    hallo,

    system: R.H. 9.0

    ich hab mir von winehq die aktuellste version (20030709) gesaugt und wollte die nun installieren.
    aber ich erhalte immer folgede fehlermeldung:

    [michaelh@localhost wine-20030709]$ ./tools/wineinstall
    WINE Installer v0.74

    Running configure...

    ./configure: line 88: conf4660.sh: No such file or directory
    ./configure: line 89: conf4660.sh: No such file or directory
    chmod: failed to get attributes of `conf4660.sh': No such file or directory
    ./configure: line 201: conf4660.file: No such file or directory
    ./configure: line 949: config.log: No such file or directory

    Configure failed, aborting install.
    [michaelh@localhost wine-20030709]$

    was ist da falsch ?

    ich habs auch schon so probiert:

    [michaelh@localhost wine-20030709]$ ./configure
    ./configure: line 88: conf4762.sh: No such file or directory
    ./configure: line 89: conf4762.sh: No such file or directory
    chmod: failed to get attributes of `conf4762.sh': No such file or directory
    ./configure: line 201: conf4762.file: No such file or directory
    ./configure: line 949: config.log: No such file or directory
    [michaelh@localhost wine-20030709]$

    aber auch leider ohne ergebnis ?

    any ideas ?
    lG AUTHacker

  5. #5
    Der nicht weiß was er tut
    Registriert seit
    Jan 2003
    Beiträge
    173

    lösung:

    eh klar - wieder mal zu früh "FEUER" geschriehen *ggg*

    wenn man nicht ROOT ist, dann schauts schlecht mit dem sourcen compilen aus ;-)

    trotzdem danke !

    ääähhh nochwas !
    was ist das nun schon wieder für ein fehler:

    [root@localhost wine-20030709]# wine --version
    wine: lstat /tmp/.wine-root/server-303-23fc7/socket : No such file or directory
    [root@localhost wine-20030709]#


    hieeelffeeee
    Geändert von AUTHacker (12.08.03 um 11:28 Uhr)
    lG AUTHacker

  6. #6
    The AngeL
    Gast

    Re: lösung:

    Original geschrieben von AUTHacker
    eh klar - wieder mal zu früh "FEUER" geschriehen *ggg*

    wenn man nicht ROOT ist, dann schauts schlecht mit dem sourcen compilen aus ;-)

    trotzdem danke !

    ääähhh nochwas !
    was ist das nun schon wieder für ein fehler:

    [root@localhost wine-20030709]# wine --version
    wine: lstat /tmp/.wine-root/server-303-23fc7/socket : No such file or directory
    [root@localhost wine-20030709]#


    hieeelffeeee
    Ich bin gerade net zu Hause, aber wenn ich heute Abend ankomme werde ich es mir mal anschauen.

  7. #7
    Der nicht weiß was er tut
    Registriert seit
    Jan 2003
    Beiträge
    173

    super

    hi,
    das wär der hammer wenn du das machen könntest !
    wär nämlich echt wichtig da ich das prob auf meinem firmen-pc hab :-(

    danke !!!
    lG AUTHacker

  8. #8
    Registrierter Benutzer
    Registriert seit
    Mar 2002
    Beiträge
    1.648

    Re: lösung:

    Original geschrieben von AUTHacker
    [root@localhost wine-20030709]# wine --version
    wine: lstat /tmp/.wine-root/server-303-23fc7/socket : No such file or directory
    [root@localhost wine-20030709]
    Da du RHL 9 benutzt, musst du beim ./configure noch die Option --with-nptl angeben.

  9. #9
    Der nicht weiß was er tut
    Registriert seit
    Jan 2003
    Beiträge
    173

    oje

    wenn ich

    "./configure --with-nptl"

    mache, kommt folgede fehlermeldung:

    *** Warning: X development files not found. Wine will be built without
    *** X support, which currently does not work, and would probably not be
    *** what you want anyway. You will need to install devel packages of
    *** Xlib/Xfree86 at the very least.

    Configure finished. Do 'make depend && make' to compile Wine.

    frage: wo kann ich die devel packages of Xlib/Xfree86 finden und wie installieren ?
    lG AUTHacker

  10. #10
    The AngeL
    Gast

    Re: oje

    Original geschrieben von AUTHacker
    wenn ich

    "./configure --with-nptl"

    mache, kommt folgede fehlermeldung:

    *** Warning: X development files not found. Wine will be built without
    *** X support, which currently does not work, and would probably not be
    *** what you want anyway. You will need to install devel packages of
    *** Xlib/Xfree86 at the very least.

    Configure finished. Do 'make depend && make' to compile Wine.

    frage: wo kann ich die devel packages of Xlib/Xfree86 finden und wie installieren ?
    Sorry wollte mich gestern melden, aber ich habe zur Zeit wegen Projektrelease vor Ende des Monats zuviel zu tun.

    Am schnellsten kannst du dir die Devel Packages mit apt-get und Synaptic Oberfläche holen. Wenn du die zum compilieren willst schau im FTP oder CVS des XFree86.org Projekts.

  11. #11
    Der nicht weiß was er tut
    Registriert seit
    Jan 2003
    Beiträge
    173

    PROBLEM GELÖST !

    hallo,
    danke nochmals für eure hilfe. den rest hab ich nun eh allein geschafft.

    system: r.h. 9.0

    XFree86-devel-4.3.0-2.i386.rpm

    runtergeladen.
    die hat dann nach den paketen:

    fontconfig-devel-2.1-9.i386.rpm
    freetype-devel-2.1.3-6.i386.rpm

    verlangt welche sich alle problemlos installieren ließen.
    dannach hab ich dann die XFree86-devel-4.3.0-2.i386.rpm installiert.

    compiliert hab ich dann fehlerfrei mit:

    ./configure --with-nptl
    make depend
    make

    installation dann mit:

    make install.

    das wars dann - hab es gleich mit "wine notepad.exe" getestet und hat auch gefunkt ohne dass
    ich in der config datei was ändern musste.,

    nochmals danke !
    Geändert von AUTHacker (09.09.03 um 13:40 Uhr)
    lG AUTHacker

  12. #12
    Mitglied Avatar von spooner
    Registriert seit
    May 2003
    Ort
    Cottbus
    Beiträge
    47
    Hallo!

    Da ich auch so meine Probleme mit wine habe, war ich erfreut, diese Beschreibungen hier zu lesen. Ich hab auch gleich alles genauso ausprobeirt, und es ging NICHT. ich bin bis zum Schritt 'MAKE' gekommen. Nachdem er schon eine halbe Ewigkeit compiled hat, trat plötzlich ein Fehler auf:

    winetest.c:158: 'my-perl' undeclared (first use in this function)
    : (Each undeclared identifier is reported only once for each function
    : it appears in)
    warning: passing arg 3 of 'Perl-newXS' from incompatible pointer type

    Ich glaube zwar nicht, daß mir jemand auf solch eine Fehlerbeschreibung viel antworten kann, aber vielleicht hat ja jemand ein ähnliches Problem gehabt.
    (Achja, ich habe auch R.H. 9 und wine-20030709 verwendet.)

    Tschüß, Spooner

  13. #13
    Der nicht weiß was er tut
    Registriert seit
    Jan 2003
    Beiträge
    173
    hmm,
    da kann ich jetzt nur mal eine mutmaßung anstellen:
    hast du perl installiert ?
    lG AUTHacker

  14. #14
    Mitglied Avatar von spooner
    Registriert seit
    May 2003
    Ort
    Cottbus
    Beiträge
    47
    Ja, das war auch meine erste Idee, aber es ist perl-5.8.0-88 installiert. Auch das Perl-CPAN -Paket. Ich weiß zwar nicht, ob es nötig ist, aber ich hab alles installiert, was irgendwie mit Perl zu tun hat.
    System: AMD 3000+, 1,5 GB DDR-RAM
    nVidia GeForce 7600 GT 512 MB DDR (PCI-e)
    Gentoo 2.6.26-gentoo, KDE 3.5)

  15. #15
    Der nicht weiß was er tut
    Registriert seit
    Jan 2003
    Beiträge
    173
    also ich hab unter R.H.9

    folgende perl-packages installiert:

    perl-Parse-Yapp-1.05-30
    perl-libxml-perl-0.07-28
    perl-XML-Grove-0.46alpha-25
    perl-5.8.0-88
    perl-DateManip-5.40-30
    perl-HTML-Parser-3.26-17
    perl-URI-1.21-7
    perl-XML-Parser-2.31-15
    perl-XML-Dumper-0.4-25
    perl-libxml-enno-1.02-29
    perl-XML-Twig-3.09-3
    perl-Filter-1.29-3
    perl-HTML-Tagset-3.03-28
    perl-libwww-perl-5.65-6
    perl-XML-Encoding-1.01-23
    perl-CPAN-1.61-88

    vielleicht hilft dir ja ein vergleich weiter.
    lG AUTHacker

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •