Anzeige:
Ergebnis 1 bis 4 von 4

Thema: Installationsprobleme mit APT

  1. #1
    Registrierter Benutzer
    Registriert seit
    Dec 2002
    Ort
    karlsruhe
    Beiträge
    33

    Installationsprobleme mit APT

    ich habe ein problem mit der installation von endeavour2.
    statt der installation des erforderlichen pakets gibt mir apt nach einem apt-get install endeavour2 nur ein
    Code:

    Reading Package Lists... Done
    Building Dependency Tree... Done
    You might want to run `apt-get -f install' to correct these:
    Sorry, but the following packages have unmet dependencies:
    openoffice.org-bin: Depends: openoffice.org (>= 1.0.2-pre1.0.3) but it is not going to be installed
    openoffice.org-debian-files: Depends: openoffice.org (>= 1.0.2-pre1.0.3) but it is not going to be installed
    openoffice.org-l10n-en: Depends: openoffice.org (>= 1.0.2-pre1.0.3) but it is not going to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

    aus.
    auch ein apt-get -f install schafft hier keinerlei abhilfe, sondern gibt lediglich ein
    Code:

    dpkg: error processing /var/cache/apt/archives/openoffice.org_1.0.3-2_all.deb (--unpack):
    trying to overwrite `/usr/share/icons/locolor/16x16/apps/001_star_butterfly.xpm', which is also in package openoffice-de-en
    dpkg-deb: subprocess paste killed by signal (Broken pipe)
    Errors were encountered while processing:
    /var/cache/apt/archives/openoffice.org_1.0.3-2_all.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    von sich

    mein naechster installations-versuch beinhaltete ein --fix-missing, mit dem selben ergebnis wie bisher.
    eine resynchronisation meines paket-index ueber apt-get update war die in meinen augen letzte option um dem problem der installation auf den leib zu ruecken, der fehler besteht aber auch hiernach noch immer.

    (ich nutze uebrigends ein unstable/testing auf einem 2.4.20er kernel).

    dpkg -l "openoffice.org*" zeigt mir die erforderlichen pakete als in der richtigen version installiert:
    Code:

    in openoffice.org 1.0.3-2 (no description available)
    iU openoffice.org-bin 1.0.3-2 OpenOffice.org office suite binary files
    iU openoffice.org-debian-files 1.0.3-2+1 Debian specific parts of OpenOffice.org package
    iU openoffice.org-l10n-en 1.0.3-2 English (US) language package for openoffice.org


    ein apt-cache policy openoffice.org spuckt (zu meiner verwunderung) ein
    Code:

    openoffice.org:
    Installed: (none)
    Candidate: 1.0.3-2
    Version Table:
    1.0.3-2 0
    990 http://ftp.de.debian.org testing/contrib Packages
    500 http://ftp.de.debian.org unstable/contrib Packages
    1.0.3-2 0
    100 /var/lib/dpkg/status

    aus, der versuch das paket per apt-get install openoffice.org nachzuinstallieren endet mit einem
    Code:

    root@blabla:/home/blabla# apt-get remove openoffice.org-l10n-en openoffice.org-debian-files
    dpkg: error processing /var/cache/apt/archives/openoffice.org_1.0.3-2_all.deb (--unpack):
    trying to overwrite `/usr/share/icons/locolor/16x16/apps/001_star_butterfly.xpm', which is also in package openoffice-de-en
    dpkg-deb: subprocess paste killed by signal (Broken pipe)
    Errors were encountered while processing:
    /var/cache/apt/archives/openoffice.org_1.0.3-2_all.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    der apt-cache show output hierfuer lautet
    Code:

    Package: openoffice.org
    Status: install ok not-installed
    Priority: optional
    Section: contrib/editors
    Version: 1.0.3-2

    ich habe nun versucht, mein fehlerhaftes openoffice zu deinstallieren, doch auch das ist nicht moeglich:
    Code:

    Reading Package Lists... Done
    Building Dependency Tree... Done
    You might want to run `apt-get -f install' to correct these:
    Sorry, but the following packages have unmet dependencies:
    openoffice.org-bin: Depends: openoffice.org (>= 1.0.2-pre1.0.3) but it is not going to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
    [/code[
    ich habe mir nun noch einmal die manuals von apt durchgelesen, bin aber nicht dahintergekommen, was ich nun fuer optionen habe, dieses inkorrekte install ueber apt loszuwerden oder zu reparieren, auch der versuch, statt der englischen die openoffice.org-l10n-de zu installieren half nicht.

    HILFE!!! ich bin verzweifelt

    liebe gruesse,

    p.
    ...Was hab' ich hier für'n Wort erfunden ( NICHTNULLHAUPTDIAGONALELEMENT ), ...UM GOTTES WILLEN !!!...

  2. #2
    mit Glied Avatar von Rebell
    Registriert seit
    Jul 2002
    Ort
    Dresden
    Beiträge
    719
    Versuch mal ein "apt-get remove --purge openoffice*" Oder ein "dpkg -P openoffice.org".
    Ich denke du hast ein altes Office mit einem neuem Überschreiben wollen, dabei beinhalten 2 Pakete ein und diesselbe Datei. Du musst es also vorher deinstallieren, damit solche Konflikte nicht auftreten. Danach kannst du ein nochmaliges "apt-get -f install" machen und dann siehst du was er alles noch brauch. Wenn ein Paket "not going to be installed" ist, dann darf es aus irgendeinem Grund nicht installiert werden. Entweder existiert es nicht, oder deine Programme würden mit diesem Paket nichtmehr laufen.
    come to daddy, windowlicker!
    M:ke 5.1 - http://www.get-mike.de

  3. #3
    Registrierter Benutzer
    Registriert seit
    Oct 1999
    Ort
    Kiel
    Beiträge
    1.796
    Hi

    bevor du openoffice ganz raus schmeisst
    versuch mal

    dpkg --purge openoffice-de-en
    apt-get upgrade
    apt-get install openoffice.org-l10n-de
    und dann

    apt-get -s install endeavour2

    (-s) damit du dir nicht gleich die paketabhängigkeiten zerschiesst
    wenns keine fehlermeldungen gibt, das (-s ) weglassen

    so sollte zumindest mit sid gehen


    gruss
    christoph

  4. #4
    Registrierter Benutzer
    Registriert seit
    Dec 2002
    Ort
    karlsruhe
    Beiträge
    33
    hah!
    ein dpkg -i --force-overwrite /var/cache/apt/archives/openoffice.org_1.0.3-2_all.deb && apt-get -f install
    konnte das problem letztendlich loesen.
    danke fuer eure hilfe, wieder ein klein wenig weiser geworden :)

    liebe gruesse,

    p.
    ...Was hab' ich hier für'n Wort erfunden ( NICHTNULLHAUPTDIAGONALELEMENT ), ...UM GOTTES WILLEN !!!...

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •