Anzeige:
Ergebnis 1 bis 4 von 4

Thema: [Gentoo] libc.so.6 nicht gefunden

  1. #1
    Ayreonaut Avatar von Sayonara
    Registriert seit
    Jul 2002
    Ort
    irgendwo im Oberberg
    Beiträge
    1.051

    [Gentoo] libc.so.6 nicht gefunden

    Bei der Installation von IntelliJ IDEA bekomm ich folgene Fehler:
    Code:
    ./idea-3.0.1v2.bin
    Preparing to install...
    Extracting the JRE from the installer archive...
    Unpacking the JRE...
    Extracting the installation resources from the installer archive...
    Configuring the installer for this system's environment...
    dirname: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
    /bin/ls: error while loading shared libraries: librt.so.1: cannot open shared object file: No such file or directory
    basename: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
    dirname: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
    basename: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
    hostname: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
    
    Launching installer...
    
    rm: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
    rm: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
    Unter /usr/lib/ existiert eine libc.so.5. Wenn ich eine Link mit Namen libc.so.6 auf diese erstelle, verändern sich die Fehler in:
    Code:
    ./idea-3.0.1v2.bin
    Preparing to install...
    Extracting the JRE from the installer archive...
    Unpacking the JRE...
    Extracting the installation resources from the installer archive...
    Configuring the installer for this system's environment...
    dirname: /usr/lib/libc.so.6: no version information available (required by dirname)
    dirname: /usr/lib/libc.so.6: no version information available (required by dirname)
    dirname: /usr/lib/libc.so.6: no version information available (required by dirname)
    dirname: /usr/lib/libc.so.6: no version information available (required by dirname)
    dirname: /usr/lib/libc.so.6: no version information available (required by dirname)
    Inconsistency detected by ld.so: do-lookup.h: 115: do_lookup_versioned: Assertion `version->filename == ((void *)0) || ! _dl_name_match_p (version->filename, map)' failed!
    /bin/ls: error while loading shared libraries: librt.so.1: cannot open shared object file: No such file or directory
    basename: /usr/lib/libc.so.6: no version information available (required by basename)
    basename: /usr/lib/libc.so.6: no version information available (required by basename)
    basename: /usr/lib/libc.so.6: no version information available (required by basename)
    basename: /usr/lib/libc.so.6: no version information available (required by basename)
    basename: /usr/lib/libc.so.6: no version information available (required by basename)
    Inconsistency detected by ld.so: do-lookup.h: 115: do_lookup_versioned: Assertion `version->filename == ((void *)0) || ! _dl_name_match_p (version->filename, map)' failed!
    dirname: /usr/lib/libc.so.6: no version information available (required by dirname)
    dirname: /usr/lib/libc.so.6: no version information available (required by dirname)
    dirname: /usr/lib/libc.so.6: no version information available (required by dirname)
    dirname: /usr/lib/libc.so.6: no version information available (required by dirname)
    dirname: /usr/lib/libc.so.6: no version information available (required by dirname)
    Inconsistency detected by ld.so: do-lookup.h: 115: do_lookup_versioned: Assertion `version->filename == ((void *)0) || ! _dl_name_match_p (version->filename, map)' failed!
    basename: /usr/lib/libc.so.6: no version information available (required by basename)
    basename: /usr/lib/libc.so.6: no version information available (required by basename)
    basename: /usr/lib/libc.so.6: no version information available (required by basename)
    basename: /usr/lib/libc.so.6: no version information available (required by basename)
    basename: /usr/lib/libc.so.6: no version information available (required by basename)
    Inconsistency detected by ld.so: do-lookup.h: 115: do_lookup_versioned: Assertion `version->filename == ((void *)0) || ! _dl_name_match_p (version->filename, map)' failed!
    hostname: /usr/lib/libc.so.6: no version information available (required by hostname)
    hostname: /usr/lib/libc.so.6: no version information available (required by hostname)
    Inconsistency detected by ld.so: do-lookup.h: 115: do_lookup_versioned: Assertion `version->filename == ((void *)0) || ! _dl_name_match_p (version->filename, map)' failed!
    
    Launching installer...
    
    rm: /usr/lib/libc.so.6: no version information available (required by rm)
    rm: /usr/lib/libc.so.6: no version information available (required by rm)
    rm: /usr/lib/libc.so.6: no version information available (required by rm)
    rm: /usr/lib/libc.so.6: no version information available (required by rm)
    rm: /usr/lib/libc.so.6: no version information available (required by rm)
    Inconsistency detected by ld.so: do-lookup.h: 115: do_lookup_versioned: Assertion `version->filename == ((void *)0) || ! _dl_name_match_p (version->filename, map)' failed!
    rm: /usr/lib/libc.so.6: no version information available (required by rm)
    rm: /usr/lib/libc.so.6: no version information available (required by rm)
    rm: /usr/lib/libc.so.6: no version information available (required by rm)
    rm: /usr/lib/libc.so.6: no version information available (required by rm)
    rm: /usr/lib/libc.so.6: no version information available (required by rm)
    Inconsistency detected by ld.so: do-lookup.h: 115: do_lookup_versioned: Assertion `version->filename == ((void *)0) || ! _dl_name_match_p (version->filename, map)' failed!
    Das Problem ist mir leider nicht neu. Auch mit anderen vorkompierten Binaries hab ich dieses Problem gehabt. Weiß jemand, was hier fehlt oder gemacht werden muss, damit es funktioniert?
    Desktop: OpenSUSE 13.2 x86_64 mit KDE
    Laptop: Acer Aspire E1-572G Powered by openSUSE

  2. #2
    Registrierter Benutzer
    Registriert seit
    Jan 2003
    Beiträge
    32
    hey genau das gleiche Problem habe ich auch, mir hat man gesagt das man es einfach nicht mit Suse 8.1 installieren könnte, aber das reicht mir leider nicht.

    Hat jemand eine andere Lösung?

  3. #3
    Bombenleger Avatar von spirou
    Registriert seit
    Mar 2002
    Ort
    Landshut
    Beiträge
    283
    Die Umstellung auf den gcc-3.x in den diversen Distributionen ist schuld. Die vorcompilierten Binaries sind nicht mit den Libraries des gcc-3.x kompatibel, weil sie mit dem gcc-2.9x erstellt wurden. Da hilft nur neucompilieren oder abwarten, bis der Hersteller eine Binary für gcc-3.x rausbringt.
    Wenn beides nicht möglich ist --> Tonne.

    Grüßle
    Spirou
    Ich mache keine Vorhersagen und werde das niemals tun.

  4. #4
    Linux Versteher
    Registriert seit
    Dec 2001
    Ort
    Wuppertal
    Beiträge
    352
    ich hatte das prob auch.
    ich werde mir heute die nötigen libs selber
    erstellen und schauen ob ich damit
    ein ergebnis bekomme.

    mfg SirAbdul
    Mein System:

    Athlon XP 2400+
    ASUS A7V600-X
    1024 MB DDR RAM
    GeForce 6600 GT (AGP)
    SB Live 5.1 Digital
    D-Link DFE 530 TX
    Debian testing (Kernel: 2.6.11-1-k7)
    KDE 3.3.2

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •