Anzeige:
Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 15 von 18

Thema: Unable to mount root fs on 3:01

Hybrid-Darstellung

Vorheriger Beitrag Vorheriger Beitrag   Nächster Beitrag Nächster Beitrag
  1. #1
    mit Glied Avatar von Rebell
    Registriert seit
    Jul 2002
    Ort
    Dresden
    Beiträge
    719

    Unable to mount root fs on 3:01

    Hallo Leute....

    Ich weiß es ist Freitag und der Tag ist kurz, aber ihr müsst mir unbedingt helfen, ich komme einfach nicht weiter, ich bin schon fast am Verzweifeln und appeliere daher an euer Wissen.

    Fakten:
    1. Ich habe einen Pentium 568 133Mhz 32MB RAM mit Debian 2.2.20 und ext2 auf 4GB
    2. Soll ein Router werden
    3. Hab nen eigenen 2.4.18 Kernel (optimiert)

    Probleme:
    1. Von Debian mitgelieferte 2.4-Kernel laufen nicht
    2. Bleiben ALLE hängen
    3. Unter anderem der eigene Kernel mit folgender Meldung:

    Code:
    hda: driver not present
    VFS: cannot open root device "301" or 03:01
    Please append a correct "root=" boot option
    Kernel panic: VFS: unable to mount root fs on 03:01
    Weitere Fakten:
    1. Die Boot Option ist korrekt (lilo.conf)
    2. Ext2 und IDE-HDD ist im Kernel eingebunden
    3. Der 2.2.20 Kernel bootet problemlos
    come to daddy, windowlicker!
    M:ke 5.1 - http://www.get-mike.de

  2. #2
    Registrierter Benutzer
    Registriert seit
    Jun 2002
    Beiträge
    517
    ich hab ja echt keine ahnung von kernel basteln und so, aber es wird doch wohl im internet zu hauf vorkompilierte kernels geben. einer wird scho passe.

  3. #3
    12te
    Registriert seit
    Dec 2001
    Beiträge
    1.377
    bleiben alle 2.4er mit der gleichen Meldung hängen ? Was ist das für ein IDE-Controller ?
    pornstars-online.de

  4. #4
    mit Glied Avatar von Rebell
    Registriert seit
    Jul 2002
    Ort
    Dresden
    Beiträge
    719
    Ich habe herrausgefunden dass es an einem initrd-Eintrag liegt den ich in der lilo.conf angeben musste.
    initrd=/boot/initrd

    Diese initrd hab ich vorher mit mk_initrd (Suse) erstellt.
    Bei Debian war der Befehl mkinitrd /etc/. Wobei man noch angeben muss dass in eine Datei geschrieben wird.

    Danach gings
    come to daddy, windowlicker!
    M:ke 5.1 - http://www.get-mike.de

  5. #5
    Registrierter Benutzer
    Registriert seit
    Feb 2002
    Ort
    Krefeld
    Beiträge
    425
    Hallo

    Habe das gleich problem wie du.

    Ich habe herrausgefunden dass es an einem initrd-Eintrag liegt den ich in der lilo.conf angeben musste.
    initrd=/boot/initrd

    Diese initrd hab ich vorher mit mk_initrd (Suse) erstellt.
    Bei Debian war der Befehl mkinitrd /etc/. Wobei man noch angeben muss dass in eine Datei geschrieben wird.


    Was ich aber nicht recht verstehe ist

    Wobei man noch angeben muss dass in eine Datei geschrieben wird. ?

    Wenn ich mkinitrd /etc/ eingebe kommt :
    Code:
    Options:
    -d confdir Specify an alternative configuration directory.
    -k Keep temporary directory used to make the image.
    -m command Set the command to make an initrd image.
    -o outfile Write to outfile.
    -r root Override ROOT setting in mkinitrd.conf


    Leider komme ich hir nicht weiter ?

    Gruß,
    Lockslay
    Geändert von Lockslay (12.06.03 um 16:10 Uhr)

  6. #6
    Registrierter Benutzer Avatar von HirschHeisseIch
    Registriert seit
    Nov 2002
    Beiträge
    3.276
    mkinitrd -o /boot/initrd.img

    -o outfile Write to outfile.
    steht doch da, oder ich hab da was falsch verstanden..
    RTFM you have to, young padawan.

  7. #7
    Registrierter Benutzer
    Registriert seit
    Feb 2002
    Ort
    Krefeld
    Beiträge
    425
    Hallo

    ich muss noch einmal nerven.

    Ich habe mkinitrd -o /boot/initrd.img-2.4.18-k7 ausgeführt.
    Dann habe ich die lilio.conf erweitert mit initrd=/boot/initrd.img-2.4.18-k7

    das system neu gestartet und ich bekomme die Meldung:

    modprobe _Can´t open dependencies file /lib/modules/2.4.18-k7/modules. dep (No such file directory)

    Was habe ich hier falsch gemacht ??

    Gruß,
    Lockslay

  8. #8
    Registrierter Benutzer Avatar von HirschHeisseIch
    Registriert seit
    Nov 2002
    Beiträge
    3.276
    Der findet die Module net... Hast du beim Kernel-Backen vielleicht vergessen make dep auszuführen??
    RTFM you have to, young padawan.

  9. #9
    Registrierter Benutzer
    Registriert seit
    Feb 2002
    Ort
    Krefeld
    Beiträge
    425
    Hallo

    Da ich den Kernel nicht selber gebacken habe, sondern mit apt-get installiert habe , habe ich kein
    make dep ausgeführt ??
    Was kann ich jetzt noch mache ?

    Gruß

    Lockslay

  10. #10
    mit Glied Avatar von Rebell
    Registriert seit
    Jul 2002
    Ort
    Dresden
    Beiträge
    719
    Das Kernel-Image läuft normalerweise sofort, esseidenn du hast vergessen lilo auszuführen damit der neue Kernel aktiv wird. Mein Problem damals war, dass ich vergessen habe das Dateisystemim Kernel unterzubringen. Ich hatte es als Modul kompiliert, was ja Schwachsinn ist wenn er das Kernel-Verzeichnis nicht lesen kann, da er das Dateisystem nicht versteht.
    come to daddy, windowlicker!
    M:ke 5.1 - http://www.get-mike.de

  11. #11
    OpenGurke Avatar von Thomas Mitzkat
    Registriert seit
    Mar 2002
    Ort
    Weimarer Republik
    Beiträge
    4.028
    mögliche fehlerquellen:
    1. das filesystem auf dem "/" läuft, ist nicht im initrd vorhanden.
    2. /etc/lilo.conf stimmt nicht.

    bitte mal /etc/lilo.conf und /etc/fstab posten.
    Deutschland ist die Kanne für alle Tassen dieser Welt

  12. #12
    Registrierter Benutzer Avatar von HirschHeisseIch
    Registriert seit
    Nov 2002
    Beiträge
    3.276
    @Lockslay
    Linke mal die initrd nach initrd.img und binde diesen link in lilo ein. Macht debian glaub ich standardmässig auch so. Kann mich da an was erinnern, dass er bei solchen namen die erweiterung hinter dem - als 'uname' nimmt.
    RTFM you have to, young padawan.

  13. #13
    Registrierter Benutzer
    Registriert seit
    Feb 2002
    Ort
    Krefeld
    Beiträge
    425
    Hallo

    hier meine fstab

    Code:
    # /etc/fstab: static file system information.
    #
    # <file system>	<mount point>	<type>	<options>		<dump>	<pass>
    /dev/hda1	/		ext2	errors=remount-ro	0	1
    /dev/hda5	none		swap	sw			0	0
    /dev/hdc1       /edonkey        ext2    errors=remount-ro       0       1
    /dev/hdd1       /daten          ext2    errors=remount-ro       0       1
    proc		/proc		proc	defaults		0	0
    /dev/fd0	/floppy		auto	user,noauto		0	0
    /dev/cdrom	/cdrom		iso9660	ro,user,noauto		0	0
    hir ein teil meiner meiner lili.conf

    Code:
    image=/vmlinuz
    label=Linux
    initrd=/boot/initrd.img-2.4.18-k7
    read-only
    # restricted
    # alias=1
    Wie gesagt der Neue Kernel läuft.
    Aber ich habe kein Netzwerk mehr.
    Dachte das es eine modconf fehler ist.
    Da komme ich aber z.Z auch nicht weiter.

    Gruß,

    Lockslay

  14. #14
    OpenGurke Avatar von Thomas Mitzkat
    Registriert seit
    Mar 2002
    Ort
    Weimarer Republik
    Beiträge
    4.028
    bitte korrigieren:
    Code:
    image=/vmlinuz
    label=Linux
    initrd=/boot/initrd.img-2.4.18-k7
    read-only
    root=/dev/hda1
    # restricted
    # alias=1
    lilo ausführen. wo ist denn das initrd her? wurde das zum kernel passend erstellet?
    Deutschland ist die Kanne für alle Tassen dieser Welt

  15. #15
    Registrierter Benutzer
    Registriert seit
    Feb 2002
    Ort
    Krefeld
    Beiträge
    425
    Hallo

    der initrd wurde von mir in die lilo.conf eingefügt.
    Werde deinen Vorschlag einmal testen.

    Gruß,
    Stefan

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •