Anzeige:
Ergebnis 1 bis 2 von 2

Thema: Umlaute im Terminal - cmp gibt keine aus

  1. #1
    Registrierter Benutzer
    Registriert seit
    Jul 2008
    Beiträge
    146

    cmp (byteweiser Vergleich) gibt keine Umlaute im Terminal aus

    Hallo
    in jedem Terminal (Ubuntu, MacOS, Termux) das ich bisher probierte, gibt der Befehl cmp (byteweises Vergleichen von zwei Strings) keine Umlaute aus.
    Ich versuche zB das:
    Code:
    $ cmp -bl <(echo -n 'AOU') <(echo -n 'ÄÖÜ')
                      1 101 A    303 M-C
                      2 117 O    204 M-^D
                      3 125 U    303 M-C
    cmp: EOF on /proc/self/fd/63 after byte 3
    also der Vergleich von AOU mit ÄÖÜ und anstatten der Umlaute auf der rechten Seite kommt da "M-C" (Ä) oder "M-^D" (Ö) oder wieder "M-C" (Ü) raus (im Mac Terminal sogar nur ? anstatten der M-D).
    Ich habe versucht mit:
    Code:
    export LANG="de_DE.UTF-8"
    UTF-8 im Terminal zu setzen, aber das scheint nicht die Ursache zu sein, das ändert nichts (hab ich in meiner .bashrc o.ä. glaube ich auch schon drin).

    Gibt es eine Möglichkeit, dass cmp mir Umlaute ausgibt?
    Danke für Tipps. franc
    Geändert von franc (10.04.24 um 18:57 Uhr)

  2. #2
    Registrierter Benutzer
    Registriert seit
    Dec 2003
    Ort
    Dettenhausen
    Beiträge
    22.067
    Wenn man sich https://git.savannah.gnu.org/cgit/di...tree/src/cmp.c anschaut - gar nicht.
    Ich bin root - ich darf das.

Ähnliche Themen

  1. Gibt es von gparted auch eine Terminal-Version mit GUI.
    Von luminox im Forum Anwendungen Allgemein, Software
    Antworten: 4
    Letzter Beitrag: 19.06.15, 17:24
  2. Verhunzte Umlaute im Terminal und MC trotz UTF-8?
    Von minze im Forum System installieren und konfigurieren
    Antworten: 4
    Letzter Beitrag: 03.07.07, 08:56
  3. Keine Umlaute mehr im KDE
    Von Diablo im Forum Windowmanager
    Antworten: 16
    Letzter Beitrag: 31.12.06, 10:44
  4. Keine Umlaute in Eterm
    Von DrunkenFreak im Forum Anwendungen Allgemein, Software
    Antworten: 2
    Letzter Beitrag: 17.06.04, 22:29
  5. Keine Umlaute & nur noch ein tty
    Von DrunkenFreak im Forum System installieren und konfigurieren
    Antworten: 5
    Letzter Beitrag: 25.04.04, 15:54

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •