Anzeige:
Ergebnis 1 bis 7 von 7

Thema: Virtualbox - Daten durcheinander gekommen

  1. #1
    ruestiger Rentner Avatar von pibi
    Registriert seit
    Jul 2002
    Ort
    Winterthur (CH)
    Beiträge
    2.678

    Virtualbox - Daten durcheinander gekommen

    Hoi zaeme

    Der Titel ist nicht ganz richtig, aber mir fiel nix besseres ein;-)

    Worum geht es? Ich habe hier mehrere VirtualBoxen fuer diverse Arbeiten. Basis ist Linux "xfce", als Gast laeuft dann Windows10. Sicherheitshalber ziehe ich von jeder Arbeit nach jeder signifikanten Aenderung eine Kopie als Backup auf mein Synology. Bei einer Arbeit ist mir leider ein kleines Missgeschick passiert, das ich anfangs gar nicht bemerkt hatte.

    Wenn besagtes Synology ausgeschaltet ist, erscheint beim Start (ganz normal, ohne Start aus dem Sleep-Mode) folgende Fehlermeldung:
    Code:
    Could not open the medium '/misc/syno-vol1/Backup-Virtual-Machines/Stage1/VirtualBox/Win10/Win10-Pers-Programs/Snapshots/{2bba1a43-2e02-41d4-af8c-76b56339c562}.vdi'.
    
    VD: error VERR_FILE_NOT_FOUND opening image file '/misc/syno-vol1/Backup-Virtual-Machines/Stage1/VirtualBox/Win10/Win10-Pers-Programs/Snapshots/{2bba1a43-2e02-41d4-af8c-76b56339c562}.vdi' (VERR_FILE_NOT_FOUND).
    Und sobald das Synology wieder am Netz ist, bootet die VM problemlos. Ich habe schon probiert, die beiden Snapshot-Files (Original und Backup, sind ja menschen-lesbar) mit "vimdiff" zu vergleichen, aber hier habe ich meiner Meinung nach nix nichts brauchbares gefunden. Hat jemand eine Idee, wie ich das System wieder "normal" hinbekomme?

    Gruesse aus Winti
    Pit.


    Warum will er nun auf dieses File, welches auf dem Backup liegt, zugreifen? Ich will wohlgemerkt die VM aus meinen Arbeitsdaten starten. Und ja, der Fehler liegt ganz klar bei mir und ja, es war etwas spaet an diesem Abend...

    Wie bringe ich diese VBox wieder normal zum Laufen? Hat jemand eine Idee?
    div. Hardware:
    Server openSuSI 15.1 / Laptops und Workstations openSuSI 15.2 und 15.3
    Fritzbox 7940, Synology DS418

  2. #2
    ruestiger Rentner Avatar von pibi
    Registriert seit
    Jul 2002
    Ort
    Winterthur (CH)
    Beiträge
    2.678
    Bitte im Moment nichts antworten, ich probiere noch etwas aus....
    div. Hardware:
    Server openSuSI 15.1 / Laptops und Workstations openSuSI 15.2 und 15.3
    Fritzbox 7940, Synology DS418

  3. #3
    ruestiger Rentner Avatar von pibi
    Registriert seit
    Jul 2002
    Ort
    Winterthur (CH)
    Beiträge
    2.678
    Hoi zaeme!

    Sorry, aber ich hatte vorher einen alten Kollegen an der Strippe. Da ich sowieso Backups speichere, gab er mir den Tip, einfach alles von der Arbeitsversion auf die Backupversion zu kopieren. Gesagt, getan. Leider ist das Ergebnis enttaeuschend, denn das Ergebnis und die Fehlermeldung sind nach wie vor identisch. Fuer mich sieht es nun so aus, dass in der Arbeitsversion falsche Daten gespeichert sind bzw. identische Daten in einem anderen Directory vorhanden sind.

    Weitere Ideen?

    Gruss Pit.
    div. Hardware:
    Server openSuSI 15.1 / Laptops und Workstations openSuSI 15.2 und 15.3
    Fritzbox 7940, Synology DS418

  4. #4
    Registrierter Benutzer
    Registriert seit
    Aug 2007
    Ort
    Sauerland
    Beiträge
    1.617
    Was ist in der Maschine als Festplattenabbild eingebunden?

    Leap15.2 - Einstellungen_001.jpg

  5. #5
    ruestiger Rentner Avatar von pibi
    Registriert seit
    Jul 2002
    Ort
    Winterthur (CH)
    Beiträge
    2.678
    Hoi Sauerland1

    Bingo, Volltreffer! Ich kann Dir jetzt leider keinen Screenshot von mir uebermitteln, weil ich schlichweg nicht weiss, wie man das hier macht. Daher als Prosa:

    - der Controller ist SATA
    - zwei VDIs sind angeschlossen
    - Win10-Pers-Programs.vdi
    - Win10-Pers-Programs-disk1.vdi

    Und beide zeigen in der Location auf "/misc/syno-vol1/Backup-Virtual-Machines/Stage1/VirtualBox/Win10/Win10-Pers-Programs/Win10-Pers-Programs.vdi". Das "/misc/syno....." usw. gehoert hier nicht hin. Es muesste
    Code:
    /VirtualMachines/VirtualBox/Win10/Win10-Pers-Standard-Template/Win10-Pers-Standard-Template.vdi
    sein. Wie kann ich das korrigieren?

    Vielen herzlichen Dank einstweilen und Gruss
    Pit.
    div. Hardware:
    Server openSuSI 15.1 / Laptops und Workstations openSuSI 15.2 und 15.3
    Fritzbox 7940, Synology DS418

  6. #6
    Registrierter Benutzer
    Registriert seit
    Aug 2007
    Ort
    Sauerland
    Beiträge
    1.617
    oben rechts auf das CD Bild klicken----virtuelle Festplatte auswählen/erzeugen

  7. #7
    ruestiger Rentner Avatar von pibi
    Registriert seit
    Jul 2002
    Ort
    Winterthur (CH)
    Beiträge
    2.678
    Hoi Sauerland1

    Vielen herzlichen Dank fuer Deine Mail. Ich schaetze Dein Know-How und Deine Tips und Hilfestellungen sehr. Allerdings scheint mir, dass Du manchmal etwas sehr kurz angebunden Dein Wissen preis gibst, wahrscheinlich auch noch proportional zur Anzahl Postings, die der- oder diejenige Frager/in hier abgesetzt hat.

    Fuer meine Anfrage in #5 habe ich zB. fast den halben Nachmittag rumgedoktert und ausprobiert und es schliesslich geschafft. Wie gesagt, alles from Scratch und komplett bei Null angefangen. Da ich nichts falsch machen wollte, dauerte eben alles etwas laenger. Meine letzte VBox-Definition habe ich naemlich vor etwa fuenf bis sechs Jahren gemacht und dementsprechend war mein Kenntnisstand. Ich hatte ja Zeit, war also fast kein Problem:-)

    Da ich gerne vor Weihnachten fertig waere und es sicherlich einen schnelleren Weg als mein Try&Error gibt, wuerde ich mich freuen, wenn Du mir hier nochmals ein paar Tips geben koenntest. Also einfach #1 mit angepassten Pfaden etc. So etwas muss es doch geben, oder?

    Gruesse aus Winti
    Pit.
    div. Hardware:
    Server openSuSI 15.1 / Laptops und Workstations openSuSI 15.2 und 15.3
    Fritzbox 7940, Synology DS418

Ähnliche Themen

  1. Wie seid Ihr überhaupt an Linux gekommen?
    Von Bullerjan im Forum Linux Allgemein
    Antworten: 64
    Letzter Beitrag: 18.06.09, 16:32
  2. Wie seid ihr zu Linuxforen gekommen?
    Von Flusswaechter im Forum Meldungen und Mitglieder
    Antworten: 93
    Letzter Beitrag: 15.01.05, 21:09
  3. wie sind wir zu den vielen user gekommen??
    Von ??Linux im Forum Meldungen und Mitglieder
    Antworten: 27
    Letzter Beitrag: 07.11.04, 01:58
  4. Wie seit ihr zu linux gekommen ?
    Von theborg im Forum Meldungen und Mitglieder
    Antworten: 23
    Letzter Beitrag: 05.11.03, 14:10
  5. So weit ist es schon gekommen :(
    Von majobu im Forum Meldungen und Mitglieder
    Antworten: 1
    Letzter Beitrag: 25.10.02, 08:38

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •