Anzeige:
Ergebnis 1 bis 4 von 4

Thema: Anbindung Cloud-Speicher per davfs sehr langsam

  1. #1
    Registrierter Benutzer Avatar von michel_vaclav
    Registriert seit
    Jan 2003
    Ort
    daheim
    Beiträge
    1.031

    Anbindung Cloud-Speicher per davfs sehr langsam

    Hallo,

    ich habe ein Speicherpaket von IONOS per davfs in mein lokales Dateisystem eingebunden.
    Genauer: openSUSE 15.4, Eintrag in der fstab (mountet den Speicher nach /tmp/ionos (ein entsprechender "secrets"-Eintrag mit Kennung und Passwort ist auch angelegt).
    Beim Boot des Systems ist das übergeordnete IONOS-Verzeichnis in /tmp verfügbar.
    Da auf dem Speicher eine Verzeichnisstruktur angelegt ist, habe ich über symbolische Links Unterverzeichnisse des Cloud-Speichers in mein Home-Verzeichnis gelegt. Das funktioniert auch alles.

    Aber: sobald ich anfange Dateien zu kopieren (von und in die Cloud) friert das System weitestgehend ein. Erst wenn die Lese-bzw. Schreibvorgänge beendet sind, ist das System wieder benutzbar (ich beobachte den Datenverkehr auf der Fritzbox).

    Klar: meine Bandbreite ist mit 50Mbit/s und einem Upload von 12Mbit/s nicht überragend. Aber muss da gleich das ganze System blockiert sein?
    Frage: Gibt es Tuning-Stellschrauben, mit denen man das System etwas geschmeidiger bekommt?

    Falls die Info nötig ist: ich benutze KDE und als Dateimanager den Dolphin.

    Danke für Tipps

    michel_vaclav
    Visit me at fehrmich.spdns.de

  2. #2
    Registrierter Benutzer
    Registriert seit
    Apr 2009
    Ort
    Erde
    Beiträge
    2.718
    Zum einen kannst du das Debugging aktivieren und dann im Log prüfen was da so lange braucht
    Kurze Suche zum Thema ergibt, das PROPFIND ein mögliche Ursache ist - gui_optimize 1
    Außerdem soll es helfen, das Locking zu deaktivieren - use_locks 0

    sa https://linux.die.net/man/5/davfs2.conf
    Geändert von nopes (19.12.22 um 16:13 Uhr)
    Gruß nopes
    (,,,)---(^.^)---(,,,) /var/log/messages | grep cat

  3. #3
    Registrierter Benutzer Avatar von michel_vaclav
    Registriert seit
    Jan 2003
    Ort
    daheim
    Beiträge
    1.031
    Danke, ich bin der Sache dann etwas mehr auf die Schliche gekommen. In einem der Verzeichnisse liegen mehrere 100MB große Backups. Offensichtlich lädt davfs zunächst jede Datei einmal runter (sieht man im Cache immer größer werden), bis sie vollständig geladen wurde, um sie danach gleich wieder zu löschen. Für mich als Laien sieht es so aus, als ob da erst eine "Datenbank" aufgebaut werden muss.
    Hoffe bloß, dass dieser Index nicht bei jedem Neustart neu erstellt werden muss. Das macht bei 250GB keinen Spaß.

    Nachtrag: offensichtlich ist das eine Endlosschleife. Denn kaum ist das Indizieren einmal erledigt und man wechselt im Dolphin in ein anderes Unterverzeichnis, beginnt der Spaß von Neuem. irgendwie muss ich dem System abgewöhnen, irgend was zu cachen... (keine Ahnung, ob das eine gute Idee ist.).
    Geändert von michel_vaclav (19.12.22 um 18:27 Uhr)
    Visit me at fehrmich.spdns.de

  4. #4
    Registrierter Benutzer
    Registriert seit
    Apr 2009
    Ort
    Erde
    Beiträge
    2.718
    Evt hilft es im Dolphin die Vorschau (oder wie es da auch heißen mag) zu deaktiveren.
    Gruß nopes
    (,,,)---(^.^)---(,,,) /var/log/messages | grep cat

Ähnliche Themen

  1. Jedes lightweight Distro läuft nach der installation sehr sehr langsam.
    Von sisqonrw im Forum System installieren und konfigurieren
    Antworten: 6
    Letzter Beitrag: 23.08.22, 17:44
  2. Cloud Speicher mit verschlüsseltem Loop File
    Von stevienowonder im Forum System installieren und konfigurieren
    Antworten: 16
    Letzter Beitrag: 11.06.20, 23:05
  3. Cloud-Speicher: davfs2 verhält sich unfreundich, was tun?
    Von Vyvyan im Forum Anbindung an die Aussenwelt
    Antworten: 1
    Letzter Beitrag: 09.11.14, 17:42
  4. Cloud Computing, oder aber Thin-Clients in der Internet Cloud
    Von ICWOnline im Forum Meldungen und Mitglieder
    Antworten: 3
    Letzter Beitrag: 20.05.13, 13:18
  5. Speedport W501V Lan sehr langsam, ping sehr hoch
    Von BLiSS im Forum Router und Netzaufbau
    Antworten: 3
    Letzter Beitrag: 04.02.08, 21:27

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •