Anzeige:
Ergebnis 1 bis 5 von 5

Thema: Samba Server ignoriert die "max log size" in der smb.conf

  1. #1
    Registrierter Benutzer
    Registriert seit
    Jul 2014
    Beiträge
    7

    Samba Server ignoriert die "max log size" in der smb.conf

    Hallo zusammen,

    wie schon im Titel beschrieben, ignoriert mein Samba Server (openSUSE Leap 15.2) die "max log size", so dass es dazu kommt,
    dass mehrere Logfiles unter /var/log/samba mehrere GB groß sind.


    Die max log size ist auf 2000 festgelegt, was meines Wissens ja ca. 2 MB sein sollten.

    Zum Testen hatte ich das "log level" von 2 auf 1 gesetzt und anschließend die Konfiguration mit
    smbcontrol smbd reload-config neu eingelesen.
    Das hat funktioniert bzw. der Inhalt der Logdateien hat sich nach dem reload deutlich verringert.

    Ich konnte im Netz bisher keine Lösung finden, die das Problem behebt.
    Vielleicht hatte ja von euch schonmal jemand dasselbe Problem oder eine Ahnung, warum das nicht funzt.

    Anbei noch die global Konfig des Samba Servers:


    [global]
    workgroup = ARBEITSGRUPPE
    netbios aliases = xxx
    server string = xxx
    interfaces = 192.168.0.2/255.255.224.0
    map to guest = Bad User
    log level = 2
    log file = /var/log/samba/log.%m
    max log size = 2000
    time server = Yes
    keepalive = 30
    load printers = No
    logon script = %U.bat
    domain logons = Yes
    os level = 2
    domain master = No
    lanman auth = Yes
    ntlm auth = Yes
    min protocol = NT1
    wins support = Yes
    ldap ssl = no


    Schomal vielen Dank

    Schöne Grüße

    Tommy

  2. #2
    kleine schwester von root Avatar von corresponder
    Registriert seit
    May 2002
    Ort
    192.67.198.56
    Beiträge
    4.440
    setz mal ein

    Code:
    testparm
    ab, dann motzt er über nicht mehr vorhandene Optionen...
    _______________________________________

    www.audio4linux.de - musik machen mit offenen quellen!

  3. #3
    Registrierter Benutzer
    Registriert seit
    Jul 2014
    Beiträge
    7
    Hallo corresponder,

    schon mal danke für deine schnelle Antwort.

    Hier die Ausgabe von testparm:

    Load smb config files from /etc/samba/smb.conf
    WARNING: The "lanman auth" option is deprecated
    WARNING: The "blocking locks" option is deprecated
    Loaded services file OK.
    idmap range not specified for domain '*'
    ERROR: Invalid idmap range for domain *!

    Server role: ROLE_DOMAIN_BDC

  4. #4
    kleine schwester von root Avatar von corresponder
    Registriert seit
    May 2002
    Ort
    192.67.198.56
    Beiträge
    4.440
    max log size = 2000
    scheint zu stimmen, wie gross ist denn das log?
    _______________________________________

    www.audio4linux.de - musik machen mit offenen quellen!

  5. #5
    Registrierter Benutzer
    Registriert seit
    Jul 2014
    Beiträge
    7
    Insgesamt, also das Samba Log Verzeichnis aktuell 80GB

    Wobei ein Log von nem Rechner 20GB hat, danach wirds entsprechend weniger, aber die meisten Logfiles sind weit über der eigentlichen
    2MB Grenze.

Ähnliche Themen

  1. Samba ignoriert "create mode" und "directory mode"
    Von hartkorn im Forum Linux in heterogenen Netzen
    Antworten: 11
    Letzter Beitrag: 12.06.12, 20:23
  2. SAMBA & "create mask" bzw. "create mode" wird ignoriert.
    Von TBVAndy im Forum Linux in heterogenen Netzen
    Antworten: 2
    Letzter Beitrag: 04.04.08, 09:10
  3. Antworten: 3
    Letzter Beitrag: 28.08.07, 10:49
  4. "Displaysize" aus xorg.conf wird ignoriert
    Von Basti_litho im Forum Mobiles Linux, Notebook, PDA
    Antworten: 1
    Letzter Beitrag: 26.03.07, 23:50
  5. Antworten: 0
    Letzter Beitrag: 15.03.06, 00:04

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •