Anzeige:
Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 15 von 26

Thema: adduser: /etc/passwd konnte nicht geöffnet werden.

  1. #1
    Registrierter Benutzer
    Registriert seit
    Nov 2021
    Beiträge
    13

    adduser: /etc/passwd konnte nicht geöffnet werden.

    Hallo zusammen ,

    ich hoffe mir kann einer weiterhelfen! Bin noch neu in Linux und kenn mich noch nicht so aus, bitte um Nachsicht .

    Ich habe das Problem das ich unter CentOs8 keinen neuen Benutzer anlegen kann.
    Ich bin als root angemeldet. Setze den Befehl adduser BENUTZER ab, als Rückmeldung auf der Konsole bekomme ich adduser: /etc/passwd konnte nicht geöffnet werden. .

    Was mache ich falsch? Wenn weitere Informationen benötigt werden kann ich diese auch gerne zur Verfügung stellen...

    Liebe Grüße
    PS: Danke schonmal

  2. #2
    Registrierter Benutzer
    Registriert seit
    Dec 2003
    Ort
    Dettenhausen
    Beiträge
    21.809
    Für's Protokoll: https://www.linux-community.de/frage...werden-centos/

    /etc/passwd ist vorhanden? Und eine Datei (kein Link auf was auch immer...)? Ebenso group und shaddow? Welche user-Database ist konfiguriert?
    Ich bin root - ich darf das.

  3. #3
    Registrierter Benutzer
    Registriert seit
    Nov 2021
    Beiträge
    13
    Hallo marce,

    danke für die schnelle Rückmeldung.

    ja die Datei /etc/passwd ist vorhanden.
    Eine Datei /etc/passwd- ist auch vorhanden.
    Eine Datei /etc/group und /etc/group- ist auch vorhanden.
    Eine Datei /etc/shadow und /etc/shadow- ist auch vorhanden.

    Was meinst du mit user-Database?


    Liebe Grüße

  4. #4
    Registrierter Benutzer
    Registriert seit
    Dec 2003
    Ort
    Dettenhausen
    Beiträge
    21.809
    Zitat Zitat von MAX_AEP Beitrag anzeigen
    Was meinst du mit user-Database?
    lokale User vs. LDAP vs. NIS, ...

    Ansonsten - versuch useradd anstatt adduser - dieses Wrapper-Script-drumherum verhaspelt sich manchmal...
    Ich bin root - ich darf das.

  5. #5
    Registrierter Benutzer
    Registriert seit
    Nov 2021
    Beiträge
    13
    User-Database ist lokal.

    Habe beide Befehlsvarianten versucht, laufen beide in den gleichen Fehler...

    Kann es an der pwd.lock Datei liegen?

  6. #6
    Registrierter Benutzer
    Registriert seit
    Dec 2003
    Ort
    Dettenhausen
    Beiträge
    21.809
    wenn die Vorhanden ist würde das das Verhalten durchaus erklären können - wobei dann die Frage wäre, wo die denn her kommt...
    Ich bin root - ich darf das.

  7. #7
    Registrierter Benutzer
    Registriert seit
    Nov 2021
    Beiträge
    13
    Wie kann ich rausfinden wo die her kommt?
    Geändert von MAX_AEP (25.11.21 um 12:40 Uhr)

  8. #8
    kleine schwester von root Avatar von corresponder
    Registriert seit
    May 2002
    Ort
    192.67.198.56
    Beiträge
    4.387
    ...wo die her kommt...

    - abgebrochener Anlegeversuch eines Benutzers
    - vielleicht übers Gui?

    würde die löschen / umbenennen, dann funktioniert es wieder...
    _______________________________________

    www.audio4linux.de - musik machen mit offenen quellen!

  9. #9
    Registrierter Benutzer
    Registriert seit
    Nov 2021
    Beiträge
    13
    Die Datei habe ich gelöscht, kann trotzdem keinen User anlegen.

  10. #10
    Registrierter Benutzer
    Registriert seit
    Dec 2003
    Ort
    Dettenhausen
    Beiträge
    21.809
    welche Datei hast Du genau gelöscht? Welchen Befehl gibst Du genau ein? Was ist die exakte Rückmeldung des Systems?
    Ich bin root - ich darf das.

  11. #11
    Registrierter Benutzer
    Registriert seit
    Nov 2021
    Beiträge
    13
    Folgenden Befehl hab ich eingegeben:
    rm /etc/.pwd.lock

    Danach hat er mich nach einer Bestätigung gebeten (y), habe ich getan, danach konnte ich die Datei mit: ls -la | grep pw nicht mehr finden..
    Nach diesem Schritt habe ich wieder versucht einen User hinzuzufügen mit: adduser (Benutzer) bzw. useradd (benutzer)
    Bei beiden Versuchen die Meldung: useradd: /etc/passwd konnte nicht geöffnet werden.
    adduser: /etc/passwd konnte nicht geöffnet werden.

  12. #12
    Registrierter Benutzer
    Registriert seit
    Dec 2003
    Ort
    Dettenhausen
    Beiträge
    21.809
    wir reden über eine klassische CentOS-Installation auf ded. Hardware oder in einer VM?

    Was sagt
    Code:
    ls -la /etc/{passwd,group,shadow}
    Ich bin root - ich darf das.

  13. #13
    Registrierter Benutzer
    Registriert seit
    Nov 2021
    Beiträge
    13
    Läuft als VM.

    -rw-r--r--. 1 root root 719 26. Mai 2021 /etc/group
    -rw-r--r--. 1 root root 1591 8. Dez 2020 /etc/passwd
    ----------. 1 root root 1071 7. Dez 2020 /etc/shadow

  14. #14
    Registrierter Benutzer
    Registriert seit
    Aug 2007
    Ort
    Sauerland
    Beiträge
    1.487
    Poste einfach einmal die komplette!!! Eingabezeile incl. der kompletten Ausgabe hier in Code-Tags.

  15. #15
    Registrierter Benutzer
    Registriert seit
    Nov 2021
    Beiträge
    13
    Hi sauerland,
    das kann ich erst morgen tun, bin im homeoffice und kann mich per putty nicht auch die maschine schalten, sonst hätte ich alles per copy/paste gepostet... Muss mich mit der Webkonsole zufrieden geben.

    lsla.PNG

Ähnliche Themen

  1. Plugin JPEG konnte nicht geöffnet werden
    Von Drkmit7 im Forum Anwendungen Allgemein, Software
    Antworten: 4
    Letzter Beitrag: 28.12.14, 12:37
  2. Gnome: Bilddatei konnte nicht geöffnet werden
    Von audience im Forum Windowmanager
    Antworten: 4
    Letzter Beitrag: 28.04.07, 15:49
  3. Antworten: 0
    Letzter Beitrag: 15.01.07, 13:59
  4. Manche mp3´s werden nicht mit xmms geöffnet
    Von Mr. Wolfenstein im Forum Musik
    Antworten: 5
    Letzter Beitrag: 12.02.05, 21:48
  5. Modemgeräte können nicht geöffnet werden
    Von realemu im Forum Anbindung an die Aussenwelt
    Antworten: 6
    Letzter Beitrag: 13.03.04, 13:33

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •