Anzeige:
Ergebnis 1 bis 3 von 3

Thema: Anadonde :: Python updaten - und VSCode etc ....

Baum-Darstellung

Vorheriger Beitrag Vorheriger Beitrag   Nächster Beitrag Nächster Beitrag
  1. #1
    Registrierter Benutzer
    Registriert seit
    Apr 2016
    Beiträge
    238

    Anadonda :: Python updaten - und VSCode etc ....

    Hallo und guten Morgen,


    ich hab auf MX-Linux Anaconda am Start:

    nun denke ich dass ich alles mal auf den allerneuesten Stand bringen will - das sollte über die Kommandozeile wohl gehen.


    conda-base Python 3.7.6

    Python 3.7.6 (default, Jan 8 2020, 19:59:22)
    Type "copyright", "credits" or "license" for more information.

    IPython 7.12.0 -- An enhanced Interactive Python.

    Spyder 4.0.1
    The Scientific Python Development Environment | Spyder-IDE.org
    Copyright © 2009-2019 Spyder Project Contributors and others.
    Distributed under the terms of the MIT License.
    Python 3.7.6 64-bit | Qt 5.9.6 | PyQt5 5.9.2 | Linux 4.19.0-6-amd64


    VSCode 1.56.2



    ich denke dass ich hier erstmal Python auf den neuesten Stand bringen sollte. Das kann man alles über die Kommandozeile erledigen.



    “update python cmd”


    Code:
    python -m pip install pip.
    python -m pip install –upgrade pip.
    python -m pip install --upgrade pip.



    Anm.; ich hab zwar kein Ubuntusystem hier - aber hier hab ich noch eine weiter Moeglichkeit entdeckt - offenslichtlich für Ubuntu gedacht;

    https://stackoverflow.com/questions/...version-to-3-8



    Step 1: First install the Ubuntu software properties package if it’s not already installed on your system.

    Code:
    $ sudo apt update
    
    $ sudo apt install software-properties-common
    Step 2: After that run the commands to add the PPA.

    Code:
    $ sudo add-apt-repository ppa:deadsnakes/ppa
    Step 3: Finally, run below to install Python 3.8

    Code:
    $ sudo apt update
    $ sudo apt install python3.8
    You can check as below:

    Code:
    $ python3 --version
    Zumindest der erste Ansatz - also der pip-basierte - sollte einfach laufen?

    Code:
    $ python -m pip install pip
    Requirement already satisfied: pip in ./anaconda3/lib/python3.7/site-packages (20.0.2)
    (base) martin@mx:~
    $ python -m pip install –upgrade pip
    ERROR: Invalid requirement: '–upgrade'
    (base) martin@mx:~
    $ python -m pip install --upgrade pip
    Collecting pip
      Downloading pip-21.1.1-py3-none-any.whl (1.5 MB)
         |████████████████████████████████| 1.5 MB 439 kB/s 
    Installing collected packages: pip
      Attempting uninstall: pip
        Found existing installation: pip 20.0.2
        Uninstalling pip-20.0.2:
          Successfully uninstalled pip-20.0.2
    Successfully installed pip-21.1.1
    (base) martin@mx:~
    $

    diese Methode - die hab ich auch noch entdeckt:

    https://levelup.gitconnected.com/a-g...9-44ccb3eae31a

    In LINUX, you may use the following commands:

    Code:
    $ sudo add-apt-repository ppa:deadsnakes/ppa
    $ sudo apt update
    $ sudo apt install python3.9
    Then, you can check your new and existing Python installation version as commands below:

    Ein sudo apt update ergibt hier folgendes:


    Code:
    (base) root@mx:/home/martin# sudo apt update
    OK:1 http://deb.debian.org/debian buster-updates InRelease
    OK:2 http://deb.debian.org/debian buster InRelease                                                 
    OK:3 http://deb.debian.org/debian-security buster/updates InRelease                                
    OK:4 http://dl.google.com/linux/chrome/deb stable InRelease                                        
    OK:5 http://ftp.halifax.rwth-aachen.de/mxlinux/packages/mx/repo buster InRelease                   
    0% [Verbunden mit packagecloud.io (54.183.38.243)] [Warten auf Kopfzeilen] [Verbunden mit packages.
    OK:6 https://packages.microsoft.com/repos/vscode stable InRelease                                  
    Ign:7 http://repo.vivaldi.com/stable/deb stable InRelease                                          
    OK:8 http://repo.vivaldi.com/stable/deb stable Release                    
    OK:9 https://packagecloud.io/AtomEditor/atom/any any InRelease
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut.       
    Statusinformationen werden eingelesen.... Fertig
    Alle Pakete sind aktuell.
    (base) root@mx:/home/martin# 
    (base) root@mx:/home/martin#
    Geändert von diver (16.05.21 um 07:14 Uhr)
    Tools für Wordpress-Entwicklung http://wpgear.org/

Ähnliche Themen

  1. VSCode: Pip installer und die Einrichtung der Umgebung: ( /venv )
    Von diver im Forum Anwendungen Allgemein, Software
    Antworten: 0
    Letzter Beitrag: 10.02.21, 23:14
  2. Linux Server Problem! | MC Overviewer | Python usw. Updaten!
    Von schneidi im Forum Linux als Server
    Antworten: 4
    Letzter Beitrag: 07.11.11, 16:08
  3. SUCHE: fuse python bindings für python 2.4 und Suse 10
    Von skurial im Forum System installieren und konfigurieren
    Antworten: 4
    Letzter Beitrag: 20.11.05, 16:21
  4. Python 2.1 auf 2.2 updaten?
    Von repa im Forum Anwendungen Allgemein, Software
    Antworten: 9
    Letzter Beitrag: 26.09.05, 09:37
  5. debian, kann debconf nicht updaten wegen angeblichem Fehler in python script.
    Von dedeibel im Forum System installieren und konfigurieren
    Antworten: 1
    Letzter Beitrag: 13.03.04, 17:51

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •