Anzeige:
Ergebnis 1 bis 2 von 2

Thema: bycr-rt5640 Soundkarte will nicht mit PulseAusio

  1. #1
    Registrierter Benutzer
    Registriert seit
    Jan 2021
    Beiträge
    1

    bytcr-rt5640 Soundkarte will nicht mit PulseAudio

    Hallo,
    ich versuche nun schon seit einigen Wochen die Soundkarte zum Laufen zu bekommen, es will mir allerdings mit allen gefundenen Tipps nicht gelingen. Daher habe ich mich jetzt hier mal angemeldet in der Hoffnung, dass mit weitergeholfen werden kann. :-)

    Es ist ein etwas älteres CaptivaNotebook 14.1 (dieses hier).
    Bei den meisten, die Probleme mit der Karte hatten half im Prinzip das hier, bei mir jedoch nicht.
    Nach der Installation von ZorinOS 15.3 lief PulseAudio nicht richtig und stürzte immer ab, woraufhin ich jenes tat.
    Außerdem habe ich, wie hier angegeben, das Modul snd_hdmi_lpe_audio geblacklistet.

    Wenn ich, wie hier angegeben, die /etc/pulse/default.pa anpasse habe ich das gleiche Problem, dass PulseAudio immer abstürzt. Das tut es im derzeitigen Zustand nicht, es gibt aber eben nur das Dummy-Device. :-(

    Also zusammengefasst: ich habe die Dateien von hier nach /usr/share/alsa/ucm kopiert und die /var/lib/alsa/asound.state entsprechend ersetzt.

    Hier noch einige technische Daten:
    Code:
    milena@milena-NB-14-1:~$ inxi -Fx
    System:    Host: milena-NB-14-1 Kernel: 5.4.0-64-generic x86_64 bits: 64 gcc: 7.5.0
               Desktop: Xfce 4.14.2 (Gtk 3.22.30) Distro: Zorin OS 15.3
    Machine:   Device: desktop System: CAPTIVA product: NB 14.1 serial: N/A
               Mobo: AMI model: Aptio CRB serial: N/A UEFI: American Megatrends v: 5.6.5 date: 08/16/2016
    CPU:       Quad core Intel Atom Z3735F (-MCP-) arch: Silvermont rev.8 cache: 1024 KB
               flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10666
               clock speeds: max: 1832 MHz 1: 549 MHz 2: 564 MHz 3: 798 MHz 4: 619 MHz
    Graphics:  Card: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display bus-ID: 00:02.0
               Display Server: x11 (X.Org 1.20.8 ) drivers: modesetting (unloaded: fbdev,vesa)
               Resolution: 1920x1080@60.01hz
               OpenGL: renderer: Mesa DRI Intel HD Graphics (BYT) version: 4.2 Mesa 20.0.8 Direct Render: Yes
    Audio:     Card bytcr-rt5640 driver: bytcr-rt5640 Sound: ALSA v: k5.4.0-64-generic
    Network:   Card: Failed to Detect Network Card!
    Drives:    HDD Total Size: NA (-)
               ID-1: /dev/mmcblk1 model: N/A size: 31.3GB
    Partition: ID-1: / size: 29G used: 14G (50%) fs: ext4 dev: /dev/mmcblk1p2
    RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
    Sensors:   System Temperatures: cpu: 53.0C mobo: N/A
               Fan Speeds (in rpm): cpu: N/A
    Info:      Processes: 208 Uptime: 2 min Memory: 911.0/1916.4MB Init: systemd runlevel: 5 Gcc sys: 7.5.0
               Client: Shell (bash 4.4.201) inxi: 2.3.56
    Code:
    milena@milena-NB-14-1:~$ aplay -L
    default
        Playback/recording through the PulseAudio sound server
    null
        Discard all samples (playback) or generate zero samples (capture)
    pulse
        PulseAudio Sound Server
    sysdefault:CARD=bytcrrt5640
        bytcr-rt5640, 
        Default Audio Device
    dmix:CARD=bytcrrt5640,DEV=0
        bytcr-rt5640, 
        Direct sample mixing device
    dmix:CARD=bytcrrt5640,DEV=1
        bytcr-rt5640, 
        Direct sample mixing device
    dsnoop:CARD=bytcrrt5640,DEV=0
        bytcr-rt5640, 
        Direct sample snooping device
    dsnoop:CARD=bytcrrt5640,DEV=1
        bytcr-rt5640, 
        Direct sample snooping device
    hw:CARD=bytcrrt5640,DEV=0
        bytcr-rt5640, 
        Direct hardware device without any conversions
    hw:CARD=bytcrrt5640,DEV=1
        bytcr-rt5640, 
        Direct hardware device without any conversions
    plughw:CARD=bytcrrt5640,DEV=0
        bytcr-rt5640, 
        Hardware device with all software conversions
    plughw:CARD=bytcrrt5640,DEV=1
        bytcr-rt5640, 
        Hardware device with all software conversions
    Code:
    milena@milena-NB-14-1:~$ sudo pulseaudio -v
    W: [pulseaudio] main.c: Dieses Programm sollte ohne die Option --system nicht als Administrator ausgeführt werden.
    I: [pulseaudio] core-util.c: Successfully gained nice level -11.
    I: [pulseaudio] main.c: This is PulseAudio 11.1
    I: [pulseaudio] main.c: Page size is 4096 bytes
    I: [pulseaudio] main.c: Machine ID is f1cfddfcda8c4e1e9cfa4b2e59f01395.
    E: [pulseaudio] core-util.c: Home directory not accessible: Keine Berechtigung
    Vielleicht liegt ja dort der Hund begraben?

    Code:
    milena@milena-NB-14-1:~$ cat /etc/modprobe.d/alsa-base.conf
    # autoloader aliases
    install sound-slot-0 /sbin/modprobe snd-card-0
    install sound-slot-1 /sbin/modprobe snd-card-1
    install sound-slot-2 /sbin/modprobe snd-card-2
    install sound-slot-3 /sbin/modprobe snd-card-3
    install sound-slot-4 /sbin/modprobe snd-card-4
    install sound-slot-5 /sbin/modprobe snd-card-5
    install sound-slot-6 /sbin/modprobe snd-card-6
    install sound-slot-7 /sbin/modprobe snd-card-7
    
    # Cause optional modules to be loaded above generic modules
    install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
    #
    # Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
    install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
    install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
    install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
    #
    install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
    # Cause optional modules to be loaded above sound card driver modules
    install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
    install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }
    
    # Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
    install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
    # Prevent abnormal drivers from grabbing index 0
    options bt87x index=-2
    options cx88_alsa index=-2
    options saa7134-alsa index=-2
    options snd-atiixp-modem index=-2
    options snd-intel8x0m index=-2
    options snd-via82xx-modem index=-2
    options snd-usb-audio index=-2
    options snd-usb-caiaq index=-2
    options snd-usb-ua101 index=-2
    options snd-usb-us122l index=-2
    options snd-usb-usx2y index=-2
    # Ubuntu #62691, enable MPU for snd-cmipci
    options snd-cmipci mpu_port=0x330 fm_port=0x388
    # Keep snd-pcsp from being loaded as first soundcard
    options snd-pcsp index=-2
    # Keep snd-usb-audio from beeing loaded as first soundcard
    options snd-usb-audio index=-2
    Code:
    milena@milena-NB-14-1:~$ ls -l /etc/modprobe.d
    insgesamt 44
    -rw-r--r-- 1 root root 2508 Jan 24 17:31 alsa-base.conf
    -rw-r--r-- 1 root root  154 Nov 25  2019 amd64-microcode-blacklist.conf
    -rw-r--r-- 1 root root  325 Jan 28  2018 blacklist-ath_pci.conf
    -rw-r--r-- 1 root root 1667 Jul 28  2020 blacklist.conf
    -rw-r--r-- 1 root root  210 Jan 28  2018 blacklist-firewire.conf
    -rw-r--r-- 1 root root  677 Jul 28  2020 blacklist-framebuffer.conf
    -rw-r--r-- 1 root root  156 Jul 31  2015 blacklist-modem.conf
    lrwxrwxrwx 1 root root   41 Jan 24 15:03 blacklist-oss.conf -> /lib/linux-sound-base/noOSS.modprobe.conf
    -rw-r--r-- 1 root root  583 Jan 28  2018 blacklist-rare-network.conf
    -rw-r--r-- 1 root root   29 Jan 23 21:36 blacklist_snd_hdmi_lpe_audio.conf
    -rw-r--r-- 1 root root  154 Jun 10  2020 intel-microcode-blacklist.conf
    -rw-r--r-- 1 root root  347 Jan 28  2018 iwlwifi.conf
    Code:
    milena@milena-NB-14-1:~$ pacmd list-sinks
    1 sink(s) available.
      * index: 0
    	name: <auto_null>
    	driver: <module-null-sink.c>
    	flags: DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
    	state: SUSPENDED
    	suspend cause: IDLE 
    	priority: 1000
    	volume: front-left: 65536 / 100% / 0,00 dB,   front-right: 65536 / 100% / 0,00 dB
    	        balance 0,00
    	base volume: 65536 / 100% / 0,00 dB
    	volume steps: 65537
    	muted: no
    	current latency: 0,00 ms
    	max request: 344 KiB
    	max rewind: 344 KiB
    	monitor source: 0
    	sample spec: s16le 2ch 44100Hz
    	channel map: front-left,front-right
    	             Stereo
    	used by: 0
    	linked by: 0
    	configured latency: 0,00 ms; range is 0,50 .. 2000,00 ms
    	module: 13
    	properties:
    		device.description = "Dummy-Ausgabe"
    		device.class = "abstract"
    		device.icon_name = "audio-card"
    Code:
    milena@milena-NB-14-1:~$ pacmd list-cards
    0 card(s) available.
    Ha jemand noch eine Idee? Ich komme nämlich mit meinem begrenzten Wissen nicht mehr weiter. :-(
    Geändert von Kangaxx (30.01.21 um 15:59 Uhr) Grund: Rechtschreibkorrekturen

  2. #2
    kleine schwester von root Avatar von corresponder
    Registriert seit
    May 2002
    Ort
    192.67.198.56
    Beiträge
    4.318
    Code:
    https://askubuntu.com/questions/338382/pulseaudio-not-working-home-directory-not-accessible-permission-denied
    das finde ich zu:

    Code:
    E: [pulseaudio] core-util.c: Home directory not accessible: Keine Berechtigung
    _______________________________________

    www.audio4linux.de - musik machen mit offenen quellen!

Ähnliche Themen

  1. Antworten: 35
    Letzter Beitrag: 07.09.06, 21:38
  2. Antworten: 2
    Letzter Beitrag: 09.03.05, 15:46
  3. Antworten: 0
    Letzter Beitrag: 01.02.05, 05:57
  4. Soundkarte will nicht
    Von Morgenstern im Forum Linux Allgemein
    Antworten: 1
    Letzter Beitrag: 23.09.04, 12:36
  5. soundkarte will nicht
    Von real-challo im Forum Musik
    Antworten: 1
    Letzter Beitrag: 05.05.03, 07:52

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •