Anzeige:
Ergebnis 1 bis 2 von 2

Thema: [Raspbian] Apache Webserver: CNAME Record funktioniert nicht richtig

  1. #1
    Registrierter Benutzer
    Registriert seit
    Jan 2021
    Beiträge
    1

    [Raspbian] Apache Webserver: CNAME Record funktioniert nicht richtig

    Hallo Leute! ☺

    Ich hab mich mit meiner vielen Freizeit in letzter Zeit ein wenig an Linux versucht. Dazu hab ich mir einen kleinen Server zugelegt auf dem ich eine Webseite hosten möchte. Das ganze an sich funktioniert schon mit der Website selbst und auch die Portweiterleitungen klappen reibungslos.

    Damit ich nicht ständig meine IP Adresse auslesen muss hab ich in meinem Router DynDNS eingerichtet. Da mir die DynDNS Domain aber nicht besonders gut gefällt und ich sowieso noch eine gekaufte besitze, habe ich recherchiert wie ich die beiden Domains miteinander verbinden kann. Das Ergebnis meiner Suche: CNAME Record. Derselbe war auch schnell erstellt und sollte (laut meinem Domain Anbieter) auch funktionieren.

    Jetzt zum Problem: Wenn ich die DynDNS Domain nutze komme ich auf die richtige Website. Will ich aber die gekaufte Domain benutzen, erhalte ich die Fehlermeldung "Not Found.The requested URL was not found on this directory".

    Ich habe gelesen, dass ich dem Webserver beibringen muss die gewollte Domain durchzulassen, aber auch nachdem ich damit ein wenig rumprobiert hab bin ich zu keinem Ergebnis gekommen. Ich schätze im Server ist etwas falsch eingestellt, aber ich weiß nicht was.

    Hier ein paar Informationen zum Server:

    Modell: Raspberry Pi 4 OS: Raspbian Webserver: Apache2, PHP 8

    Sagt gerne Bescheid falls mehr Informationen nötig sind.

    Vielen Dank im voraus ☺

    Airblade

  2. #2
    Registrierter Benutzer
    Registriert seit
    Dec 2003
    Ort
    Dettenhausen
    Beiträge
    21.649
    Du vermutest, Du hast etwas falsch eingestellt.

    Daher wäre es sinnvoll, uns das, was Du eingestellt hast, zukommen zu lassen. z.B. die von Dir verwendete relevanten Teile der Apache-Konfig.
    Ich bin root - ich darf das.

Ähnliche Themen

  1. CNAME Record für dyndns
    Von basstscho im Forum Linux als Server
    Antworten: 0
    Letzter Beitrag: 20.01.08, 08:33
  2. Apache mit PHP Support funktioniert nicht richtig
    Von uepselon im Forum Linux als Server
    Antworten: 13
    Letzter Beitrag: 19.01.06, 02:50
  3. Webserver -> Browser geht nicht; Telnet funktioniert
    Von maxxle im Forum Linux als Server
    Antworten: 3
    Letzter Beitrag: 05.11.05, 12:41
  4. Webserver funktioniert nicht :(
    Von DaQuark im Forum Linux als Server
    Antworten: 13
    Letzter Beitrag: 09.04.03, 14:40
  5. ftp funktioniert nicht richtig
    Von lou_ziffer im Forum Linux als Server
    Antworten: 1
    Letzter Beitrag: 27.08.02, 21:35

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •