Anzeige:
Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 15 von 16

Thema: twinkle sound problem

  1. #1
    Registrierter Benutzer Avatar von Klaus1
    Registriert seit
    Oct 2003
    Ort
    Schörfling am Attersee
    Beiträge
    157

    twinkle sound problem

    Hi,



    habe einen alten RaspberryPI A mit einer Soundkarte ausgestattet und verwende da drauf den Logitech Media Server erfolgreich mit angeschlossenem Verstärker, etc. als Client.


    Jetzt möchte ich twinkle drauf installieren und per command line bedienen. Wichtig wäre das ganze als babyphone zu nutzen, also auto answer.

    Ich scheitere jedoch schon am start von twinkle. Die Registrierung des phones funktioniert, aber der Sound spielt nicht ganz mit, hier der Start:



    Code:
    root@raspiInsel:~/.twinkle# twinkle -c
    
    Firewall/NAT discovery in progress.
    Please wait.
    
    
    Critical: Cannot open ALSA driver for PCM capture: No such file or directory
    
    
    Critical: Cannot open ALSA driver for PCM capture: No such file or directory
    
    
    Warning: Cannot access the speaker (ALSA: default).
    Cannot access the microphone (ALSA: default).
    
    
    Twinkle 1.10.1, October 7, 2016
    Copyright (C) 2005-2015  Michel de Boer and contributors
    
    Users:
    * twinkle
        204 <sip:204@192.168.1.50>
    
    Local IP:       255.255.255.255
    
    
    twinkle: registering phone...
    
    
    twinkle: registration succeeded (expires = 3600 seconds)
    
    Twinkle> exit
    
    Info: Deregistering phone...
    
    
    twinkle: deregistering phone...
    
    
    twinkle, de-registration succeeded: 200 OK



    hier ein Log auszug:


    Code:
    Diff
    +++ 20-10-2020 08:56:23.256286 INFO NORMAL t_log::t_log
    Twinkle 1.10.1, October 7, 2016
    ---
    
    +++ 20-10-2020 08:56:23.263281 INFO NORMAL t_log::t_log
    Built with support for: ALSA, Speex
    ---
    
    +++ 20-10-2020 08:56:23.263678 INFO NORMAL ::main
    Threading implementation is NPTL.
    ---
    
    +++ 20-10-2020 08:56:23.264516 INFO NORMAL t_user::read_config
    Reading config: twinkle.cfg
    ---
    
    +++ 20-10-2020 08:56:23.277928 INFO NORMAL t_phone_user::t_phone_user
    twinkle: buddy list loaded.
    ---
    
    +++ 20-10-2020 08:56:23.279095 INFO NORMAL ::main
    ICMP processing enabled.
    ---
    
    +++ 20-10-2020 08:56:23.360800 INFO NORMAL ::main
    Created local socket: /root/.twinkle/.cmdsock
    ---
    
    +++ 20-10-2020 08:56:23.364957 INFO NORMAL t_alsa_io::open
    Opening ALSA device: default
    play
    ---
    
    +++ 20-10-2020 08:56:23.480065 INFO NORMAL t_alsa_io::open
    Opening ALSA device: default
    play
    capture
    ---
    
    +++ 20-10-2020 08:56:23.480519 INFO NORMAL t_alsa_io::open
    Opening ALSA device: default
    play
    ---
    
    +++ 20-10-2020 08:56:23.498962 INFO NORMAL t_alsa_io::open
    Opening ALSA device: default
    capture
    ---
    
    +++ 20-10-2020 08:56:23.502831 CRITICAL NORMAL t_alsa_io::open
    snd_pcm_open failed: No such file or directory
    ---
    
    +++ 20-10-2020 08:56:23.517678 CRITICAL NORMAL t_audio_io::open
    Open audio device failed
    ---
    
    +++ 20-10-2020 08:56:23.519282 INFO NORMAL t_alsa_io::open
    Opening ALSA device: default
    play
    capture
    ---
    
    +++ 20-10-2020 08:56:23.519698 INFO NORMAL t_alsa_io::open
    Opening ALSA device: default
    play
    ---
    
    +++ 20-10-2020 08:56:23.538184 INFO NORMAL t_alsa_io::open
    Opening ALSA device: default
    capture
    ---
    
    +++ 20-10-2020 08:56:23.555711 CRITICAL NORMAL t_audio_io::open
    Open audio device failed
    ---

    und hier noch aplay auflistung:



    Code:
    root@raspiInsel:~/.twinkle# aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
      Subdevices: 7/7
      Subdevice #0: subdevice #0
      Subdevice #1: subdevice #1
      Subdevice #2: subdevice #2
      Subdevice #3: subdevice #3
      Subdevice #4: subdevice #4
      Subdevice #5: subdevice #5
      Subdevice #6: subdevice #6
    card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 IEC958/HDMI [bcm2835 IEC958/HDMI]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: ALSA [bcm2835 ALSA], device 2: bcm2835 IEC958/HDMI1 [bcm2835 IEC958/HDMI1]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 1: Device [USB Audio Device], device 0: USB Audio [USB Audio]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    root@raspiInsel:~/.twinkle#
    bitte um hilfe. ich brauch keine audio ausgabe, nur mikrofon sollte klappen.

    danke.

  2. #2
    Registrierter Benutzer
    Registriert seit
    Apr 2009
    Ort
    Erde
    Beiträge
    2.467
    Ich denke du willst mal arecord stat aplay verwenden - https://linuxconfig.org/how-to-test-...hitecture-alsa - neben der Soundkarte hast du aber auch ein Mikrofon dran?
    Gruß nopes
    (,,,)---(^.^)---(,,,) /var/log/messages | grep cat

  3. #3
    Registrierter Benutzer Avatar von Klaus1
    Registriert seit
    Oct 2003
    Ort
    Schörfling am Attersee
    Beiträge
    157
    ich möchte eigentlich sound aufnahme richtig. in kombi mit auto answer über SIP Client dazu verwende ich twinkle. calls klappen. soundkarte macht aber probleme. daher der eintrag. Mikrofon ist auch dran natürlich. auf einer USB Soundkarte die prinzipiell für meinen Logitech Media Server auch klappt.

  4. #4
    Registrierter Benutzer
    Registriert seit
    Apr 2009
    Ort
    Erde
    Beiträge
    2.467
    Ok, das klingt ein bisschen wiedersprüchlich, wenn Twinkle klappt, sollte es auch einfach so im CLI klappen, dort wird aber relativ eindeutig gemeldet, dass es kein Aufnahemgerät findet. Zunächst solltest du also prüfen, ob du auch ohne diesen Logitech Media Server aufnehmen kannst.
    Ich vermute du musst, dann etwas in der Twinkle Konfiguraiton anpassen, damit es klar kommt, was aber wieder nicht zu anrufe klappen passt.
    Gruß nopes
    (,,,)---(^.^)---(,,,) /var/log/messages | grep cat

  5. #5
    Registrierter Benutzer Avatar von Klaus1
    Registriert seit
    Oct 2003
    Ort
    Schörfling am Attersee
    Beiträge
    157
    Sorry, meinte natürlich der SIP Teil von Twinkle klappt. d.h. verbindungsanmeldung, aufgbau, telefonat rein die connection. nicht die Audio ausgabe / aufnahme.
    hab mal den Logitech Client gekillt, auch keine aufnahme möglich. mein Versuch:

    root@raspiInsel:~/.twinkle# arecord -l
    **** List of CAPTURE Hardware Devices ****
    card 1: Device [USB Audio Device], device 0: USB Audio [USB Audio]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    root@raspiInsel:~/.twinkle# arecord -d 60 -c 1 recording.wav
    arecord: main:788: audio open error: No such file or directory
    root@raspiInsel:~/.twinkle#

  6. #6
    Registrierter Benutzer
    Registriert seit
    Apr 2009
    Ort
    Erde
    Beiträge
    2.467
    Gruß nopes
    (,,,)---(^.^)---(,,,) /var/log/messages | grep cat

  7. #7
    Registrierter Benutzer Avatar von Klaus1
    Registriert seit
    Oct 2003
    Ort
    Schörfling am Attersee
    Beiträge
    157
    das klappt ganz gut. mit: arecord -D sysdefault:CARD=1 test.wavarecord -D sysdefault:CARD=1 test.wav
    aber twinkle meckert immer noch.
    config teil für audio von mir festgelegt an beispiele gehalten:

    Code:
    # AUDIO
    dev_speaker=alsa:plughw:1,0
    dev_mic=alsa:plughw:1,0
    ich denk da ist das problem oder ?

  8. #8
    Registrierter Benutzer
    Registriert seit
    Apr 2009
    Ort
    Erde
    Beiträge
    2.467
    Ok das ist ja schon mal gut - ich vermute eher das auch das Zutrifft:
    Zitat Zitat von https://www.raspberrypi.org/forums/viewtopic.php?t=206692
    Thank you for that! Sure enough, the first example works. The card is listed in /proc/asound/cards, but there is no ~/.asoundrc or /etc/asound.conf file, though, so I created the latter and put this in it...
    Die Konfiguration von twinkle sagt mir leider nichts, ich vermute aber weiterhin, dass arecord ohne Parameter klappen muss, damit twinkle klar kommt (ggf die beiden Zeilen aus der Twinkle Konfiguraiton auskommentieren):
    Code:
    $ arecord test.wav
    Ansonsten halt mal mit GUI starten, ich würde erwarten, dass man da Konfigurieren kann, dann könnte man vergleichen und wüsste was einzutragen ist...
    Gruß nopes
    (,,,)---(^.^)---(,,,) /var/log/messages | grep cat

  9. #9
    Registrierter Benutzer Avatar von Klaus1
    Registriert seit
    Oct 2003
    Ort
    Schörfling am Attersee
    Beiträge
    157
    Hab die zwei zeilen aus der config genommen... Hat nichts bewirkt.
    Kann ich meinen stretch überhaupt eine Oberfläche starten?
    Ich denke auch das ich ohne gui hier nicht weiter komme

  10. #10
    Registrierter Benutzer
    Registriert seit
    Apr 2009
    Ort
    Erde
    Beiträge
    2.467
    Druch das entfernen bzw kommentieren der beiden Zeilen, hast du ALSA noch nicht mitgeteilt, wie das laufen soll - aus dem gelinkten
    I got that by tweaking what was suggested on this page. Now it works without the -D on the command line!
    Ich denke wenn du da bist, wird auch twinkel gehen
    Gruß nopes
    (,,,)---(^.^)---(,,,) /var/log/messages | grep cat

  11. #11
    Registrierter Benutzer Avatar von Klaus1
    Registriert seit
    Oct 2003
    Ort
    Schörfling am Attersee
    Beiträge
    157
    Wie bekomm ich nachträglich eine gui drauf die ich nur bei bedarf starte? Danke

  12. #12
    Registrierter Benutzer
    Registriert seit
    Apr 2009
    Ort
    Erde
    Beiträge
    2.467
    Gruß nopes
    (,,,)---(^.^)---(,,,) /var/log/messages | grep cat

  13. #13
    Registrierter Benutzer Avatar von Klaus1
    Registriert seit
    Oct 2003
    Ort
    Schörfling am Attersee
    Beiträge
    157
    so, danke, sound problem mit der GUI gelöst. auch auto answer einstellung etc. Leider speichert der das nicht in das cfg file ;-) aber es klappt trotzdem.
    Bleibt nur noch die frage wie ich das kontinuierlich auch beim beenden meiner SSH Session starten kann...
    twinkle -c wäre der Befehl.
    nach beenden ist der prozess auch tot.

    mein versuch:
    root@raspiInsel:~/.twinkle# nohup twinkle -c
    nohup: ignoring input and appending output to 'nohup.out'
    root@raspiInsel:~/.twinkle# ps aux | grep twinkle
    root 1151 0.0 0.4 4360 2044 pts/1 S+ 12:23 0:00 grep twinkle
    root@raspiInsel:~/.twinkle#

    leider kein prozess da...

  14. #14
    Registrierter Benutzer
    Registriert seit
    Apr 2009
    Ort
    Erde
    Beiträge
    2.467
    Gruß nopes
    (,,,)---(^.^)---(,,,) /var/log/messages | grep cat

  15. #15
    Registrierter Benutzer Avatar von Klaus1
    Registriert seit
    Oct 2003
    Ort
    Schörfling am Attersee
    Beiträge
    157
    ok. screen installiert. mit screen öffne ich einen neuen screen, danach twinkle -c aber wie gehts weiter ? kann ich dann die ssh session beenden ?

Ähnliche Themen

  1. TBDialOut: twinkle als "url handler" für sip:// definieren
    Von Newbie314 im Forum Anwendungen Allgemein, Software
    Antworten: 6
    Letzter Beitrag: 11.02.12, 12:49
  2. bei Twinkle die Rufnummer ünterdrücken
    Von Moha im Forum Anbindung an die Aussenwelt
    Antworten: 6
    Letzter Beitrag: 26.05.09, 18:56
  3. voip ekiga/twinkle
    Von simpleminds im Forum Anbindung an die Aussenwelt
    Antworten: 2
    Letzter Beitrag: 28.09.07, 01:20
  4. VoIP mit Twinkle
    Von moulin im Forum Anwendungen Allgemein, Software
    Antworten: 0
    Letzter Beitrag: 10.07.07, 22:18
  5. sound problem mit alsa und einer sound blaster live!
    Von TobGod im Forum System installieren und konfigurieren
    Antworten: 0
    Letzter Beitrag: 07.10.04, 18:17

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •