Anzeige:
Ergebnis 1 bis 4 von 4

Thema: Debian mit OMV: Wake-on-LAN

  1. #1
    Registrierter Benutzer
    Registriert seit
    Aug 2016
    Beiträge
    3

    Debian mit OMV: Wake-on-LAN

    Hallo,

    ich nutze Debian 9.1 mit OpenMediaVault um meinen Dell T30 Server zu betreiben. Der Server läuft nicht dauerhaft und ich möchte ihn gerne, sobald mein Handy im WLAN ist, z.B. von einem Raspberry Pi, der dauerhaft läuft, aus starten lassen,...

    Testweise habe ich mir hierfür WOL.exe heruntergeladen, ein Windows-Tool, um "Weckrufe" abzusetzen. Das hat funktioniert, wenn ich den Dell T30 in den suspend-Modus geschickt habe (systemctl suspend). Da hat aber noch so viel gerattert und geblickt am Dell T30, dass ich nicht das Gefühl hatte, dass der Rechner wirklich "aus" ist. Auch die App meiner Photovoltaik-Anlage hat höher ausgeschlagen, als normal. Über die WOL.exe konnte ich den Server auch wieder starten.

    Die Voraussetzungen sind meiner Meinung nach alle erfüllt:
    1. Verfügbare Wake-on-LAN-Funktion. Wenn WoL auf Ihrem System verfügbar ist, können Sie das Systemhandbuch einsehen.
    2. Wake-on-LAN-fähige Netzwerkkarte
    3. Energieeffizientes Ethernet muss deaktiviert werden
    4. Deep Sleep muss im BIOS deaktiviert werden, wenn die Option vorhanden ist.
    5. Das System muss sich im S3-, S4-oder S5-Zustand befinden. Dies hängt auch von Ihrem Systemmodell ab.


    Punkt 3 und 4 habe ich eingestellt.

    Dann habe ich versucht ihn in den Hibernate zu schicken, woraus er laut Dell T30-Anleitung auch wieder aufwachen können sollte: https://www.dell.com/support/article...system?lang=de. Der Netzwerkanschluss am Dell T30 hat auch geblinkt, die Netzwerkkarte war also grundsätzlich noch aktiv. Allerdings wachte der Dell T30 nach dem "Weckruf" nicht mehr auf.

    Ich hoffe, ihr Linux-Experten könnt mir da weiterhelfen. Ich nutze OMV auch deshalb, weil ich nicht so tief in der Thematik drin bin.

    Vielen Dank und viele Grüße

    Dirk

  2. #2
    Registrierter Benutzer
    Registriert seit
    Aug 2016
    Beiträge
    3
    Keiner eine Idee?

  3. #3
    Registrierter Benutzer
    Registriert seit
    Dec 2003
    Ort
    Dettenhausen
    Beiträge
    21.593
    Google meint, Du bist nicht alleine. https://www.hardwareluxx.de/communit...142541/page-15 meint, daß Du ggf. den Netzwerkadapter nur über den Windows-Treiber zum Zusammenspiel bekommst.

    Evtl. kannst Du hier auch ein paar mehr konkretere Infos zum verwendeten Treiber, Logeinträge, Bios-Einstellunge, ... posten.

    Manche Dinge kann Dir evtl. auch nur jemand sagen, der exakt die gleiche Idee mit der gleichen Hardware hatte und evtl. die gleichen Fehler schon behoben oder aufgegeben hat.
    Ich bin root - ich darf das.

  4. #4
    Registrierter Benutzer
    Registriert seit
    Aug 2016
    Beiträge
    3
    Vielen Dank. Hardwareluxx.de hatte ich auch bereits gelesen. Nichtsdestotrotz habe ich gehofft, dass es doch irgendwie gehen würde.

    Hier mal, was ich gemacht habe:
    - BIOS Dell T30: Energieeffizientes Ethernet und Deep Sleep deaktiviert
    - OpenMediaVault: Über die OMV-Oberfläche WoL für den Netzwerkadapter aktiviert. Das führte dazu, dass /etc/network/interfaces wie folgt aussieht:
    # enp0s31f6 network interface
    auto enp0s31f6
    allow-hotplug enp0s31f6
    iface enp0s31f6 inet static
    address **.**.**.**.**
    gateway **.**.**.**.1
    netmask ***.***.***.***
    dns-nameservers **.**.**.**.1
    pre-down ethtool -s $IFACE wol g
    iface enp0s31f6 inet6 manual
    pre-down ip -6 addr flush dev $IFACE
    # Include additional interface stanzas.
    source interfaces.d
    - wenn ich ethtool enp0s31f6 aufrufe, bekomme ich folgende Ausgabe:
    Settings for enp0s31f6:
    Supported ports: [ TP ]
    Supported link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    1000baseT/Full
    Supported pause frame use: No
    Supports auto-negotiation: Yes
    Advertised link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    1000baseT/Full
    Advertised pause frame use: No
    Advertised auto-negotiation: Yes
    Speed: 1000Mb/s
    Duplex: Full
    Port: Twisted Pair
    PHYAD: 1
    Transceiver: internal
    Auto-negotiation: on
    MDI-X: off (auto)
    Supports Wake-on: pumbg
    Wake-on: g
    Current message level: 0x00000007 (7)
    drv probe link
    Link detected: yes
    Wie ich die Treiberinfo auslese und/oder welche Logs ich posten könnte, weiß ich leider nicht. Könnt ihr mir dabei bitte auf die Sprünge helfen oder reichen eventuell diese Infos schon, um mir weiterhelfen zu können?

    Vielen Dank und viele Grüße

    Dirk

Ähnliche Themen

  1. Wake on LAN
    Von der_dude im Forum System installieren und konfigurieren
    Antworten: 1
    Letzter Beitrag: 15.02.06, 15:08
  2. Debian 3.1: Stromsparen / Standby und Wake-on-Lan
    Von smartysmart34 im Forum System installieren und konfigurieren
    Antworten: 6
    Letzter Beitrag: 24.08.05, 16:27
  3. Wake on Modem/Wake on Ring
    Von Zalon im Forum stationäre Hardware
    Antworten: 4
    Letzter Beitrag: 06.10.04, 21:43
  4. wake on Lan?
    Von SAdemar im Forum stationäre Hardware
    Antworten: 1
    Letzter Beitrag: 17.04.02, 07:55
  5. wake on lan ???
    Von Backi im Forum Linux als Server
    Antworten: 1
    Letzter Beitrag: 08.10.00, 16:27

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •