Anzeige:
Seite 2 von 4 ErsteErste 1234 LetzteLetzte
Ergebnis 16 bis 30 von 47

Thema: Schwierigkeiten beim Download aus der Tele5 Mediathek

  1. #16
    Mod. FAQ/Howto/Emulation
    Registriert seit
    Sep 2000
    Beiträge
    17.362
    Python ist eine Scriptsprache, wird vermutlich zur Ausführung von youtube-dl benötigt. Wenn nicht vorhanden, dann eben installieren per Paketmanager.

  2. #17
    Registrierter Benutzer
    Registriert seit
    Nov 2017
    Ort
    Sinzig
    Beiträge
    188
    Ich weiß das Python eine Scriptsprache ist. Python3 ist installiert.

    Code:
    heiko@heiko-VirtualBox:~$ python3
    Python 3.8.2 (default, Apr 27 2020, 15:53:34) 
    [GCC 9.3.0] on linux
    Type "help", "copyright", "credits" or "license" for more information.
    >>> 
    heiko@heiko-VirtualBox:~$
    Muß ich was neues installieren? Wie lautet der Befehl sudo apt install ... ?

    Danke.

    LG
    Heiko

  3. #18
    Registrierter Benutzer
    Registriert seit
    Apr 2009
    Ort
    Erde
    Beiträge
    2.455
    /usr/bin/env: »python“: Datei oder Verzeichnis nicht gefunden
    Code:
    heiko@heiko-VirtualBox:~$ python # python != python3
    Prüfen, ob es python überhaupt gibt, oder ob es nur python3 gibt - https://stackoverflow.com/questions/...eady-installed

    1.01 Varianten:
    1 Skript anpassen, also python3 statt python in den shebang
    1.01 python3 nach python kopieren - nimm lieber 1
    Gruß nopes
    (,,,)---(^.^)---(,,,) /var/log/messages | grep cat

  4. #19
    Registrierter Benutzer
    Registriert seit
    Nov 2017
    Ort
    Sinzig
    Beiträge
    188
    Danke. Mich hatte es keine Ruhe gelassen und habe
    Code:
    sudo apt install python
    laufen lassen.

    Danach konnte ich youtube-dl ausführen. youtbe-dlg geht trotzdem nicht.
    Naja, ich probiere nachher den .deb Befehl aus. War ja im YouTube Video auch so gemacht worden. Learning by doing.

    Im Post ging es zuerst um JDownloader und dann youtube-dlg.

    Schönen Abend noch,
    Heiko

  5. #20
    Registrierter Benutzer
    Registriert seit
    Nov 2017
    Ort
    Sinzig
    Beiträge
    188
    Huhu?

    Habe den Befehl ausprobiert, aber mit Fehler:
    Code:
    heiko@heiko-VirtualBox:~$ sudo apt install '/home/heiko/Downloads/youtube-dlg_0.4-1~webupd8~zesty4_all.deb' 
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut.       
    Statusinformationen werden eingelesen.... Fertig
    Hinweis: »youtube-dlg« wird an Stelle von »/home/heiko/Downloads/youtube-dlg_0.4-1~webupd8~zesty4_all.deb« gewählt.
    Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
    Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
    Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
    nicht erstellt wurden oder Incoming noch nicht verlassen haben.
    Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:
    
    Die folgenden Pakete haben unerfüllte Abhängigkeiten:
     youtube-dlg : Hängt ab von: python-twodict (>= 1.2) ist aber nicht installierbar
    E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
    heiko@heiko-VirtualBox:~$
    Wie gehe ich am besten vor?

    LG
    Heiko

  6. #21
    Registrierter Benutzer
    Registriert seit
    Apr 2009
    Ort
    Erde
    Beiträge
    2.455
    Zitat Zitat von https://mrs0m30n3.github.io/youtube-dl-gui/#downloads
    ...
    Requirements
    Python 2.7.3+
    wxPython 3
    TwoDict
    GNU gettext (build)
    FFmpeg (optional)
    ...
    Alle Abhängigkeiten müssen erfüllt sein, es wird gemeldet das TwoDict fehlt. Am besten prüfst du, welche dir fehlen und installierst diese nach, auf https://mrs0m30n3.github.io/youtube-dl-gui/#downloads sind die Abhängigkeiten verlinkt.

    Am Ende noch ein paar Worte der Warnung. Du hast auf deinem System Fremde Dinge installiert, dass kann deine Systemverwaltung beschädigen. Das gilt auch für Sachen die man mit anderen Installern einspielt (hier pip, da gibt es aber noch viele andere Nestbeschmutzer). Python 2 ist abgelaufen und sollte nicht mehr benutzt werden.

    Ist das einfacher als einen Web Services dafür zu nutzen, übersehe ich gerade was - warum sollte man sich das geben?

    Es geht natürlich, dir fehlt wie gesagt TwoDict, das musst du ebenfalls installieren, das geht mit "pip install twodict", falls du die Anweisung auf der Seite nicht findest.
    Gruß nopes
    (,,,)---(^.^)---(,,,) /var/log/messages | grep cat

  7. #22
    Registrierter Benutzer
    Registriert seit
    Nov 2017
    Ort
    Sinzig
    Beiträge
    188
    Hallo. Danke für die Antworten.

    Ich wollte das twict installieren. Ging nicht wegen pip. Wollte ich nach dieser Seite pip installieren:
    Code:
    https://wiki.ubuntuusers.de/pip/
    Ich habe dann das pip3 installiert:
    Code:
    sudo apt install python3-pip
    War doch das richtige pip oder wäre python-pip richtig?
    Wie rufe ich dann pip(3) install... auf?

    LG
    Heiko

  8. #23
    Registrierter Benutzer
    Registriert seit
    Nov 2017
    Ort
    Sinzig
    Beiträge
    188
    Hallo?

    Ich habe pip3 genommen:
    Code:
    heiko@heiko-VirtualBox:~$ pip3 install twodict
    Collecting twodict
      Downloading twodict-1.2.tar.gz (7.0 kB)
    Building wheels for collected packages: twodict
      Building wheel for twodict (setup.py) ... done
      Created wheel for twodict: filename=twodict-1.2-py3-none-any.whl size=4296 sha256=ca48eb5eb185462fcecca7dc794a3ac843eb18126a1f9f2c8d3829f30b0fe042
      Stored in directory: /home/heiko/.cache/pip/wheels/5b/83/70/198d19519d35eb7be44cae75f90c175b091ff80ca253ad26b0
    Successfully built twodict
    Installing collected packages: twodict
    Successfully installed twodict-1.2
    Sieht doch ganz gut aus. Aber der Installationsbefehl zeigt immer noch Fehler an. Ich will ja jetzt nicht wie wild an den Requirements experimentieren. Daher warte ich Eure Antwort ab.
    Code:
    eiko@heiko-VirtualBox:~$ sudo apt install '/home/heiko/Downloads/youtube-dlg_0.4-1~webupd8~zesty4_all.deb' 
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut.       
    Statusinformationen werden eingelesen.... Fertig
    Hinweis: »youtube-dlg« wird an Stelle von »/home/heiko/Downloads/youtube-dlg_0.4-1~webupd8~zesty4_all.deb« gewählt.
    Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
    Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
    Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
    nicht erstellt wurden oder Incoming noch nicht verlassen haben.
    Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:
    
    Die folgenden Pakete haben unerfüllte Abhängigkeiten:
     youtube-dlg : Hängt ab von: python-twodict (>= 1.2) ist aber nicht installierbar
    E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
    heiko@heiko-VirtualBox:~$
    Lieben Dank.

    LG
    Heiko

  9. #24
    Registrierter Benutzer
    Registriert seit
    Nov 2017
    Ort
    Sinzig
    Beiträge
    188
    PS: Mit welchem Web Services kann ich denn Live-Sendungen von den einzelnen Sendern runterladen? Danke.

  10. #25
    Registrierter Benutzer
    Registriert seit
    Nov 2017
    Ort
    Sinzig
    Beiträge
    188
    Arte live kann ich über youtube-dl schon mal nicht runterladen:
    Code:
    heiko@heiko-VirtualBox:~$ cd neu
    heiko@heiko-VirtualBox:~/neu$ mkdir arte-live
    heiko@heiko-VirtualBox:~/neu$ cd arte-live
    heiko@heiko-VirtualBox:~/neu/arte-live$ youtube-dl https://www.arte.tv/de/live/
    [generic] live: Requesting header
    WARNING: Falling back on generic information extractor.
    [generic] live: Downloading webpage
    [generic] live: Extracting information
    ERROR: Unsupported URL: https://www.arte.tv/de/live/
    heiko@heiko-VirtualBox:~/neu/arte-live$

  11. #26
    Registrierter Benutzer
    Registriert seit
    Apr 2009
    Ort
    Erde
    Beiträge
    2.455
    Auwei, klingt so also ob du mehrere Python Version installiert hast, das macht es nicht leichter. Web Service musst du mal suchen - online video converter. Mediatheken sind nicht Youtube, in Deutschland kannst du den MediathekView nehmen, da kann man auch Dinge aus der Arte Mediathek laden. Generell würde ich mal unterstellen, dass das bei den meisten Fernsehsendern noch anders läuft, als bei Youtube&Co. Das ist halt ein Gebiet, wo es intressen Konflikte gibt, am Ende will die Plattform Geld mit den Content machen, die Urheber oft auch. Unsere frein Mediatheken stehen deswegen schon lange unter großem Druck, daher gibt es Dinge dort nicht für immer. Gerade wird gefühlt alles viel schlimmer, stell dich also drauf ein, dass offline kucken bald einfach nicht mehr möglich ist, je nach Lesart, wird lesen bald nicht mehr drin sein bzw von der verwendeten Suchmaschine abhängig sein.
    Gruß nopes
    (,,,)---(^.^)---(,,,) /var/log/messages | grep cat

  12. #27
    Registrierter Benutzer
    Registriert seit
    Nov 2017
    Ort
    Sinzig
    Beiträge
    188
    Hallo zusammen,

    das youtube-dlg hat mir u. a. keine Ruhe gelassen.

    Wollte dann neuen Versuch mit https://wiki.ubuntuusers.de/youtube-dlG/ starten.

    Dazu brauche ich gem. der Anleitung das pip. Das konnte ich aber nicht installieren:
    Code:
    heiko@heiko-VirtualBox:~$ sudo apt install python-pip
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut.       
    Statusinformationen werden eingelesen.... Fertig
    E: Paket python-pip kann nicht gefunden werden.
    heiko@heiko-VirtualBox:~$
    Da fehlt mir was. Wie kann ich die Quelle Repository herausfinden die ich dann adden kann?

    Lieben Dank.

    LG
    Heiko


    PS: Sorry, wenn ich schon wieder mit youtube-dl(g) ankomme. Ich wollte was probieren. Ich habe hier ein virtuelles Ubuntu 20.04. Bevor ich mein richtiges Ubuntu 18.04 zumülle, frage ich besser hier noch mal nach.

  13. #28
    Registrierter Benutzer
    Registriert seit
    Apr 2009
    Ort
    Erde
    Beiträge
    2.455
    Nun du wirst das Problem haben, dass Python2 offiziell am Ende ist - wie man das trotzdem installieren kann steht zB hier: https://linuxize.com/post/how-to-ins...-ubuntu-20.04/
    Gruß nopes
    (,,,)---(^.^)---(,,,) /var/log/messages | grep cat

  14. #29
    Registrierter Benutzer
    Registriert seit
    Nov 2017
    Ort
    Sinzig
    Beiträge
    188
    Moin in die Runde. Vielen Dank.

    Der curl-Befehl gibt es nicht:
    Code:
    heiko@heiko-VirtualBox:~$ curl https://bootstrap.pypa.io/get-pip.py --output get-pip.py
    
    Der Befehl 'curl' wurde nicht gefunden, kann aber installiert werden mit:
    
    sudo apt install curl
    
    heiko@heiko-VirtualBox:~$
    .
    Aber nicht schlimm, ich habe das genannte Python-Script manuell runtergeladen. Konnte ich mit
    Code:
    sudo python2 get-pip.py
    auch laufen lassen.

    Das youtube-dlg konnte ich aber trotzdem nicht installieren:
    Code:
    heiko@heiko-VirtualBox:~$ sudo apt install '/home/heiko/Downloads/youtube-dlg_0.4-1~webupd8~zesty4_all.deb' 
    [sudo] Passwort für heiko: 
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut.       
    Statusinformationen werden eingelesen.... Fertig
    Hinweis: »youtube-dlg« wird an Stelle von »/home/heiko/Downloads/youtube-dlg_0.4-1~webupd8~zesty4_all.deb« gewählt.
    Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
    Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
    Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
    nicht erstellt wurden oder Incoming noch nicht verlassen haben.
    Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:
    
    Die folgenden Pakete haben unerfüllte Abhängigkeiten:
     youtube-dlg : Hängt ab von: python-twodict (>= 1.2) ist aber nicht installierbar
    E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
    heiko@heiko-VirtualBox:~$
    Verstehe ich nicht, das twodict ist doch installiert.

    Auch über pip install konnte ich das youtube-dlg nicht installieren:

  15. #30
    Registrierter Benutzer
    Registriert seit
    Nov 2017
    Ort
    Sinzig
    Beiträge
    188
    Code:
    heiko@heiko-VirtualBox:~$ pip install --user youtube-dlg
    DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
    Collecting youtube-dlg
      Using cached Youtube-DLG-0.4.tar.gz (153 kB)
    Building wheels for collected packages: youtube-dlg
      Building wheel for youtube-dlg (setup.py) ... error
      ERROR: Command errored out with exit status 1:
       command: /usr/bin/python2 -u -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/tmp/pip-install-oJ5khx/youtube-dlg/setup.py'"'"'; __file__='"'"'/tmp/pip-install-oJ5khx/youtube-dlg/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' bdist_wheel -d /tmp/pip-wheel-6pEdEg
           cwd: /tmp/pip-install-oJ5khx/youtube-dlg/
      Complete output (6 lines):
      running bdist_wheel
      running build
      running build_bin
      running build_trans
      building MO file for 'youtube_dl_gui/locale/es_ES/LC_MESSAGES/youtube_dl_gui.po'
      could not locate file 'msgfmt', exiting...
      ----------------------------------------
      ERROR: Failed building wheel for youtube-dlg
      Running setup.py clean for youtube-dlg
    Failed to build youtube-dlg
    DEPRECATION: Could not build wheels for youtube-dlg which do not use PEP 517. pip will fall back to legacy 'setup.py install' for these. pip 21.0 will remove support for this functionality. A possible replacement is to fix the wheel build issue reported above. You can find discussion regarding this at https://github.com/pypa/pip/issues/8368.
    Installing collected packages: youtube-dlg
        Running setup.py install for youtube-dlg ... error
        ERROR: Command errored out with exit status 1:
         command: /usr/bin/python2 -u -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/tmp/pip-install-oJ5khx/youtube-dlg/setup.py'"'"'; __file__='"'"'/tmp/pip-install-oJ5khx/youtube-dlg/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' install --record /tmp/pip-record-BEr0uE/install-record.txt --single-version-externally-managed --user --prefix= --compile --install-headers /home/heiko/.local/include/python2.7/youtube-dlg
             cwd: /tmp/pip-install-oJ5khx/youtube-dlg/
        Complete output (6 lines):
        running install
        running build
        running build_bin
        running build_trans
        building MO file for 'youtube_dl_gui/locale/es_ES/LC_MESSAGES/youtube_dl_gui.po'
        could not locate file 'msgfmt', exiting...
        ----------------------------------------
    ERROR: Command errored out with exit status 1: /usr/bin/python2 -u -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/tmp/pip-install-oJ5khx/youtube-dlg/setup.py'"'"'; __file__='"'"'/tmp/pip-install-oJ5khx/youtube-dlg/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' install --record /tmp/pip-record-BEr0uE/install-record.txt --single-version-externally-managed --user --prefix= --compile --install-headers /home/heiko/.local/include/python2.7/youtube-dlg Check the logs for full command output.
    heiko@heiko-VirtualBox:~$
    Daß das so kompliziert ist das youtube-dlg zu installieren, hätte ich nicht gedacht. Kein Wunder das viele User vor Linux noch zurückschrecken.
    Unter Windows einfach das Setup.exe laufen lassen, durchklicken und gut ist.

Ähnliche Themen

  1. Antworten: 10
    Letzter Beitrag: 02.08.16, 18:41
  2. Gelöst: Schwierigkeiten beim Download aus der ZDF Mediathek
    Von Newbie314 im Forum Meldungen und Mitglieder
    Antworten: 13
    Letzter Beitrag: 22.09.14, 21:21
  3. Schwierigkeiten beim Einrichten eines Mailservers
    Von picki im Forum Linux als Server
    Antworten: 3
    Letzter Beitrag: 14.02.06, 12:57
  4. Fehler beim Download von Download NVIDIA(c) Graphics Driver
    Von michaelx003 im Forum X-Konfiguration
    Antworten: 24
    Letzter Beitrag: 25.06.05, 15:52
  5. Samba - Files beim upload komprimieren und beim download entpacken?
    Von philoman im Forum Linux in heterogenen Netzen
    Antworten: 2
    Letzter Beitrag: 04.03.02, 16:51

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •