Anzeige:
Ergebnis 1 bis 7 von 7

Thema: Leere /boot/grun/grub.cfg - 'update-grup' misslingt

  1. #1
    Registrierter Benutzer
    Registriert seit
    Jan 2016
    Beiträge
    12

    [GELÖST] Leere /boot/grub/grub.cfg - 'update-grub' misslingt

    Hallo Leute,

    ich benutze standardmäßig schon seit einigen Jahren Sparky-Linux, ein Debian-Derivat in der Testing-Version. Bisher lief alles reibungslos, doch seit einigen Tagen habe ich ein Problem - vielleicht könnt Ihr mir helfen.

    Folgendes ist passiert:
    Zu Testzwecken installierte ich parallel ein Arch-Derivat. Mein bisheriger Grub2-Bootmanager aus dem Sparky-Linux erkannte das neue System, konnte es aber nicht booten. Ich erhielt nur eine Kernel panic-Fehlermeldung. In diversen Foren habe ich ich erfahren, dass Debian in dem Fall das Manjaro-System nicht booten kann - anders herum schon. Also installierte ich in Manjaro Grub2 - soweit so gut, alles läuft.
    Neben den beiden genannten Linux-Varianten gibt es noch ein Windows 10. Gestartet wird der Rechner noch über BIOS, also nicht Efi.

    Nun möchte ich Manjaro wieder deinstallieren und meinen 'alten' Bootmanager wieder herstellen. Und das scheitert.

    Ich erhalte folgendes:

    Code:
    # update-grub
    Generating grub configuration file ...
    Skript »/boot/grub/grub.cfg.new« enthält nichts, es wird nichts ausgeführt
    Syntax errors are detected in generated GRUB config file.
    Ensure that there are no errors in /etc/default/grub
    and /etc/grub.d/* files or please file a bug report with
    /boot/grub/grub.cfg.new file attached.
    In der Tat, die Datei '/boot/grub/grub.cfg' ist leer.

    Der Inhalt meiner '/etc/default/grub' sieht folgendermaßen aus:

    Code:
    # If you change this file, run 'update-grub' afterwards to update
    # /boot/grub/grub.cfg.
    # For full documentation of the options in this file, see:
    #   info -f grub -n 'Simple configuration'
    
    GRUB_DEFAULT="Sparky GNU/Linux"
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux"
    #GRUB_CMDLINE_LINUX="vga=794 splash"
    #GRUB_CMDLINE_LINUX="splash"
    
    # Uncomment to enable BadRAM filtering, modify to suit your needs
    # This works with Linux (no patch required) and with any kernel that obtains
    # the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
    #GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"
    
    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL="console"
    
    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    GRUB_GFXMODE="1280x1024x16"
    GRUB_GFXPAYLOAD_LINUX="keep"
    
    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID="true"
    
    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_RECOVERY="true"
    
    # Uncomment to get a beep at grub start
    #GRUB_INIT_TUNE="480 440 1"
    
    #GRUB_CMDLINE_LINUX="vga=775"
    
    GRUB_SAVEDEFAULT="false"
    #GRUB_HIDDEN_TIMEOUT="3"
    
    #GRUB_CMDLINE_LINUX="vga=775"
    
    #auskommentiert am 13.05.2020
    #GRUB_CMDLINE_LINUX="vga=775"
    
    #GRUB_CMDLINE_LINUX="vga=775"
    Ich kann keinen Fehler erkennen.

    Auch ein manuelles Erzeugen der Datei '/boot/grub/grub.cfg' gelingt nicht:
    Code:
    # /usr/sbin/grub-mkconfig -o /boot/grub/grub.cfg
    Generating grub configuration file ...
    Skript »/boot/grub/grub.cfg.new« enthält nichts, es wird nichts ausgeführt
    Syntax errors are detected in generated GRUB config file.
    Ensure that there are no errors in /etc/default/grub
    and /etc/grub.d/* files or please file a bug report with
    /boot/grub/grub.cfg.new file attached.
    Die neu erzeugte Datei ist leer.

    Desweiteren habe ich erkannt, dass es einen älteren und nicht passenden Kernel gibt, der nicht deinstalliert werden kann. Darum werden wohl auch keine gültigen grub-Dateien erzeugt. Kann das sein?

    Hier einmal die Ausgabe nach dem Aufruf der Deinstallation:

    Code:
    # apt-get purge linux-image-4.19.0-5-amd64
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut.       
    Statusinformationen werden eingelesen.... Fertig
    Die folgenden Pakete werden ENTFERNT:
      linux-image-4.19.0-5-amd64
    0 aktualisiert, 0 neu installiert, 1 zu entfernen und 11 nicht aktualisiert.
    5 nicht vollständig installiert oder entfernt.
    Nach dieser Operation werden 267 MB Plattenplatz freigegeben.
    Möchten Sie fortfahren? [J/n] J
    (Lese Datenbank ... 512466 Dateien und Verzeichnisse sind derzeit installiert.)
    Entfernen von linux-image-4.19.0-5-amd64 (4.19.37-5) ...
    /etc/kernel/postrm.d/initramfs-tools:
    update-initramfs: Deleting /boot/initrd.img-4.19.0-5-amd64
    /etc/kernel/postrm.d/zz-update-grub:
    Generating grub configuration file ...
    Skript »/boot/grub/grub.cfg.new« enthält nichts, es wird nichts ausgeführt
    Syntax errors are detected in generated GRUB config file.
    Ensure that there are no errors in /etc/default/grub
    and /etc/grub.d/* files or please file a bug report with
    /boot/grub/grub.cfg.new file attached.
    run-parts: /etc/kernel/postrm.d/zz-update-grub exited with return code 1
    dpkg: Fehler beim Bearbeiten des Paketes linux-image-4.19.0-5-amd64 (--remove):
     »installiertes linux-image-4.19.0-5-amd64-Skript des Paketes post-removal«-Unterprozess gab den Fehlerwert 1 zurück
    dpkg: Zu viele Fehler, Abbruch
    Fehler traten auf beim Bearbeiten von:
     linux-image-4.19.0-5-amd64
    Bearbeitung wurde angehalten, da zu viele Fehler auftraten.
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Was könnte ich tun, um wieder einen funktionierenden Grub-Bootmanager zu erhalten?
    Jetzt kann ich mein Sparky nur mit einer 'SuperGrub2disc' starten.

    Für Eure Hilfe bin ich sehr dankbar.
    Geändert von galusare (24.05.20 um 12:56 Uhr) Grund: Tippfehler

  2. #2
    Registrierter Benutzer
    Registriert seit
    Jan 2016
    Beiträge
    12
    Hallo,

    schade, dass bisher noch niemand geantwortet hat. Ist das Problem zu trivial oder zu schwierig?

    Ich kam einen Schritt weiter.
    Und zwar konnte ich den widerspenstigen Kernel entfernen. Das lag an der Datei /rtc/kernel/postrm.d/zz-update-grub. Ich benannte die temporär um. Anschließend konnte ich den Kernel 4.19.... entfernen. Auch dann konnte ich erst die Pakete 'grub-customizer' und 'startapmanager' entfernen.

    Leider bleib meine '/boot/grub/grub.cfg' nachwievor leer. Woran kann das bloß liegen?

    Bitte um Hilfe!!!

    Noch eine Frage: Wie könen im Titel des Beitrages die Tippfehler von "Leere /boot/grun/grub.cfg - 'update-grup' misslingt" in "Leere /boot/grub/grub.cfg - 'update-grub' misslingt" geändert werden?

  3. #3
    Registrierter Benutzer
    Registriert seit
    Jul 2009
    Ort
    Meißen
    Beiträge
    281
    Zitat Zitat von galusare Beitrag anzeigen
    ... schade, dass bisher noch niemand geantwortet hat. Ist das Problem zu trivial oder zu schwierig?
    Weder das eine noch das andere; in Foren ist einfach nicht mehr so viel los wie z.B. noch vor zehn Jahren ...

    Zitat Zitat von galusare Beitrag anzeigen
    Und zwar konnte ich den widerspenstigen Kernel entfernen. Das lag an der Datei /rtc/kernel/postrm.d/zz-update-grub. Ich benannte die temporär um. Anschließend konnte ich den Kernel 4.19.... entfernen. Auch dann konnte ich erst die Pakete 'grub-customizer' und 'startapmanager' entfernen.
    Obwohl dies zweifellos wie ein Teilerfolg klingt, besteht damit die Gefahr, dass Du die Paketverwaltung noch mehr durcheinander gebracht hast.

    Zitat Zitat von galusare Beitrag anzeigen
    Leider bleib meine '/boot/grub/grub.cfg' nachwievor leer. Woran kann das bloß liegen?
    Was ist mit den Dateien in /etc/grub.d/ - ist da etwas fehlerhaft?

    Gruß, FM_81
    Ein Mann, der wollte fangen einen Barsch, das Wasser stand ihm bis zum Knie!
    (Du musst bis Frühjahr warten, da kommt Hochwasser, dann reimt es sich von selbst!)

  4. #4
    Registrierter Benutzer
    Registriert seit
    Jan 2016
    Beiträge
    12
    Hallo FM_81,

    danke für die Antwort.

    Hm, schade, dass nicht mehr so viel los ist.

    In '/etc/grub.d' befindet sich komischerweise nur die Datei '60-grub-imageboot.dpkg-new.

    Im Ordner '/etc/grub.d.bak' dagegen die im angehängten Bild dargestellten Ordner und Konfigurationsdateien.

    Hm, eigenartig!
    Angehängte Grafiken Angehängte Grafiken

  5. #5
    Registrierter Benutzer
    Registriert seit
    Jul 2009
    Ort
    Meißen
    Beiträge
    281
    Im Ordner '/etc/grub.d.bak' dagegen die im angehängten Bild dargestellten Ordner und Konfigurationsdateien
    Naja, das sind offensichtlich die aus denen die /boot/grub/grub.cfg sonst normalerweise gebaut wird. 60-grub-imageboot.dpkg-new allein ist offenbar nicht ausreichend ...
    Zurück umbenennen und probieren, würde ich sagen? Und immer ein Rettungssystem in der Nähe haben, falls was schief geht ...
    Das gilt natürlich nur, so lange man nicht vor hat, die Methode "ich installiere sowieso immer neu" durchzuziehen.

    Gruß, FM_81
    Ein Mann, der wollte fangen einen Barsch, das Wasser stand ihm bis zum Knie!
    (Du musst bis Frühjahr warten, da kommt Hochwasser, dann reimt es sich von selbst!)

  6. #6
    Registrierter Benutzer
    Registriert seit
    Jan 2016
    Beiträge
    12
    Danke wieder für die Antwort.

    Ich denke, ich mache von diesen Dateien eine weitere Sicherungskopie, deinstalliere Grub, um ihn dann wieder neu zu installieren. Das ist bestimmt die saubere Lösung.
    Zumindest bin ich schon mal froh, dass ich den unbequemen Kernel und auch die 'firmware-b43' los bin, die immer wieder zu Fehlermeldungen führten. So wie ich erlesen habe, ist 'firmware-b43' für WLAN-Geräte, die an dem Rechner soundso nicht angeschlossen sind.

    Ich melde mich wieder, wenn es Neuigkeiten gibt.

    Viele Grüße und einen schönen Sonntag,

    galusare

  7. #7
    Registrierter Benutzer
    Registriert seit
    Jan 2016
    Beiträge
    12
    Juhuuu - es hat funktioniert!!!

    Ich habe mehrmals versucht, mittels

    '$ apt-get install grub-pc grub-common os-prober'

    Grub neu zu installieren, natürlich mit zuvoriger Deinstallation. Immer blieb die Datei '/boot/grub/grub.cfg' leer.

    Dann habe ich den Befehl geändert und wie folgt eingegeben:

    '$ apt-get install grub-common grub-pc os-prober'

    Ich habe also nur die Reihenfolge der zu installierenden Pakete getauscht. Und das funktionierte!

    Nun läuft alles wieder so, wie es sein soll - damit ist mein Problem gelöst.

    Danke noch einmal für die Hilfe.

Ähnliche Themen

  1. Dual-Boot: Plötzlich ist im GRUP das Windows 10 verschwunden
    Von W_Guenzl im Forum System installieren und konfigurieren
    Antworten: 2
    Letzter Beitrag: 19.02.20, 19:22
  2. Antworten: 0
    Letzter Beitrag: 16.10.11, 19:42
  3. Leere E-Mails nach Update
    Von webshark im Forum Linux als Server
    Antworten: 1
    Letzter Beitrag: 28.10.09, 10:30
  4. frage zu grub nach update-grub unter Etch
    Von magicslider im Forum Linux als Server
    Antworten: 7
    Letzter Beitrag: 15.06.07, 13:28
  5. freetype 1.3.1 - übersetzung misslingt wegen fehler in ftdump.o
    Von TuX_RuLeZ im Forum Kompilieren von Kernel und Sourcen
    Antworten: 2
    Letzter Beitrag: 07.11.04, 20:05

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •