Anzeige:
Ergebnis 1 bis 3 von 3

Thema: Debian vServer: 2x static IPv4 & 2x static IPv6 auf selbem Interface

  1. #1
    Registrierter Benutzer Avatar von Freeze24
    Registriert seit
    Feb 2003
    Ort
    Oberpfalz
    Beiträge
    58

    Debian vServer: 2x static IPv4 & 2x static IPv6 auf selbem Interface

    Hallo Leute,

    ich bräuchte nochmal eure Hilfe..

    Die /etc/network/interfaces auf meinem Debian-vServer sieht wie folgt aus:
    Code:
    # The loopback network interface
    auto lo
    iface lo inet loopback
    
    # The primary network interface
    auto eth0
    iface eth0 inet static
        address 62.171.138.39
        netmask 255.255.224.0
        gateway 62.171.128.1
        dns-search invalid
        dns-nameservers 213.136.95.11 213.136.95.10
        up ip route replace 62.171.128.0/19 via 62.171.128.1 dev eth0
        up ip addr add 62.171.138.42/19 dev eth0
        down ip addr del 62.171.138.42/19 dev eth0
    
    iface eth0 inet6 static
        address 2a02:c207:3004:8467::1
        netmask 64
        gateway fe80::1
        accept_ra 0
        autoconf 0
        privext 0
        up ip -6 addr add 2a02:c207:3004:8467::2/64 dev eth0
        down ip -6 addr del 2a02:c207:3004:8467::2/64 dev et0
    D.h. ich habe zwei IPv4-Adressen und zwei IPv6-Adressen, die alle über eth0 bedient werden sollen.

    Mein Problem ist, wenn ich den networking Dienst neu starte, passiert folgendes:
    Code:
    Mar  6 11:56:26 vmd48467 systemd[1]: Starting Raise network interfaces...
    Mar  6 11:56:26 vmd48467 ifup[7589]: RTNETLINK answers: File exists
    Mar  6 11:56:26 vmd48467 ifup[7589]: ifup: failed to bring up eth0
    Mar  6 11:56:26 vmd48467 ifup[7589]: run-parts: /etc/network/if-up.d/postfix exited with return code 75
    Mar  6 11:56:26 vmd48467 ifup[7589]: ifup: post-up script failed
    Mar  6 11:56:26 vmd48467 systemd[1]: networking.service: Main process exited, code=exited, status=1/FAILURE
    Mar  6 11:56:26 vmd48467 systemd[1]: networking.service: Failed with result 'exit-code'.
    Mar  6 11:56:26 vmd48467 systemd[1]: Failed to start Raise network interfaces.
    Die Postfix Fehlermeldung ist
    Code:
    Mar  6 11:56:26 vmd48467 postfix/sendmail[7607]: fatal: parameter inet_interfaces: no local interface found for 2a02:c207:3004:8467::1
    "ip addr show" zeigt dann auch keine IPv6-Adressen mehr:
    Code:
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo
           valid_lft forever preferred_lft forever
        inet6 ::1/128 scope host 
           valid_lft forever preferred_lft forever
    2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
        link/ether 00:50:56:3f:29:b8 brd ff:ff:ff:ff:ff:ff
        inet 62.171.138.39/19 brd 62.171.159.255 scope global eth0
           valid_lft forever preferred_lft forever
        inet 62.171.138.42/19 scope global secondary eth0
           valid_lft forever preferred_lft forever
        inet6 fe80::250:56ff:fe3f:29b8/64 scope link 
           valid_lft forever preferred_lft forever
    Selbst ein nachträgliches "ip -6 addr add 2a02:c207:3004:8467::1/64 dev eth0" bringt nichts.
    Die IP Adresse taucht dann zwar auf, aber die Verbindung funktioniert nicht.

    Wenn ich reboote, klappt alles problemlos.
    Nur beim Neustart des networking Dienstes klappt es nicht.

    Woran könnte das liegen?

  2. #2
    Registrierter Benutzer
    Registriert seit
    Apr 2009
    Ort
    Erde
    Beiträge
    2.392
    Gruß nopes
    (,,,)---(^.^)---(,,,) /var/log/messages | grep cat

  3. #3
    Registrierter Benutzer Avatar von Freeze24
    Registriert seit
    Feb 2003
    Ort
    Oberpfalz
    Beiträge
    58
    Danke für die Antwort, das hilft mir allerdings leider nicht weiter.
    Der Postfix soll ja auf IPv6 lauschen und das tut er ja auch.
    Nur wenn ich den networking Dienst neu starte, verliert der Server jegliche v6 Verbindung (ganz unabhängig von postfix, das ist nur ein Nebeneffekt), was nicht sein sollte.

Ähnliche Themen

  1. Static Routes
    Von h0mer`- im Forum Router und Netzaufbau
    Antworten: 4
    Letzter Beitrag: 28.06.06, 08:13
  2. Kinternet mit Static IP
    Von aldaris im Forum Router und Netzaufbau
    Antworten: 2
    Letzter Beitrag: 23.11.05, 15:38
  3. Static Routes auf Red Hat 3.0
    Von Baertronics im Forum System installieren und konfigurieren
    Antworten: 2
    Letzter Beitrag: 06.07.04, 11:00
  4. PCMCIA WLAN geht mit static ip aber kein dhcp (debian sarge)
    Von baka im Forum Mobiles Linux, Notebook, PDA
    Antworten: 2
    Letzter Beitrag: 11.10.03, 20:46
  5. Static und Shared
    Von Kashmir im Forum Kompilieren von Kernel und Sourcen
    Antworten: 2
    Letzter Beitrag: 14.07.02, 11:07

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •