Anzeige:
Ergebnis 1 bis 3 von 3

Thema: webmin: Handles the name-based server www.my-domain.org on address *.

  1. #1
    Registrierter Benutzer
    Registriert seit
    Apr 2016
    Beiträge
    175

    webmin: Handles the name-based server www.my-domain.org on address *.

    Hallo ujnd guten Tag



    auf einem frisch auf Webmin angelegten Vhost hab ich eine folgendes Handle.


    Code:
    webmin: Handles the name-based server www.my-domain.org on address *.
    Was mich wundert ist - dass die Phrase so lautet:


    Code:
    Handles the name-based server www.my-domain.org on address *.

    und auf *.
    endet!?


    und nicht auf *.*


    update: hier die Direktiven:


    Code:
    DocumentRoot "/sites/www.my_domain.org"        /usr/local/apache/conf/vhost/vhost.conf (67)
    ServerName www.my_domain.org                   /usr/local/apache/conf/vhost/vhost.conf (68)
    <Directory "/sites/www.my_domain.org">
     allow from all                               /usr/local/apache/conf/vhost/vhost.conf (70)
     Options None                                 /usr/local/apache/conf/vhost/vhost.conf (71)
     Require all granted                          /usr/local/apache/conf/vhost/vhost.conf (72)
    </Directory>


    Annahme: *. sieht im Grunde Korrekt aus , * steht wohl für alle Adressen und der Punkt markiert das Ende im Handle.




    also : denke, das alles stimme muesste - dann sollte im Grunde wenn die Einträge des Nameservers alle stimmen dann sollte alles okay sein



    - was mich etwas wundert ist - dass es ansonstein in der Oberfläche so aussieht:


    Handles the name-based server www.the_domain_.org on all addresses



    also hier heißt es - on all adresses!?

    Das ist ein Unterschied...

    Freue mich auf einen Tipp



    update:


    hab noch einen ping test ausgeführt
    mit 10 ICMP-Paketen - verrschickt an den server

    resultat: - invalid host.​​


    Also - zwischenfazit: ​so wie es jetzt aussieht - scheint es wohl an den NS-Server- Einträgen zu liegen.
    Der Vhost sieht im Grunde eigentlich so aus - als wär er gut / und richtig aufgesetz..
    Geändert von diver (24.01.20 um 23:28 Uhr)
    Tools für Wordpress-Entwicklung http://wpgear.org/

  2. #2
    Registrierter Benutzer
    Registriert seit
    Apr 2016
    Beiträge
    175
    soweit ich alles verstanden habe sollte ich die directive aendern
    Code:
    .*. oder zu  *
    zu
    Code:
    .*
    jedenfalls denke ich dass das hier irgendwie komisch aussieht:

    Code:
    <VirtualHost *.>
    https://httpd.apache.org/docs/2.2/mo...ml#virtualhost

    <VirtualHost> und </VirtualHost> werden dazu verwendet, eine Gruppe von Direktiven zusammenzufassen, die nur auf einen bestimmten virtuellen Host angewendet werden. Jede Direktive, die im Virtual-Host-Kontext zulässig ist, kann verwendet werden. Wenn der Server eine Anfrage für ein bestimmtes Dokument eines bestimmten virtuellen Hosts empfängt, dann benutzt er die im <VirtualHost>-Container enthaltenen Konfigurationsanweisungen. Adresse kann sein:

    Die IP-Adresse des virtuellen Hosts.
    Ein voll qualifizierter Domainname für die IP-Adresse des virtuellen Hosts.
    Das Zeichen *, welches nur in Kombination mit NameVirtualHost * verwendet wird, um allen IP-Adressen zu entsprechen.
    Die Zeichenkette _default_, die nur mit IP-basierten virtuellen Hosts verwendet wird, um nicht zugewiesene IP-Adressen aufzufangen.

    example.

    Code:
    <VirtualHost 10.1.2.3>
    ServerAdmin webmaster@host.foo.com
    DocumentRoot /www/docs/host.foo.com
    ServerName host.foo.com
    ErrorLog logs/host.foo.com-error_log
    TransferLog logs/host.foo.com-access_log
    </VirtualHost>

    VirtualHost Examples*

    This document attempts to answer the commonly-asked questions about setting up virtual hosts. These scenarios are those involving multiple web sites running on a single server, via name-based or IP-based virtual hosts.

    https://httpd.apache.org/docs/2.4/vhosts/examples.html

    Running several name-based web sites on a single IP address.
    Your server has multiple hostnames that resolve to a single address, and you want to respond differently for www.example.com and www.example.org.

    Note Creating virtual host configurations on your Apache server does not magically cause DNS entries to be created for those host names. You must have the names in DNS, resolving to your IP address, or nobody else will be able to see your web site. You can put entries in your hosts file for local testing, but that will work only from the machine with those hosts entries.


    Using _default_ vhosts *_default_ vhosts for all ports
    Catching every request to any unspecified IP address and port, i.e., an address/port combination that is not used for any other virtual host.

    Code:
    <VirtualHost _default_:*>
    * * DocumentRoot "/www/default"
    </VirtualHost>
    Using such a default vhost with a wildcard port effectively prevents any request going to the main server.

    A default vhost never serves a request that was sent to an address/port that is used for name-based vhosts. If the request contained an unknown or no Host: header it is always served from the primary name-based vhost (the vhost for that address/port appearing first in the configuration file). You can use AliasMatch or RewriteRule to rewrite any request to a single information page (or script).


    *conclusio - ich glaube dass ich diese directive ggf. doch aendern sollte:_ *


    zu
    Code:
    .*. or to to *
    Tools für Wordpress-Entwicklung http://wpgear.org/

  3. #3
    Registrierter Benutzer
    Registriert seit
    Apr 2016
    Beiträge
    175
    hi @all


    was den Nameserver anbelangt: Soweit ich alles übersehen kann, sind die Einstellungen bei alle korrekt gesetzt.
    Die Domain ist auf die gewünschten Nameserver konnektiert, löst aber noch nicht auf. Bei einer Abfrage der Daten erhalte vom Primary nichts erhalten.Hier müssen die DNS Daten ggf. dann auch noch korrekt hinterlegt werden.

    Wie es jetzt weitergeht: ich glaube dass ich hier nochmals den Bau des vhost überprüfen sollte. Da stimmt was nicht.

    Ich guck mal nach - und melde mich wieder.


    update: also ich denke dass ich hier noch das Problem habe - bezüglich der Auflösung der Domain;
    Es scheint so dass der Primäre Nameserver keine Daten ausliefert.
    Es sieht ganz danach aus, dass dort keine Zonendaten zur Domain hinterlegt ist.
    ich muss noch die Zone auf dem gewünschten Primary anpassen, sodass die Domain auflösen soll.

    Werde alles überprüfen und mich wieder melden vg
    Geändert von diver (28.01.20 um 22:43 Uhr)
    Tools für Wordpress-Entwicklung http://wpgear.org/

Ähnliche Themen

  1. Postfix: Sender address rejected: Domain not found
    Von meinereinerseiner im Forum Linux als Server
    Antworten: 1
    Letzter Beitrag: 21.07.07, 00:24
  2. Antworten: 3
    Letzter Beitrag: 02.05.07, 21:41
  3. sendmail - 5.0.0 EHLO requires domain address
    Von Managor im Forum Linux als Server
    Antworten: 1
    Letzter Beitrag: 08.09.06, 15:06
  4. 5.0.0 EHLO requires domain address
    Von MaDDeePee im Forum Linux als Server
    Antworten: 7
    Letzter Beitrag: 12.10.04, 20:33
  5. Antworten: 1
    Letzter Beitrag: 21.09.01, 23:28

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •