Anzeige:
Ergebnis 1 bis 6 von 6

Thema: Datenträgerprüfung nach Nutzung von GNU-GRUB

  1. #1
    Registrierter Benutzer
    Registriert seit
    Feb 2018
    Beiträge
    31

    Datenträgerprüfung nach Nutzung von GNU-GRUB

    Linux Mint 19.2 Cinnamon
    Cinnamon-Version 4.2.4
    Linux-Kernel 4.15.0-72-generic


    Hallo

    Ich benutze 3 Betriebssysteme getrennt auf drei Festplatten.
    Linux Mint Cinnamon, Win7 und Win10.
    Linux Mint als Hauptsystem benutze ich primär fürs Internet.
    Diese Festplatte enthält auch GNU-GRUB und ist im UEFI als Startplatte deklariert.
    Alle drei Festplatten sind im MBR-Format formatiert.

    Über GNU-GRUB als Bootmanager starte ich also auch meine anderen Betriebssysteme.
    Dabei zeigt sich allerdings, das das auf diese Weise gestartete Win7 oder Win10
    eine automatische Datenträgerprüfung auslöst.

    Kann mir jemand sagen, was der Grund für diese Datenträgerprüfung ist?
    Liegt das an GNU-GRUB oder an Win7 / Wind10?

    Habe das auch mit verschiedenen FP getestet. Eine nagelneue HDD und eine nagelneue SSD
    für Win10. Es bleibt dabei: Wenn ich Win7 oder Win10 von GNU-GRUB
    aus starte, soll eine Datenträgerprüfung (entweder durch Win7 oder durch Win10) durchgeführt werden.

    Starte ich Windows 7/10 NICHT über GNU-GRUB so wird nur noch einmalig
    eine Datenträgerprüfung durchgeführt und dann ist ruhe.
    Dies lässt mich vermuten, das GNU-GRUB irgendwie die Datenträgerprüfungen auslöst
    was doch eigentlich nicht sein dürfte.

    Als Notlösung habe ich nun auf der Win7 sowie auf der Win10-Platte über die Registry
    die automatische Datenträgerpüfung unterbunden. Bei Win7 klappt das gut.
    Dort wird nun beim Systemstart keine Datenträgerprüfung mehr ausgeführt.
    Bei Win10 ist es ebenso, allerdings erscheint hier nun rechts unten des öfteren
    der Hinweis, das eine Datenträgerprüfung durchgeführt werden sollte.
    Nun könnte ich diese Meldung sicherlich auch noch abschalten aber ich würde gerne
    sinvollerweise die Ursache des Problems kennen und beseitigen.

    GNU-GRUB (2.02) ist ausschliesslich auf der Linux-Festplatte eingerichtet.
    Dies habe ich mir über Linux anzeigen lassen.
    Und man kann ganz sicherlich davon ausgehen das die Festplatten in Ordnung sind.
    Desshalb habe ich das auch extra zusätzlich mit neuen FP und frisch installierten
    Windows10 abermals getestet.

    Weiss hier jemand Rat?



    Grüsse :-)

  2. #2
    Mod. FAQ/Howto/Emulation
    Registriert seit
    Sep 2000
    Beiträge
    17.330
    Bei Windows sollte die Schnellstartoption in Dual Boot Konfigurationen deaktiviert werden.

  3. #3
    Registrierter Benutzer
    Registriert seit
    Feb 2018
    Beiträge
    31
    Hallo Stefan
    Das werde ich gleich mal bei beiden Win-Systemen prüfen und dann ggf. deaktivieren
    (obwohl hier in meinem Fall ja kein Dual-Boot vorliegt).
    Danke. Ich poste dann das Ergebnis.

  4. #4
    Registrierter Benutzer
    Registriert seit
    Feb 2018
    Beiträge
    31
    Leider gibt es diese Option bei mir weder in Win7 noch in Win10.

    Deaktivieren Schnellstart:
    https://www.heise.de/tipps-tricks/Wi...n-4000088.html

    Im UEFI ist bei mir FAST-BOOT deaktivert.

  5. #5
    Registrierter Benutzer
    Registriert seit
    Mar 2009
    Beiträge
    153
    Hallo extron,

    beachte bitte auch das insbesondere unter W10 "Herunterfahren" nicht mehr herunterfahren bedeutet. Dies trifft u.U. ebenso auf W7 zu.
    Die Datenträgerprüfung solltest Du nicht deaktivieren. Wenn diese anläuft ist das Dateisystem nicht mehr 100% konsistent.

    Teste bitte folgendes: Beende beide "Windosen" immer mit "Neustart" - das sollte kein Problem sein denn Du läufst ja wieder in den Grub-Bootloader und kannst wählen bzw. dort dann abschalten.
    Wenn der Fehler durch "Neustart" nicht auftritt, kannst Du Win10/7 so umkonfigurieren das es "richtig" herunterfährt. Nachteil: die Windosen brauchen damit natürlich länger zum starten - aber in diesen sauren Apfel musst du dann beißen...

    Hast Du den Fehler trotzdem noch, liege ich falsch und es ist was anderes

    Gruß

    Tom

  6. #6
    Registrierter Benutzer
    Registriert seit
    Feb 2018
    Beiträge
    31
    Hi
    Habe folgendes gemacht:
    Habe die automatische Datenträgerprüfung in der Registry auf der Win7 und der Win10 -Festplatte wieder aktiviert.
    Nach dem Start (über GNU-GRUB) der Win10-Platte startete wie erwartet wieder die automatische Datenträgerprüfung.
    Diese hat die Festplatte auf der sich Win7 befindet gescannt und dort einen Fehler behoben.
    Seit dem ist ruhe mit dem automatischen Datenträgerprüfungen beim Systemstart von Win7 und Win10 über GNU-GRUB.
    Habe mehrfache Systemstarts aller drei Systeme (Platten) durchgeführt. Alles scheint nun wieder ohne Probleme zu funktionieren.
    Vielen Dank für eure Hilfe und ein frohes neues Jahr 2020 :-)

Ähnliche Themen

  1. Nach Nutzung von VMWare bleibt X hängen
    Von Kevin26 im Forum Virtuelle Maschinen und Emulatoren
    Antworten: 2
    Letzter Beitrag: 15.01.07, 18:55
  2. vmware nach nutzung wird profil nicht syncronisiert
    Von ramsys im Forum Linux in heterogenen Netzen
    Antworten: 3
    Letzter Beitrag: 29.12.06, 17:10
  3. Kein Bild mit xawtv4 nach Nutzung von Totem
    Von Simpel im Forum Fernsehen
    Antworten: 1
    Letzter Beitrag: 22.02.06, 19:27
  4. Nach Linux Nutzung startet Windows im interlaced Modus
    Von AlexPausB im Forum stationäre Hardware
    Antworten: 0
    Letzter Beitrag: 24.08.04, 09:01
  5. Sound weg, nach kurzer Nutzung von xmms
    Von luckyloop im Forum Musik
    Antworten: 1
    Letzter Beitrag: 26.11.03, 07:43

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •