Anzeige:
Ergebnis 1 bis 6 von 6

Thema: USB HDD wird immer als /dev/sda erkannt...

  1. #1
    ganz altes Inventar Avatar von robert
    Registriert seit
    Apr 1999
    Ort
    Rheinstetten
    Beiträge
    1.023

    Question USB HDD wird immer als /dev/sda erkannt...

    Hallo!

    Ich habe an meinem Home-Server eine externes (Hardware RAID1) Laufwerk über USB 3.x angeschlossen. Dieses wird dann über LVM ins System integriert.
    Allerdings, jedes mal wenn ich das System neu starte (z.B. Kernel-Updates...), wird das externe USB Laufwerk als /dev/sda beim Booten erkannt. Im BIOS sind aber alle statischen Laufwerke korrekt eingestellt und werden auch vom System in der korrekten Reihenfolgen erkannt. Leider werden in dem BIOS keine USB Laufwerke angezeigt und können somit auch nicht in der Reihenfolgen geändert werden. Da aber das System trotzdem von der korrekten Festplatten bootet, scheint Linux immer das externe USB Laufwerk als /dev/sda einzubinden (und nicht das BIOS). Das System läuft dann zwar korrekt, aber ich möchte eigentlich nicht ein externes USB Laufwerk als /dev/sda haben, sondern als letztes Laufwerk haben.
    Seltsamerweise habe ich noch ein anderes externes USB 3.x Gehäuse mit 4 Wechselplatten angeschlossen und diese werden korrekt als letzte Laufwerke (also alles was nach den statischen Laufwerken kommt...) eingebunden.

    Hat jemand eine Idee, wie ich verhindern kann, dass beim Booten dieses USB Laufwerk als /dev/sda eingebunden wird?

    Die einzige Lösung die ich bis jetzt gefunden habe, ist das USB Laufwerk beim Booten auszustecken und erst beim Boot-vorgang, wenn z.B. das LVM eingebunden wird, wieder einzustecken. Das heißt aber auch, dass ich bei einem Neustart jedes mal neben dem Server stehen muss, welcher in einem Keller-Raum steht. Sehr umständlich...

    Danke und Gruß
    Robert

  2. #2
    PaganicaPro@SlopePointNZ Avatar von craano
    Registriert seit
    Jul 2004
    Beiträge
    1.274
    Moin,
    ist das eigentlich egal unter welchem Device Namen die Laufwerke eingebunden werden.
    Alles was mit LVM zu tun hat sprichst Du doch eh über die Volumes an.

    Wie werden denn die anderen internen HDDs erkannt?
    Eventuell könntest Du auch die UUID in der /etc/fstag angeben.

    Herzlichen Gruß
    craano

  3. #3
    ganz altes Inventar Avatar von robert
    Registriert seit
    Apr 1999
    Ort
    Rheinstetten
    Beiträge
    1.023
    Im Prinzip ist es egal in welcher Reihenfolge die Laufwerke angesprochen werden, da beim Booten ja alles korrekt läuft.
    Ist aber sehr irritierend, wenn das Root-Laufwerk nicht auf /dev/sda liegt. Für mich zumindest...
    Die internen Laufwerke werden ja alle korrekt (wie im Bios eingestellt) erkannt. Nur dieses eine USB Laufwerk wird als /dev/sda zugewiesen, was ich nicht wirklich verstehe.

    Ja, ich mache schon alles mit UUID, also es liegt kein Problem mit der fstab oder anderen Sachen vor. Auch LVM läuft ohne Probleme.
    Ist halt nur sehr ungewöhnlich, dass dieses USB Laufwerk immer als /dev/sda zugewiesen wird. Ich würde das gerne ändern.

  4. #4
    Registrierter Benutzer
    Registriert seit
    Dec 2003
    Ort
    Dettenhausen
    Beiträge
    21.353
    ... dann halt eine entsprechende UDEV-Rule definieren.
    Ich bin root - ich darf das.

  5. #5
    ganz altes Inventar Avatar von robert
    Registriert seit
    Apr 1999
    Ort
    Rheinstetten
    Beiträge
    1.023
    Zitat Zitat von marce Beitrag anzeigen
    ... dann halt eine entsprechende UDEV-Rule definieren.
    Würde ich gerne, nur kenne ich mich nicht wirklich mit udev aus und habe mich auch noch nie tiefgehend damit beschäftigt.
    Müsste wohl erst mal googln...

  6. #6
    Registrierter Benutzer
    Registriert seit
    Aug 2007
    Ort
    Sauerland
    Beiträge
    1.256
    Bei openSUSE ist das Verhalten ein Fallback:
    More Solid Device Names in fstab and crypttab

    Back to topics related to storage management, you surely know there are several ways to specify a device to be mounted in the /etc/fstab file or a device to be activated in the /etc/crypttab. Apart from using directly the name of the device (like /dev/sda1) or any of its alternative names based on udev, you can also use the UUID or the label of the file-system or of the LUKS device.

    By default, YaST will use the udev path in s390 systems and the UUID in any other architecture. Although that’s something that can be configured modifying the /etc/sysconfig/storage file or simply using this screen of the Partitioner, which makes possible to change how the installation (both the Guided Setup and the Expert Partitioner) writes the resulting fstab and crypttab files.

    But, what happens when the default option (like the udev path) is not a valid option for some particular device? So far, YaST simply used the device name (e.g. /dev/sda1) as an immediate fallback. That happened at the very end of the process, when already writing the changes to disk.

    We have improved that for Tumbleweed, for SLE-15-SP1 (which implies Leap 15.1) and for the upcoming versions of (open)SUSE. Now, if the default value is not suitable for a particular device because the corresponding udev path does not exists, because using a given name is incompatible with the chosen encryption method, or for any other reason, YaST will fall back to the most reasonable and stable alternative. And it will do it from the very beginning of the process, being immediately visible in the Partitioner.

Ähnliche Themen

  1. Antworten: 3
    Letzter Beitrag: 01.07.18, 13:27
  2. USB-Drucker unter opensuse 10.3 immer wieder neu erkannt
    Von mirkux im Forum stationäre Hardware
    Antworten: 0
    Letzter Beitrag: 27.10.07, 17:26
  3. öffnen von .rpm-dateien in ubuntu (motzt immer: archivtyp nicht erkannt)
    Von thademon im Forum Anwendungen Allgemein, Software
    Antworten: 15
    Letzter Beitrag: 01.06.07, 14:56
  4. Antworten: 5
    Letzter Beitrag: 19.02.05, 13:17
  5. Maus wird nicht immer erkannt beim Start von KDE
    Von ylares im Forum stationäre Hardware
    Antworten: 4
    Letzter Beitrag: 18.08.03, 00:37

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •