Anzeige:
Ergebnis 1 bis 5 von 5

Thema: Unknown module pam_mount

  1. #1
    PaganicaPro@SlopePointNZ Avatar von craano
    Registriert seit
    Jul 2004
    Beiträge
    1.238

    Unknown module pam_mount

    Hallo,
    ich versuche pam_mount auf eine opensuse Leap 15.1 Box zu einzurichten

    Das Modul wird beim Login nicht durchlaufen, weil es vom System überhaupt nicht gefunden wird; unabhängig ob ich es in common-auth, common-session oder common-account aufrufe.

    Code:
    dm2:~ # pam-config --verify
    /etc/pam.d/common-auth-pc: Unknown module pam_mount.so, ignored!
    dm2:~ # 
    dm2:~ # ls -l /lib64/security/pam_mount.so
    -rwxr-xr-x 1 root root 68632 Sep 29 23:18 /lib64/security/pam_mount.so
    dm2:~ # 
    dm2:~ # ls /etc/security/pam_mount.conf.xml
    /etc/security/pam_mount.conf.xml
    Deinstallieren und reinstallieren habe ich bereits versucht.

    Code:
    dm2:~ # zypper rm pam_mount
    dm2:~ # zypper in -f pam_mount
    Was ist hier los?
    Unter welchem Namen kann ich pam_mount.so aufrufen?

    Die Datei /etc/security/pam_mount.conf.xml ist vorhanden und auch richtig konfiguriert.

    Gruß
    craano

  2. #2
    PaganicaPro@SlopePointNZ Avatar von craano
    Registriert seit
    Jul 2004
    Beiträge
    1.238
    OK, ich bin einen Schritt weiter.
    Manchmal hilft RTFM!
    In der Manpage von pam-config steht es etwas versteckt:
    SINGLE SERVICE MODULES
    These modules can only be added to single service files. See also the section called "USAGE EXAMPLES".
    ...
    --mount
    Enable/Disable pam_mount.so
    ...
    USAGE EXAMPLES
    ...
    pam-config --service gdm -a --mount
    Enable pam_mount.so for service gdm.
    Jetzt muss ich wohl alle möglichen Module der verschiedenen Möglichkeiten sich am System anzumelden.
    Das wären dann wohl: login, sddm, sshd, su, su-l, sudo, sudo-i

    Oder kennt noch jemand ein Modul, dass immer bei einer Anmeldung aufgerufen wird und eben nicht mit common-* beginnt?

    HG
    craano

  3. #3
    Registrierter Benutzer
    Registriert seit
    Dec 2003
    Ort
    Dettenhausen
    Beiträge
    21.158
    Da ich Deine restliche Config drumherum nicht kenne - https://wiki.archlinux.org/index.php/Pam_mount sieht eigentlich nach einem weniger "komplexen" Weg aus.
    Ich bin root - ich darf das.

  4. #4
    kleine schwester von root Avatar von corresponder
    Registriert seit
    May 2002
    Ort
    192.67.198.56
    Beiträge
    4.135
    Zitat Zitat von craano Beitrag anzeigen
    Manchmal hilft RTFM!
    butte ersetze "manchmal" durch IMMER!

    ;-P
    _______________________________________

    www.audio4linux.de - musik machen mit offenen quellen!

  5. #5
    PaganicaPro@SlopePointNZ Avatar von craano
    Registriert seit
    Jul 2004
    Beiträge
    1.238
    Hallo Marce,

    Zitat Zitat von marce Beitrag anzeigen
    Da ich Deine restliche Config drumherum nicht kenne - https://wiki.archlinux.org/index.php/Pam_mount sieht eigentlich nach einem weniger "komplexen" Weg aus.
    Ja, genauso habe ich es jetzt gemacht.

    Anders als im Arch Wiki verwende sddm als Display Manager und muss daher in /etc/pam.d/sddm die Zeile für pam_mount eingetragen.
    Code:
    #%PAM-1.0
    auth     include        common-auth
    account  include        common-account
    password include        common-password
    session  required       pam_loginuid.so
    session optional        pam_mount.so disable_interactive
    session  include        common-session
    Ich wollte es anfangs in /etc/pam.d/common-session eingetragen, dann würde pam_mount jedem Login (unabhängig ob tty, pts, Display Manager oder ssh) ausgeführt. Ich habe sehr lange gebraucht, bis ich herausgefunden hatte, dass in /etc/pam.d/common-session pam_mount ignoriert wird, weil man es dort nicht eingetragen darf. Was das soll - keine Ahnung?!
    Laut manpage von pam-config kann das Modul nur in Single Service Files und nicht in Global Service Files eingetragen werden. Würde dieser Hinweis direkt in man pam_mount stehen, hätte ich mir viel Debug-zeit gespart!

    HG
    craano

Ähnliche Themen

  1. Antworten: 5
    Letzter Beitrag: 07.10.14, 05:52
  2. V4L - Unknown symbol in module
    Von blabub im Forum Kompilieren von Kernel und Sourcen
    Antworten: 0
    Letzter Beitrag: 10.01.07, 17:36
  3. pam_mount
    Von funnix im Forum Linux Allgemein
    Antworten: 1
    Letzter Beitrag: 31.03.05, 09:24
  4. Anmeldung klappt nicht - Module is unknown
    Von Cougar im Forum Linux Allgemein
    Antworten: 1
    Letzter Beitrag: 28.11.04, 18:18
  5. Debian: passwd: Module is unknown
    Von tassadar im Forum Linux als Server
    Antworten: 0
    Letzter Beitrag: 15.09.04, 12:37

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •