Anzeige:
Ergebnis 1 bis 5 von 5

Thema: gpg-agent Log Einträge unterdrücken

  1. #1
    Registrierter Benutzer
    Registriert seit
    Dec 2016
    Beiträge
    6

    gpg-agent Log Einträge unterdrücken

    Hallo liebe Gemeinde,

    ich habe das Problem, dass systemd Meldungen zu gpg-agent mein syslog zuspammen:

    Sep 13 13:48:22 server systemd[21528]: Listening on GnuPG cryptographic agent (ssh-agent emulation).
    Sep 13 13:48:22 server systemd[21528]: Starting D-Bus User Message Bus Socket.
    Sep 13 13:48:22 server systemd[21528]: Listening on GnuPG cryptographic agent and passphrase cache (access for web browsers).
    Sep 13 13:48:22 server systemd[21528]: Reached target Timers.
    Sep 13 13:48:22 server systemd[21528]: Reached target Paths.
    Sep 13 13:48:22 server systemd[21528]: Listening on GnuPG cryptographic agent and passphrase cache (restricted).
    Sep 13 13:48:22 server systemd[21528]: Listening on GnuPG network certificate management daemon.
    Sep 13 13:48:22 server systemd[21528]: Listening on D-Bus User Message Bus Socket.
    Sep 13 13:48:22 server systemd[21528]: Reached target Sockets.
    Sep 13 13:48:22 server systemd[21528]: Reached target Basic System.
    Sep 13 13:48:22 server systemd[21528]: Reached target Default.
    Sep 13 13:48:22 server systemd[21528]: Startup finished in 35ms.

    Soweit ich es verstehe, passiert das aufgrund des Zusammenspiels von sshd und gpg-agent und kommt bei jedem ein- und ausloggen per ssh. Ich möchte die Meldungen gerne unterdrücken.
    Im Netz habe ich einen syslog-filter gefunden, aber der bekämpft ja nur das Symptom. Ich würde lieber die Meldung im systmed/gpg-agent unterdrücken.
    Brauch ich den agent überhaupt und was macht der? Ich betreibe mehrere VMs mit Ubuntu 18.04.3 LTS bezw. desktop, allerdings ohne GUI, sondern nur per text terminal.
    Ich logge mich immer mit benutzer/passwort ein oder habe keine Scripte, die per ssh Daten zwischen VMs austauschen.
    Ich brauche auch keine komplexe user Verwaltung, da nur ich mich als user oder root einlogge.

    Viele Grüße

  2. #2
    kleine schwester von root Avatar von corresponder
    Registriert seit
    May 2002
    Ort
    192.67.198.56
    Beiträge
    4.138
    https://gnupg.org/documentation/manu...t-Options.html

    Code:
    --debug-level level
    
        Select the debug level for investigating problems. level may be a numeric value or a keyword:
    
        none
    schon versucht?
    _______________________________________

    www.audio4linux.de - musik machen mit offenen quellen!

  3. #3
    Registrierter Benutzer
    Registriert seit
    Dec 2016
    Beiträge
    6
    Hallo,

    sorry, hat ein paar Tage gedauert bis ich wieder online war.
    Wo kann ich das denn eintragen? Es gibt kein file in /etc oder so. Es läuft auch kein Dienst permanent (ps ax).
    Das Paket gpg-agent ist aber installiert. Mit dpkg-query -L sehe ich auch, dass es einen systemd service und ein socket file gibt. Die scheinen aber nicht aktiv oder nicht im Suchpfad zu sein, da systemctl status bei beiden 'not found' ausgibt.

    Mir scheint sshd nutzt das über den Socket?! Es gibt aber keinen Hinweis darauf in der sshd_config. Es gibt kein PAM Modul oder so.
    Ich habe keine Ahnung, was da abläuft und wie das reinkonfiguriert ist. Ich habe auch keinen Windows Manager, der das irgendwie mit starten könnte,sondern eine reine Konsolen-Installation.
    Ich weiss auch nicht, ob man es einfach deinstallieren kann oder ob ich mich danach nicht mehr anmelden kann.

  4. #4
    kleine schwester von root Avatar von corresponder
    Registriert seit
    May 2002
    Ort
    192.67.198.56
    Beiträge
    4.138
    leg doch die config in /etc an.....
    _______________________________________

    www.audio4linux.de - musik machen mit offenen quellen!

  5. #5
    Registrierter Benutzer
    Registriert seit
    Dec 2016
    Beiträge
    6
    Ich habe das Paket jetzt deinstalliert. Ich sehe den Mehrwert in meiner Installation nicht.
    Dennoch habe ich jetzt immer noch eine Zeile in meinem Log:
    Sep 17 11:16:30 server systemd[24791]: Listening on GnuPG network certificate management daemon.

    Damit lebe ich jetzt aber.
    Vielen Dank für die Hilfe.

Ähnliche Themen

  1. Antworten: 6
    Letzter Beitrag: 19.02.14, 16:27
  2. Tungsten E2 + Kpilot = doppelte Einträge/Einträge gelöscht
    Von ZeiTw1Nd3r im Forum Mobiles Linux, Notebook, PDA
    Antworten: 0
    Letzter Beitrag: 29.09.08, 16:29
  3. VNC& GPG-Agent
    Von Scoutman im Forum Linux als Server
    Antworten: 0
    Letzter Beitrag: 18.01.05, 21:26
  4. Suche WWW-Agent
    Von prostetnik im Forum Anwendungen Allgemein, Software
    Antworten: 2
    Letzter Beitrag: 14.01.03, 13:03
  5. User Agent
    Von DaGrrr im Forum Sicherheit
    Antworten: 5
    Letzter Beitrag: 20.08.02, 05:42

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •