Anzeige:
Ergebnis 1 bis 2 von 2

Thema: ZFS RAM Problem

  1. #1
    Registrierter Benutzer
    Registriert seit
    Jan 2010
    Beiträge
    10

    ZFS RAM Problem

    Guten Abend Linuxforen Community.

    Ich bin hier neu und hoffe den richtgen Thema bereich erwischt zu haben. vor weg ich kenne mich nicht gut aus mit ZFS

    folgendes habe ein Test system daheim mit Proxmox und Raid0 als zfs.

    i5 9400
    4x 250gb ssd
    32gb ram

    aktuell laufen 8vms mit insgesammt 18gb eingestellte Ram (mit balloming das sie nicht mehr nehmen dürfen) Habe mit dem ram was anderes vor gehabt.

    Mein Problem ist jetzt das zfs so viel ram zieht. Da mein Mainboard kein raid kann musste ich es via software machen. Aktuell nutzt er 30gb ram. normal sollte er doch ca 20gb nehmen.

    Folgendes habe ich schon gemacht

    bei mir gab "/etc/modprobe.d/zfs.conf " datei nicht da habe ich sie von hand erstellt und

    "options zfs zfs_arc_max=1073741824" eingefügt für ein 1GB Ram.

    [laut proxmox wiki https://pve.proxmox.com/wiki/ZFS_on_Linux]

    habe dann das system neu gestartet und leider kein erfolg.


    dann habe ich nach langen googlen. arcstat gefunden.

    also arcstat sagt folgendes:

    options zfs zfs_arc_max=1073741824root@pve:~# arcstat
    time read miss miss% dmis dm% pmis pm% mmis mm% arcsz c
    20:06:33 32 0 0 0 0 0 0 0 0 15G 15G

    wie kann ich es minimal einstellen und für was braucht zfs überhaupt so viel ram?

    ich bedanke mich für jede antowort

  2. #2
    Registrierter Benutzer
    Registriert seit
    Dec 2003
    Ort
    Dettenhausen
    Beiträge
    21.143
    Was man konkret ändern kann - keine Ahnung.

    ZFS nutzt massiv RAM für caching und seine interne Verwaltungs-/Organisationsstruktur.

    Aus genau dem Grund sind wir bei unseren zentralen NFS-Storage von ZFS auf ext4 gewechselt. ZFS ist, was den Ressourcenverbrauch angeht, unter Linux irgendwie noch nicht "production-ready".

    Gibt's konkrete Gründe, warum Du ZFS einsetzen willst?
    Ich bin root - ich darf das.

Ähnliche Themen

  1. Antworten: 16
    Letzter Beitrag: 08.05.17, 18:52
  2. komisches Problem mit antinat (könnte allgemeines Problem sein!)
    Von Cluster5020 im Forum Router und Netzaufbau
    Antworten: 1
    Letzter Beitrag: 03.09.08, 18:35
  3. ssh-x problem (gibts oft hier, ist aber neues problem)
    Von Mendark im Forum Linux als Server
    Antworten: 5
    Letzter Beitrag: 03.01.05, 12:43
  4. Antworten: 2
    Letzter Beitrag: 27.05.04, 12:15
  5. Antworten: 8
    Letzter Beitrag: 06.01.04, 17:16

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •