Anzeige:
Ergebnis 1 bis 8 von 8

Thema: Java unter Linux Mint

  1. #1
    Registrierter Benutzer
    Registriert seit
    Aug 2019
    Beiträge
    4

    Java unter Linux Mint

    Moin,

    in den letzten 20+ Jahren hatte ich immer mal wieder Kontakt mit Linux, generell würde ich mich aber als Anfänge betrachten.
    Ja ich habe die Suchfunktion genutzt und auch im FaQ gelesen, bin aber leider nicht weiter gekommen...

    Aber nun zu meinem Problem:
    Ich habe ein älteres Lenovo ThinkPad (i5-4300M CPU), auf welchem Linux Mint 17.2 Cinnamon 64-bit läuft.

    Standardmäßig ist openjdk7 installiert, allerdings benötige ich Java 8.

    Bisher probiert habe ich folgendes:
    sudo add-apt-repository ppa:webupd8team/java (die Ausgabe findet ihr weiter unten unter: "1."

    Gefolgt von: sudo apt update (siehe "2.")

    Und zu guter Letzt: sudo apt install oracle-java8-installer (siehe "3.")


    Es wäre schön, wenn mir jemand zielführende Tips geben könnte.

    Viele Grüße

    tribbel42

    PS: Ja, ich weiß, dass ein Lesen des ersten Abschnitts schon gereicht haben sollte, um das Problem selbständig zu beheben, allerdings kam ich mit den Links (so sie überhaupt funktionierten) auch nicht wirklich weiter...


    1.Sie sind dabei Ihrem System das folgende PPA hinzuzufügen:
    The Oracle JDK License has changed for releases starting April 16, 2019.

    The new Oracle Technology Network License Agreement for Oracle Java SE is substantially different from prior Oracle JDK licenses. The new license permits certain uses, such as personal use and development use, at no cost -- but other uses authorized under prior Oracle JDK licenses may no longer be available. Please review the terms carefully before downloading and using this product. An FAQ is available here: https://www.oracle.com/technetwork/j...-jdk-faqs.html

    Oracle Java downloads now require logging in to an Oracle account to download Java updates, like the latest Oracle Java 8u211 / Java SE 8u212. Because of this I cannot update the PPA with the latest Java (and the old links were broken by Oracle).

    For this reason, THIS PPA IS DISCONTINUED (unless I find some way around this limitation).

    Oracle Java (JDK) Installer (automatically downloads and installs Oracle JDK8). There are no actual Java files in this PPA.

    Important -> Why Oracle Java 7 And 6 Installers No Longer Work: http://www.webupd8.org/2017/06/why-o...allers-no.html

    Update: Oracle Java 9 has reached end of life: http://www.oracle.com/technetwork/ja...s-3848520.html

    The PPA supports Ubuntu 18.10, 18.04, 16.04, 14.04 and 12.04.

    More info (and Ubuntu installation instructions):
    - http://www.webupd8.org/2012/09/insta...u-via-ppa.html

    Debian installation instructions:
    - Oracle Java 8: http://www.webupd8.org/2014/03/how-t...in-debian.html

    For Oracle Java 11, see a different PPA -> https://www.linuxuprising.com/2019/0...or-ubuntu.html
    Mehr Informationen: https://launchpad.net/~webupd8team/+archive/ubuntu/java
    Zum Fortfahren bitte die Eingabetaste drücken oder Strg+C, um das Hinzufügen abzubrechen

    Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.uXQRfoKEJ4 --no-auto-check-trustdb --trust-model always --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyring /etc/apt/trusted.gpg.d/steam.gpg --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys EEA14886
    gpg: Schlüssel EEA14886 von hkp-Server keyserver.ubuntu.com anfordern
    gpg: Schlüssel EEA14886: "Totally Legit Signing Key <mallory@example.org>" nicht geändert
    gpg: Anzahl insgesamt bearbeiteter Schlüssel: 1
    gpg: unverändert: 1



    2.
    OK http://security.ubuntu.com trusty-security InRelease
    OK http://repo.steampowered.com precise InRelease
    Ign http://dl.google.com stable InRelease
    Ign http://archive.ubuntu.com trusty InRelease
    Ign http://archive.canonical.com trusty InRelease
    OK http://repo.steampowered.com precise/steam Sources
    Holen: 1 http://ppa.launchpad.net trusty InRelease [15,5 kB]
    OK http://security.ubuntu.com trusty-security/main amd64 Packages
    OK http://archive.ubuntu.com trusty-updates InRelease
    OK http://dl.google.com stable Release.gpg
    OK http://archive.canonical.com trusty Release.gpg
    OK http://security.ubuntu.com trusty-security/restricted amd64 Packages
    Ign http://ppa.launchpad.net trusty InRelease
    OK http://repo.steampowered.com precise/steam amd64 Packages
    OK http://archive.ubuntu.com trusty Release.gpg
    OK http://archive.canonical.com trusty Release
    OK http://dl.google.com stable Release
    OK http://security.ubuntu.com trusty-security/universe amd64 Packages
    OK http://archive.ubuntu.com trusty-updates/main amd64 Packages
    OK http://archive.canonical.com trusty/partner amd64 Packages
    OK http://repo.steampowered.com precise/steam i386 Packages
    OK http://security.ubuntu.com trusty-security/multiverse amd64 Packages
    OK http://dl.google.com stable/main amd64 Packages
    OK http://archive.ubuntu.com trusty-updates/restricted amd64 Packages
    OK http://archive.canonical.com trusty/partner i386 Packages
    Ign http://ppa.launchpad.net trusty/main Sources/DiffIndex
    Ign http://extra.linuxmint.com rafaela InRelease
    Ign http://packages.linuxmint.com rafaela InRelease
    OK http://security.ubuntu.com trusty-security/main i386 Packages
    OK http://archive.ubuntu.com trusty-updates/universe amd64 Packages
    OK http://archive.canonical.com trusty/partner Translation-en
    OK http://security.ubuntu.com trusty-security/restricted i386 Packages
    OK http://archive.ubuntu.com trusty-updates/multiverse amd64 Packages
    OK http://security.ubuntu.com trusty-security/universe i386 Packages
    Ign http://ppa.launchpad.net trusty/main amd64 Packages/DiffIndex
    OK http://archive.ubuntu.com trusty-updates/main i386 Packages
    OK http://security.ubuntu.com trusty-security/multiverse i386 Packages
    OK http://archive.ubuntu.com trusty-updates/restricted i386 Packages
    OK http://packages.linuxmint.com rafaela Release.gpg
    OK http://security.ubuntu.com trusty-security/main Translation-en
    OK http://extra.linuxmint.com rafaela Release.gpg
    OK http://archive.ubuntu.com trusty-updates/universe i386 Packages
    OK http://security.ubuntu.com trusty-security/multiverse Translation-en
    Ign http://ppa.launchpad.net trusty/main i386 Packages/DiffIndex
    OK http://archive.ubuntu.com trusty-updates/multiverse i386 Packages
    OK http://security.ubuntu.com trusty-security/restricted Translation-en
    OK http://archive.ubuntu.com trusty-updates/main Translation-en
    OK http://security.ubuntu.com trusty-security/universe Translation-en
    OK http://archive.ubuntu.com trusty-updates/multiverse Translation-en
    OK http://archive.ubuntu.com trusty-updates/restricted Translation-en
    OK http://archive.ubuntu.com trusty-updates/universe Translation-en
    OK http://archive.ubuntu.com trusty Release
    OK http://packages.linuxmint.com rafaela Release
    OK http://extra.linuxmint.com rafaela Release
    OK http://archive.ubuntu.com trusty/main amd64 Packages
    OK http://ppa.launchpad.net trusty/main Translation-en
    OK http://archive.ubuntu.com trusty/restricted amd64 Packages
    OK http://ppa.launchpad.net trusty/main Sources
    Ign http://dl.google.com stable/main Translation-de_DE
    OK http://archive.ubuntu.com trusty/universe amd64 Packages
    Ign http://dl.google.com stable/main Translation-de
    OK http://archive.ubuntu.com trusty/multiverse amd64 Packages
    OK http://ppa.launchpad.net trusty/main amd64 Packages
    Ign http://dl.google.com stable/main Translation-en
    OK http://archive.ubuntu.com trusty/main i386 Packages
    OK http://packages.linuxmint.com rafaela/main amd64 Packages
    OK http://extra.linuxmint.com rafaela/main amd64 Packages
    OK http://archive.ubuntu.com trusty/restricted i386 Packages
    OK http://ppa.launchpad.net trusty/main i386 Packages
    OK http://archive.ubuntu.com trusty/universe i386 Packages
    OK http://archive.ubuntu.com trusty/multiverse i386 Packages
    OK http://archive.ubuntu.com trusty/main Translation-de
    OK http://archive.ubuntu.com trusty/main Translation-en
    OK http://packages.linuxmint.com rafaela/upstream amd64 Packages
    OK http://extra.linuxmint.com rafaela/main i386 Packages
    OK http://archive.ubuntu.com trusty/multiverse Translation-de
    OK http://archive.ubuntu.com trusty/multiverse Translation-en
    OK http://archive.ubuntu.com trusty/restricted Translation-de
    OK http://archive.ubuntu.com trusty/restricted Translation-en
    OK http://archive.ubuntu.com trusty/universe Translation-de
    OK http://packages.linuxmint.com rafaela/import amd64 Packages
    OK http://archive.ubuntu.com trusty/universe Translation-en
    Ign http://ppa.launchpad.net trusty/main Translation-de_DE
    Ign http://ppa.launchpad.net trusty/main Translation-de
    OK http://packages.linuxmint.com rafaela/main i386 Packages
    OK http://packages.linuxmint.com rafaela/upstream i386 Packages
    Ign http://archive.ubuntu.com trusty/main Translation-de_DE
    Ign http://archive.ubuntu.com trusty/multiverse Translation-de_DE
    Ign http://archive.ubuntu.com trusty/restricted Translation-de_DE
    Ign http://archive.ubuntu.com trusty/universe Translation-de_DE
    OK http://packages.linuxmint.com rafaela/import i386 Packages
    Ign http://extra.linuxmint.com rafaela/main Translation-de_DE
    Ign http://extra.linuxmint.com rafaela/main Translation-de
    Ign http://extra.linuxmint.com rafaela/main Translation-en
    Ign http://repo.steampowered.com precise/steam Translation-de_DE
    Ign http://repo.steampowered.com precise/steam Translation-de
    Ign http://repo.steampowered.com precise/steam Translation-en
    Ign http://packages.linuxmint.com rafaela/import Translation-de_DE
    Ign http://packages.linuxmint.com rafaela/import Translation-de
    Ign http://packages.linuxmint.com rafaela/import Translation-en
    Ign http://packages.linuxmint.com rafaela/main Translation-de_DE
    Ign http://packages.linuxmint.com rafaela/main Translation-de
    Ign http://packages.linuxmint.com rafaela/main Translation-en
    Ign http://packages.linuxmint.com rafaela/upstream Translation-de_DE
    Ign http://packages.linuxmint.com rafaela/upstream Translation-de
    Ign http://packages.linuxmint.com rafaela/upstream Translation-en
    Es wurden 15,5 kB in 11 s geholt (1.347 B/s).
    Paketlisten werden gelesen... Fertig
    W: GPG-Fehler: http://ppa.launchpad.net trusty InRelease: Die folgenden Signaturen konnten nicht überprüft werden, weil ihr öffentlicher Schlüssel nicht verfügbar ist: NO_PUBKEY C2518248EEA14886



    3.
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut.
    Statusinformationen werden eingelesen.... Fertig
    E: Paket oracle-java8-installer kann nicht gefunden werden.

  2. #2
    Registrierter Benutzer
    Registriert seit
    Apr 2009
    Ort
    Erde
    Beiträge
    2.298
    https://mintguide.org/other/440-how-...inux-mint.html für 2 bzw NO_PUBKEY, der Rest sollte sich damit dann auch erledigt haben
    Gruß nopes
    (,,,)---(^.^)---(,,,) /var/log/messages | grep cat

  3. #3
    Registrierter Benutzer
    Registriert seit
    Aug 2019
    Beiträge
    4
    Danke für den Link
    Die Anweisung habe ich befolgt, leider bringt es mich bei dem Grundproblematik nicht weiter...

  4. #4
    kleine schwester von root Avatar von corresponder
    Registriert seit
    May 2002
    Ort
    192.67.198.56
    Beiträge
    4.114
    mit welchem Problem, Java 8 oder gpg-key?
    _______________________________________

    www.audio4linux.de - musik machen mit offenen quellen!

  5. #5
    Registrierter Benutzer
    Registriert seit
    Dec 2003
    Ort
    Dettenhausen
    Beiträge
    21.143
    Ich bin root - ich darf das.

  6. #6
    Registrierter Benutzer Avatar von Schreibtroll
    Registriert seit
    Jan 2009
    Beiträge
    557
    Dir ist aber schon bewusst, dass 17.2 Rafaela seit April EOL ist oder?
    https://de.wikipedia.org/wiki/Linux_Mint
    Mein Lieblingsbefehl: dd if=/dev/null of=/dev/bock bs=666

  7. #7
    Registrierter Benutzer
    Registriert seit
    Aug 2019
    Beiträge
    4
    @corresponder Dem Java-Problem

    @Schreibtroll
    Offensichtlich nicht...
    Es war die Version, die unetbootin bei mir automatisch gewählt hat...
    Ich installiere mal die aktuelle Version und melde mich dann nochmal.
    Aber schon mal danke für die Hilfe, auch an die anderen Schreiber

  8. #8
    Registrierter Benutzer
    Registriert seit
    Aug 2019
    Beiträge
    4
    So, die aktuelle Mint-Version (jetzt wirklich) ist installiert und, nach ein wenig Rumgerödel, funktioniert nun wie gewünscht.
    Vielen Dank nochmal und verzeiht bitte meine Verpeiltheit...

Ähnliche Themen

  1. Antworten: 6
    Letzter Beitrag: 07.07.18, 14:42
  2. knuddels unter Linux mint 18.3
    Von lino im Forum Anwendungen Allgemein, Software
    Antworten: 7
    Letzter Beitrag: 22.03.18, 15:18
  3. Übertragungsrate unter Linux Mint
    Von Tom75 im Forum Router und Netzaufbau
    Antworten: 4
    Letzter Beitrag: 21.12.16, 15:05
  4. Java-Plugin für Opera unter Linux Mint 11
    Von Tybaldt im Forum Anwendungen Allgemein, Software
    Antworten: 0
    Letzter Beitrag: 05.03.12, 10:26
  5. apache2 unter linux mint
    Von bweichel im Forum Linux als Server
    Antworten: 1
    Letzter Beitrag: 16.09.09, 11:11

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •