Anzeige:
Ergebnis 1 bis 7 von 7

Thema: Logrotate funktioniert nicht

  1. #1
    nobody.nogroup Avatar von pibi
    Registriert seit
    Jul 2002
    Ort
    Winterthur (CH)
    Beiträge
    2.437

    Logrotate funktioniert nicht

    Hallo zusammen

    Mein Server: openSuSI 13.2 (wird ersetzt durch eine neue Hardware unter openSuSI 42.3, ist schon fast fertig aufgebaut).

    Heute hat mir mein Nagios/Icinga gemeldet, dass das Volume /var auf meinem Server einen kritischen Fuellstand erreicht hat. Und wirklich, es waren nur noch wenige Prozent freier Speicherplatz vorhanden. Dabei ist mir aufgefallen, dass anscheinend schon seit laengerem kein "logrotate" mehr stattgefunden hat.

    Angeblich soll "logrotate" durch einen Cronjob angekickt werden. Ich habe aber weder unter den System-Jobs (/etc/cron.*) noch unter den personalisierten Jobs (/var/spool/cron/tabs) einen entsprechenden Eintrag gefunden. Lustigerweise sind aber die TimeStamps der Files unter /var/spool/cron/lastrun halbwegs aktuell, so dass irgendetwas passiert sein muss. Hmmm?!

    Anyway: Ich habe daraufhin das Logrotate auf der Kommandozeile manuell angestossen mit
    Code:
    logrotate  /etc/logrotate.conf
    Dieser Job ist dann geschaetzte 20min. gelaufen und hat den Platz bereinigt und die Logfiles komprimiert, so wie es sein sollte.

    Wie bzw. wo wird denn der Logrotate angekickt? Auch auf meinen anderen Rechnern, auf denen es funktioniert, finde ich keinen Cronjob oder aehnliches.

    Gruss Pit.
    div. Hardware:
    Server: openSUSI 13.2 / Laptop, Workstation: openSuSI 42.3
    Fritzbox 7940, Synology DS411

  2. #2
    Registrierter Benutzer
    Registriert seit
    Aug 2007
    Ort
    Sauerland
    Beiträge
    1.090

  3. #3
    nobody.nogroup Avatar von pibi
    Registriert seit
    Jul 2002
    Ort
    Winterthur (CH)
    Beiträge
    2.437
    Hoi Sauerland1

    Vielen Dank fuer den Link. Leider komme ich damit auch nicht wirklich weiter:-(

    zu #3 aus dem Link:
    /usr/lib/systemd/system/logrotate.service gibt es bei mir und hat folgenden Inhalt:
    Code:
    [Unit]
    Description=Rotate log files
    Documentation=man:logrotate(8) man:logrotate.conf(5)
    ConditionACPower=true
    [Service]
    Type=oneshot
    ExecStart=/usr/sbin/logrotate /etc/logrotate.conf
    Nice=19
    IOSchedulingClass=best-effort
    IOSchedulingPriority=7
    Wenn ich "/usr/sbin/logrotate /etc/logrotate.conf" manuell starte, wird das Logrotate richtig ausgefuehrt. Aber das schrub ich bereits in #1.

    Ein "systemctl status logrotate.service" zeigt mir dass der Status "dead" ist. Ein "systemctl start logrotate.service" fuehrt ebenfalls das Logrotate aus. Ein "systemctl enable logrotate.service" bringt folgendes:

    Code:
    The unit files have no [Install] section. They are not meant to be enabled
    using systemctl.
    Possible reasons for having this kind of units are:
    1) A unit may be statically enabled by being symlinked from another unit's
       .wants/ or .requires/ directory.
    2) A unit's purpose may be to act as a helper for some other unit which has
       a requirement dependency on it.
    3) A unit may be started when needed via activation (socket, path, timer,
       D-Bus, udev, scripted systemctl call, ...).
    zu #3 aus dem Link:
    Das File "/var/lib/logrotate.status" zeigt alle Namen der Logfiles und wann sie zuletzt von Logrotate komprimiert wurden. Leider nutzt mir das nicht viel, sondern ist rein informativ.

    zu #9:
    Das Ergebnis von "systemctl list-timers --all" gibt aus:
    Code:
    NEXT                         LEFT     UNIT                         ACTIVATES
    Mon 2018-11-12 11:44:46 CET  21h left systemd-tmpfiles-clean.timer systemd-tmpfiles-clean.service
    n/a                          n/a      systemd-readahead-done.timer systemd-readahead-done.service
    
    2 timers listed.
    zu #10:
    Die Maschine, um die es hier geht, ist (m)ein Server im Keller. Und wie der Name impliziert, laeuft diese Kiste 24/7.

    Aus alledem schliesse ich, dass irgendetwas bei meinem Server nicht mehr richtig funktioniert. "Frueher" (das letzte Logfile mit Extension "xz" datiert vom Sommer 2017) lief es definitiv noch. Anyway: Da diese Kiste sowieso ersetzt wird, baue ich als work-around das Logrotate als Cronjob ein.

    Und uebrigens: Auch der neue Server, der momentan als Stand-by laeuft, hat ebenfalls keinerlei Cronjob-Eintraege. Er funktioniert, aber anscheinend ebenso mit irgenwelchen kruden Mechanismen. Hier sieht es mit dem Timer allerdings besser aus:
    Code:
    NEXT                         LEFT    LAST                         PASSED     UNIT                         ACTIVATES
    Sun 2018-11-11 21:17:15 CET  6h left Sat 2018-11-10 21:17:15 CET  17h ago    systemd-tmpfiles-clean.timer systemd-tmpfiles-clean.service
    Mon 2018-11-12 00:00:00 CET  9h left Mon 2018-11-05 00:00:00 CET  6 days ago fstrim.timer                 fstrim.service
    Mon 2018-11-12 00:00:00 CET  9h left Sun 2018-11-11 00:00:00 CET  14h ago    logrotate.timer              logrotate.service
    
    3 timers listed.
    Pass --all to see loaded but inactive timers, too.

    Besten Dank fuer Deine Hilfe und Gruss aus Winti
    Pit.
    div. Hardware:
    Server: openSUSI 13.2 / Laptop, Workstation: openSuSI 42.3
    Fritzbox 7940, Synology DS411

  4. #4
    Registrierter Benutzer
    Registriert seit
    Aug 2007
    Ort
    Sauerland
    Beiträge
    1.090
    Als root:
    Code:
    zypper in -f logrotate

  5. #5
    nobody.nogroup Avatar von pibi
    Registriert seit
    Jul 2002
    Ort
    Winterthur (CH)
    Beiträge
    2.437
    Hoi Sauerland1
    Code:
    server:~ # zypper install --force logrotate
    Loading repository data...
    Warning: Repository 'openSuSE-13.2-Update' appears to be outdated. Consider using a different mirror or server.
    Reading installed packages...
    Forcing installation of 'logrotate-3.8.7-6.1.2.x86_64' from repository 'openSUSE-13.2-oss'.
    Resolving package dependencies...
    
    The following package is going to be reinstalled:
      logrotate
    
    1 package to reinstall.
    Overall download size: 58.6 KiB. Already cached: 0 B  No additional space will be used or freed after the operation.
    Continue? [y/n/? shows all options] (y): y
    Retrieving package logrotate-3.8.7-6.1.2.x86_64                                                        (1/1),  58.6 KiB ( 99.6 KiB unpacked)
    Checking for file conflicts: .........................................................................................................[done]
    (1/1) Installing: logrotate-3.8.7-6.1.2 ..............................................................................................[done]
    server:~ # systemctl list-timers --all
    NEXT                         LEFT     UNIT                         ACTIVATES
    Wed 2018-11-14 11:45:01 CET  23h left systemd-tmpfiles-clean.timer systemd-tmpfiles-clean.service
    n/a                          n/a      systemd-readahead-done.timer systemd-readahead-done.service
    
    2 timers listed.
    server:~ #
    Ist immer gut, wenn man fuer alle produktiven OS-Versionen einen local Mirror zur Verfuegung hat;-))

    Wie ich bereits schrub, werde ich die pragmatische Loesung waehlen und "logrotate" als Cronjob definieren. Danke fuer Deine Hilfe.

    Gruss Pit.
    div. Hardware:
    Server: openSUSI 13.2 / Laptop, Workstation: openSuSI 42.3
    Fritzbox 7940, Synology DS411

  6. #6
    Registrierter Benutzer
    Registriert seit
    Aug 2007
    Ort
    Sauerland
    Beiträge
    1.090
    Und so etwas kommt dabei herum, wenn man abgelaufenen Distributionen benutzt und nicht nachhilft:
    Warning: Repository 'openSuSE-13.2-Update' appears to be outdated. Consider using a different mirror or server.

  7. #7
    nobody.nogroup Avatar von pibi
    Registriert seit
    Jul 2002
    Ort
    Winterthur (CH)
    Beiträge
    2.437
    Jaja, das weiss ich doch alles. Und ich habe es voller Absicht so gemacht.

    So, und jetzt Schluss mit dieser Diskussion betreffend Nicht-Updates.

    Ich wuensche Dir einen schoenen Abend.
    Pit.
    div. Hardware:
    Server: openSUSI 13.2 / Laptop, Workstation: openSuSI 42.3
    Fritzbox 7940, Synology DS411

Ähnliche Themen

  1. logrotate will nicht wie ich will
    Von Dono im Forum System installieren und konfigurieren
    Antworten: 3
    Letzter Beitrag: 10.09.14, 10:43
  2. Logrotate rotiert nicht sondern
    Von nieselfriem im Forum Linux als Server
    Antworten: 1
    Letzter Beitrag: 19.07.13, 21:15
  3. logrotate will nicht rotieren
    Von kelups im Forum Anwendungen Allgemein, Software
    Antworten: 15
    Letzter Beitrag: 22.02.10, 17:17
  4. logrotate rotiert nicht
    Von tozu im Forum Linux als Server
    Antworten: 2
    Letzter Beitrag: 19.11.08, 12:21
  5. logrotate für mysql will nicht
    Von sutterp im Forum Linux als Server
    Antworten: 2
    Letzter Beitrag: 13.10.02, 03:06

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •