Anzeige:
Ergebnis 1 bis 4 von 4

Thema: Probleme mit OpenGL bzw. Mesa

  1. #1
    Registrierter Benutzer Avatar von check5
    Registriert seit
    Jan 2012
    Beiträge
    30

    Probleme mit OpenGL bzw. Mesa

    Hi,
    ich habe ein Problem und zwar:
    Ich habe immer wieder Programme die kein OpenGL bzw. Mesa erkennen.
    Habe auch schon viel gegoogelt aber nichts zu finden.
    Laut glxinfo ist aber alles vorhanden:
    Code:
    OpenGL vendor string: Intel Open Source Technology Center
    OpenGL renderer string: Mesa DRI Intel(R) Haswell Desktop 
    OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.1.3
    OpenGL core profile shading language version string: 3.30
    OpenGL core profile context flags: (none)
    OpenGL core profile profile mask: core profile
    OpenGL core profile extensions:
    OpenGL version string: 3.0 Mesa 10.1.3
    OpenGL shading language version string: 1.30
    OpenGL context flags: (none)
    OpenGL extensions:
    Hab dann sämtliche dev-libs installiert ging aber auch nicht.
    Zum Schluss versuchte ich noch Mesa aus den Quellen zu kompilieren aber da stieg der Compiler aus.
    Hier noch ein paar Beispiele:

    Cairo-Dock:
    Code:
    warning : (/build/buildd/cairo-dock-3.3.99.beta1.2.really.3.3.2/src/implementations/cairo-dock-glx.c:_initialize_opengl_backend:181)
      couldn't find an appropriate visual, trying to get one without Stencil buffer
    (it may cause some little deterioration in the rendering) ...
    warning : (/build/buildd/cairo-dock-3.3.99.beta1.2.really.3.3.2/src/implementations/cairo-dock-glx.c:_get_visual_from_fbconfigs:114)
      this FBConfig has no visual.
    warning : (/build/buildd/cairo-dock-3.3.99.beta1.2.really.3.3.2/src/implementations/cairo-dock-glx.c:_initialize_opengl_backend:241)
      couldn't find a suitable GLX Visual, OpenGL can't be used.
     (sorry to say that, but your graphic card and/or its driver is crappy)
    
     ============================================================================
    	Cairo-Dock version : 3.3.2
    	Compiled date      : Jun 19 2014 21:27:13
    	Built with GTK     : 3.10
    	Running with OpenGL: 0
     ============================================================================
    
    cairo_dock_create_surface_from_image_simple: assertion 'cImageFile != NULL' failed
    In Steam kann ich zum Beispiel auch nur die Bibliothek öffnen aber nicht den Shop. Da zeigt es mir gar nichts an.
    Auch bei Spielen habe ich keine OpenGL-Unterstützung wie z.B Terraria unter wine das mir dann immer sagt: no suitable Graphics Card found.

    Hat irgendjemand eine Idee?
    Mein OS ist ein Linux-Eigenbau aber auf Basis von Ubuntu 14.04 und mein Prozessor ein Intel Core i5-2540m mit integrierter HD3000 GPU.

    Die xorg.conf ist folgendermaßen:
    Code:
    # **********************************************************************
    # Module section -- this  section  is used to specify
    # which dynamically loadable modules to load.
    # **********************************************************************
    #
    Section "Module"
    	Load "synaptics" #loadsynaptics
    
    # This loads the DBE extension module.
    
        Load        "dbe"  	# Double buffer extension
    
    # This loads the miscellaneous extensions module, and disables
    # initialisation of the XFree86-DGA extension within that module.
        SubSection  "extmod"
          Option    "omit xfree86-dga"   # don't initialise the DGA extension
        EndSubSection
    
    # This loads the font modules
    #    Load        "type1"
    #    Load        "freetype"
    
    # This loads xtrap extension, used by xrandr
    #    Load       "xtrap"
    
    # This loads the GLX module (if present). xorg 7.4/5 need explicit disable to disable...
    #    Disable    "glx" #LOADGLX
    
    # This loads dri module (if present). 7.4 loads it by default, have to disable...
    #    Load       "dri" #LOADDRI
    #    Disable "dri"
    
    EndSection
    
    # **********************************************************************
    # Files section.  This allows default font paths to be set
    # **********************************************************************
    
    Section "Files"
    
    # Multiple FontPath entries are allowed (which are concatenated together),
    # as well as specifying multiple comma-separated entries in one FontPath
    # command (or a combination of both methods)
    
        FontPath   "/usr/share/X11/fonts/misc/"
        FontPath   "/usr/share/X11/fonts/Type1/"
        FontPath   "/usr/share/X11/fonts/TTF/"
    
    EndSection
    
    # **********************************************************************
    # Server flags section.
    # **********************************************************************
    
    Section "ServerFlags"
    
    # Uncomment this to disable the <Crtl><Alt><Fn> VT switch sequence
    # (where n is 1 through 12).  This allows clients to receive these key
    # events.
    
    #    Option "DontVTSwitch"
    
    # Enables mode switching with xrandr
    # There is a report that this can cause Xorg not to work on some
    # video hardware, so default is commented-out...
    # but i want to use it in xorgwizard so leave on...
    
        Option "RandR" "on"
    
    # With this, Xorg won't talk to HAL to add evdev devices and you'll be back
    # with the old Xorg behavior (pre-7.4)...
    
        Option "AutoAddDevices" "false"
    
    # For no-Hal, kirk also suggests this...
    
    #    Option "AllowMouseOpenFail" "true"
    
    # Xorg 7.4, Ubuntu Jaunty, CTRL-ALT-BACKSPACE is disabled by default...
    
        Option "DontZap" "false"
    
    EndSection
    
    Section "ServerLayout"
    	Identifier "Default Layout"
    	Screen "Screen0" 0 0
    	InputDevice "Keyboard0" "CoreKeyboard"
    	InputDevice "Mouse0" "CorePointer"
    	InputDevice "SynapticsMouse" "AlwaysCore" #serverlayoutsynaptics
    EndSection
    
    Section "InputDevice"
    	Identifier  "Keyboard0"
    	Driver      "kbd"
    	Option      "XkbRules" "xorg"
    	Option      "XkbModel" "microsoft"
    	Option      "XkbLayout" "de" #xkeymap0
    EndSection
    
    Section "InputDevice"
    	Identifier  "Mouse0"
    	Driver      "mouse"
    	Option	    "Device" "/dev/input/mice"
    	Option	    "Protocol" "IMPS/2" #mouse0protocol
    	#Option      "Emulate3Buttons"
    	#Option      "Emulate3Timeout" "50"
    	Option      "ZAxisMapping" "4 5" #scrollwheel
    EndSection
    
    Section "InputDevice"
    	Identifier "SynapticsMouse"
    	Driver "synaptics"
    	Option "SHMConfig" "on"
    EndSection
    
    Section "Monitor"
    	Identifier   "Monitor0"
    	VendorName   "Monitor Vendor"
    	ModelName    "Monitor Model"
    	#HorizSync    31-50
    	VertRefresh  59-76
    	#UseModes     "Modes0" #monitor0usemodes
    	Option      "PreferredMode" "1366x768"
    EndSection
    
    Section "Modes"
    	Identifier "Modes0"
    	#modes0modeline0
    EndSection
    
    Section "Device"
            ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
            ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
            ### <percent>: "<f>%"
            ### [arg]: arg optional
            #Option     "NoAccel"            	# [<bool>]
            #Option     "AccelMethod"        	# <str>
            #Option     "Backlight"          	# <str>
            #Option     "DRI"                	# <str>
            #Option     "ColorKey"           	# <i>
            #Option     "VideoKey"           	# <i>
            #Option     "Tiling"             	# [<bool>]
            #Option     "LinearFramebuffer"  	# [<bool>]
            #Option     "VSync"              	# [<bool>]
            #Option     "PageFlip"           	# [<bool>]
            #Option     "SwapbuffersWait"    	# [<bool>]
            #Option     "TripleBuffer"       	# [<bool>]
            #Option     "XvPreferOverlay"    	# [<bool>]
            #Option     "HotPlug"            	# [<bool>]
            #Option     "ReprobeOutputs"     	# [<bool>]
            #Option     "XvMC"               	# [<bool>]
            #Option     "ZaphodHeads"        	# <str>
            #Option     "VirtualHeads"       	# <i>
            #Option     "TearFree"           	# [<bool>]
            #Option     "PerCrtcPixmaps"     	# [<bool>]
            #Option     "FallbackDebug"      	# [<bool>]
            #Option     "DebugFlushBatches"  	# [<bool>]
            #Option     "DebugFlushCaches"   	# [<bool>]
            #Option     "DebugWait"          	# [<bool>]
            #Option     "BufferCache"        	# [<bool>]
    	Identifier  "Card0"
    	Driver      "intel" #card0driver
    EndSection
    
    Section "Screen"
    	Identifier "Screen0"
    	Device     "Card0"
    	Monitor    "Monitor0"
    	DefaultDepth 24
    	#Option         "metamodes" "1366x768_60 +0+0" #METAMODES_0
    	Subsection "Display"
    		Depth       24
    		Modes       "1366x768"
    	EndSubsection
    EndSection
    dd if=/dev/null of=/dev/brain bs=512 skip=1 && sync :-)

  2. #2
    Registrierter Benutzer Avatar von towo2099
    Registriert seit
    Feb 2002
    Ort
    Pößneck
    Beiträge
    4.421
    Also für Steam und diverse Spiele:

    Steam ist eine 32bit App und viele Spiele existieren auch nur in 32bit, das bedeuted im Umkehrschluss, dass Du auch die 32bit mesa Pakete installiert haben musst, damit das funktioniert.
    Mal davon ab, dein Mesa und Grphicks-Stack ist mit ziemlicher Sicherheit veraltet, ich sage nur Ubuntu 14.irgendwas!
    Signatur nach Diktat Spazieren gegangen ;)

  3. #3
    Registrierter Benutzer Avatar von check5
    Registriert seit
    Jan 2012
    Beiträge
    30
    Ja schon klar, hab ich ja auch. Die Steam-Games funktionieren ohne Probleme, aber die ganzen Fester nicht ausser Spiele-Bibliothek.
    Das der Grafik-Stack älter ist ist mir auch klar. Von dem aber mal abgesehen unter einem Debian 8 funktioniert es. Ich hab nur keine Lust den ganzen Unterbau zu wechseln.
    Hat jemand schon mal ähnliche Probleme gehabt und vielleicht eine Lösung?

    VG
    dd if=/dev/null of=/dev/brain bs=512 skip=1 && sync :-)

  4. #4
    kleine schwester von root Avatar von corresponder
    Registriert seit
    May 2002
    Ort
    192.67.198.56
    Beiträge
    3.972
    unter Debian 9.5 auch
    _______________________________________

    www.audio4linux.de - musik machen mit offenen quellen!

Ähnliche Themen

  1. fglrx Treiber : MESA OpenGL Treiber werden immernoch geladen
    Von Lifeguard im Forum X-Konfiguration
    Antworten: 3
    Letzter Beitrag: 09.12.06, 00:45
  2. Probleme mit OpenGL
    Von Malte-Kiefer im Forum X-Konfiguration
    Antworten: 4
    Letzter Beitrag: 24.08.06, 12:21
  3. OpenGL Problem NVidia/Mesa?
    Von ghostface1500 im Forum stationäre Hardware
    Antworten: 13
    Letzter Beitrag: 13.07.04, 08:22
  4. OpenGL vs. Mesa bei Suse Prof 8.0??????
    Von peter82 im Forum Spielen Allgemein
    Antworten: 5
    Letzter Beitrag: 27.08.02, 13:27
  5. Mesa vs. OpenGL
    Von Sym im Forum X-Konfiguration
    Antworten: 3
    Letzter Beitrag: 21.08.02, 18:17

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •