Anzeige:
Ergebnis 1 bis 6 von 6

Thema: LEAP 15 YaST2 - Bootloader Internal Error

  1. #1
    Registrierter Benutzer
    Registriert seit
    Jul 2018
    Beiträge
    4

    LEAP 15 YaST2 - Bootloader Internal Error

    Ich habe mich heute durch die Systemkonfiguration meines Notebooks mit OpenSuse Leap15 Gnome geklickt, um mich allmählich mit den Möglichkeiten des Geräts vertraut zu machen. Dabei öffnete sich beim Klick auf die Einstellung für "Bootloader" ein Fenster mit folgender Fehlermeldung:
    Internal Error: Please report a bug reports with logs.
    Run save_y2logs to get complete logs.
    Details: undefinded method "ancestors" for nil:NilClass
    Caller: /usr/share/YaST2/modules/BootStorage.rb:198:in "stage1_disks_for"

    Die Anweisung "Run save_y2logs to get complete logs" habe ich durchgeführt, und es wird eine Datei im tmp-Ordner erzeugt - nicht mehr, nicht weniger.

    Da ich aber ein Linux-Newby bin und kryptische Fehlermeldungen wie die oben genannte mir nichts sagen, bin ich auf Hilfe angewiesen. Was sagt mir diese Fehlermeldung? Wie kann ich sie vermeiden?

    Ich bin für jede (einfach nachzuvollziehende) Lösung dankbar.

  2. #2
    Registrierter Benutzer
    Registriert seit
    Aug 2007
    Ort
    Sauerland
    Beiträge
    1.071
    Poste:
    Code:
    zypper lr -d
    Code:
    zypper se -si ruby yast
    Benutze für die Konsolenausgaben 2 separate Code-Tags.

  3. #3
    Registrierter Benutzer
    Registriert seit
    Jul 2018
    Beiträge
    4
    Zitat Zitat von Sauerland1 Beitrag anzeigen
    Poste:
    Code:
    zypper lr -d
    Code:
    zypper se -si ruby yast
    Benutze für die Konsolenausgaben 2 separate Code-Tags.
    Das ist das was rauskam:


    Code:
    zypper lr -d
    Repository-Prioritäten treten in Kraft:       (Siehe 'zypper lr -P' für Details)
          90 (erhöhte Priorität)  :  2 Repositorys
          99 (Standard-Priorität) :  8 Repositorys
    
    #  | Alias                               | Name                              | Aktiviert | GPG-Überprüfung | Aktualisierung | Priorität | Typ    | URI                                                                               | Dienst
    ---+-------------------------------------+-----------------------------------+-----------+-----------------+----------------+-----------+--------+-----------------------------------------------------------------------------------+-------
     1 | http-download.opensuse.org-ad18d9aa | X11:Pantheon:Apps                 | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/repositories/X11:/Pantheon:/Apps/openSUSE_Leap_15.0/ |       
     2 | isv_TUXEDO                          | isv:TUXEDO (openSUSE_Leap_15.0)   | Ja        | (r ) Ja         | Nein           |   99      | rpm-md | http://download.opensuse.org/repositories/isv:/TUXEDO/openSUSE_Leap_15.0/         |       
     3 | openSUSE-Leap-15.0-1                | openSUSE-Leap-15.0-1              | Nein      | ----            | ----           |   99      | rpm-md | cd:///?devices=/dev/disk/by-id/ata-VBOX_CD-ROM_VB2-01700376                       |       
     4 | packman                             | packman                           | Ja        | (r ) Ja         | Ja             |   90      | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.0/                |       
     5 | packman-essentials                  | packman-essentials                | Ja        | (r ) Ja         | Ja             |   90      | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.0/Essentials      |       
     6 | repo-non-oss                        | openSUSE-Leap-15.0-Non-Oss        | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/distribution/leap/15.0/repo/non-oss/                 |       
     7 | repo-nvidia-tuxedo                  | TUXEDO Computers - 15.0 NVIDIA    | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://nvidia.tuxedocomputers.com/opensuse/15.0                                   |       
     8 | repo-oss                            | openSUSE-Leap-15.0-Oss            | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/distribution/leap/15.0/repo/oss/                     |       
     9 | repo-source                         | openSUSE-Leap-15.0-Source         | Nein      | ----            | ----           |   99      | NONE   | http://download.opensuse.org/source/distribution/leap/15.0/repo/oss/              |       
    10 | repo-source-non-oss                 | openSUSE-Leap-15.0-Source-Non-Oss | Nein      | ----            | ----           |   99      | NONE   | http://download.opensuse.org/source/distribution/leap/15.0/repo/non-oss/          |       
    11 | repo-update                         | openSUSE-Leap-15.0-Update         | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/update/leap/15.0/oss/                                |       
    12 | repo-update-non-oss                 | openSUSE-Leap-15.0-Update-Non-Oss | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/update/leap/15.0/non-oss/                            |       
    13 | snappy                              | snappy                            | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/repositories/system:/snappy/openSUSE_Leap_42.3/

    Code:
    zypper se -si ruby yast
    Repository-Daten werden geladen...
    Installierte Pakete werden gelesen...
    
    S  | Name                            | Typ       | Version                            | Arch   | Repository               
    ---+---------------------------------+-----------+------------------------------------+--------+--------------------------
    i+ | YaST                            | Anwendung |                                    | noarch | openSUSE-Leap-15.0-Oss   
    i+ | autoyast2-installation          | Paket     | 4.0.55-lp150.2.3.1                 | noarch | openSUSE-Leap-15.0-Update
    i+ | libruby2_5-2_5                  | Paket     | 2.5.0-lp150.2.11                   | x86_64 | openSUSE-Leap-15.0-Oss   
    i+ | libstorage-ng-ruby              | Paket     | 3.3.312-lp150.2.6.1                | x86_64 | openSUSE-Leap-15.0-Update
    i+ | patterns-gnome-gnome_yast       | Paket     | 20180321-lp150.3.1                 | x86_64 | openSUSE-Leap-15.0-Oss   
    i+ | patterns-yast-x11_yast          | Paket     | 20180409-lp150.3.1                 | x86_64 | openSUSE-Leap-15.0-Oss   
    i+ | patterns-yast-yast2_basis       | Paket     | 20180409-lp150.3.1                 | x86_64 | openSUSE-Leap-15.0-Oss   
    i+ | ruby                            | Paket     | 2.5-lp150.1.5                      | x86_64 | openSUSE-Leap-15.0-Oss   
    i+ | ruby-common                     | Paket     | 2.1-lp150.3.1                      | noarch | openSUSE-Leap-15.0-Oss   
    i+ | ruby2.5                         | Paket     | 2.5.0-lp150.2.11                   | x86_64 | openSUSE-Leap-15.0-Oss   
    i+ | ruby2.5-rubygem-abstract_method | Paket     | 1.2.1-lp150.1.9                    | x86_64 | openSUSE-Leap-15.0-Oss   
    i+ | ruby2.5-rubygem-cfa             | Paket     | 0.6.4-lp150.1.1                    | x86_64 | openSUSE-Leap-15.0-Oss   
    i+ | ruby2.5-rubygem-cfa_grub2       | Paket     | 0.6.5-lp150.1.5                    | x86_64 | openSUSE-Leap-15.0-Oss   
    i+ | ruby2.5-rubygem-cheetah         | Paket     | 0.5.0-lp150.1.11                   | x86_64 | openSUSE-Leap-15.0-Oss   
    i+ | ruby2.5-rubygem-fast_gettext    | Paket     | 1.6.0-lp150.1.4                    | x86_64 | openSUSE-Leap-15.0-Oss   
    i+ | ruby2.5-rubygem-gem2rpm         | Paket     | 0.10.1-lp150.3.30                  | x86_64 | openSUSE-Leap-15.0-Oss   
    i+ | ruby2.5-rubygem-ruby-augeas     | Paket     | 0.5.0-lp150.1.12                   | x86_64 | openSUSE-Leap-15.0-Oss   
    i+ | ruby2.5-rubygem-ruby-dbus       | Paket     | 0.14.0-lp150.1.6                   | x86_64 | openSUSE-Leap-15.0-Oss   
    i+ | ruby2.5-rubygem-simpleidn       | Paket     | 0.0.9-lp150.1.2                    | x86_64 | openSUSE-Leap-15.0-Oss   
    i+ | ruby2.5-stdlib                  | Paket     | 2.5.0-lp150.2.11                   | x86_64 | openSUSE-Leap-15.0-Oss   
    i+ | yast2                           | Paket     | 4.0.79-lp150.2.6.1                 | x86_64 | openSUSE-Leap-15.0-Update
    i+ | yast2-add-on                    | Paket     | 4.0.8-lp150.1.1                    | noarch | openSUSE-Leap-15.0-Oss   
    i+ | yast2-apparmor                  | Paket     | 4.0.4-lp150.1.3                    | noarch | openSUSE-Leap-15.0-Oss   
    i+ | yast2-auth-client               | Paket     | 4.0.0-lp150.1.1                    | noarch | openSUSE-Leap-15.0-Oss   
    i+ | yast2-auth-server               | Paket     | 4.0.0-lp150.1.1                    | noarch | openSUSE-Leap-15.0-Oss   
    i+ | yast2-bootloader                | Paket     | 4.0.35-lp150.2.5.1                 | x86_64 | openSUSE-Leap-15.0-Update
    i+ | yast2-branding-openSUSE         | Paket     | 4.0.4-lp150.1.1                    | noarch | openSUSE-Leap-15.0-Oss   
    i+ | yast2-control-center            | Paket     | 4.0.3-lp150.1.1                    | x86_64 | openSUSE-Leap-15.0-Oss   
    i+ | yast2-control-center-qt         | Paket     | 4.0.3-lp150.1.1                    | x86_64 | openSUSE-Leap-15.0-Oss   
    i+ | yast2-core                      | Paket     | 4.0.3-lp150.2.3.1                  | x86_64 | openSUSE-Leap-15.0-Update
    i+ | yast2-country                   | Paket     | 4.0.22-lp150.2.3.1                 | x86_64 | openSUSE-Leap-15.0-Update
    i+ | yast2-country-data              | Paket     | 4.0.22-lp150.2.3.1                 | x86_64 | openSUSE-Leap-15.0-Update
    i+ | yast2-firewall                  | Paket     | 4.0.25-lp150.1.1                   | noarch | openSUSE-Leap-15.0-Oss   
    i+ | yast2-firstboot                 | Paket     | 4.0.5-lp150.2.3.1                  | noarch | openSUSE-Leap-15.0-Update
    i+ | yast2-fonts                     | Paket     | 4.0.0-lp150.1.1                    | x86_64 | openSUSE-Leap-15.0-Oss   
    i+ | yast2-hardware-detection        | Paket     | 4.0.0-lp150.1.1                    | x86_64 | openSUSE-Leap-15.0-Oss   
    i+ | yast2-installation              | Paket     | 4.0.67-lp150.2.9.1                 | noarch | openSUSE-Leap-15.0-Update
    i+ | yast2-iscsi-client              | Paket     | 4.0.0-lp150.1.1                    | noarch | openSUSE-Leap-15.0-Oss   
    i+ | yast2-journal                   | Paket     | 4.0.0-lp150.1.1                    | noarch | openSUSE-Leap-15.0-Oss   
    i+ | yast2-ldap                      | Paket     | 4.0.0-lp150.1.1                    | x86_64 | openSUSE-Leap-15.0-Oss   
    i+ | yast2-mail                      | Paket     | 4.0.3-lp150.1.2                    | noarch | openSUSE-Leap-15.0-Oss   
    i+ | yast2-metapackage-handler       | Paket     | 4.0.0-lp150.1.3                    | noarch | openSUSE-Leap-15.0-Oss   
    i+ | yast2-network                   | Paket     | 4.0.31-lp150.1.1                   | noarch | openSUSE-Leap-15.0-Oss   
    i+ | yast2-nfs-client                | Paket     | 4.0.6-lp150.2.3.1                  | noarch | openSUSE-Leap-15.0-Update
    i+ | yast2-nfs-common                | Paket     | 4.0.0-lp150.1.4                    | noarch | openSUSE-Leap-15.0-Oss   
    i+ | yast2-nis-client                | Paket     | 4.0.2-lp150.1.4                    | x86_64 | openSUSE-Leap-15.0-Oss   
    i+ | yast2-ntp-client                | Paket     | 4.0.12-lp150.1.1                   | noarch | openSUSE-Leap-15.0-Oss   
    i+ | yast2-online-update             | Paket     | 4.0.0-lp150.1.1                    | noarch | openSUSE-Leap-15.0-Oss   
    i+ | yast2-online-update-frontend    | Paket     | 4.0.0-lp150.1.1                    | noarch | openSUSE-Leap-15.0-Oss   
    i+ | yast2-packager                  | Paket     | 4.0.67-lp150.2.6.2                 | x86_64 | openSUSE-Leap-15.0-Update
    i+ | yast2-pam                       | Paket     | 4.0.0-lp150.1.1                    | noarch | openSUSE-Leap-15.0-Oss   
    i+ | yast2-perl-bindings             | Paket     | 4.0.1-lp150.1.1                    | x86_64 | openSUSE-Leap-15.0-Oss   
    i+ | yast2-pkg-bindings              | Paket     | 4.0.11-lp150.2.6.1                 | x86_64 | openSUSE-Leap-15.0-Update
    i+ | yast2-printer                   | Paket     | 4.0.2-lp150.2.3.1                  | x86_64 | openSUSE-Leap-15.0-Update
    i+ | yast2-proxy                     | Paket     | 4.0.1-lp150.2.3.1                  | noarch | openSUSE-Leap-15.0-Update
    i+ | yast2-ruby-bindings             | Paket     | 4.0.6-lp150.1.1                    | x86_64 | openSUSE-Leap-15.0-Oss   
    i+ | yast2-samba-client              | Paket     | 4.0.1-lp150.1.1                    | noarch | openSUSE-Leap-15.0-Oss   
    i+ | yast2-samba-server              | Paket     | 4.0.1-lp150.1.2                    | noarch | openSUSE-Leap-15.0-Oss   
    i+ | yast2-scanner                   | Paket     | 4.0.1-lp150.1.1                    | x86_64 | openSUSE-Leap-15.0-Oss   
    i+ | yast2-security                  | Paket     | 4.0.0-lp150.1.1                    | noarch | openSUSE-Leap-15.0-Oss   
    i+ | yast2-services-manager          | Paket     | 4.0.3-lp150.1.3                    | noarch | openSUSE-Leap-15.0-Oss   
    i+ | yast2-slp                       | Paket     | 4.0.0-lp150.1.1                    | x86_64 | openSUSE-Leap-15.0-Oss   
    i+ | yast2-snapper                   | Paket     | 4.0.1-lp150.1.6                    | x86_64 | openSUSE-Leap-15.0-Oss   
    i+ | yast2-sound                     | Paket     | 3.1.10-lp150.1.24                  | x86_64 | openSUSE-Leap-15.0-Oss   
    i+ | yast2-storage-ng                | Paket     | 4.0.200-lp150.2.9.1                | x86_64 | openSUSE-Leap-15.0-Update
    i+ | yast2-sudo                      | Paket     | 3.1.2-lp150.1.9                    | noarch | openSUSE-Leap-15.0-Oss   
    i+ | yast2-support                   | Paket     | 3.2.0-lp150.1.5                    | noarch | openSUSE-Leap-15.0-Oss   
    i+ | yast2-sysconfig                 | Paket     | 4.0.0-lp150.1.1                    | noarch | openSUSE-Leap-15.0-Oss   
    i+ | yast2-trans-de                  | Paket     | 84.87.20180514.157a0650d-lp150.1.1 | noarch | openSUSE-Leap-15.0-Oss   
    i+ | yast2-trans-de                  | Paket     | 84.87.20180514.157a0650d-lp150.1.1 | noarch | openSUSE-Leap-15.0-Oss   
    i+ | yast2-trans-en                  | Paket     | 84.87.20180514.157a0650d-lp150.1.1 | noarch | openSUSE-Leap-15.0-Oss   
    i+ | yast2-trans-en_GB               | Paket     | 84.87.20180514.157a0650d-lp150.1.1 | noarch | openSUSE-Leap-15.0-Oss   
    i+ | yast2-trans-en_GB               | Paket     | 84.87.20180514.157a0650d-lp150.1.1 | noarch | openSUSE-Leap-15.0-Oss   
    i+ | yast2-trans-en_US               | Paket     | 84.87.20180514.157a0650d-lp150.1.1 | noarch | openSUSE-Leap-15.0-Oss   
    i+ | yast2-trans-en_US               | Paket     | 84.87.20180514.157a0650d-lp150.1.1 | noarch | openSUSE-Leap-15.0-Oss   
    i+ | yast2-trans-stats               | Paket     | 2.19.0-lp150.1.6                   | noarch | openSUSE-Leap-15.0-Oss   
    i+ | yast2-transfer                  | Paket     | 4.0.0-lp150.1.1                    | x86_64 | openSUSE-Leap-15.0-Oss   
    i+ | yast2-tune                      | Paket     | 4.0.0-lp150.1.7                    | x86_64 | openSUSE-Leap-15.0-Oss   
    i+ | yast2-update                    | Paket     | 4.0.17-lp150.2.3.1                 | x86_64 | openSUSE-Leap-15.0-Update
    i+ | yast2-users                     | Paket     | 4.0.5-lp150.1.1                    | x86_64 | openSUSE-Leap-15.0-Oss   
    i+ | yast2-vm                        | Paket     | 4.0.1-lp150.1.1                    | x86_64 | openSUSE-Leap-15.0-Oss   
    i+ | yast2-vpn                       | Paket     | 3.1.5-lp150.1.5                    | noarch | openSUSE-Leap-15.0-Oss   
    i+ | yast2-x11                       | Paket     | 4.0.0-lp150.1.3                    | x86_64 | openSUSE-Leap-15.0-Oss   
    i+ | yast2-xml                       | Paket     | 4.0.0-lp150.1.1                    | x86_64 | openSUSE-Leap-15.0-Oss   
    i+ | yast2-ycp-ui-bindings           | Paket     | 4.0.0-lp150.1.4                    | x86_64 | openSUSE-Leap-15.0-Oss   
    i+ | yast2_basis                     | Schema    | 20180409-lp150.3.1                 | x86_64 | openSUSE-Leap-15.0-Oss

  4. #4
    Registrierter Benutzer
    Registriert seit
    Jul 2018
    Beiträge
    4
    Kann mir niemand bei diesem "Problem" helfen? Mit den Resultaten von zypper lr -d und zypper se -si ruby yast kann ich leider nichts anfangen.

  5. #5
    Organisiertes Chaos
    Registriert seit
    Jul 2011
    Ort
    OWL
    Beiträge
    372
    Zitat Zitat von angelos Beitrag anzeigen
    Kann mir niemand bei diesem "Problem" helfen? Mit den Resultaten von zypper lr -d und zypper se -si ruby yast kann ich leider nichts anfangen.
    Geht doch schon weiter: https://forums.opensuse.org/showthre...Internal-Error

    Mal lesen, verstehen und umsetzen: https://www.linux-tips-and-tricks.de...mag-die-keiner

  6. #6
    Registrierter Benutzer
    Registriert seit
    Jul 2018
    Beiträge
    4
    Zitat Zitat von tomm.fa Beitrag anzeigen
    ...sorry, ich muss offenbar noch viel lernen, wenn ich mich in LINUX-Kreisen bewegen will. Ich habe über 30 Jahre mit Apple-Geräten gearbeitet und kenne weder kryptische Fehlermeldungen noch Einschränkungen in Foren. Wenn ich also durch ein Multiposting hier für Unmut gesorgt habe, dann möge man mir diese Unachtsamkeit nachsehen. Werde mich in Zukunft beschränken.

Ähnliche Themen

  1. Samba (2.2.8) internal error
    Von Leander8 im Forum Linux in heterogenen Netzen
    Antworten: 0
    Letzter Beitrag: 01.09.04, 09:17
  2. internal compiler error
    Von floschuh im Forum stationäre Hardware
    Antworten: 1
    Letzter Beitrag: 03.11.03, 16:18
  3. 500 Internal Server Error...
    Von darktr00per im Forum Linux als Server
    Antworten: 1
    Letzter Beitrag: 23.12.01, 16:36
  4. Internal Compiler error
    Von leon im Forum Kompilieren von Kernel und Sourcen
    Antworten: 2
    Letzter Beitrag: 09.10.01, 21:28
  5. INTERNAL ERROR
    Von im Forum Linux in heterogenen Netzen
    Antworten: 0
    Letzter Beitrag: 02.11.00, 16:26

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •