Anzeige:
Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 15 von 23

Thema: unicap-Treiber für DMK-Kamera bauen

  1. #1
    Registrierter Benutzer
    Registriert seit
    May 2014
    Beiträge
    10

    unicap-Treiber für DMK-Kamera bauen

    Hallihallo.

    Nu will ich hier doch auch mal um hilfe bitten.
    Derzeit beschäftige ich mich mit der Astrofotografie unter Linux. Das heisst derzeit versuche ich es eher.
    Im moment hägt es an der Unterstützunf meiner DMK-Guidingkamera unter Kubuntu wie auch bei dem Raspberry-Pi.

    Jedes mal wenn ich versuche die Kamera zu verbinden, kommt die Meldung:
    "unable to open device. Cannot identify /dev/video0: 2, No such file or directory"

    Wenn ich mit lsusb nachschaue, werden Hersteller und Modell korrekt erkannt.

    An anderer Stelle erhilt ich bereits insofern Hilfe, als dass ich mir den unicap-Treiber für die Kamera bauen sollte.
    Allerdings scheitere ich derzeit an dem Befehl:
    Code:
    patch -p1 < uvcvideo_add_tis_ccd.patch
    Dieser wird mit folgendem Text abgebrochen:
    Code:
    root@bernd-ThinkPad-R60:/home/bernd/media_build/linux# patch -p1 < uvcvideo_add_tis_ccd.patch
    can't find file to patch at input line 16
    Perhaps you used the wrong -p or --strip option?
    The text leading up to this was:
    --------------------------
    |From a16d2c044f5e8bf9fc16727d2c6a6055812b366c Mon Sep 17 00:00:00 2001
    |From: Arne Caspari <arne@unicap-imaging.org>
    |Date: Sat, 30 Jul 2011 13:29:11 +0200
    |Subject: [PATCH] [media] uvcvideo: Detect The Imaging Source CCD cameras by vendor and product ID
    |
    |The Imaging Source CCD cameras use a vendor specific interface class
    |even though they are actually UVC compliant.
    |---
    | drivers/media/video/uvc/uvc_driver.c |    8 ++++++++
    | 1 files changed, 8 insertions(+), 0 deletions(-)
    |
    |diff --git a/drivers/media/video/uvc/uvc_driver.c b/drivers/media/video/uvc/uvc_driver.c
    |index d29f9c2..339ded4 100644
    |--- a/drivers/media/video/uvc/uvc_driver.c
    |+++ b/drivers/media/video/uvc/uvc_driver.c
    --------------------------
    File to patch:
    Kann mir vielleicht jemand weiterhelfen?

  2. #2
    Registrierter Benutzer
    Registriert seit
    Dec 2003
    Ort
    Dettenhausen
    Beiträge
    21.418
    könntest Du die "andere Stelle" nennen oder ist die geheim?

    Zudem wären ein paar weitere konkrete Infos nicht schlecht, dann kann man ggf. auch was nachvollziehen... Also sowas wie Kameramodel, Ausgabe von lspci, konkrete OS-Version, ...
    Ich bin root - ich darf das.

  3. #3
    Registrierter Benutzer
    Registriert seit
    May 2014
    Beiträge
    10
    Die ist nicht geheim. Das war ein Post in einer Gruppe bei Facebook.

    Die Kamera ist eine DMK 21AU04.AS vin The Imaging Source. Das Problem besteht zum einen unter meiner Kubuntu-Instalation und auch auf meinem Raspberry-PI. Welche genaue Version auf den Jeweiligen Systemen käuft kann ich auf die schnelle nicht sagen. Sind halt beides erst kürzlich (vor wenigen Tagen) aus jeweils aktuellen Quellen installiert worden. Und lspci meldet mangels PCI-Bus auf dem Raspberry nix. Aber lsusb meldet:
    Code:
    Bus 001 Device 004: ID 199e:8101 The Imaging Source Europe GmbH DFx 21BU04 Camera
    Grüßle
    Bernd

  4. #4
    Registrierter Benutzer
    Registriert seit
    Dec 2003
    Ort
    Dettenhausen
    Beiträge
    21.418
    ich vermute, man hat Dich auf http://unicap-imaging.org/tis_devices_en.htm verwiesen? Hast Du alle (soweit ich die Seite verstehe) vorher notwendigen Schritte durchgeführt?
    Ich bin root - ich darf das.

  5. #5
    Registrierter Benutzer
    Registriert seit
    May 2014
    Beiträge
    10
    Hat man.

    Ich habe vorher die Befehle:
    Code:
    git clone git://linuxtv.org/media_build.git
    cd media_build
    cd linux
    durchgeführt.

    Zyrusthc war soweit so nett mir zu helfen und hat mich auch an dieses Forum verwiesen. Bei meiner Kubuntu-Installation scheint es aber soweit weiter zu gehen. Nur beim Pi hänge ich noch. :-(

  6. #6
    Registrierter Benutzer
    Registriert seit
    Dec 2003
    Ort
    Dettenhausen
    Beiträge
    21.418
    wenn ich das richtig verstanden habe auf der Seite: Die Kernel-Sourcen sind auch installiert?

    Ach ja - das Git-Repo wurde kürzlich aktualisiert, bist Du diesbezüglich auf dem neuesten Stand?
    Geändert von marce (15.05.14 um 18:28 Uhr)
    Ich bin root - ich darf das.

  7. #7
    Registrierter Benutzer
    Registriert seit
    May 2014
    Beiträge
    10
    Nun, ich habe das beides heute erst noch einmal ausprobiert.
    Das durchfuhren von ./build und make install hat unter dem kubuntu geklappt. aber wie gesagt, unter dem raspian komme ich nicht mal soweit.

  8. #8
    Shell-User Avatar von zyrusthc
    Registriert seit
    Jan 2004
    Ort
    http://www.thale.de
    Beiträge
    6.331
    Der Ablauf so wie ich das gelesen habe scheint:
    git clone git://linuxtv.org/media_build.git
    cd media_build
    cd linux
    wget http://unicap-imaging.org/downloads/..._tis_ccd.patch
    patch -p1 < uvcvideo_add_tis_ccd.patch
    cd ..
    ./build
    make install


    Poste mal Schritt für Schritt was dein Raspi dazu schimpft.

    PS: Zur genauen Distriversion "cat /etc/version"
    Geändert von zyrusthc (15.05.14 um 20:10 Uhr)
    Notebook: Lenovo Z570 CoreI7
    Workstation: Core2Quad Q6700 - ASUS P5WDG2-WS Pro - 8800GT - 4GB-DDR2/800 - 4x500GB=RAID1 - 120GB SSD - Innovatek Wakü - 27Widescreen/AcerTFT
    Server: IBM X345 + Netfinity 5000

    http://zyrusthc-linux.no-ip.org

  9. #9
    Registrierter Benutzer
    Registriert seit
    Aug 2007
    Ort
    Sauerland
    Beiträge
    1.272

  10. #10
    Shell-User Avatar von zyrusthc
    Registriert seit
    Jan 2004
    Ort
    http://www.thale.de
    Beiträge
    6.331
    Zitat Zitat von sbernd78 Beitrag anzeigen
    Code:
    Bus 001 Device 004: ID 199e:8101 The Imaging Source Europe GmbH DFx 21BU04 Camera
    Ich sehe gerade in dem Patch steht ne abweichende ID
    Code:
    From a16d2c044f5e8bf9fc16727d2c6a6055812b366c Mon Sep 17 00:00:00 2001
    From: Arne Caspari <arne@unicap-imaging.org>
    Date: Sat, 30 Jul 2011 13:29:11 +0200
    Subject: [PATCH] [media] uvcvideo: Detect The Imaging Source CCD cameras by vendor and product ID
    
    The Imaging Source CCD cameras use a vendor specific interface class
    even though they are actually UVC compliant.
    ---
     drivers/media/video/uvc/uvc_driver.c |    8 ++++++++
     1 files changed, 8 insertions(+), 0 deletions(-)
    
    diff --git a/drivers/media/video/uvc/uvc_driver.c b/drivers/media/video/uvc/uvc_driver.c
    index d29f9c2..339ded4 100644
    --- a/drivers/media/video/uvc/uvc_driver.c
    +++ b/drivers/media/video/uvc/uvc_driver.c
    @@ -2361,6 +2361,14 @@ static struct usb_device_id uvc_ids[] = {
     	  .bInterfaceProtocol	= 0,
     	  .driver_info		= UVC_QUIRK_PROBE_MINMAX
     				| UVC_QUIRK_IGNORE_SELECTOR_UNIT },
    +	/* The Imaging Source USB CCD cameras */
    +	{ .match_flags		= USB_DEVICE_ID_MATCH_DEVICE
    +				| USB_DEVICE_ID_MATCH_INT_INFO,
    +	  .idVendor		= 0x199e,
    +	  .idProduct		= 0x8102,
    +	  .bInterfaceClass	= USB_CLASS_VENDOR_SPEC,
    +	  .bInterfaceSubClass	= 1,
    +	  .bInterfaceProtocol	= 0 },
     	/* Generic USB Video Class */
     	{ USB_INTERFACE_INFO(USB_CLASS_VIDEO, 1, 0) },
     	{}
    -- 
    1.7.4.1
    Notebook: Lenovo Z570 CoreI7
    Workstation: Core2Quad Q6700 - ASUS P5WDG2-WS Pro - 8800GT - 4GB-DDR2/800 - 4x500GB=RAID1 - 120GB SSD - Innovatek Wakü - 27Widescreen/AcerTFT
    Server: IBM X345 + Netfinity 5000

    http://zyrusthc-linux.no-ip.org

  11. #11
    Registrierter Benutzer
    Registriert seit
    May 2014
    Beiträge
    10
    So. Hier nu die Infos was der raspi sagt:
    Code:
    ******************
    * Start building *
    ******************
    make -C /home/pi/media_build/v4l allyesconfig
    make[1]: Entering directory `/home/pi/media_build/v4l'
    make[2]: Entering directory `/home/pi/media_build/linux'
    Applying patches for kernel 3.10.25+
    patch -s -f -N -p1 -i ../backports/api_version.patch
    patch -s -f -N -p1 -i ../backports/pr_fmt.patch
    patch -s -f -N -p1 -i ../backports/drx39xxj.patch
    patch -s -f -N -p1 -i ../backports/v3.11_dev_groups.patch
    patch -s -f -N -p1 -i ../backports/v3.10_fw_driver_probe.patch
    Patched drivers/media/dvb-core/dvbdev.c
    Patched drivers/media/v4l2-core/v4l2-dev.c
    Patched drivers/media/rc/rc-main.c
    make[2]: Leaving directory `/home/pi/media_build/linux'
    ./scripts/make_kconfig.pl /lib/modules/3.10.25+/build /lib/modules/3.10.25+/build 1
    Preparing to compile for kernel version 3.10.25
    File not found: /lib/modules/3.10.25+/build/.config at ./scripts/make_kconfig.pl line 33, <IN> line 4.
    make[1]: *** [allyesconfig] Fehler 2
    make[1]: Leaving directory `/home/pi/media_build/v4l'
    make: *** [allyesconfig] Fehler 2
    can't select all drivers at ./build line 490.
    root@raspberrypi:/home/pi/media_build#
    Und hier noch die Linux-Version mit der sich der Pi beim anmelden via SSH meldet:
    Linux raspberrypi 3.10.25+ #622 PREEMPT

    Stimmt. Die Product-ID weicht ab... Die von der Kamera ist 8101 und im Patch steht die 8102... :-(

    Soll ich das mal ändern? wobei ich fürchte dass das an der ausführung des scripts nicht viel ändert. :-(

    EDIT
    Den anderen Weg, aus dem Astrotreff-Forum werd ich bei dem Notebook selbst mal 'testen'. ;-)
    Geändert von sbernd78 (15.05.14 um 20:30 Uhr)

  12. #12
    Shell-User Avatar von zyrusthc
    Registriert seit
    Jan 2004
    Ort
    http://www.thale.de
    Beiträge
    6.331
    File not found: /lib/modules/3.10.25+/build/.config at ./scripts/make_kconfig.pl line 33, <IN> line 4.
    Kernel Header fehlen da
    Code:
    sudo apt-get install linux-headers-$(uname -r)
    Notebook: Lenovo Z570 CoreI7
    Workstation: Core2Quad Q6700 - ASUS P5WDG2-WS Pro - 8800GT - 4GB-DDR2/800 - 4x500GB=RAID1 - 120GB SSD - Innovatek Wakü - 27Widescreen/AcerTFT
    Server: IBM X345 + Netfinity 5000

    http://zyrusthc-linux.no-ip.org

  13. #13
    Registrierter Benutzer
    Registriert seit
    May 2014
    Beiträge
    10
    Da sagt mir 'der kleine' nur, dass er nix findet.
    Code:
    E: Paket linux-headers-3.10.25 kann nicht gefunden werden.
    E: Mittels regulärem Ausdruck »linux-headers-3.10.25« konnte kein Paket gefunden werden.
    Mit Aptitude fin ich allerdings 'ähnliche' Pakete wie linux-headers-3.10-3-all.

  14. #14
    Shell-User Avatar von zyrusthc
    Registriert seit
    Jan 2004
    Ort
    http://www.thale.de
    Beiträge
    6.331
    Suche mal nach linux headers 3.10.25 . Wichtig ist die selbe Version die gerade läuft. Was gerade läuft bekommst du mit uname -r raus.
    Notebook: Lenovo Z570 CoreI7
    Workstation: Core2Quad Q6700 - ASUS P5WDG2-WS Pro - 8800GT - 4GB-DDR2/800 - 4x500GB=RAID1 - 120GB SSD - Innovatek Wakü - 27Widescreen/AcerTFT
    Server: IBM X345 + Netfinity 5000

    http://zyrusthc-linux.no-ip.org

  15. #15
    Registrierter Benutzer
    Registriert seit
    Dec 2003
    Ort
    Dettenhausen
    Beiträge
    21.418
    und ich sach noch :-)

    hm, idealerweise sollten die Kernelheader mit der aktuell installierten Version übereinstimmen, müssen es aber nicht "so 100%" - APIs ändern sich meist nicht so extrem.

    Kann aber auch sein, daß Dein System nicht so 100% auf dem aktuellen Stand ist oder die Repositories noch nicht komplett gesynct, ...
    Ich bin root - ich darf das.

Ähnliche Themen

  1. nVidia Treiber unter SuSE 8.0
    Von DeBIGBOSS im Forum System installieren und konfigurieren
    Antworten: 12
    Letzter Beitrag: 17.12.02, 17:34
  2. Nvidia Grafikkarten unter Linux (Treiber, AGP, 3D ...)
    Von netzmeister im Forum Hier Suchen und Finden, Links, Tutorials
    Antworten: 13
    Letzter Beitrag: 13.11.02, 22:48
  3. Digitalkameras unter Linux
    Von stefan.becker im Forum Hier Suchen und Finden, Links, Tutorials
    Antworten: 0
    Letzter Beitrag: 14.07.02, 18:49
  4. eumex504pc usb
    Von cs_jesus im Forum Anbindung an die Aussenwelt
    Antworten: 3
    Letzter Beitrag: 17.08.01, 13:21
  5. Performance Linux - Win
    Von thorwin im Forum Spielen Allgemein
    Antworten: 11
    Letzter Beitrag: 27.04.01, 18:40

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •