Anzeige:
Ergebnis 1 bis 8 von 8

Thema: Apache Subdomain erstellen klappt einfach nicht

  1. #1
    Registrierter Benutzer
    Registriert seit
    May 2009
    Beiträge
    50

    Apache Subdomain erstellen klappt einfach nicht

    Morgen,

    habe schon tausende Tuts über Apache VirtualHosts und Subdomains gelesen, doch ich bin einfach zu blöd und krieg das mit den Subdomains einfach nicht gebacken.

    Und zwar:
    Mein WinXP-Läppi und meine Debian-Kiste sind über LAN vernetzt. In der hosts-Datei auf Windows habe ich dem Server nen Namen gegeben:
    Code:
    192.168.0.91	debian-server
    Bis dahin klappt alles. Doch jetzt möchte ich mir ne Subdomain bzw. einen zweiten Hostnamen erstellen unter dem ich dann ein bestimmtes Verzeichnis meines Apachen aufrufen kann.

    Und zwar will ich unter Windows debian-server-blog aufrufen und ich starte anstatt im DocRoot direkt Verzeichnis /blog

    Könnte mir da mal einer den passenden VirtualHosts-Container posten ?

    Wäre echt nett, weil ich sitz jetzt schon ne Stunde an so ner doofen "Subdomain"

    mfg
    jan

  2. #2
    Registrierter Benutzer
    Registriert seit
    Dec 2003
    Ort
    Dettenhausen
    Beiträge
    21.464
    "Es geht nicht" ist keine Fehlerbeschreibung.

    Poste doch mal die "Versuche" - brauchen willst Du vermutlich einen NamedVirtualHost.

    Den Eintrag in der hosts des Client hast Du gemacht?
    Ich bin root - ich darf das.

  3. #3
    Registrierter Benutzer Avatar von drcux
    Registriert seit
    Oct 2003
    Beiträge
    6.947
    "debian-server-blog" ist übrigens auch keine Subdomain von "debian-server", "blog.debian-server" schon eher...

  4. #4
    Registrierter Benutzer
    Registriert seit
    May 2009
    Beiträge
    50
    Zitat Zitat von marce Beitrag anzeigen
    Den Eintrag in der hosts des Client hast Du gemacht?
    Also den Eintrag hab ich jetzt nur auf Windows gemacht. Nicht auf der Debian-Kiste wo der Apache läuft

    So und mein bislang bestes Ergebnis war dieses:
    Code:
    NameVirtualHost *:80
    
    <VirtualHost *:80>
    ServerName debian-server
    ServerAlias debian-server *.debian-server
    DocumentRoot /opt/lampp/htdocs
    </VirtualHost>
    
    <VirtualHost *:80>
    ServerName debian-server-blog
    DocumentRoot /opt/lampp/htdocs/blog
    </VirtualHost>
    Leider bekomm ich da aber nen 500er-Serverfehler

    mfg
    jan

  5. #5
    Registrierter Benutzer
    Registriert seit
    Dec 2003
    Ort
    Dettenhausen
    Beiträge
    21.464
    "wo" bekommst Du "da" bei "was" einen 500er-Fehler? Und was sagt das Logfile dazu?
    Ich bin root - ich darf das.

  6. #6
    Registrierter Benutzer
    Registriert seit
    May 2009
    Beiträge
    50
    Wo:
    Beim Aufrufen der zweiten Domain (debian-server-2) auf meinem Windoof Läppi. Startseite geht noch. Doch wenn ich irgendein Link oder Verzeichnis anklicke bsp:
    http://debian-server-2/wp-admin
    erhalte ich den 500er Error:
    Code:
    Internal Server Error
    
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    
    Please contact the server administrator, you@example.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.
    
    More information about this error may be available in the server error log.
    
    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/2.2.11 (Unix) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8k PHP/5.2.9 mod_apreq2-20051231/2.6.0 mod_perl/2.0.4 Perl/v5.10.0 Server at debian-server-2 Port 80
    Im error_log steht folgendes:
    Code:
    [Wed Aug 26 12:20:47 2009] [notice] cannot use a full URL in a 401 ErrorDocument directive --- ignoring!
    [Wed Aug 26 12:20:47 2009] [error] [client 192.168.0.1] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace., referer: http://debian-server-2/
    [Wed Aug 26 12:20:47 2009] [error] [client 192.168.0.1] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace., referer: http://debian-server-2/
    mfg
    jan

  7. #7
    Registrierter Benutzer
    Registriert seit
    Dec 2003
    Ort
    Dettenhausen
    Beiträge
    21.464
    ... ja und? Fehler und Ursache steht da.

    Eine potentielle Behebung auch.
    Ich bin root - ich darf das.

  8. #8
    Registrierter Benutzer
    Registriert seit
    May 2009
    Beiträge
    50
    Also. Problem gelöst. Es lag komischerweise an Wordpress
    Hab die BlogURL in der WP-DB mal entsprechend geändert und nun funzt alles. Mit nem anderen CMS funktionierts ebenfalls.

    Meine Vhosts habe ich jetzt so festgelegt:
    Code:
    <VirtualHost *:80>
        ServerAdmin admin@localhost
        DocumentRoot /opt/lampp/htdocs
        ServerName debian-server
        ServerAlias 192.168.0.91
    </VirtualHost>
    
    <VirtualHost *:80>
        ServerAdmin admin@localhost
        DocumentRoot /opt/lampp/htdocs/wb28
        ServerName blog.debian-server
        ErrorLog /opt/lampp/logs/error_log
    </VirtualHost>
    Vielen Dank für eure Hilfe
    mfg
    jan

Ähnliche Themen

  1. Antworten: 10
    Letzter Beitrag: 11.05.07, 06:40
  2. xawtv: DVB-T
    Von michiS im Forum Fernsehen
    Antworten: 14
    Letzter Beitrag: 28.08.06, 16:52
  3. Apache: "Webseite wird gewartet" erstellen
    Von Sonny im Forum Linux als Server
    Antworten: 1
    Letzter Beitrag: 05.09.05, 14:34
  4. make modules - fehlermeldung
    Von Nobse im Forum Kompilieren von Kernel und Sourcen
    Antworten: 8
    Letzter Beitrag: 15.11.04, 01:23
  5. php Seiten werden nicht angezeigt
    Von H3mpm4n im Forum Linux als Server
    Antworten: 7
    Letzter Beitrag: 05.11.04, 20:14

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •