Anzeige:
Ergebnis 1 bis 12 von 12

Thema: HD-Videos (1080i) ruckeln bei Wiedergabe

  1. #1
    Registrierter Benutzer
    Registriert seit
    Jun 2008
    Beiträge
    52

    HD-Videos (1080i) ruckeln bei Wiedergabe

    Hallo,

    Habe ein Problem mit HD-Videos, und zwar bekomme ich die mit FullHD-Auflösung nicht richtig abgespielt. Ich habe schon mehrere Player ausprobiert, bei mplayer ist zwar das Bild halbwegs flüssig, dafür wird der Ton extrem asynchron. Dann kriege ich folgende Meldung:
    ************************************************
    **** Your system is too SLOW to play this! ****
    ************************************************

    Possible reasons, problems, workarounds:
    - Most common: broken/buggy _audio_ driver
    - Try -ao sdl or use the OSS emulation of ALSA.
    - Experiment with different values for -autosync, 30 is a good start.
    - Slow video output
    - Try a different -vo driver (-vo help for a list) or try -framedrop!
    - Slow CPU
    - Don't try to play a big DVD/DivX on a slow CPU! Try some of the lavdopts,
    e.g. -vfm ffmpeg -lavdopts lowres=1:fast:skiploopfilter=all.
    - Broken file
    - Try various combinations of -nobps -ni -forceidx -mc 0.
    - Slow media (NFS/SMB mounts, DVD, VCD etc)
    - Try -cache 8192.
    - Are you using -cache to play a non-interleaved AVI file?
    - Try -nocache.
    Read DOCS/HTML/en/video.html for tuning/speedup tips.
    If none of this helps you, read DOCS/HTML/en/bugreports.html.
    vlc-player gibt mir keine Meldungen, ruckelt aber extrem. Ähnlich ist es mit Kaffeine.
    Kann es an meiner Hardware liegen? Habe zur Zeit:
    CPU: AMD X2 4200+
    RAM: MDT 2x512MB
    Grafik: GeForce 6800 128mb [AGP]
    SATA-Platte, Audigy 2 ZS

    Denke eigentlich, dass sowas reichen müsste. Außerdem erreicht meine CPU auch nur ca. 50% Auslastung, wenn ich die Videos abspiele.

    Hat jemand eine Idee, woran das liegt?

  2. #2
    Registrierter Benutzer
    Registriert seit
    Oct 2004
    Beiträge
    251
    haste die Vorschlaege von mplayer mal ausprobiert?
    Michael

    Laptop : Archlinux, 2.6.29, KDE 4.2.4, Toshiba M115-S0394, Intel CoreDuo 1.6, 1,0 Gb-Ram
    Server: Archlinux, 2.6.29, AMD X2 5200+, 2,0 Gb-Ram, NV 8600 GT

  3. #3
    Registrierter Benutzer
    Registriert seit
    Jun 2008
    Beiträge
    52
    Joa, also mit
    -vfm ffmpeg -lavdopts lowres=1:fast:skiploopfilter=all
    Läuft es schon besser, je höher ich den lowres Parameter stelle, desto später wird es asynchron. Aber auch bei 3 läuft's nicht perfekt.
    Aber das wäre ohnehin nur ein workauround, damit habe ich weder das Problem gelöst, noch weiß ich, woran's liegt.
    Die anderen Vorschläge bringen nichts.

  4. #4
    Registrierter Benutzer
    Registriert seit
    Jan 2008
    Beiträge
    2.495
    Zitat Zitat von Mister-X Beitrag anzeigen
    Grafik: GeForce 6800 128mb [AGP]
    Welchen Grafiktreiber verwendest Du? Hoffentlich den von nvidia.de, z.B.

    http://www.nvidia.de/object/linux_di...177.82_de.html

    Welche Distri, welcher Kernel?

  5. #5
    Registrierter Benutzer
    Registriert seit
    Jun 2008
    Beiträge
    52
    Nicht direkt von nvidia.de, aber ich benutze den proprietären Treiber von nvidia, version ist die 177.82-1. Habe ihn mir über den Paketmanager (pacman) besorgt.
    Distribution ist Arch Linux, Kernel ist der 2.6.27.

  6. #6
    Registrierter Benutzer Avatar von mischel
    Registriert seit
    Nov 2008
    Ort
    zwischen N und NM
    Beiträge
    191
    Hi,

    ich weiß, der Thread ist uralt.

    Meine Frage geht aber in die gleiche Richtung: Full-HD-Videos, aufgenommen von einem DVBT-Receiver mit hevc-Codec, laufen, gelinde gesagt, unzufriedenstellend.

    Meine Hardware: Rechner Intel Core 2 - 4x2.4 GHz, 6GB RAM, OpenSuSE Tumbleweed, GraKa Nvidia 560Ti (Treiber Nvidia propietär)

    Mit SMPlayer, meinem bevorzugten Medienspieler, habe ich nach langem Rumprobieren einen Modus gefunden, wo diese o.g. Videos geradeso ruckfrei laufen, die CPU-Belastung ist dabei so, daß alle 4 Kerne am Anschlag laufen, schnelle Bildschwenks im Video oder ein wenig testweises Herumklicken auf dem Desktop erzeugen Ruckeln..

    Mit Xine geht es gar nicht, das Bild ist nicht ruckelfrei zu bekommen.

    Mit dem VLC-Player geht es besser, das Bild ist ruckelfrei, die CPU-Belastung liegt mit allen 4 Kernen etwa bei 70%.

    Gleiches gilt für qmplay2, auch hier geht es, wie beim vlc-Player ohne Rumprobieren einwandfrei, CPU-Belastung wie beim VLC-Player.

    Wenn man im Internet so herumliest, müßte FullHD mit der vorhandenen Hardware problemlos funktionieren, wenigstens wird das schon
    mit wesentlich weniger Rechenleistung und RAM für das OS aus Redmont geschrieben, gesehen hab' ich es nicht.

    mplayer in der Konsole gestartet behauptet, die Datei hätte nur Audio, kein Video, gleichgültig ob mit oder ohne eingeschaltetes vdpau.

    Kennt jemand Parameter für den smplayer, der das Verhalten deutlich verbessert?


    Danke und Tschüß
    der Michael
    aus Franken
    OpenSuSE Tumbleweed, KDE/Plasma aktuell, auf verschiedenen Rechnern

  7. #7
    Mod. FAQ/Howto/Emulation
    Registriert seit
    Sep 2000
    Beiträge
    17.330
    "ich weiß, der Thread ist uralt." => Genau wie deine Hardware.

    Der Parameter heißt "kaufe vernünftige Hardware". Core2 ist doch so ca. von 2008, also 12 Jahre alt. Und dann wunderst du dich ernsthaft?

  8. #8
    Registrierter Benutzer Avatar von towo2099
    Registriert seit
    Feb 2002
    Ort
    Pößneck
    Beiträge
    4.459
    Die CPU is hier weniger das Problem, aber die verwendete NVidia Karte kann halt kein hevc decodieren.
    Signatur nach Diktat Spazieren gegangen ;)

  9. #9
    Registrierter Benutzer Avatar von mischel
    Registriert seit
    Nov 2008
    Ort
    zwischen N und NM
    Beiträge
    191
    Hallo,

    danke für die Antworten.

    @stefan.becker: Deine Parameter sind zwar einfach aber unkreativ und auch nicht besonders resourcenschonend. Einen Rechner neu kaufen, wenn es hakt, kann jeder.

    @towo2099: Ich hab' in den nvidia-settings nachgesehen und fand Deine Aussage dort bestätigt. Also werd' ich mal eine neuere Grafikkarte ausprobieren (lt. https://developer.nvidia.com/video-e...support-matrix muß es eine ab GTX1050 sein). Wär' ich allein nicht draufgekommen. Danke für den Tip.

    Tschüß
    einen guten Rutsch allerseits
    der Michael
    OpenSuSE Tumbleweed, KDE/Plasma aktuell, auf verschiedenen Rechnern

  10. #10
    Mod. FAQ/Howto/Emulation
    Registriert seit
    Sep 2000
    Beiträge
    17.330
    In so ne Möhre, die eh nichts mehr an Leistung bringt, noch Geld investieren?

    Kaufst du auch bei einem durchgerosteten Fahrgestell noch neue Reifen?

  11. #11
    Registrierter Benutzer Avatar von mischel
    Registriert seit
    Nov 2008
    Ort
    zwischen N und NM
    Beiträge
    191
    Zitat Zitat von stefan.becker Beitrag anzeigen
    ...

    Kaufst du auch bei einem durchgerosteten Fahrgestell noch neue Reifen?
    Ne, dann wechsel ich defekte Teile aus - nicht Jeder ist Anhänger der weit verbreiteten Wegwerfmentalität und nicht jeder braucht eine Cray zu Hause.
    OpenSuSE Tumbleweed, KDE/Plasma aktuell, auf verschiedenen Rechnern

  12. #12
    kleine schwester von root Avatar von corresponder
    Registriert seit
    May 2002
    Ort
    192.67.198.56
    Beiträge
    4.231
    Zitat Zitat von stefan.becker Beitrag anzeigen
    Kaufst du auch bei einem durchgerosteten Fahrgestell noch neue Reifen?
    erst wird es geschweisst und dann lackiert, Reifen kommen später.
    _______________________________________

    www.audio4linux.de - musik machen mit offenen quellen!

Ähnliche Themen

  1. Wine 0.9.57
    Von Fisch.666 im Forum Neue Programme/Versionen
    Antworten: 9
    Letzter Beitrag: 11.06.08, 16:41
  2. BeOS 5 ohne Bootdisk starten?
    Von michael90 im Forum Alternativen zu Linux
    Antworten: 8
    Letzter Beitrag: 10.06.08, 21:58
  3. Ruckeln bei DVD Wiedergabe
    Von frbie im Forum Fernsehen
    Antworten: 8
    Letzter Beitrag: 22.05.04, 09:07

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •