Anzeige:
Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 15 von 28

Thema: VirtualBox externe Festplatte nutzen

  1. #1
    Linux Noob
    Registriert seit
    Aug 2008
    Beiträge
    73

    VirtualBox externe Festplatte nutzen

    Hallo, ich habe die VirtualBox grafische Benutzeroberfläche Version 1.6.4 mit windows xp drauf.
    Als Betriebssystem wo VirtualBox lauft habe ich Linux open suse 10.3 mit KDE als Benutzeroberfläche.
    Ich habe das Problem, dass wenn ich die externe HDD einschalte, kommt die auf Linux, ich würde die aber auf Windows gebrauchen, wie mach ich das, USB hab ich aktiviert, wenn ich aber in der VirtualBox auf ändern klicke kommt immer eine Meldung "Kein Zugriff auf das USB Subsystem"
    Wenn die HDD eingeschaltet ist und ich in der Virtualbox auf USB einbinden oder wie das heißt gehe, kommt kein USB Gerät gefunden...

  2. #2
    Registrierter Benutzer
    Registriert seit
    Apr 2003
    Beiträge
    614
    Die opensource-Variante von VirtualBox kann kein USB.

  3. #3
    Mod. FAQ/Howto/Emulation
    Registriert seit
    Sep 2000
    Beiträge
    17.344
    Kannst du nicht mal bitte im Handbuch oder im Howto hier im Forum nachlesen?

    Das ist alles bereits 1000 mal beschrieben. Einfach im Handbuch oder im Howto suchen nach USB.

  4. #4
    Linux Noob
    Registriert seit
    Aug 2008
    Beiträge
    73
    Ich hab nicht mehr die opensurce Version.

    Ich hab mir das schon durchgelesen, aber ich komm einfach nicht weiter, hab die Befehle auch schon in die Konsole eingegeben: usbfs /proc/bus/usb usbfs devgid=109,devmode=0664 0 0
    da kommt command not found, ich komme einfach nicht weiter, also helft mir mal bitte ein bisschen

  5. #5
    Mod. FAQ/Howto/Emulation
    Registriert seit
    Sep 2000
    Beiträge
    17.344
    Ne, hilf dir selbst. Lies bitte noch mal genau nach. Da steht nix von Eingeben in der Kommandozeile.

  6. #6
    Linux Noob
    Registriert seit
    Aug 2008
    Beiträge
    73
    4.1.4) USB:

    Zur Nutzung von USB muss die Version von der VirtualBox Homepage installiert sein. Der Open Source Version (OSE), die man über das Paketmanagement der jeweiligen Distribution installieren kann, fehlt diese Funktion.

    In der Standard-Gastkonfiguration ist USB deaktiviert. Aktivierung über den Button "Settings", dann "USB". Mit "USB Controller aktivieren" erhält der virtuelle PC einen USB Controller.

    Im Gast wird ein "Standard OpenHCD USB-Hostcontroller" erkannt.

    Durch die Zusatzoption "Aktiviere EHCI-Controller" wird im im Gast ein USB 2.0 EHCI Controller erkannt (ab Version 1.54).

    Über den Menüpunkt "Devices / USB Devices" kann man einzelne USB Geräte des Hosts mit dem Gast verbinden.

    Damit im Gast USB benutzt werden kann, muss der Linuxkernel mit USBFS übersetzt worden sein und USBFS in "/etc/fstab" aktiviert sein. Z. B.:
    Code:

    usbfs /proc/bus/usb usbfs devgid=1001,devmode=0664 0 0

    Im Beispiel steht bei "devgid=1001" die 1001 für die Gruppen-ID der Gruppe der "vboxusers". Die ID lässt sich ermitteln per:
    Code:

    cat /etc/group | grep vboxusers
    wo soll ich das dann eingeben?

  7. #7
    Mod. FAQ/Howto/Emulation
    Registriert seit
    Sep 2000
    Beiträge
    17.344
    "/etc/fstab" ist eine Datei. Genau das steht dort. Alternativ mal im Handbuch nachlesen, auch dort wie das so erklärt.

  8. #8
    Registrierter Benutzer
    Registriert seit
    Apr 2003
    Beiträge
    614
    Steht doch da:
    und USBFS in "/etc/fstab" aktiviert sein.
    Das ist eine Datei in deinem Host.

  9. #9
    Linux Noob
    Registriert seit
    Aug 2008
    Beiträge
    73
    Tut mir Leid, ich kenne mich mit Linux nicht aus, bin noch windows gewohnt.....
    ok, wenn ich Alt+F2 drücke, dort "/etc/fstab" eingebe, dort steht noauto, da hab ich devgid=109,devmode=0664 eingegeben, wenn ich da dann speicher, kommt dass ich keine Berechtigung habe, wenn ich in alt+f2 kdesu konqueror eingebe und dort in das verzeichnis "/etc/fstab" gehe, kann ich dort am text nichts verändern

  10. #10
    Rain_maker
    Gast
    Und jetzt nimmst Du statt konqueror kate oder kwrite.

    (Oder den Finger, den Du für die rechte Maustaste verwendest)

  11. #11
    Registrierter Benutzer
    Registriert seit
    Apr 2003
    Beiträge
    614
    Das wirst du auch mit einem entsprechenden Editor machen müssen. Unter Windows kannst du mit dem Explorer auch keine Textdatei bearbeiten, da nimmt man notepad oder sowas. Ist hier das gleiche in grün.

    nano /etc/fstab
    ging z. B. aus einer root-Konsole heraus (Wenn nano installiert ist).
    Oder "kdesu kate /etc/fstab" aufrufen. Gibt aber noch 1923970 andere Möglichkeiten.

  12. #12
    Linux Noob
    Registriert seit
    Aug 2008
    Beiträge
    73
    erstmal danke für eure Hilfe!!
    Ich hab das jetzt genau so eingegeben wo noato stand: devgid=109,devmode=0664
    109, weil wenn ich in der Konsole cat /etc/group | grep vboxusers eingebe 109 kommt.
    Wenn ich jetzt auf USB Geräte klicke, kommt immer noch Keine USB Geräte, hab ich da was falsch eingegeben?

  13. #13
    Rain_maker
    Gast
    Das würde man wissen, wenn man genau wüsste, was Du eingegeben hast.

    Also? Was steht in der fstab drin? (Wörtlich und nicht "da habe ich dann wo....")

    Gasterweiterungen sind natürlich installiert, oder?

    Anschliessend auch usbfs gemountet?

  14. #14
    Linux Noob
    Registriert seit
    Aug 2008
    Beiträge
    73
    Hab das so gemacht, die fstab sieht jetz so aus
    usbfs /proc/bus/usb usbfs devgid=109,devmode=0664 0 0
    dann hab ich gemountet( externe HDD war ausgeschaltet, sah so aus:
    linux-rli2:~ # mount usbfs
    [mntent]: line 3 in /etc/fstab is bad
    dann hab ich den Befehl eingegeben, wo stehen soll ob alles installiert wurde, sieht so aus:
    linux-rli2:~ # cat /proc/bus/usb/devices

    T: Bus=05 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=480 MxCh= 8
    B: Alloc= 0/800 us ( 0%), #Int= 0, #Iso= 0
    D: Ver= 2.00 Cls=09(hub ) Sub=00 Prot=01 MxPS=64 #Cfgs= 1
    P: Vendor=0000 ProdID=0000 Rev= 2.06
    S: Manufacturer=Linux 2.6.22.18-0.2-default ehci_hcd
    S: Product=EHCI Host Controller
    S: SerialNumber=0000:00:1d.7
    C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr= 0mA
    I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
    E: Ad=81(I) Atr=03(Int.) MxPS= 4 Ivl=256ms

    T: Bus=04 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=12 MxCh= 2
    B: Alloc= 11/900 us ( 1%), #Int= 1, #Iso= 0
    D: Ver= 1.10 Cls=09(hub ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
    P: Vendor=0000 ProdID=0000 Rev= 2.06
    S: Manufacturer=Linux 2.6.22.18-0.2-default uhci_hcd
    S: Product=UHCI Host Controller
    S: SerialNumber=0000:00:1d.3
    C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr= 0mA
    I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
    E: Ad=81(I) Atr=03(Int.) MxPS= 2 Ivl=255ms

    T: Bus=04 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 2 Spd=1.5 MxCh= 0
    D: Ver= 1.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
    P: Vendor=1267 ProdID=0201 Rev= 2.30
    S: Product=USB Mouse
    C:* #Ifs= 1 Cfg#= 1 Atr=a0 MxPwr= 48mA
    I:* If#= 0 Alt= 0 #EPs= 1 Cls=03(HID ) Sub=01 Prot=02 Driver=usbhid
    E: Ad=81(I) Atr=03(Int.) MxPS= 4 Ivl=8ms

    T: Bus=03 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=12 MxCh= 2
    B: Alloc= 0/900 us ( 0%), #Int= 0, #Iso= 0
    D: Ver= 1.10 Cls=09(hub ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
    P: Vendor=0000 ProdID=0000 Rev= 2.06
    S: Manufacturer=Linux 2.6.22.18-0.2-default uhci_hcd
    S: Product=UHCI Host Controller
    S: SerialNumber=0000:00:1d.2
    C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr= 0mA
    I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
    E: Ad=81(I) Atr=03(Int.) MxPS= 2 Ivl=255ms

    T: Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=12 MxCh= 2
    B: Alloc= 0/900 us ( 0%), #Int= 0, #Iso= 0
    D: Ver= 1.10 Cls=09(hub ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
    P: Vendor=0000 ProdID=0000 Rev= 2.06
    S: Manufacturer=Linux 2.6.22.18-0.2-default uhci_hcd
    S: Product=UHCI Host Controller
    S: SerialNumber=0000:00:1d.1
    C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr= 0mA
    I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
    E: Ad=81(I) Atr=03(Int.) MxPS= 2 Ivl=255ms

    T: Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=12 MxCh= 2
    B: Alloc= 0/900 us ( 0%), #Int= 0, #Iso= 0
    D: Ver= 1.10 Cls=09(hub ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
    P: Vendor=0000 ProdID=0000 Rev= 2.06
    S: Manufacturer=Linux 2.6.22.18-0.2-default uhci_hcd
    S: Product=UHCI Host Controller
    S: SerialNumber=0000:00:1d.0
    C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr= 0mA
    I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
    E: Ad=81(I) Atr=03(Int.) MxPS= 2 Ivl=255ms
    schaute dann bei windows nach, wird immer noch kein usb Gerät angezeigt, hab logischerweise die externe HDD eingeschaltet.
    Dann lies ich die externe HDD eingeschaltet und versuchte das mit dem mounten noch mal, sah so aus:
    linux-rli2:~ # mount usbfs
    [mntent]: line 3 in /etc/fstab is bad
    mount: usbfs already mounted or /proc/bus/usb busy
    mount: according to mtab, usbfs is already mounted on /proc/bus/usb
    und wenn ich da dann den Befehl eingebe, ob alles installiert wurde sah das so aus:
    linux-rli2:~ # cat /proc/bus/usb/devices

    T: Bus=05 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=480 MxCh= 8
    B: Alloc= 0/800 us ( 0%), #Int= 0, #Iso= 0
    D: Ver= 2.00 Cls=09(hub ) Sub=00 Prot=01 MxPS=64 #Cfgs= 1
    P: Vendor=0000 ProdID=0000 Rev= 2.06
    S: Manufacturer=Linux 2.6.22.18-0.2-default ehci_hcd
    S: Product=EHCI Host Controller
    S: SerialNumber=0000:00:1d.7
    C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr= 0mA
    I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
    E: Ad=81(I) Atr=03(Int.) MxPS= 4 Ivl=256ms

    T: Bus=05 Lev=01 Prnt=01 Port=02 Cnt=01 Dev#= 10 Spd=480 MxCh= 0
    D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
    P: Vendor=067b ProdID=2507 Rev= 1.00
    S: Manufacturer=Prolific Technology Inc.
    S: Product=Mass Storage Device
    S: SerialNumber=0
    C:* #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr=100mA
    I:* If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
    E: Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
    E: Ad=82(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms

    T: Bus=04 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=12 MxCh= 2
    B: Alloc= 11/900 us ( 1%), #Int= 1, #Iso= 0
    D: Ver= 1.10 Cls=09(hub ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
    P: Vendor=0000 ProdID=0000 Rev= 2.06
    S: Manufacturer=Linux 2.6.22.18-0.2-default uhci_hcd
    S: Product=UHCI Host Controller
    S: SerialNumber=0000:00:1d.3
    C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr= 0mA
    I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
    E: Ad=81(I) Atr=03(Int.) MxPS= 2 Ivl=255ms

    T: Bus=04 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 2 Spd=1.5 MxCh= 0
    D: Ver= 1.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
    P: Vendor=1267 ProdID=0201 Rev= 2.30
    S: Product=USB Mouse
    C:* #Ifs= 1 Cfg#= 1 Atr=a0 MxPwr= 48mA
    I:* If#= 0 Alt= 0 #EPs= 1 Cls=03(HID ) Sub=01 Prot=02 Driver=usbhid
    E: Ad=81(I) Atr=03(Int.) MxPS= 4 Ivl=8ms

    T: Bus=03 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=12 MxCh= 2
    B: Alloc= 0/900 us ( 0%), #Int= 0, #Iso= 0
    D: Ver= 1.10 Cls=09(hub ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
    P: Vendor=0000 ProdID=0000 Rev= 2.06
    S: Manufacturer=Linux 2.6.22.18-0.2-default uhci_hcd
    S: Product=UHCI Host Controller
    S: SerialNumber=0000:00:1d.2
    C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr= 0mA
    I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
    E: Ad=81(I) Atr=03(Int.) MxPS= 2 Ivl=255ms

    T: Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=12 MxCh= 2
    B: Alloc= 0/900 us ( 0%), #Int= 0, #Iso= 0
    D: Ver= 1.10 Cls=09(hub ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
    P: Vendor=0000 ProdID=0000 Rev= 2.06
    S: Manufacturer=Linux 2.6.22.18-0.2-default uhci_hcd
    S: Product=UHCI Host Controller
    S: SerialNumber=0000:00:1d.1
    C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr= 0mA
    I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
    E: Ad=81(I) Atr=03(Int.) MxPS= 2 Ivl=255ms

    T: Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=12 MxCh= 2
    B: Alloc= 0/900 us ( 0%), #Int= 0, #Iso= 0
    D: Ver= 1.10 Cls=09(hub ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
    P: Vendor=0000 ProdID=0000 Rev= 2.06
    S: Manufacturer=Linux 2.6.22.18-0.2-default uhci_hcd
    S: Product=UHCI Host Controller
    S: SerialNumber=0000:00:1d.0
    C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr= 0mA
    I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
    E: Ad=81(I) Atr=03(Int.) MxPS= 2 Ivl=255ms
    immer noch nichts, hab windows neu gestartet, dann nochmal versucht, es wird immer noch keine HDD angezeigt

  15. #15
    Rain_maker
    Gast
    Ist es eigentlich so schwer zu verstehen?

    Du sollst die ganze fstab posten, vor allem auch wegen des "line 3 is bad".

Ähnliche Themen

  1. Externe Festplatte (USB) u. Dateien größer 4GB
    Von Phimay im Forum stationäre Hardware
    Antworten: 6
    Letzter Beitrag: 16.02.07, 09:07
  2. Neue externe Festplatte 400 GB formatieren ?
    Von Triple666Blood im Forum stationäre Hardware
    Antworten: 8
    Letzter Beitrag: 27.01.07, 18:27
  3. externe Festplatte wird beim booten immer gesucht
    Von ak01 im Forum stationäre Hardware
    Antworten: 15
    Letzter Beitrag: 19.01.07, 19:41
  4. openSuSE 10.2 und meine externe Festplatte
    Von king_of_tuxland im Forum System installieren und konfigurieren
    Antworten: 15
    Letzter Beitrag: 24.12.06, 12:59
  5. externe festplatte - geschwindigkeit
    Von lamp im Forum stationäre Hardware
    Antworten: 15
    Letzter Beitrag: 04.09.05, 16:02

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •