Anzeige:
Ergebnis 1 bis 8 von 8

Thema: Frage nach Kernel Update keine Disk mehr (openSuse 10.2)

  1. #1
    Registrierter Benutzer
    Registriert seit
    Aug 2007
    Beiträge
    8

    Frage nach Kernel Update keine Disk mehr (openSuse 10.2)

    Hallo,

    ich bin etwas am verzweifeln da ich eine Web Server aufsetzen möchte (OpenSuse 10.2) aber immer nachdem ich einen Kernel Update (über YAST) gemacht habe findet das System meine Boot Disk nicht mehr.


    Als Controller habe ich einen 3Ware 9650SE Raid 5 Controller und sonst keine andere Disk. Ich kann sehen das der Treiber geladen wird aber es gibt keine Einträge unter /dev/sda*

    Kann mir irgend jemand helfen?

    Danke

  2. #2
    Rain_maker
    Gast
    Du wirst vermutlich das entsprechende Kernelmodul gegen die neuen Kernelquellen erneut übersetzen müssen.

    Greetz,

    RM

  3. #3
    Registrierter Benutzer
    Registriert seit
    Aug 2007
    Beiträge
    8
    Danke aber der Treiber wird geladen also kann es nicht der Kernel sein.
    Modprobe -l zeigt den Treiber 3w-9xxx.ko geladen.
    Das System startet (siehe Anhang) aber die Platten sind nicht aktive. Irgendeine Idee wie ich die Platte mounten kann? Ansonsten muss ich wieder von vorne Anfangen und neu installieren.

    Danke

  4. #4
    Registrierter Benutzer
    Registriert seit
    Jun 2004
    Beiträge
    1.368
    Laut Screenshot werden ATA(SATA)-Errors gemeldet,, und ganz oben steht: "SCSI ... initialized".
    Kannst du vielleicht ein Floppy/USB-Stick mounten und z.B. mit `dmesg > /floppy-oder-USB/dmesg.txt` die ganze Ausgabe vom anderen PC hochladen?

  5. #5
    Registrierter Benutzer
    Registriert seit
    Aug 2007
    Beiträge
    8
    Hallo,

    Danke für die Antwort aber laut Aussage des technischen Supports meines Server Hersteller ist das ein Problem von OpenSuse. 3Ware Raid 9650SE wird erst in Kernel > 2.6.18 native unterstützt und Suse hat 2.6.8 :-(. Ich habe keine ATA/SATA Geräte am System deswegen die Fehler. Wenn Debian jetzt auch nicht geht (Fedora 7.9 startet nicht wegen PCI Error :-( ) dann wird es doch wieder Microsoft als Hauptsystem werden :-(. Aber vielen Dank für die Unterstützung

  6. #6
    Registrierter Benutzer
    Registriert seit
    Jun 2004
    Beiträge
    1.368
    Na kennt sich der Support aber super aus! Mach mal ein `uname -a` und schau' dir die Ausgabe an.

    Problem liegt woanders, denn vor dem Onlineupdate gehts ja...Kann eben sein, dass im Modul des update-kernels ein Fehler ist.

    EDIT:
    ich habe da einen leisen Verdacht: boote dein System von der DVD, lass "installiertes System starten" und poste danach die Ausgabe von
    Code:
    grep TYPE /etc/sysconfig/bootloader
    Geändert von temir (23.08.07 um 08:50 Uhr)

  7. #7
    Registrierter Benutzer
    Registriert seit
    Aug 2007
    Beiträge
    8
    Danke fuer die Info, kann es leider erst in 1 1/2 Wochen wieder versuchen da ich z.Z im Urlaub bin :-).

  8. #8
    Registrierter Benutzer
    Registriert seit
    Aug 2007
    Beiträge
    8
    Habe das Problem gelöst.

    Der Kernel Update lädt alte Treiber für den 3Ware Controller welche nicht den 9650SE unterstützen. Nachdem ich die neuen 3ware Treiber nehme und direkt in den Kernel einbinde (nicht als Module) geht es. Aus irgendeinen nicht verständlichen Grund wird das Module nicht in RAM Disk übernommen :-(. Ein 2.6.22 Kernel (Suse 10.3) läuft ohne diese Probleme jedoch gehen dann andere Module (Netzwerk) nicht mehr. Würde gerne 10.3 nehmen aber eine Beta produktiv zu schalten ist doch ein zu hohes Risiko.

Ähnliche Themen

  1. Nur noch als Root anmelden geht
    Von Ballerman23 im Forum Linux als Server
    Antworten: 15
    Letzter Beitrag: 11.07.07, 10:56
  2. RedHat Fedora Core 6 HILFE!
    Von RedHat25 im Forum System installieren und konfigurieren
    Antworten: 5
    Letzter Beitrag: 22.03.07, 19:55
  3. Nvidia Treiber für Fedora 6 installieren
    Von mib86 im Forum X-Konfiguration
    Antworten: 27
    Letzter Beitrag: 08.01.07, 21:44
  4. Antworten: 5
    Letzter Beitrag: 12.11.05, 09:57
  5. Freeze..
    Von gast44 im Forum System installieren und konfigurieren
    Antworten: 9
    Letzter Beitrag: 01.04.04, 17:43

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •