Anzeige:
Seite 1 von 3 123 LetzteLetzte
Ergebnis 1 bis 15 von 45

Thema: VirtualBox: Kernel-Problem?

  1. #1
    Registrierter Benutzer Avatar von Asparagus
    Registriert seit
    Mar 2007
    Ort
    Erfurt
    Beiträge
    60

    Exclamation VirtualBox: Kernel-Problem?

    Hallo Forumaner,

    Ich habe mein System vor ca. 1 Woche auf Linux umgestellt, allerdings benötige ich noch ein Programm, welches nur unter Windows läuft.Deshalb habe ich mir VirtualBox auf meiner openSUSE 10.2 Kernel 2.6.18.8 installiert, um damit dann ein virtuelles minimales Windows98 zu emulieren.

    Wenn ich nun aber VirtualBox starte, erscheint die Fehlermeldung:

    "VirtualBox kernel driver not installed. The vboxdrv kernel module was either not loaded or /dev/vboxdrv was not created for some reason. Re-setup the kernel module by executing '/etc/init.d/vboxdrv setup' as root. VBox status code: -1908 (VERR_VM_DRIVER_NOT_INSTALLED).

    Result Code: 0x80004005 Component: Console Interface: IConsole {1dea5c4b-0753-4193-b909-22330f64ec45}"

    Resetup des Moduls brachte folgende Meldung:

    "pegasus:/home/guido # /etc/init.d/vboxdrv setup Stopping VirtualBox kernel module done Recompiling VirtualBox kernel module failed (Look at /var/log/vbox-install.log to find out what went wrong)"

    Unter deisem Install.log steht folgendes:

    "Makefile:88: *** Error: unable to find the include directory for your current Linux kernel. Specify ERN_INCL=<directory> and run Make again.. Stop."

    Da ich Linux-Neuling bin, habe ich keine Ahnung, was ich mit diesen Hinweisen anfangen, geschweige denn das Problem lösen kann. Deshalb bitte ich euch um Hilfe!

    thx +mfg

    Guido

  2. #2
    Registrierter Benutzer Avatar von drcux
    Registriert seit
    Oct 2003
    Beiträge
    6.920
    Füge in YaST folgendes als Installationsquelle hinzu:

    http://software.opensuse.org/downloa...openSUSE_10.2/

    und installiere virtualbox/virtualbox-kmp-default mit YaST

  3. #3
    Registrierter Benutzer Avatar von Asparagus
    Registriert seit
    Mar 2007
    Ort
    Erfurt
    Beiträge
    60

    Question Funzt net :-(

    Zitat Zitat von drcux Beitrag anzeigen
    Füge in YaST folgendes als Installationsquelle hinzu:

    http://software.opensuse.org/downloa...openSUSE_10.2/

    und installiere virtualbox/virtualbox-kmp-default mit YaST
    Hallo,

    danke für den Tip. Hab alles so gemacht, doch leider ergebnislos. Unter /var/log/boot.msg steht weiterhin Kernel Module not found ---FAILED, auch die oben bereits geposteten Meldungen sind die gleichen.

    MfG

    Guido

  4. #4
    Registrierter Benutzer Avatar von drcux
    Registriert seit
    Oct 2003
    Beiträge
    6.920
    hast du nen 64bit-SUSE installiert?

  5. #5
    Registrierter Benutzer Avatar von Asparagus
    Registriert seit
    Mar 2007
    Ort
    Erfurt
    Beiträge
    60
    nein, ist ne 32bit-suse...

    habe kernel 2.6.18.8...hat das vielleicht damit was zu tun?

  6. #6
    Registrierter Benutzer Avatar von WishMaster@NND
    Registriert seit
    Feb 2006
    Beiträge
    747
    Die Fehlermeldung sagt dir doch bereits was du tun must:
    /etc/init.d/vboxdrv setup
    ausführen.
    Sofern du die Kernel-Sourcen, gcc & Co installiert hast, wird das Skript das benötigte Kernelmodul selbst erstellen.
    Danach Virtualbox neu starten et voilà...

  7. #7
    Registrierter Benutzer Avatar von Asparagus
    Registriert seit
    Mar 2007
    Ort
    Erfurt
    Beiträge
    60
    Zitat Zitat von WishMaster@NND Beitrag anzeigen
    Die Fehlermeldung sagt dir doch bereits was du tun must:
    /etc/init.d/vboxdrv setup
    ausführen.
    Sofern du die Kernel-Sourcen, gcc & Co installiert hast, wird das Skript das benötigte Kernelmodul selbst erstellen.
    Danach Virtualbox neu starten et voilà...
    Hallo,

    genau das habe ich getan, doch leider funzt es trotzdem nicht. Wenn ich das ausführe, schmeißt mir die Konsole folgendes aus (wie oben gepostet):

    "pegasus:/home/guido # /etc/init.d/vboxdrv setup

    Stopping VirtualBox kernel module done Recompiling VirtualBox kernel module failed (Look at /var/log/vbox-install.log to find out what went wrong)"

    Nun steh ich da, ich armer Tor, und bin so schlau als wie zuvor ;-) :-(

  8. #8
    Mod. FAQ/Howto/Emulation
    Registriert seit
    Sep 2000
    Beiträge
    17.193
    Ja haben wir denn schon das Handbuch zum Thema gelesen? Wenn nein:

    http://www.virtualbox.org/download/UserManual.pdf

  9. #9
    Registrierter Benutzer Avatar von Asparagus
    Registriert seit
    Mar 2007
    Ort
    Erfurt
    Beiträge
    60
    Zitat Zitat von stefan.becker Beitrag anzeigen
    Ja haben wir denn schon das Handbuch zum Thema gelesen? Wenn nein:

    http://www.virtualbox.org/download/UserManual.pdf
    Danke für den Hinweis...meinst du damit den Part "Troubleshooting"? Da wird was von Kernel 2.6.19 geschrieben, ich hab aber 2.6.18

  10. #10
    Registrierter Benutzer
    Registriert seit
    Oct 2006
    Ort
    Wuppertal
    Beiträge
    259
    Führe mal ein "modprobe vboxdrv" aus und starte dann Virtualbox. Sollte dann laufen (war zumindest bei mir so ).
    Muss aber bei jedem Systemneustart gemacht werden. Weiss jemand wie das fest in die modprobe.conf eingebunden wird ?

    Ach ja, Du mußt den User in die Gruppe "vboxusers" aufnehmen. Kannst Du einfach mit YAST machen.


    Dietger

  11. #11
    Registrierter Benutzer Avatar von Asparagus
    Registriert seit
    Mar 2007
    Ort
    Erfurt
    Beiträge
    60

    Thumbs up

    Zitat Zitat von WishMaster@NND Beitrag anzeigen
    Sofern du die Kernel-Sourcen, gcc & Co installiert hast, wird das Skript das benötigte Kernelmodul selbst erstellen.
    Danach Virtualbox neu starten et voilà...
    Danke...das hab ich doch total überlesen, dass du mir die Kernel sources empfiehlst...die hab ich nun installiert und es funzt! Danke für die Lösung! *freu*
    Debian Lenny -- 2.6.26 -- KDE 3.5
    Debian Squeeze -- 2.6.32 -- Xfce
    --
    Intel PentiumIV 1800 MHz -- 1.23 GiB RAM -- Nvidia GeForce 4 MX 4000

  12. #12
    Registrierter Benutzer
    Registriert seit
    Dec 2005
    Beiträge
    37
    Sooo... mir ist damit leider nicht geholfen... ich hab nen 64er Prozzi, die Kernel- Sourcen installiert, modprobe ausgeführt, mich als User der Gruppe vbox hinzugefügt, aber es funktioniert immernoch nicht. wenn ich modprobe versuche, erhalte ich folgendes:
    Code:
    MJL-machine:/home/MJL # modprobe vboxdrv
    FATAL: Error inserting vboxdrv (/lib/modules/2.6.18.8-0.3-default/weak-updates/vboxdrv.ko): Invalid argument
    Und nu?

  13. #13
    Registrierter Benutzer Avatar von drcux
    Registriert seit
    Oct 2003
    Beiträge
    6.920
    vbox gibt es (noch) nicht für 64bit...

  14. #14
    Registrierter Benutzer
    Registriert seit
    Dec 2005
    Beiträge
    37
    Lustig... denn die Installation und der Programmstart funktioniert einwandfrei.
    Davon mal ab... normalerweise müssten doch 32er- Anwendungen auf 64er- Systemen laufen, nur umgekehrt nicht?!
    Kann ich VBox vielleicht "vormachen", dass es auf nem 32er bruzelt?

  15. #15
    Registrierter Benutzer Avatar von drcux
    Registriert seit
    Oct 2003
    Beiträge
    6.920
    Bei dem Programm ist es egal, ob du 64bit oder 32bit hast, nicht aber bei dem Kernelmodul, das muss zum laufendem Kernel passen!

Ähnliche Themen

  1. Ubuntu macht komische sachen :(
    Von mr.schrotti im Forum Linux Allgemein
    Antworten: 4
    Letzter Beitrag: 07.03.07, 11:32
  2. Gnome startet nicht (Fedora Core 4)
    Von Stift im Forum Windowmanager
    Antworten: 8
    Letzter Beitrag: 25.06.06, 17:21
  3. Kein automatischer Wlan Start
    Von Cpt_Chaos1978 im Forum Mobiles Linux, Notebook, PDA
    Antworten: 3
    Letzter Beitrag: 04.01.06, 18:00
  4. ACPI Problem auf Notebook
    Von samy-delux im Forum System installieren und konfigurieren
    Antworten: 6
    Letzter Beitrag: 10.05.05, 16:10
  5. Antworten: 2
    Letzter Beitrag: 27.05.04, 13:15

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •