Anzeige:
Ergebnis 1 bis 8 von 8

Thema: Kontact & GPG: Wrong Passphrase? (Kubuntu 6.10)

  1. #1
    mal hier, mal dort Avatar von robotangel
    Registriert seit
    Feb 2004
    Ort
    mount -t country /dev/germany/nrw/cologne /
    Beiträge
    589

    Kontact & GPG: Wrong Passphrase? (Kubuntu 6.10)

    Hallo Board-Gemeinde !

    Nach etwas längerer Zeit (benutze sowieso nicht so viel E-Mail) , wollte mir ein Freund mal eine E-Mail schicken. Dies wollte er mit GPG tun (anders will ich eigentlich sowieso keinen E-Mail-Verkehr). Also habe ich mir Kontact eingerichtet, sodass es mit meinem Google-Account zusammenarbeitet. Während alles auf unverschlüsselter Basis klappt, gibt es Probleme mit GPG.

    Wenn ich eine GPG-verschlüsselte E-Mail sende klappt das ebenfalls, wenn ich allerdings eine Mail empfange kriege ich direkt angezeigt, dass meine "Passphrase" falsch sei ("Wrong Passphrase") - dabei wurde ich überhaupt nicht nach ihr gefragt.
    Daraufhin habe ich etwas gegoogled und diese beiden Links (inkl. Tipps) gefunden:

    * http://archive.kanotix.com/module-pn...lGpgAgent.html
    * https://bugzilla.novell.com/show_bug.cgi?id=205688

    Allerdings funktioniert der Befehl nicht - muss man den GPG-Agenten extra installieren? Ich finde ihn in den Repos nämlich nicht...

    Code:
    $ eval "$(gpg-agent --daemon)" 
     bash: gpg-agent: command not found
    Bin für jede Hilfe dankbar!
    Arch Linux x86_64 | Intel Core 2 Duo T7250 | 2048MB RAM | nv 8600m gt | laptop
    Jabber: *Auf Anfrage* | GPG

    "Von V.I.S.T.A. Usern kann halt nicht viel rauskommen." - Ararat++ zu Stephanw

  2. #2
    Registrierter Benutzer
    Registriert seit
    Aug 2005
    Beiträge
    130
    apt-cache zeigt mir, dass es für gpg-agent offenbar ein eigenes Paket gibt:

    Code:
    [stell @ nexxus:~]% apt-cache search gpg-agent
    [ ... ]
    gnupg-agent - GNU privacy guard - password agent
    Versuche mal, das zu installieren und gehe dann erneut nach Deinem HOWTO vor. Ich bin übrigens auch gerade dabei, mich mal wieder mit Kontact/KMail/KNode zu beschäftigen und stehe demnächst möglicherweise vor dem gleichen Problem.

    Nachtrag: Das Paket liegt im universe-Repo (http://security.ubuntu.com edgy-security/universe gnupg-agent 1.9.21-0ubuntu5.2 [176kB])

  3. #3
    mal hier, mal dort Avatar von robotangel
    Registriert seit
    Feb 2004
    Ort
    mount -t country /dev/germany/nrw/cologne /
    Beiträge
    589
    Okay, werde es versuchen, eine Suche in Adept nur nach "gpg" hat nämlich nicht funktioniert. Den Agent findet er aber - habe nur falsch gesucht, danke für den Tipp!

    edit: Bin irgendwie gerade verdammt ratlos... Es geht irgendwie immer noch nicht.... Habe keine Ahnung mehr woran das liegen könnte.... "Falsche Passphrase"...
    Geändert von robotangel (26.12.06 um 17:00 Uhr)
    Arch Linux x86_64 | Intel Core 2 Duo T7250 | 2048MB RAM | nv 8600m gt | laptop
    Jabber: *Auf Anfrage* | GPG

    "Von V.I.S.T.A. Usern kann halt nicht viel rauskommen." - Ararat++ zu Stephanw

  4. #4
    Registrierter Benutzer
    Registriert seit
    Aug 2005
    Beiträge
    130
    Zitat Zitat von robotangel Beitrag anzeigen
    edit: Bin irgendwie gerade verdammt ratlos... Es geht irgendwie immer noch nicht.... Habe keine Ahnung mehr woran das liegen könnte.... "Falsche Passphrase"...
    Ich habe es hier gerade mal eingerichtet und habe den gleichen Fehler wie Du. Ich hatte es vor einem Jahr schonmal eingerichtet, damals auch den gleichen Fehler und konnte das Problem damals auch beheben.

    Ich kann mich an die Lösung nicht erinnern, ich geh da mal in meine Erinnerungen abtauchen, ich melde mich wieder.

  5. #5
    Registrierter Benutzer
    Registriert seit
    Aug 2005
    Beiträge
    130
    Ok, die gute Nachricht: Die Mails werden korrekt erstellt und da, wo er von "wrong passphrase" faselt, sind die Mails eigentlich ok. Mein normaler Mailreader ist Emacs/Gnus, damit kann ich die an mich selbst verschickten und verschlüsselten Mails problemlos entschlüsseln.

    Am Rest knobel ich noch weiter.

  6. #6
    Stadtwache Ankh-Morpok Avatar von Detrius
    Registriert seit
    Feb 2003
    Ort
    Altena
    Beiträge
    706
    Für den gpg-agent sollte es ein Skript in /etc/X11/Xsession.d geben. Dieses überprüft, ob in ~/.gnupg/gpg.conf der Eintrag use-agent gesetzt ist und startet ihn in diesem Fall.

    http://www.debian-administration.org/articles/452

  7. #7
    Registrierter Benutzer
    Registriert seit
    Aug 2005
    Beiträge
    130
    Ich glaube, hier klappt es mittlerweile mit fremden verschlüsselten Mails. Lediglich verschlüsselte Mails an mich selber kann ich nicht lesen.

    Nach langer Zeit läuft auch endlich der gpg-agent mal wieder.

  8. #8
    Ein Möchtegern-Haluter Avatar von icho40
    Registriert seit
    Dec 2005
    Ort
    Vöhringen
    Beiträge
    15

    Exclamation Fortschritte?

    Hallo,
    Kennt schon jemand eine Lösung für dieses Problem?
    Mir gehts nach einem upgrade von dapper auf feisty genauso.
    bin dankbar für jeden Tip!
    Grüße
    Willi

    Nachtrag:
    Hab das problem gelöst wie oben beschrieben:
    gpg-agent und pinentry installiert,
    in gpg-conf
    Code:
    user-agent
    eingetragen und in eine erzeugte .gnupg/gpg-agent.conf
    Code:
    pinentry-program /usr/bin/pinentry-gtk-2
    no-grab
    default-cache-ttl 1800
    geschrieben. Dann Neustart und es ging
    Geändert von icho40 (06.04.07 um 15:40 Uhr) Grund: Gelöst
    slackware 10.2
    linux 2.4.31
    AMD 800
    nvidia riva tnt2
    HD: Samsung 40 GB

Ähnliche Themen

  1. Slackware + HAL
    Von ghostface1500 im Forum Kompilieren von Kernel und Sourcen
    Antworten: 1
    Letzter Beitrag: 03.12.05, 11:05
  2. Antworten: 7
    Letzter Beitrag: 02.02.05, 16:09
  3. apt-get Probleme!!!
    Von Djinn im Forum System installieren und konfigurieren
    Antworten: 10
    Letzter Beitrag: 13.07.04, 17:06
  4. APT4RPM gibt Fehler aus, falsche KEYs....
    Von Yussuf im Forum Anwendungen Allgemein, Software
    Antworten: 2
    Letzter Beitrag: 02.06.04, 18:01
  5. Fussball Manager 2004
    Von krischan2000 im Forum Emulatoren für Spiele
    Antworten: 3
    Letzter Beitrag: 21.01.04, 20:12

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •