Anzeige:
Ergebnis 1 bis 6 von 6

Thema: VMWare Server und USB

  1. #1
    Registrierter Benutzer
    Registriert seit
    Mar 2005
    Beiträge
    30

    VMWare Server und USB

    Hi,

    meine Konfiguration:
    VMWare Server
    - Wirt: SuSE 10.1
    - Gast: Windows

    Ich möchtet in der VM mein DruckerScanner Gerät MP360 von Canon nutzen. Gerät wird problemlos in der VM erkannt und der Treiber wird ebenso problemlos installiert.
    Versuche ich jetzt zu scannen bewegt sich der Scanner kurz und hört dann auf, wenn sich Windows mit einem BlueScreen verabschiedet. Der BlueScreen meint, dass es an einem falschen Treiber liegen kann. Der Treiber funktioniert allerdings auf meinem Windows PC problemlos. Nach dem herbeigeführten Neustart erscheint eine Meldung, dass ein an USB angschlossenes Gerät nicht funktioniert.

    Ähnlich ergeht es mir mit meinem TDK LabelPrinter, er wird erkannt und die Treiberinstallation funktioniert ohne Probleme. Dirket nach der Treiberinstallation konnte ich auch eine CD beschriften, nach einem Neustart, wird aber das Gerät nicht mehr angesprochen.

    Welche Ursachen können meine Probleme haben? Braucht VMWare zum Ausführen von USB-Geräten bestimmte Rechte? Die Geräte werden mir im SuSE mit dem Befahl lsusb auch angezeigt, muss ich das Gerät, um es in VMWare zu benutzen vielleicht irgendwie von SuSE trennen?

    Bitte helft mir!

    Gruß
    Julian

  2. #2
    Open-Xchange Avatar von cane
    Registriert seit
    Nov 2002
    Ort
    NRW
    Beiträge
    6.682
    Was sagen die Eventlogs?
    Was sagen die logs der VM?

    mfg
    cane
    Es existiert kein Patch für die menschliche Dummheit.

  3. #3
    Registrierter Benutzer
    Registriert seit
    Mar 2005
    Beiträge
    30
    Hallo,

    also ich weiß nicht, ob Dir die VM Log was hilft, weil ich benutze VMWare schon wieder einige Tage, seit diese Fehler kamen, also die Aufzeichnungen von den Fehlern werden wohl nicht mehr vorhanden sein.
    Wo finde ich aber die Eventlog?

    Thx
    julian

  4. #4
    Mod. FAQ/Howto/Emulation
    Registriert seit
    Sep 2000
    Beiträge
    17.344
    Die Probleme mit dem Scanner kommen mir bekannt vor. Ich habe das auch mal mit meinem getestet. Aber nur aus Interesse, weil er unter Linux geht. Das Endergebnis war wie bei dir.

    In einer Qemu VM ging es, warum auch immer.

    Wäre mal eine Alternative zum Testen.

    Generell ist das USB Zeugs zumeist problematisch. Du musst verhindern, dass sich Linux die Devices schnappt. Hier kommt man u. U. über die Hotplug Konfiguration mit einer Blacklist weiter.

  5. #5
    Registrierter Benutzer
    Registriert seit
    Mar 2005
    Beiträge
    30
    Danke!
    Aber wie kann ich eine Blacklist erstellen?

  6. #6
    stuck under the Table Avatar von pcdog
    Registriert seit
    Apr 2003
    Ort
    Novi Sad
    Beiträge
    1.828
    achja, mit dem scannen ist mir vmware auch immer geschmiert, neuerdings geht der dafür nativ
    meine blacklist (ohne garantie, ausm kopf) lag doch unter /etc/hotplug/blacklist

    oder wars /etc/modprobe.d/blacklist?

    glaub das zweite
    wenn ich meinen server ausschalte, wird die Strassenlaterne draussen heller...

Ähnliche Themen

  1. USB (2.0) Festplatte unter SuSE 9.1 beschreiben geht nicht
    Von user9999 im Forum stationäre Hardware
    Antworten: 7
    Letzter Beitrag: 18.09.05, 13:16
  2. Antworten: 5
    Letzter Beitrag: 03.03.05, 13:52
  3. Hach... Usb-Floppy
    Von Zinnwurm im Forum stationäre Hardware
    Antworten: 15
    Letzter Beitrag: 23.11.04, 21:11
  4. Suse 9.1 bleibt hängen
    Von satfan im Forum System installieren und konfigurieren
    Antworten: 5
    Letzter Beitrag: 23.07.04, 09:20
  5. mldonkey installieren (compilieren!)
    Von DrainDZ im Forum Kompilieren von Kernel und Sourcen
    Antworten: 5
    Letzter Beitrag: 30.04.03, 12:25

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •