Anzeige:
Ergebnis 1 bis 3 von 3

Thema: /dev/hde1 existiert noch nicht wenn fsck ausgeführt wird

  1. #1
    Registrierter Benutzer
    Registriert seit
    May 2006
    Beiträge
    5

    beim booten existiert /dev/hde1 noch nicht wenn fsck ausgeführt wird

    Hallo Freunde,

    ich habe ein SuSE 10 am Laufen und mir mal eben schnell einen Promise Ultra133 TX2 Controller eingebaut damit ich mehr Platten hosten kann.

    Der Controller wird auch promt vom SuSE erkannt und ich kann die Platten auch im YaST Partitionieren und einhängen.

    Wenn ich aber dann reboote, sind die Platten zum Zeitpunkt wenn fsck ausgeführt wird noch nicht präsent --> fsck schlägt fehl da kein /dev/hde1 existiert.

    Setze ich in der fstab den Parameter 6 auf 0, also kein fsck on reboot,
    bootet die Maschine durch.

    Nun ist auch das /dev/hde1 präsent, fsck kann manuell ausgeführt werden und ich kann die Platte einhängen.

    Wie bringe ich SuSE dazu den 2. Controller beim booten einzubinden bevor der fsck ausgefürt wird?

    Danke für Eure Hilfe
    Geändert von TArminK (20.05.06 um 20:17 Uhr)

  2. #2
    Registrierter Benutzer Avatar von drcux
    Registriert seit
    Oct 2003
    Beiträge
    6.938
    mcedit /etc/sysconfig/kernel

    INITRD_MODULES="namedestreibers"

    Danach noch ein "mkinitrd", dann landet der Treiber für deinen Controler in der initrd und wird früh genug geladen

  3. #3
    Registrierter Benutzer
    Registriert seit
    May 2006
    Beiträge
    5
    Danke, das wars :-)
    Das Leben könnt so einfach sein wenn man auch die Readme liest, da stand das auch drin :-((
    Mann bin ich bescheuert, nach 11 Stunden Arbeit sollte man nicht mehr an einem PC basteln

    Nochmal Danke

Ähnliche Themen

  1. Openssl installieren Probleme
    Von Captain_Tuvok im Forum Linux als Server
    Antworten: 2
    Letzter Beitrag: 17.03.05, 14:15
  2. fsck mit --rebuild-tree laufen lassen
    Von inner.glow im Forum stationäre Hardware
    Antworten: 2
    Letzter Beitrag: 07.12.04, 12:01
  3. FSCK??? Partition abgeschossen??
    Von Diavolo86 im Forum Linux Allgemein
    Antworten: 4
    Letzter Beitrag: 03.12.04, 17:24
  4. fsck gibt Meldung beim booten aus
    Von Henner im Forum System installieren und konfigurieren
    Antworten: 9
    Letzter Beitrag: 13.04.04, 15:05
  5. fsck bei boot
    Von akittstein im Forum System installieren und konfigurieren
    Antworten: 2
    Letzter Beitrag: 19.09.02, 09:24

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •