Anzeige:
Ergebnis 1 bis 6 von 6

Thema: Linux und Windows auf einem Notebook

  1. #1
    SorcererCB
    Gast

    Linux und Windows auf einem Notebook

    Hi,

    ich hab mal ein kleines Problem.

    Mein Chef hat ein auf seinem Notebook Windows und Linux zusammen auf einer Festplatte installiert.

    Erst war Windows XP installiert, danach würde Red Hat Linux installiert.

    Der Rechner bootet so auch am Anfang zum Grub Bootloader wo man dann zwischen Linux und Windows unterscheiden kann.

    Das Problem ist jetzt das sich das Windows mal wieder verabschiedet hat und ich es neu installieren muss. Nur wenn ich Windows installiere überschreibt es mir ja den MBR und ich kann später das Red Hat Linux nicht mehr booten

    Wie bekomm ich es hin das ich nach der Windows Installation wieder den Grub Bootmanager nutzen kann? Muss dazu sagen ich bin leider noch nicht der bewanderste unter linux

    Gruß,

    Sorcerer

  2. #2
    Registrierter Benutzer Avatar von towo2099
    Registriert seit
    Feb 2002
    Ort
    Pößneck
    Beiträge
    4.459
    Installier Grub dann halt wieder in den MBR, das kannste von einer Live-CD aus machen, wenn RedHat solch eine Funktion der Reparatur des MBR nicht anbietet.
    Signatur nach Diktat Spazieren gegangen ;)

  3. #3
    SorcererCB
    Gast
    Und gibst da vielleicht nene ToDo oder eine Anleitung weil ich mich wie gesagt noch nicht so stark mit Linux auskenne.

    Gruß,

    Sorcerer

  4. #4
    Registrierter Benutzer Avatar von reni
    Registriert seit
    Apr 2003
    Beiträge
    1.589
    Gruß reni

    Ich würde gern die Welt verbessern, doch Gott gibt mir den Quellcode nicht!

  5. #5
    SorcererCB
    Gast
    Ich muss mich entschuldigen, ich hab das Notebook nun vor mir liegen und könnte selber schauen und entgegen den mir gesagten Infos wird Lilo als Bootloader verwendet und nicht Grub.

    Gibt es so eine gute Anleitung wie die im Link auch für Lilo damit ich damit das System wieder zum laufen bekomme?

    Gruß,

    Sorcerer

  6. #6
    LU #373839 Avatar von Tranalogic
    Registriert seit
    Mar 2004
    Ort
    Schwechat, Niederösterreich
    Beiträge
    291
    Naja LiveCD nehmen, / mounten, chroot auf / machen, lilo ausführen.

    zb. mount -t ext3 /dev/hda3 /mnt/hda3
    chroot /mnt/hda3 /bin/bash


    und dann einfach lilo eingeben. Dann müsst der MBR neu geschrieben sein

    Ahja nicht vergessen: root musst du sein.


    LG
    Server: Gentoo 2004.2, Linux 2.6.x-gentoo, AMD AthlonXP 2000+, 256 MB RAM, 557 GB HDD
    Desktop: Gentoo 2005.1, Linux 2.6.x-gentoo, Gnome 2.X, AMD Athlon64 3500+, ASUS A8N-E, GeForce 6600 @ 256 MB, 1024 MB RAM, 600 GB HDD

Ähnliche Themen

  1. EasyLite TV Tuner
    Von alex23 im Forum Fernsehen
    Antworten: 11
    Letzter Beitrag: 23.05.06, 21:03
  2. [kernel 2.6.7 und suse9.0] Problem mit hotplug/udev? Kann booten, aber ....
    Von carnil im Forum Kompilieren von Kernel und Sourcen
    Antworten: 14
    Letzter Beitrag: 29.03.06, 09:33
  3. suse 9.2 hängt mit USB stick
    Von zaunmayrchris im Forum stationäre Hardware
    Antworten: 13
    Letzter Beitrag: 31.10.05, 17:44
  4. Einwahl ins WWW wird ohne Fehlermeldung abgebrochen
    Von MarcusLiebig im Forum System installieren und konfigurieren
    Antworten: 8
    Letzter Beitrag: 21.10.03, 19:53
  5. 2.4.22 auf SuSE 8.2?
    Von DaVinciXL im Forum Kompilieren von Kernel und Sourcen
    Antworten: 53
    Letzter Beitrag: 06.10.03, 18:23

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •