Anzeige:
Ergebnis 1 bis 4 von 4

Thema: Problem mit PGP

  1. #1
    open force Avatar von stevens
    Registriert seit
    Feb 2005
    Beiträge
    20

    Problem mit PGP

    Hallo.

    Folgendes Problem:

    Ich habe ein Keypair generieren lassen. Wenn ich nun den Public Key jemand gebe, um ihn signieren zu lassen und dann wieder unter KGPG (oder auch Thunderbird Enigmail etc) importiere, habe ich auf einmal zwei Selbst-Signaturen drin. Gebe ich ihn einer zweiten Person zum signieren, habe ich nach dem Re-Import plötzlich drei Signaturen von mir selbst im Schlüssel. usw...

    Kann mir jemand sagen, was es damit auf sich hat? Mache ich da irgendetwas falsch?
    // GNU/Linux - Weil man sich Freunde nicht kaufen kann
    // False Website // False Junksite // GPG Public Key // German-Bash

  2. #2
    Klugsch***er Avatar von Krischi
    Registriert seit
    Feb 2004
    Ort
    Wo's blitzt und kracht
    Beiträge
    2.021
    Ich habe da ein Paar Verständnisschwierigkeiten wie Du genau vorgehst.

    Also:
    Du exportierst Deinen Schlüssel. Dann gibst oder schickst Du ihn jemand anders. Der signiert ihn dann und schickt/gibt ihn Dir zurück. Und dann importierst Du ihn wieder.

    Soweit richtig?

    Wenn ja:
    Warum?

    Das ist zwar sicherlich auch eine Möglichkeit zu verfahren und wird möglicherweise nicht unbedingt etwas mit Deinem Problem zu tun haben, aber eigentlich sind dafür Schlüsselserver da. Die machen das eine Ecke einfacher.

    Des weiteren könnte für die Lösung des Problems relevant sein, was Du denn genau verwendest.
    PGP oder GPG?


  3. #3
    open force Avatar von stevens
    Registriert seit
    Feb 2005
    Beiträge
    20
    Ja, deine Beschreibung passt :-)

    > Warum?

    Naja. Das mit dem Keyserver stimmt schon, aber mir ist eben beim letzten Schlüssel schon das gleiche passiert, weshalb ich einen neuen hochgeladen habe und das jetzt erstmal ohne Keyserver testen will, auch wenn ich den "blanken" Public Key schon aufm Server habe. Grundsätzlich werde ich in Zukunft aber keine Keys mehr auf öffentliche Server laden, weil das effektiv zu Spam führt. Hatte auf meiner frisch eingerichteten Adresse keinen Spam, bis ich dann einen Key einrichtete. Ein Freund wies mich halt darauf hin, dass das tatsächlich daher rühren kann. Und die Aussage findet man auch in Infoseiten zu PGP im Netz.

    > Des weiteren könnte für die Lösung des Problems relevant sein, was Du denn genau
    > verwendest. PGP oder GPG?

    Also ich nutze GPG und der Schlüssel wurde mit DSA/ElGamal generiert, wobei ich zugeben muss, dass ich keine Ahnung habe, was es genau mit diesem 4096-Bit ElGamal-Subkey auf sich hat, der im 1024-Bit Schlüssel drinne steckt. Ich habe aber nun mit ein bisschen ausprobieren feststellen dürfen, dass diese mehrfache Selbst-Signierung nicht auftritt, wenn ich einen reinen RSA-Schlüssel ohne Subkey generiere.

    Ein Freund von mir hat übrigens genau das gleiche Problem, einfach mit einem RSA*-Subkey anstelle eines ElGamal-Subkeys. Irgendwie scheint e salso wohl mit dem Subkey zusammen zu hängen.
    // GNU/Linux - Weil man sich Freunde nicht kaufen kann
    // False Website // False Junksite // GPG Public Key // German-Bash

  4. #4
    open force Avatar von stevens
    Registriert seit
    Feb 2005
    Beiträge
    20
    Also ich habe gerade festgestellt:

    Die beiden Freunde hatten einen RSA-Subkey. Ich hatte einen ElGamal-Subkey. Ich habe nun noch einen dritten Freund signieren lassen (und meinerseits seinen Key signiert). Der hatte wie ich einen ElGamal-Subkey. Weder bei ihm, noch bei mir entstand durch das signieren eine weitere Selbst-Signierung.

    Könnte es tatsächlich möglich sein, dass sich RSA-Subkeys und ElGamal-Subkeys irgendwie nicht vertragen?
    // GNU/Linux - Weil man sich Freunde nicht kaufen kann
    // False Website // False Junksite // GPG Public Key // German-Bash

Ähnliche Themen

  1. Problem mit SMTP SASL Auth
    Von HorusMS im Forum Linux als Server
    Antworten: 8
    Letzter Beitrag: 12.10.06, 20:18
  2. VPN Problem über Debian-Router
    Von SicKBoy74 im Forum Router und Netzaufbau
    Antworten: 0
    Letzter Beitrag: 05.06.03, 13:09
  3. Treiberproblem führt zu DSL problem
    Von sirefour im Forum Anbindung an die Aussenwelt
    Antworten: 5
    Letzter Beitrag: 26.05.03, 20:19
  4. Upload-Ping-Router Problem !!
    Von MidnightRambler im Forum System installieren und konfigurieren
    Antworten: 0
    Letzter Beitrag: 20.01.02, 19:16
  5. Problem mit SuSE Linux 7.3 Pro und SuSEfirewall2
    Von outi im Forum Linux als Server
    Antworten: 1
    Letzter Beitrag: 15.12.01, 18:52

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •