Anzeige:
Ergebnis 1 bis 15 von 15

Thema: WLAN Karte wird nicht erkannt

  1. #1
    sizeof(zyon) Avatar von Zy0n
    Registriert seit
    Jun 2005
    Ort
    Göttingen
    Beiträge
    401

    Unhappy WLAN Karte wird nicht erkannt

    Hallo Linuxforen user,

    vielleicht fällt euch ja was ein bei meinem Problem den ich sehen (eigentlich) keine Fehler oder was ich Falsch gemacht haben könnte. Ich habe mir mir im tuxhardware shop diese Karte gekaufe: „WLAN Allnet ALL0281 54 Mbit/s WLAN PCI-Karte“

    Alles wunderbar habe ich mir gedacht, tuxhardware hat auch ein kleines HOWTO auf ihrer seite. Dort steh das mal sich einen Kernel backen muss mit diesen Optionen:
    Code:
    Device Drivers  ---> 
        Networking support  ---> 
            Wireless LAN (non-hamradio)  ---> [*] Wireless LAN drivers (non-hamradio) & Wireless Extensions
    Dieses hat mich zu meinen ersten Problem gebracht, da ich noch nie einen Kernel gebacken haben. Aber nach par HOWTOs ist mir dieses gut gelungen und ich habe mir den Kernel: 2.6.14.3 zurecht gemacht. Mit dieses gebootet und dann eingestellt das bei jedem booten diese Module geladen werden:

    Code:
    wlan 
    ath_hal 
    ath_pci
    alles wunderbar. Dann habe ich mir den Treiber: Madwifi runter geladen von der Homepage:

    http://madwifi.org/wiki/UserDocs/GettingMadwifi

    und mit make und make install kompeliert. Dieses gab auch keine Fehlermeldung.

    Nun dachte ich mir eigentlich sollte das alles ein. Leider wenn ich iwconfig starte bekomme ich nur:

    Code:
    eth0      no wireless extensions. 
    
    lo        no wireless extensions. 
    
    wifi0     no wireless extensions. 
    
    sit0      no wireless extensions. 
    
    ppp0      no wireless extensions.


    unter
    cat /proc/modules sind die Module auch geladen:

    Code:
    ppp_deflate 4864 0 - Live 0xe0a7f000 
    zlib_deflate 22552 1 ppp_deflate, Live 0xe0a92000 
    zlib_inflate 17664 1 ppp_deflate, Live 0xe0a85000 
    bsd_comp 5632 0 - Live 0xe0a71000 
    ppp_async 9472 1 - Live 0xe0a1c000 
    crc_ccitt 2048 1 ppp_async, Live 0xe098d000 
    ppp_generic 21012 7 ppp_deflate,bsd_comp,ppp_async, Live 0xe0a41000 
    slhc 6400 1 ppp_generic, Live 0xe09f0000 
    af_packet 17416 4 - Live 0xe0a48000 
    ipv6 226624 21 - Live 0xe0ab5000 
    parport_pc 32324 0 - Live 0xe0a68000 
    parport 33480 1 parport_pc, Live 0xe0a5e000 
    floppy 56164 0 - Live 0xe0a4f000 
    i2c_i801 8076 0 - Live 0xe09ed000 
    i2c_core 17664 1 i2c_i801, Live 0xe0a00000 
    usbhid 29316 0 - Live 0xe0a13000 
    uhci_hcd 29840 0 - Live 0xe0a0a000 
    usbcore 105472 3 usbhid,uhci_hcd, Live 0xe0a20000 
    snd_ens1371 18980 1 - Live 0xe09fa000 
    snd_rawmidi 20000 1 snd_ens1371, Live 0xe09f4000 
    snd_seq_device 7052 1 snd_rawmidi, Live 0xe098f000 
    snd_ac97_codec 90876 1 snd_ens1371, Live 0xe09b3000 
    snd_pcm_oss 47648 0 - Live 0xe09e0000 
    snd_mixer_oss 16768 2 snd_pcm_oss, Live 0xe08e4000 
    snd_pcm 78468 3 snd_ens1371,snd_ac97_codec,snd_pcm_oss, Live 0xe09cb000 
    snd_timer 20868 1 snd_pcm, Live 0xe0993000 
    snd 44132 8 snd_ens1371,snd_rawmidi,snd_seq_device,snd_ac97_codec,snd_pcm_oss,sn        
    d_mixer_oss,snd_pcm,snd_timer, Live 0xe09a7000 
    soundcore 7520 2 snd, Live 0xe080d000 
    snd_page_alloc 8456 1 snd_pcm, Live 0xe0971000 
    snd_ac97_bus 2048 1 snd_ac97_codec, Live 0xe08e2000 
    piix 9348 0 [permanent], Live 0xe095b000 
    nls_iso8859_1 4096 1 - Live 0xe081b000 
    nls_cp437 5760 1 - Live 0xe0818000 
    vfat 11008 1 - Live 0xe08de000 
    fat 45468 1 vfat, Live 0xe099a000 
    nls_base 6528 4 nls_iso8859_1,nls_cp437,vfat,fat, Live 0xe0815000 
    ath_pci 85920 0 - Live 0xe0975000 
    ath_rate_sample 11648 1 ath_pci, Live 0xe0804000 
    ath_hal 196048 3 ath_pci,ath_rate_sample, Live 0xe08fe000 
    wlan 171996 3 ath_pci,ath_rate_sample, Live 0xe0930000 
    ide_cd 36612 0 - Live 0xe08f4000 
    cdrom 36256 1 ide_cd, Live 0xe08ea000 
    unix 23568 74 - Live 0xe081d00

    und unter dmesg

    schaut auch alles ok aus:

    Code:
    wlan: 0.8.4.2 (Atheros/multi-bss) 
    ath_hal: module license 'Proprietary' taints kernel. 
    ath_hal: 0.9.16.3 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413, DFS) 
    ath_rate_sample: 1.2 
    ath_pci: 0.9.4.5 (Atheros/multi-bss) 
    ACPI: PCI Interrupt 0000:02:0d.0[A] -> GSI 21 (level, low) -> IRQ 18 
    wifi0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 
    wifi0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 5 
    4Mbps 
    wifi0: turboG rates: 6Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps 
    wifi0: H/W encryption support: WEP AES AES_CCM TKIP 
    wifi0: mac 5.9 phy 4.3 radio 4.6 
    wifi0: Use hw queue 1 for WME_AC_BE traffic 
    wifi0: Use hw queue 0 for WME_AC_BK traffic 
    wifi0: Use hw queue 2 for WME_AC_VI traffic 
    wifi0: Use hw queue 3 for WME_AC_VO traffic 
    wifi0: Use hw queue 8 for CAB traffic 
    wifi0: Use hw queue 9 for beacons 
    wifi0: Atheros 5212: mem=0xfbfe0000, irq=18


    Auch unter :

    make && make install von den madwifi-n Treibern sehe ich keinen Fehler:


    ****up:/home/zyon/madwifi-n# make && make install




    Code:
    Checking requirements... ok.
    Checking kernel configuration... ok.
    mkdir -p ./symbols
    for i in ./ath_hal ./net80211 ath_rate/sample ./ath ./tools ; do \
            make -C $i || exit 1; \
    done
    make[1]: Entering directory `/home/zyon/madwifi-n/ath_hal'
    cp -f ./../hal/public/i386-elf.opt_ah.h opt_ah.h
    cp -f ./../hal/linux/ah_osdep.c ah_osdep.c
    /usr/bin/uudecode ./../hal/public/i386-elf.hal.o.uu
    make -C /usr/src/linux-2.6.14.3 SUBDIRS=/home/zyon/madwifi-n/ath_hal MODVERDIR=/home/zyo           
    n/madwifi-n/ath_hal/../symbols modules
    make[2]: Entering directory `/usr/src/linux-2.6.14.3'
      CC [M]  /home/zyon/madwifi-n/ath_hal/ah_osdep.o
      LD [M]  /home/zyon/madwifi-n/ath_hal/ath_hal.o
      Building modules, stage 2.
      MODPOST
      CC      /home/zyon/madwifi-n/ath_hal/ath_hal.mod.o
      LD [M]  /home/zyon/madwifi-n/ath_hal/ath_hal.ko
    make[2]: Leaving directory `/usr/src/linux-2.6.14.3'
    make[1]: Leaving directory `/home/zyon/madwifi-n/ath_hal'
    make[1]: Entering directory `/home/zyon/madwifi-n/net80211'
    make -C /usr/src/linux-2.6.14.3 SUBDIRS=/home/zyon/madwifi-n/net80211 MODVERDIR=/home/zy           
    on/madwifi-n/net80211/../symbols modules
    make[2]: Entering directory `/usr/src/linux-2.6.14.3'
      CC [M]  /home/zyon/madwifi-n/net80211/if_media.o
      CC [M]  /home/zyon/madwifi-n/net80211/ieee80211.o
      CC [M]  /home/zyon/madwifi-n/net80211/ieee80211_beacon.o
      CC [M]  /home/zyon/madwifi-n/net80211/ieee80211_crypto.o
      CC [M]  /home/zyon/madwifi-n/net80211/ieee80211_crypto_none.o
      CC [M]  /home/zyon/madwifi-n/net80211/ieee80211_input.o
      CC [M]  /home/zyon/madwifi-n/net80211/ieee80211_node.o
      CC [M]  /home/zyon/madwifi-n/net80211/ieee80211_output.o
      CC [M]  /home/zyon/madwifi-n/net80211/ieee80211_power.o
      CC [M]  /home/zyon/madwifi-n/net80211/ieee80211_proto.o
      CC [M]  /home/zyon/madwifi-n/net80211/ieee80211_scan.o
      CC [M]  /home/zyon/madwifi-n/net80211/ieee80211_wireless.o
      CC [M]  /home/zyon/madwifi-n/net80211/ieee80211_linux.o
      CC [M]  /home/zyon/madwifi-n/net80211/ieee80211_monitor.o
      CC [M]  /home/zyon/madwifi-n/net80211/ieee80211_acl.o
      CC [M]  /home/zyon/madwifi-n/net80211/ieee80211_crypto_ccmp.o
      CC [M]  /home/zyon/madwifi-n/net80211/ieee80211_scan_ap.o
      CC [M]  /home/zyon/madwifi-n/net80211/ieee80211_scan_sta.o
      CC [M]  /home/zyon/madwifi-n/net80211/ieee80211_crypto_tkip.o
      CC [M]  /home/zyon/madwifi-n/net80211/ieee80211_crypto_wep.o
      CC [M]  /home/zyon/madwifi-n/net80211/ieee80211_xauth.o
      LD [M]  /home/zyon/madwifi-n/net80211/wlan.o
      LD [M]  /home/zyon/madwifi-n/net80211/wlan_wep.o
      LD [M]  /home/zyon/madwifi-n/net80211/wlan_tkip.o
      LD [M]  /home/zyon/madwifi-n/net80211/wlan_ccmp.o
      LD [M]  /home/zyon/madwifi-n/net80211/wlan_acl.o
      LD [M]  /home/zyon/madwifi-n/net80211/wlan_xauth.o
      LD [M]  /home/zyon/madwifi-n/net80211/wlan_scan_sta.o
      LD [M]  /home/zyon/madwifi-n/net80211/wlan_scan_ap.o
      Building modules, stage 2.
      MODPOST
      CC      /home/zyon/madwifi-n/net80211/wlan.mod.o
      LD [M]  /home/zyon/madwifi-n/net80211/wlan.ko
      CC      /home/zyon/madwifi-n/net80211/wlan_acl.mod.o
      LD [M]  /home/zyon/madwifi-n/net80211/wlan_acl.ko
      CC      /home/zyon/madwifi-n/net80211/wlan_ccmp.mod.o
      LD [M]  /home/zyon/madwifi-n/net80211/wlan_ccmp.ko
      CC      /home/zyon/madwifi-n/net80211/wlan_scan_ap.mod.o
      LD [M]  /home/zyon/madwifi-n/net80211/wlan_scan_ap.ko
      CC      /home/zyon/madwifi-n/net80211/wlan_scan_sta.mod.o
      LD [M]  /home/zyon/madwifi-n/net80211/wlan_scan_sta.ko
      CC      /home/zyon/madwifi-n/net80211/wlan_tkip.mod.o
      LD [M]  /home/zyon/madwifi-n/net80211/wlan_tkip.ko
      CC      /home/zyon/madwifi-n/net80211/wlan_wep.mod.o
      LD [M]  /home/zyon/madwifi-n/net80211/wlan_wep.ko
      CC      /home/zyon/madwifi-n/net80211/wlan_xauth.mod.o
      LD [M]  /home/zyon/madwifi-n/net80211/wlan_xauth.ko
    make[2]: Leaving directory `/usr/src/linux-2.6.14.3'
    make[1]: Leaving directory `/home/zyon/madwifi-n/net80211'
    make[1]: Entering directory `/home/zyon/madwifi-n/ath_rate/sample'
    make -C /usr/src/linux-2.6.14.3 SUBDIRS=/home/zyon/madwifi-n/ath_rate/sample MODVERDIR=/home/zyon/m           
    adwifi-n/ath_rate/sample/../../symbols modules
    make[2]: Entering directory `/usr/src/linux-2.6.14.3'
      CC [M]  /home/zyon/madwifi-n/ath_rate/sample/sample.o
      LD [M]  /home/zyon/madwifi-n/ath_rate/sample/ath_rate_sample.o
      Building modules, stage 2.
      MODPOST
      CC      /home/zyon/madwifi-n/ath_rate/sample/ath_rate_sample.mod.o
      LD [M]  /home/zyon/madwifi-n/ath_rate/sample/ath_rate_sample.ko
    make[2]: Leaving directory `/usr/src/linux-2.6.14.3'
    make[1]: Leaving directory `/home/zyon/madwifi-n/ath_rate/sample'
    make[1]: Entering directory `/home/zyon/madwifi-n/ath'
    make -C /usr/src/linux-2.6.14.3 SUBDIRS=/home/zyon/madwifi-n/ath MODVERDIR=/home/zyon/madwifi-n/ath           
    /../symbols modules
    make[2]: Entering directory `/usr/src/linux-2.6.14.3'
      CC [M]  /home/zyon/madwifi-n/ath/if_ath.o
      CC [M]  /home/zyon/madwifi-n/ath/if_ath_pci.o
      LD [M]  /home/zyon/madwifi-n/ath/ath_pci.o
      Building modules, stage 2.
      MODPOST
      CC      /home/zyon/madwifi-n/ath/ath_pci.mod.o
      LD [M]  /home/zyon/madwifi-n/ath/ath_pci.ko
    make[2]: Leaving directory `/usr/src/linux-2.6.14.3'
    make[1]: Leaving directory `/home/zyon/madwifi-n/ath'
    make[1]: Entering directory `/home/zyon/madwifi-n/tools'
    gcc -o athstats -g -O2 -Wall -include ../include/compat.h -I. -I../hal -I.. -I../ath  athstats.c
    athstats.c: In function 'main':
    athstats.c:346: warning: 'sigblock' is deprecated (declared at /usr/include/signal.h:181)
    athstats.c:348: warning: 'sigpause' is deprecated (declared at /usr/include/signal.h:158)
    athstats.c:349: warning: 'sigsetmask' is deprecated (declared at /usr/include/signal.h:184)
    gcc -o 80211stats -g -O2 -Wall -include ../include/compat.h -I. -I../hal -I..  80211stats.c
    gcc -o athkey -g -O2 -Wall -include ../include/compat.h -I. -I../hal -I..  athkey.c
    gcc -o athchans -g -O2 -Wall -include ../include/compat.h -I. -I../hal -I..  athchans.c
    gcc -o athctrl -g -O2 -Wall -include ../include/compat.h -I. -I../hal -I..  athctrl.c
    gcc -o athdebug -g -O2 -Wall -include ../include/compat.h -I. -I../hal -I..  athdebug.c
    gcc -o 80211debug -g -O2 -Wall -include ../include/compat.h -I. -I../hal -I..  80211debug.c
    gcc -o wlanconfig -g -O2 -Wall -include ../include/compat.h -I. -I../hal -I..  wlanconfig.c
    make[1]: Leaving directory `/home/zyon/madwifi-n/tools'
    sh scripts/find-madwifi-modules.sh /lib/modules/2.6.14.3
    
    WARNING:
    It seems that there are modules left from previous MadWifi installations.
    You should consider removing them before you continue, or else you might
    experience problems during operation. Remove old modules?
    r
    for i in ./ath_hal ./net80211 ath_rate/sample ./ath ./tools ; do \
            make -C $i install || exit 1; \
    done
    make[1]: Entering directory `/home/zyon/madwifi-n/ath_hal'
    make -C /usr/src/linux-2.6.14.3 SUBDIRS=/home/zyon/madwifi-n/ath_hal MODVERDIR=/home/zyon/madwifi-n/ath_hal/../symbols modules
    make[2]: Entering directory `/usr/src/linux-2.6.14.3'
      Building modules, stage 2.
      MODPOST
    make[2]: Leaving directory `/usr/src/linux-2.6.14.3'
    test -d //lib/modules/2.6.14.3/net || mkdir -p //lib/modules/2.6.14.3/net
    strip -S ath_hal.ko
    cp ath_hal.ko //lib/modules/2.6.14.3/net
    make[1]: Leaving directory `/home/zyon/madwifi-n/ath_hal'
    make[1]: Entering directory `/home/zyon/madwifi-n/net80211'
    make -C /usr/src/linux-2.6.14.3 SUBDIRS=/home/zyon/madwifi-n/net80211 MODVERDIR=/home/zyon/madwifi-n/net80211/../symbols modules
    make[2]: Entering directory `/usr/src/linux-2.6.14.3'
      Building modules, stage 2.
      MODPOST
    make[2]: Leaving directory `/usr/src/linux-2.6.14.3'
    test -d //lib/modules/2.6.14.3/net || mkdir -p //lib/modules/2.6.14.3/net
    for i in wlan.o wlan_wep.o wlan_tkip.o wlan_ccmp.o wlan_acl.o wlan_xauth.o wlan_scan_sta.o wlan_scan_ap.o; do \
            f=`basename $i .o`; \
            strip -S $f.ko; \
            cp $f.ko //lib/modules/2.6.14.3/net; \
    done
    make[1]: Leaving directory `/home/zyon/madwifi-n/net80211'
    make[1]: Entering directory `/home/zyon/madwifi-n/ath_rate/sample'
    make -C /usr/src/linux-2.6.14.3 SUBDIRS=/home/zyon/madwifi-n/ath_rate/sample MODVERDIR=/home/zyon/madwifi-n/ath_rate/sample/../../symbols modules
    make[2]: Entering directory `/usr/src/linux-2.6.14.3'
      Building modules, stage 2.
      MODPOST
    make[2]: Leaving directory `/usr/src/linux-2.6.14.3'
    test -d //lib/modules/2.6.14.3/net || mkdir -p //lib/modules/2.6.14.3/net
    strip -S ath_rate_sample.ko
    cp ath_rate_sample.ko //lib/modules/2.6.14.3/net
    make[1]: Leaving directory `/home/zyon/madwifi-n/ath_rate/sample'
    make[1]: Entering directory `/home/zyon/madwifi-n/ath'
    make -C /usr/src/linux-2.6.14.3 SUBDIRS=/home/zyon/madwifi-n/ath MODVERDIR=/home/zyon/madwifi-n/ath/../symbols modules
    make[2]: Entering directory `/usr/src/linux-2.6.14.3'
      Building modules, stage 2.
      MODPOST
    make[2]: Leaving directory `/usr/src/linux-2.6.14.3'
    test -d //lib/modules/2.6.14.3/net || mkdir -p //lib/modules/2.6.14.3/net
    strip -S ath_pci.ko
    cp ath_pci.ko //lib/modules/2.6.14.3/net
    make[1]: Leaving directory `/home/zyon/madwifi-n/ath'
    make[1]: Entering directory `/home/zyon/madwifi-n/tools'
    sh ../scripts/find-madwifi-tools.sh /usr/local/bin /usr/local/man
    
    WARNING:
    It seems that there are tools left from previous MadWifi installations.
    You should consider removing them before you continue, or else you might
    experience problems during operation. Remove old tools?
    r
    install -d /usr/local/bin
    for i in athstats 80211stats athkey athchans athctrl athdebug 80211debug wlanconfig; do \
            install $i /usr/local/bin/$i; \
            strip /usr/local/bin/$i; \
    done
    install -d /usr/local/man/man8
    install ./man/* /usr/local/man/man8
    echo "DESTDIR=" > ./install.log
    echo "BINDIR=/usr/local/bin" >> ./install.log
    echo "MANDIR=/usr/local/man" >> ./install.log
    make[1]: Leaving directory `/home/zyon/madwifi-n/tools'
    (export MODULEPATH=/lib/modules/2.6.14.3/net; depmod -ae)
    echo "KERNELRELEASE=2.6.14.3" > ./install.log
    echo "DESTDIR=" >> ./install.log



    Ich weiß echt nicht mehr was ich machen soll und wo ich noch nach Fehlern suchen kann. Ich würde mich sehr freuen wenn jemand von dieser großem Community eine Ahnung hätte was ich noch machen kann

    Danke

    Zy0n

    P.S. die Wireless-Tools natürlich installiert.
    Distribution: Debian SID
    Kernel: 2.6.14.3
    Geändert von Zy0n (07.12.05 um 08:42 Uhr)

  2. #2
    Flachinformatiker Avatar von MiGo
    Registriert seit
    Oct 2002
    Ort
    Heidelberg
    Beiträge
    5.270
    ifconfig?

    MiGo
    "Da steht sowas ähnliches wie" oder "das funzt net!!" ist keine Fehlermeldung!

  3. #3
    Shell-User Avatar von zyrusthc
    Registriert seit
    Jan 2004
    Ort
    http://www.thale.de
    Beiträge
    6.331
    lspci ?
    lsmod | grep modulename?

    gruss Oli
    Notebook: Lenovo Z570 CoreI7
    Workstation: Core2Quad Q6700 - ASUS P5WDG2-WS Pro - 8800GT - 4GB-DDR2/800 - 4x500GB=RAID1 - 120GB SSD - Innovatek Wakü - 27Widescreen/AcerTFT
    Server: IBM X345 + Netfinity 5000

    http://zyrusthc-linux.no-ip.org

  4. #4
    sizeof(zyon) Avatar von Zy0n
    Registriert seit
    Jun 2005
    Ort
    Göttingen
    Beiträge
    401
    Zitat Zitat von MiGo
    ifconfig?

    MiGo

    Also ich bin grade nicht zu hause kann erst um 16:30 posten, aber ich glaubedas ifconfig die anzeigt. Seid dem die WLAN karte drin ist muss ich auch jedesmal pppoeconf durchlaufen lassen mit mit meiner eth0 noch ins i-net zukommen. Aber am anfang von pppoeconf zeigt er mit eth0 und wifi0 an.

    Gruß

    Zy0n

    schuat bidee noch mal um 16:30 vorbei. Oder wenn ihr jetzt schon eine idee habt herdamit

  5. #5
    Shell-User Avatar von zyrusthc
    Registriert seit
    Jan 2004
    Ort
    http://www.thale.de
    Beiträge
    6.331
    Code:
    no wireless extensions.
    deutet darauf hin das das Kernelmodul nicht richtig oder gar nicht geladen ist!

    gruss Oli
    Notebook: Lenovo Z570 CoreI7
    Workstation: Core2Quad Q6700 - ASUS P5WDG2-WS Pro - 8800GT - 4GB-DDR2/800 - 4x500GB=RAID1 - 120GB SSD - Innovatek Wakü - 27Widescreen/AcerTFT
    Server: IBM X345 + Netfinity 5000

    http://zyrusthc-linux.no-ip.org

  6. #6
    sizeof(zyon) Avatar von Zy0n
    Registriert seit
    Jun 2005
    Ort
    Göttingen
    Beiträge
    401
    Zitat Zitat von zyrusthc
    Code:
    no wireless extensions.
    deutet darauf hin das das Kernelmodul nicht richtig oder gar nicht geladen ist!

    gruss Oli

    aber laut cat /proc/modules und dmesg

    schaut doch alles ok aus oder nicht?

  7. #7
    Registrierter Benutzer Avatar von Iluminat23
    Registriert seit
    Mar 2003
    Beiträge
    1.087
    eventuell ist die version der wireless-tools veraltet?
    wird deine karte wirklich von madwifi unterstützt?
    Code:
    lspci | grep Eth
    sind wirklich alle module geladen?
    Code:
    ls /lib/modules/`uname -r`/net/
    lsmod
    funktioniert die karte korrekt? (underer rechner anderes OS)

    mfg philipp
    Wer Rechtschreibfehler findet, darf diese behalten. Legasthenie
    Oh Herr, meine Überlegenheit wird mir langsam zur Last.
    Ruf mich zurück!
    -- Dr. Perry Cox

  8. #8
    sizeof(zyon) Avatar von Zy0n
    Registriert seit
    Jun 2005
    Ort
    Göttingen
    Beiträge
    401
    Hier nen paar infos für euch:

    ifconfig:


    Code:
     ifconfig              
    eth0      Protokoll:Ethernet  Hardware Adresse 00:0C:6E:52:4C:3A  
              inet6 Adresse: fe80::20c:6eff:fe52:4c3a/64 Gültigkeitsbereich:Verbindung
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:330 errors:0 dropped:0 overruns:0 frame:0
              TX packets:355 errors:0 dropped:0 overruns:0 carrier:0
              Kollisionen:0 Sendewarteschlangenlänge:1000 
              RX bytes:317889 (310.4 KiB)  TX bytes:95922 (93.6 KiB)
              Interrupt:16 Speicher:fbff4000-0 
                                    
    ppp0      Protokoll:Punkt-zu-Punkt Verbindung  
              inet Adresse:84.132.219.246  P-z-P:217.0.116.119  Maske:255.255.255.255
              UP PUNKTZUPUNKT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
              RX packets:316 errors:0 dropped:0 overruns:0 frame:0
              TX packets:338 errors:0 dropped:0 overruns:0 carrier:0
              Kollisionen:0 Sendewarteschlangenlänge:3 
              RX bytes:309923 (302.6 KiB)  TX bytes:85916 (83.9 KiB)


    lspci

    Code:
    0000:00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
    0000:00:01.0 PCI bridge: Intel Corporation 82865G/PE/P PCI to AGP Controller (rev 02)
    0000:00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1 (rev 02)
    0000:00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2 (rev 02)
    0000:00:1d.2 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #3 (rev 02)
    0000:00:1d.3 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #4 (rev 02)
    0000:00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
    0000:00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
    0000:00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge (rev 02)
    0000:00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller (rev 02)
    0000:00:1f.2 IDE interface: Intel Corporation 82801EB (ICH5) SATA Controller (rev 02)
    0000:00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
    0000:01:00.0 VGA compatible controller: ATI Technologies Inc R300 AD [Radeon 9500 Pro]
    0000:01:00.1 Display controller: ATI Technologies Inc R300 AD [Radeon 9500 Pro] (Secondary)
    0000:02:03.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev 80)
    0000:02:04.0 RAID bus controller: VIA Technologies, Inc. VT6410 ATA133 RAID controller (rev 06)
    0000:02:05.0 Ethernet controller: 3Com Corporation 3c940 10/100/1000Base-T [Marvell] (rev 12)
    0000:02:0a.0 Multimedia audio controller: Ensoniq 5880 AudioPCI (rev 02)
    0000:02:0d.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)
    lsmod | grep wlan
    Code:
    wlan                  171996  3 ath_pci,ath_rate_sample
    lsmod | grep ath_hal
    Code:
    ath_hal               196048  3 ath_pci,ath_rate_sample
    lsmod | grep ath_pci
    Code:
    ath_pci                85920  0 
    ath_rate_sample        11648  1 ath_pci
    ath_hal               196048  3 ath_pci,ath_rate_sample
    wlan                  171996  3 ath_pci,ath_rate_sample
    lspci | grep Eth
    Code:
    0000:02:05.0 Ethernet controller: 3Com Corporation 3c940 10/100/1000Base-T [Marvell] (rev 12)
    0000:02:0d.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)
    ****up:/# ls /lib/modules/`uname -r`/net/
    Code:
    ath_hal.ko  ath_rate_sample.ko  wlan_ccmp.ko  wlan_scan_ap.ko   wlan_tkip.ko  wlan_xauth.ko
    ath_pci.ko  wlan_acl.ko         wlan.ko       wlan_scan_sta.ko  wlan_wep.ko

    lsmod

    Code:
    Module                  Size  Used by
    ppp_deflate             4864  0 
    zlib_deflate           22552  1 ppp_deflate
    zlib_inflate           17664  1 ppp_deflate
    bsd_comp                5632  0 
    ppp_async               9472  1 
    crc_ccitt               2048  1 ppp_async
    ppp_generic            21012  7 ppp_deflate,bsd_comp,ppp_async
    slhc                    6400  1 ppp_generic
    af_packet              17416  4 
    ipv6                  226624  21 
    parport_pc             32324  0 
    parport                33480  1 parport_pc
    floppy                 56164  0 
    i2c_i801                8076  0 
    i2c_core               17664  1 i2c_i801
    usbhid                 29316  0 
    uhci_hcd               29840  0 
    usbcore               105472  3 usbhid,uhci_hcd
    snd_ens1371            18980  2 
    snd_rawmidi            20000  1 snd_ens1371
    snd_seq_device          7052  1 snd_rawmidi
    snd_ac97_codec         90876  1 snd_ens1371
    snd_pcm_oss            47648  0 
    snd_mixer_oss          16768  3 snd_pcm_oss
    snd_pcm                78468  3 snd_ens1371,snd_ac97_codec,snd_pcm_oss
    snd_timer              20868  1 snd_pcm
    snd                    44132  8 snd_ens1371,snd_rawmidi,snd_seq_device,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
    soundcore               7520  3 snd
    snd_page_alloc          8456  1 snd_pcm
    snd_ac97_bus            2048  1 snd_ac97_codec
    piix                    9348  0 [permanent]
    nls_iso8859_1           4096  1 
    nls_cp437               5760  1 
    vfat                   11008  1 
    fat                    45468  1 vfat
    nls_base                6528  4 nls_iso8859_1,nls_cp437,vfat,fat
    ath_pci                85920  0 
    ath_rate_sample        11648  1 ath_pci
    ath_hal               196048  3 ath_pci,ath_rate_sample
    wlan                  171996  3 ath_pci,ath_rate_sample
    ide_cd                 36612  0 
    cdrom                  36256  1 ide_cd
    unix                   23568  78


    So alle infos die ihr haben wolltet ich hoffe ihr könnt damit was anfangen. Ich sehe das alles in ordnung ist. Ach ja und zum Thema wireless-tools. Ich habe sie mit apt installiert.
    Code:
    ****up:/# iwconfig -v
    iwconfig  Wireless-Tools version 28
              Compatible with Wireless Extension v11 to v19.
    
    Kernel    Currently compiled with Wireless Extension v19.

    DANKE für jede Hilfe/Tipp ...usw

  9. #9
    sizeof(zyon) Avatar von Zy0n
    Registriert seit
    Jun 2005
    Ort
    Göttingen
    Beiträge
    401
    Und keine Ahnung,wa ;( ach mist auch

  10. #10
    Flachinformatiker Avatar von MiGo
    Registriert seit
    Oct 2002
    Ort
    Heidelberg
    Beiträge
    5.270
    versuch' mal die Karte mit
    ifconfig wifi0 0.0.0.0 up
    hochzubringen.
    "Da steht sowas ähnliches wie" oder "das funzt net!!" ist keine Fehlermeldung!

  11. #11
    Premium Mitglied Avatar von spychodelics
    Registriert seit
    Nov 2002
    Ort
    Offenbach
    Beiträge
    610
    Same Problem,

    Karte lässt sich mit ifconfig starten, ist da wird mit Mac-Adresse erkannt, aber iwconfig mag sie immer noch nicht.

  12. #12
    Premium Mitglied Avatar von spychodelics
    Registriert seit
    Nov 2002
    Ort
    Offenbach
    Beiträge
    610
    Habs gelöst, hab den madwifi treiber rausgeschmissen und dann mit ndiswrapper die karte zum laufen bewegt.


    http://www.linux-infopage.de/show.ph...rappercentrino


    halt nen make uninstall im madwifi,
    neugebootet dann per


    $ ndiswrapper -i ALNetG.inf

    die treiber installiert und per

    $modprobe ndiswrapper

    das modul geladen

    bin in etwa nach der anleitung oben gegangen, und funktioniert

  13. #13
    Shell-User Avatar von zyrusthc
    Registriert seit
    Jan 2004
    Ort
    http://www.thale.de
    Beiträge
    6.331
    Eventuell brauch der nativetreiber ja auch eine Firmware , nur so eine Vermutung von mir.

    gruss Oli
    Notebook: Lenovo Z570 CoreI7
    Workstation: Core2Quad Q6700 - ASUS P5WDG2-WS Pro - 8800GT - 4GB-DDR2/800 - 4x500GB=RAID1 - 120GB SSD - Innovatek Wakü - 27Widescreen/AcerTFT
    Server: IBM X345 + Netfinity 5000

    http://zyrusthc-linux.no-ip.org

  14. #14
    sizeof(zyon) Avatar von Zy0n
    Registriert seit
    Jun 2005
    Ort
    Göttingen
    Beiträge
    401
    es geht nun, ich habe einfach andere Treiber genutzt nicht ganz neue sonder die old version

    Leider geht die config nicht wirklich:

    Code:
    zyon@****up:~$ su
    Password:
    ****up:/home/zyon# cd /
    
    ****up:/# ifconfig eth0 down
    
    ****up:/# iwconfig ath0 rate 54MB
    Error for wireless request "Set Bit Rate" (8B20) :
    SET failed on device ath0 ; No such device or address.
    
    ****up:/# iwconfig ath0 txpower auto
    
    ****up:/# iwconfig ath0 channel 13
    Error for wireless request "Set Frequency" (8B04) :
    SET failed on device ath0 ; Invalid argument.
    
    ****up:/# iwconfig ath0 mode managed
    
    ****up:/# ifconfig ath0 up 192.168.2.1 netmask 255.255.255.0
    Speicherzugriffsfehler
    
    ****up:/# route add default gw 192.168.2.1
    Ich will jetzt einfach nur zu meinem Router connecten der 192.168.2.1 haben soll und den dann per Browser zu config.

    jemand eine idee?

    Und danke für die super hilfe.

    Gruß

    Zy0n

  15. #15
    Registrierter Benutzer Avatar von Zakharov
    Registriert seit
    Apr 2005
    Beiträge
    33

    Arrow

    Offenbar heißts nicht ath0, sondern evtl. wlan0, wifi0 oder eth1 - versuchs mit ifconfig und/oder iwconfig rauszufinden..

Ähnliche Themen

  1. Antworten: 3
    Letzter Beitrag: 03.12.05, 19:59
  2. SuSE kompatible WLAN pcmcia Karte
    Von Jakez im Forum stationäre Hardware
    Antworten: 3
    Letzter Beitrag: 13.01.05, 07:19
  3. Probleme mit Wlan pcmcia Karte
    Von berlina im Forum Anbindung an die Aussenwelt
    Antworten: 12
    Letzter Beitrag: 04.11.04, 17:34
  4. Feststellen ob die Wlan Karte leuft ?
    Von theborg im Forum stationäre Hardware
    Antworten: 0
    Letzter Beitrag: 01.05.04, 16:12
  5. Antworten: 5
    Letzter Beitrag: 30.10.03, 21:42

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •