Anzeige:
Ergebnis 1 bis 5 von 5

Thema: Umlaute teilweise falsch auf Netzlaufwerk

  1. #1
    Registrierter Benutzer
    Registriert seit
    Jun 2002
    Beiträge
    22

    Umlaute teilweise falsch auf Netzlaufwerk

    Hallo,

    ich habe hier ein System Kubuntu 5.04 laufen. Systemzeichensatz ist ISO 8859-15. Bei Eingabe "locale" in Konsole spuckt diese folgendes aus:

    Code:
    LANG=de_DE@euro
    LC_CTYPE="de_DE@euro"
    LC_NUMERIC="de_DE@euro"
    LC_TIME="de_DE@euro"
    LC_COLLATE="de_DE@euro"
    LC_MONETARY="de_DE@euro"
    LC_MESSAGES="de_DE@euro"
    LC_PAPER="de_DE@euro"
    LC_NAME="de_DE@euro"
    LC_ADDRESS="de_DE@euro"
    LC_TELEPHONE="de_DE@euro"
    LC_MEASUREMENT="de_DE@euro"
    LC_IDENTIFICATION="de_DE@euro"
    LC_ALL=
    Jetzt habe ich ein ein Netzwerk bestehend aus meinen Linuxrechner(oben genanten) und einem Windowsrechner XP SP2. Auf meinem Windowsrechner gibt es zwei FAT 32 Laufwerke gemountet mit:

    Code:
    /dev/hdb5  /mnt/Daten  vfat  shortname=mixed,codepage=850,uni_xlate,dev,iocharset=iso8859-15,suid,umask=000,exec  0  0
    /dev/hda5  /mnt/Sicherung  vfat  shortname=mixed,codepage=850,uni_xlate,dev,sync,iocharset=iso8859-15,suid,umask=000,exec  0  0
    Wenn ich jetzt lokal auf diese beiden Platten schaue vom Linuxrechner aus stimmen die Umlaute der Dateinamen alle. Auch wenn ich neue Dateien und Ordner erstelle stimmen die Umlaute.

    Um von dem Windowsrechner aus auf die FAT 32 Platten schauen zu können, läuft auf diesem Samba. In der smb.conf steht unter

    Code:
    [global]
    unix charset = iso8859-15
    dieser Zeichensatz eingetragen. Wenn ich jetzt von dem Windowsrechner auf die Platten FAT 32 des Linuxrechners schaue stimmen die Umlaute. Ich kann auch neue Dateien und Ordner erzeugen, auch dort stimmen die Umlaute. Was nicht funktioniert ist, vom Linuxrechner aus auf die Platten des Windowsrechners geschaut-stimmen die Umlaute nicht. Diese erscheinen dann folgendermaßen:

    K??ndigung BKK

    Auch wenn ich dort über Samba, Filesystem des Windowsrechners ist "NTFS", Dateien oder Ordner mit Umlauten erstellen will-es kommt nur Zeichensalat heraus. Ich denke es liegt an einer Einstellung des Samba Servers. Auch wenn ich über Samba Freigaben auf den eigenen Linux Rechner schaue stimmen die Umlaute nicht. Wenn ich direkt per Konqueror auf /mnt/meine gemounteten FAT 32/ schaue stimmen die Umlaute.

    Was kann ich ändern? Bitte keine Vorschläge Systemzeichensatz in UTF-8 ändern, ich nutzt als Newsreader slrn und dieser kommt mit utf-8 schlecht hin, bzw. gar nicht. Es gibt seit der Umstellung auf ISO 8859-15 auch sonst keine Proble nur diese!
    Geändert von Willly (26.06.05 um 12:51 Uhr)

  2. #2
    Premium Mitglied Avatar von Stormbringer
    Registriert seit
    Sep 2002
    Ort
    Hattingen/Ruhr
    Beiträge
    2.514
    Was passiert denn, wenn Du in der smb.con kein charset angibst?

    Gruß
    Continuum Hierarchy Supervisor:
    You have already been assimilated.
    Save our cows - eat Vegetarians!
    (Rechtschreibreformverweigerer)

  3. #3
    Registrierter Benutzer
    Registriert seit
    Jun 2002
    Beiträge
    22
    Zitat Zitat von Stormbringer
    Was passiert denn, wenn Du in der smb.con kein charset angibst?

    Gruß
    Da gehts grad andersrum nicht. Das heist es kann der Win Rechner die Dateien nicht lesen.

    Es sieht so aus dann B_roanwendungen. z.b.!

  4. #4
    Premium Mitglied Avatar von Stormbringer
    Registriert seit
    Sep 2002
    Ort
    Hattingen/Ruhr
    Beiträge
    2.514
    Und wenn Du dies angibst (Sorry, ich habe komplett auf UTF-8 umgestellt, und daher eigentlich keine Problemchen mehr damit):
    dos charset = 850
    unix charset = ISO-8859-15
    display charset = ISO-8859-15

    Gruß
    Continuum Hierarchy Supervisor:
    You have already been assimilated.
    Save our cows - eat Vegetarians!
    (Rechtschreibreformverweigerer)

  5. #5
    Registrierter Benutzer
    Registriert seit
    Jun 2002
    Beiträge
    22
    Zitat Zitat von Stormbringer
    Und wenn Du dies angibst (Sorry, ich habe komplett auf UTF-8 umgestellt, und daher eigentlich keine Problemchen mehr damit):
    dos charset = 850
    unix charset = ISO-8859-15
    display charset = ISO-8859-15

    Gruß
    Ich habe mittlerweile auch komplett wieder auf UTF-8 umgestellt und es geht ohne Probleme, ich suche mir grad nen neuen Newsreader.

Ähnliche Themen

  1. Desknote A 907 und SuSE Linux 8.2
    Von schuelsche im Forum System installieren und konfigurieren
    Antworten: 20
    Letzter Beitrag: 06.06.06, 20:47
  2. D-Link DFE-528TX
    Von Tyrsinis im Forum Router und Netzaufbau
    Antworten: 3
    Letzter Beitrag: 27.07.05, 00:42
  3. Antworten: 9
    Letzter Beitrag: 26.10.04, 17:23
  4. Antworten: 15
    Letzter Beitrag: 09.03.04, 12:45
  5. Antworten: 1
    Letzter Beitrag: 23.08.02, 12:30

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •