Anzeige:
Ergebnis 1 bis 8 von 8

Thema: NAch Update auf KDE 3.2 - error bei make von k3b 0.11.1

  1. #1
    Registrierter Benutzer Avatar von Wuppi109
    Registriert seit
    Nov 2001
    Ort
    Bad Bramstedt
    Beiträge
    1.091

    NAch Update auf KDE 3.2 - error bei make von k3b 0.11.1

    Hallo,

    Habe da ein merkwürdiges Prob nach dem update von der 3.14er auf die 3.2er bei meiner SuSE 8.1:

    Bei der 3.14er konnte ich das Progri problemlos kompilieren. jetzt nach update bricht make mit folgender Meldung ab:

    libtool: link: cannot find the library `/opt/gnome/lib/libgmodule-2.0.la'
    make[3]: *** [k3b] Fehler 1

    ...usw.

    libgmodule-2.0.la ist in der /usr/lib drin ?!! Da war die auch vor dem update??!!

    Was ist bei der KDE 3.2er da denn anders und wie kann ich das beheben?
    ein ./configure --prefix=/opt/gnome hat auich nix gebracht

    Ach ja ..update ist mit Yast-sourcen gelaufen

    Für Tipps bin ich echt dankbar..

    Gruß Wuppi
    ..sag' einfach.. wir benutzen Linux !

  2. #2
    Zaurus-Papa
    Registriert seit
    Aug 2003
    Ort
    Passau
    Beiträge
    33
    Ich würds mit nem symbolischen Link probieren...

    So etwa: ln -s /usr/lib/libgmodule-2.0.la /opt/gnome/lib/libgmodule-2.0.la

    Sollte das auch nicht klappen mal probieren ob du ein anderes Prefix einstellen solltest - /usr oder sowas. Hab nicht so die Ahnung von der SuSI
    Mandrake 9.2
    2.4.22-26mdkenterprise

  3. #3
    Registrierter Benutzer Avatar von drcux
    Registriert seit
    Oct 2003
    Beiträge
    6.947

    Re: NAch Update auf KDE 3.2 - error bei make von k3b 0.11.1

    Original geschrieben von Wuppi109

    libtool: link: cannot find the library `/opt/gnome/lib/libgmodule-2.0.la'
    ...
    libgmodule-2.0.la ist in der /usr/lib drin ?!! Da war die auch vor dem update??!!
    /usr/lib ist nicht /opt/gnome/lib


    ....

  4. #4
    theborg
    Gast
    hab das gleche problem aber werde heute mittag mahl nach einer lösung suchen

    p.s. auf der hp von k3b steht das der quelcode für 3.2 erst nach dem relayse geupt wird vileicht ist es dann behoben

  5. #5
    Registrierter Benutzer Avatar von Wuppi109
    Registriert seit
    Nov 2001
    Ort
    Bad Bramstedt
    Beiträge
    1.091
    Wieso werden da eigentlich gnome libiries benötigt ...ist doch eine oder?

    @theborg

    wie "schön" daß ich nicht der Einzige bin
    Poste mal ob Du´s und wie Du es hingekriegt hast.

    Werde das auch mal mit den Link setzen versuchen.

    Gruß Wuppi
    Geändert von Wuppi109 (05.02.04 um 11:19 Uhr)
    ..sag' einfach.. wir benutzen Linux !

  6. #6
    Registrierter Benutzer Avatar von Wuppi109
    Registriert seit
    Nov 2001
    Ort
    Bad Bramstedt
    Beiträge
    1.091
    Hallo
    ..für alle dies interessiert und für die SuFu:
    Der Tip mit den Links war "Gold wert".
    Folgende Links mußten noch gesetzt werden:

    ln -s /usr/lib/libgmodule-2.0.la /opt/gnome/lib/libgmodule-2.0.la
    ln -s /usr/lib/libgthread-2.0.la /opt/gnome/lib/libgthread-2.0.la
    ln -s /usr/lib/libglib-2.0.la /opt/gnome/lib/libglib-2.0.la

    ...dann lief make sauber durch

    und alles scheint zu laufen.

    Danke nochmal ..ich kann los brezeln.

    Gruß Wuppi
    ..sag' einfach.. wir benutzen Linux !

  7. #7
    theborg
    Gast
    jup naja gut das du das hinbkommen hast mir fehlen scheinbar einige gnome libs aber ich finde dei passenden pakete nicht rpmseek spuckt leider nichts aus

  8. #8
    Registrierter Benutzer Avatar von Wuppi109
    Registriert seit
    Nov 2001
    Ort
    Bad Bramstedt
    Beiträge
    1.091
    Hallo theborg,

    Ich habe die Gnome-libs alle von den Standard-CD's/DVD die bei der Distri Suse 8.1 bei waren. Du mußt also normalerweise nicht lange rumsuchen sondern yast2 bemühen.

    Gruß Wuppi
    ..sag' einfach.. wir benutzen Linux !

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •