Anzeige:
Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 15 von 30

Thema: DVD Rippen und Audiospur brennen

  1. #1
    Registrierter Benutzer
    Registriert seit
    Jul 2003
    Beiträge
    1.134

    DVD Rippen und Audiospur brennen

    Hallo,weiss garnicht ob das möglich ist aber gibt es ein Programm womit man von einem Musik Konzert welches auf DVD ist nur die Tonspur rausschneiden kann und als normale Audio CD Brennen kann?
    Und wenn ja,ist das überhaupt legal?
    Danke!

  2. #2
    Mod. FAQ/Howto/Emulation
    Registriert seit
    Sep 2000
    Beiträge
    17.330
    Das geht mit mplayer (siehe DVD Howto).

    Legal:

    1) Du besitzt die DVD und machst eine Sicherheitskopie oder leihst die DVD aus dem dem Bekanntenkreis, also im Rahmen der "Privatkopie".
    2) Die DVD ist nicht kopiergeschützt und du benutzt auch keine entsprechende Software zum Knacken.

    Alles andere ist damit illegal.

  3. #3
    Registrierter Benutzer
    Registriert seit
    Mar 2002
    Beiträge
    2.258
    Hallo,

    ich habe das mal mit einer Tina-Turner-DVD von mir gemacht, leider weiß ich nicht mehr so genau wie
    Soweit ich mich erinnern kann, habe ich mir bei dvd::rip im log-File die Transcode-Befehle mal genauer angeschaut und dann mit transcode herumexperimentiert. DVD gerippt und dann glaube ich mit "transcode -m" oder so...

    Sorry, aber genauer weiß ich es auch nicht mehr.

    Gruß Oli.

    PS: Warum soll das nicht legal sein, wenn Dir die DVD gehört? Ok, es würd mich aber auch nicht WIRKLICH überraschen, falls das auch schon gegen das Gesetz ist

  4. #4
    Mod. FAQ/Howto/Emulation
    Registriert seit
    Sep 2000
    Beiträge
    17.330
    Das Umgehen eines wirksamen Kopierschutzes ist illegal, und DVDs haben oft den CSS (Context Scrambling System)-Kopierschutz. Leider ist das Wort "wirksam" etwas schwammig.

  5. #5
    User
    Registriert seit
    May 2001
    Beiträge
    8.688
    Gehn wir jetzt mal davon aus die DVD wäre a) orginal, b) deine und c) nicht kopiergeschützt. Dann kannst du so vorgehen:

    transcode -i /dev/dvd -y null,ac3 -x null,wav -T TITLE,CHAPTER1-CHAPTER2 -a 0 -E 48000 -b 320 -J normalize -m audio.wav

    TITLE und CHAPTER setzt du gerade nach dem fest was du von der DVD haben willst.

  6. #6
    JPH
    Gast

    transcode findet import_wav nicht

    Hallo Hunter,

    der Tipp mit transcoder ist sehr interessant, ich habe es mal mit menkoder versucht, konnte jedoch nicht einzelne Kapitel aus der Audiospur holen.

    Die Kommandozeile habe ich weitestgehend uebernommen, nur den Dateinamen der Ausgabe, sowie die Titel und Kapitel durch Nummern uebersetzt.

    Das Ergebnis:
    <---snip--->
    [transcode] warning : /usr/local/lib/transcode/import_wav.so: cannot open shared object file: No such file or directory
    (decoder.c) loading audio import module failed
    [transcode] failed to init import modules
    [transcode] critical: plug-in initialization failed

    Daraufhin habe ich mir noch die Version "transcode-0.6.12" geholt. Vorher hatte ich "transcode-0.6.11". Verdacht: neues features
    Ergebnis: das selbe!

    Kompiliert habe ich trascode mit: ./configure --with-libmpeg3 --with-openqt

    Weisst Du, wie/wo ich dieses plugin hin/her-bekomme?

    Danke schon mal!

    Joerg

  7. #7
    User
    Registriert seit
    May 2001
    Beiträge
    8.688
    Sorry. Habe -x und -y vertauscht. -x ist der Decoder und -y der Encoder.

    Also:

    transcode -i /dev/dvd -x null,ac3 -y null,wav -T TITLE,CHAPTER1-CHAPTER2 -a 0 -E 48000 -b 320 -J normalize -m audio.wav

    Damit sollte es gehn.

  8. #8
    JPH
    Gast
    Danke, jetzt klappt es besser

    Joerg

  9. #9
    Registrierter Benutzer
    Registriert seit
    Sep 2001
    Beiträge
    91

    geht bei mir nicht

    Hi,
    bei mir funktioniert das leider nicht. transcode gibt folgende Fehlermeldung aus:
    --------------------------------------------------------------------------------------------
    [import_ac3.so] v0.3.2 (2002-02-15) (audio) AC3
    [import_null.so] v0.2.0 (2002-01-19) (video) null | (audio) null
    [filter_normalize.so] v0.1.1 (2002-06-18) Volume normalizer
    [export_wav.so] v0.2.3 (2003-01-16) (audio) WAVE PCM
    [export_null.so] v0.1.2 (2001-08-17) (video) null | (audio) null
    [import_ac3.so] A52->PCM
    [import_ac3.so] tcextract -a 0 -i "/dev/dvd" -x a52 -d 0 | tcdecode -x a52 -d 0
    No accelerated IMDCT transform found
    frame size = 0 (0 0)
    (extract_ac3.c) ac3 framesize -2 invalid
    ----------------------------------------------------------------------------------------------

    ich hab alles wie oben angegeben eingetippt.
    Vielleicht kann mier ja jemand helfen.
    Vielen Dank im vorraus
    Michael

  10. #10
    JPH
    Gast

    Bei mir aber jetzt

    Hallo,

    das gewuenschte Ergebnis hatte ich damit auch nicht erreicht, aber es war
    schon mal ein guter Ansatz zum weitermachen.
    Nach ein paar Experimenten bin ich dann auf folgende Sysntax gekommen:

    transcode -a 0 -y null,wav -u 100 -o ausgabe.wav -x null -i /dev/dvd -d -T 1,13,1

    Ich habe jetzt nur folgendes Problem:

    transcode gibt aus, dass es 358,27sec extrahiert hat. Das ca. 6min.
    Wenn ich darueber die Gesamtsumme der einzelnen Titel bilde, ergibt
    sich auch etwa die Spieldauer der DVD.

    Nehme ich jetzt die Titel in cdbakoven oder arson wird mehr als die
    doppelte Spieldauer berechnet, so dass natuerlich nicht alles auf die CD
    passt, was drauf soll.

    Wenn ich die *.wav im XMMS abspiele wird auch ein groesserer Wert
    angezeigt.

    Weiss jemand woran das liegt?

    Bis dann,

    Joerg

  11. #11
    JPH
    Gast

    hab' was vergessen

    also die PArameter hinter -T 1,13,1
    | | |
    | | +--- Sprache
    | +------ Kapitel im Titel
    +--------- Titel

    Die Werte habe ich soweit mit dvdrip ermittelt.

    CU

  12. #12
    Registrierter Benutzer
    Registriert seit
    Sep 2001
    Beiträge
    91

    immer noch nicht

    @JPH
    das tuts leider auch nicht, die erzeugten files enthalten nur Rauschen :-(
    Michael

  13. #13
    JPH
    Gast
    Hallo Michael,

    mit dem Tip vom Hunter kam ich auch nur einen kleinen Schritt weiter.
    Auschlaggebend war dann jedoch der Hinweis von Oli, viel weiter oben,
    dass er sich mit DVD::RIP den transcode-Befehl angesehen hat, und damit
    experimentierte. So bin ich dann auch vorgegangen.

    Ich vermute mal, dass das audio codec fuer den import nicht richtig ist.
    Du hast ja einen Ausschnitt aus der Ausgabe von transcode gepostet.
    Da kann man ja den verwendeten import- und export-Filter sehen.

    Hast Du die Moeglichkeit Dir die DVD mal mit DVD anzusehen?
    Die Ausgaben sind ewas strukturierter. Sieh Dir unter Audio den codec
    auf der DVD an, und dann pruefe mal ob dazu ein Filter existiert.

    Die Filter findest Du in
    /usr/local/lib/transcode/import_*.so (wenn selbst kompiliert)
    /usr/lib/transcode/import_*.so (VERMUTUNG!! wenn von Dritribution)
    oder ein simples
    find /usr -name import\*.so -print | more

    Viel Gueck!

    Joerg

  14. #14
    Registrierter Benutzer
    Registriert seit
    Sep 2001
    Beiträge
    91

    Unhappy aufgeben?

    ich glaub´, ich geb´s auf! Ich habe verschiedene Einstellungen durchprobiert, auch mplayer als Decoder verwendet (mit mplayer kann ich die DVD problemlos abspielen!), nix, immer nur Rauschen!
    Tschö
    Michael

  15. #15
    JPH
    Gast
    Hallo Michael,

    versuch doch mal mencoder.
    Damit habe ich es auch zuerst probiert. Hatte nur den Nachteil, das ich
    die audio Spur titelweise rausziehen konnte. Das bedeutet, dass das
    Ergebnis von einer 120min DVD fuer eine Audio-CD von 80min zu
    gross sein kann. Wenn man sowieso vor hat mp3 oder ogg zu verwenden
    passt es.

    Hier gibt es Hinweise zu dem mencoder
    http://www.linuxforen.de/forums/show...hreadid=100942

    und hier ganz allgemein zum Thema
    http://bunkus.org/dvdripping4linux/de/single/index.html

    Gruss, Joerg

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •