Anzeige:
Seite 10 von 11 ErsteErste ... 891011 LetzteLetzte
Ergebnis 136 bis 150 von 155

Thema: NVIDIA + 3D-Beschleunigung für Dummies

  1. #136
    Registrierter Benutzer
    Registriert seit
    Jul 2003
    Beiträge
    1.134

    re

    Hab da auch mal eine Frage, hab mir OSS 10.2 instaliert und die aktuellen Nvidia Treiber via Yast eingespielt, jetzt habe ich auf
    http://de.opensuse.org/Propriet%C3%A...lg_pr.C3.BCfen
    gelesen das bei dem Befehl:
    glxinfo | grep direct
    direct rendering: Yes stehen sollt, bei mir steht da ber
    direct rendering: No

    Was mach ich falsch bzw. wo kann ich das umstellen und was bringt es?
    Ich habe eine Geforce 4Ti4200
    Geändert von Coolzero (25.12.06 um 11:48 Uhr)

  2. #137
    - - - - - - - - - - Avatar von zander
    Registriert seit
    Mar 2001
    Beiträge
    6.144
    @Coolzero: bitte starte einen neuen thread für Dein Problem und hänge eine nvidia-bug-report.log-Datei an.

  3. #138
    LinuxWinter
    Gast
    Erst mal Hallo.

    Ich habe nachdem ich erste Erfahrungen mit Knoppix 5.2 gesammelt habe SuSE 10.0 installiert und upgedatet. GNU CC ist angeblich komplett installiert. Dabei ist mir schon aufgefallen das nicht alles was man Installiert auch im K-Menue auftaucht (Etwa Wine. Ist installiert, - finde ich aber nicht ???)

    Mein Fehler gehört vielleicht nicht unbedingt hier rein, verhindert aber auch das ich meine GeForce 2 mit 3D-Beschleunigung nutzen kann.

    Wenn ich Programmpakete geladen und entpackt habe und versuche SIe zu installieren bekomme ich dauernd nach einigen OK´s, DONE´s und DAS WAR´s folgende Zeilen präsentiert :

    ...
    checking whether debugging is enabled... yes
    checking whether building the dav module is enabled... no
    checking for gcc... no
    checking for cc... no
    checking for cc... no
    checking for cl... no
    configure: error: no acceptable C compiler found in $PATH
    See `config.log' for more details.

    Ich habe schon einige Hinweise und Beschreibungen gelesen, aber als Neuling sind die meisten Beschreibungen für mich noch immer böhmische Dörfer.

    Alle anderen Teile der "Installiere nVidia-Treiber" Prozedur habe ich schon erfolgreich hinter mich gebracht, aber was nutzt das ohne die eigentliche Installation ?

    Da der Mensch nun einmal Fehler macht, besonders wenn er sich auf neues Gebiet begibt : Wo habe ich da also Mist gebaut ?
    Geändert von LinuxWinter (30.04.07 um 09:23 Uhr)

  4. #139
    tanzender affe Avatar von MonkeyKing
    Registriert seit
    Apr 2006
    Beiträge
    65
    Hi,
    die installation der treiber will bei mir einfach nicht klappen, seitdem ich auf opensuse 10.2 upgedatet hab. Bei früheren suse versionen gings immer ohne probleme.
    Hab den kernel 2.6.18.2-34-default und suse 10.2. Hab mir den treiber runter geladen, die kernel-sources installiert (tausendmal kontrolliert obs die richtigen sind!), init 3, treiber paket ausgeführt, durch die abfragen getippt und am ende kommt die meldung:
    /lib/modules/2.6.18.2-34-default/build/include/linux/kernel.h' does not
    exist. The most likely reason for this is that the kernel include path
    '/lib/modules/2.6.18.2-34-default/build/include' is incorrect. Please
    make sure you have installed the kernel header files for your kernel; on
    Red Hat Linux systems, for example, be sure you have the 'kernel-source'
    rpm installed. If you know the correct kernel header files are
    installed, you may specify the kernel include path with the
    '--kernel-include-path' commandline option.
    Da ich mir sicher bin, dass die kernel-sourcen installiert sind, kann es doch höchstens daran liegen, dass die kernel sourcen nicht in dem standard verzeichnis liegen oder? Wie finde ich jetzt raus, wo meine kernel-header liegen?

    Hier nochmal das komplette log:

    nvidia-installer log file '/var/log/nvidia-installer.log'
    creation time: Mon Aug 13 12:57:07 2007

    option status:
    license pre-accepted : false
    update : false
    force update : false
    expert : false
    uninstall : false
    driver info : false
    no precompiled interface: false
    no ncurses color : false
    query latest driver ver : false
    OpenGL header files : false
    no questions : false
    silent : false
    XFree86 install prefix : /usr/X11R6
    OpenGL install prefix : /usr
    Installer install prefix: /usr
    kernel include path : (not specified)
    kernel install path : (not specified)
    proc mount point : /proc
    ui : (not specified)
    tmpdir : /tmp
    ftp site : ftp://download.nvidia.com

    Using: nvidia-installer ncurses user interface
    -> License accepted.
    -> No precompiled kernel interface was found to match your kernel; would you li
    ke the installer to attempt to download a kernel interface for your kernel f
    rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: Yes)
    -> No matching precompiled kernel interface was found on the NVIDIA ftp site;
    this means that the installer will need to compile a kernel interface for
    your kernel.
    ERROR: The kernel header file
    '/lib/modules/2.6.18.2-34-default/build/include/linux/kernel.h' does not
    exist. The most likely reason for this is that the kernel include path
    '/lib/modules/2.6.18.2-34-default/build/include' is incorrect. Please
    make sure you have installed the kernel header files for your kernel; on
    Red Hat Linux systems, for example, be sure you have the 'kernel-source'
    rpm installed. If you know the correct kernel header files are
    installed, you may specify the kernel include path with the
    '--kernel-include-path' commandline option.
    ERROR: Installation has failed. Please see the file
    '/var/log/nvidia-installer.log' for details. You may find suggestions
    on fixing installation problems in the README available on the Linux
    driver download page at www.nvidia.com.
    EDIT: Vergesst diesen post ganz schnell! Ich hatte den falschen nvidia treiber (64 statt 32 bit) runter geladen, worauf mich ein freund gerade aufmerksam gemacht hat. Jetzt läuft alles!
    Geändert von MonkeyKing (13.08.07 um 12:33 Uhr)

  5. #140
    PhanX
    Gast
    Okay, ich bin am Verzweifeln mit den NVidia-Treibern. Bevor ich anfange, was ich bislang versucht habe, erstmal: Ich habe Ubuntu 7.04 und den aktuellsten NVidia-Treiber heruntergeladen sowie die Kernelquellen. Das möchte ich jetzt mit einer NVidia Vanta/Vanta LT zum Laufen kriegen. Und da fängt das Problem an...

    Ich habe also alles parat, meine xorg.conf gesichert. Springe mit [Strg]+[Alt]+[F1] in die Konsole, logge mich ein und stoppe gdm.
    sudo /etc/init.d/gdm stop
    Danach installiere ich den Treiber.
    sudo sh NVIDIA-Linux-x86-1.0-7185-pkg1.run
    Das klappt auch alles 1A und ich kriege die Bestätigung: Treiber installiert. Ich ändere in der xorg.conf alles entsprechend um, dass der Treiber genutzt wird, wie hier beschrieben (dri, GLcore - auskommentieren, driver "nv" zu driver "nvidia"), tippe
    sudo /etc/init.d/gdm start
    und lande wieder im GNOME... mit einer Auflösung von 800x600. Okay, erstmal nicht so tragisch, kann es aber auch in den Einstellung nicht höherschrauben (800x600 und 640x480 stehen zur Wahl). Gut, teste ich mal mit glxgears - der meldet, das kein GLX verfügbar ist. Gleiches tut übrigens auch Blender und ich bin versucht, dieser Aussage zu glauben.

    Habe jetzt mit
    sudo sh NVIDIA-Linux-x86-1.0-7185-pkg1.run --uninstall
    und dem Wiederherstellen meiner alten xorg.conf alles rückgängig gemacht - aber somit immer noch keine 3D-Beschleunigung!

    In einem anderen Forum (Link müsste ich mir nochmal raussuchen), habe ich eine veränderte xorg.conf gefunden mit "metamodes" für die Auflösung - wenn ich das nutze, dann kann ich auch auf mein 1024x768 kommen - allerdings auch dies: Ohne GLX.

    So, und jetzt seid ihr dran... was kann ich noch tun?

  6. #141
    Registrierter Benutzer
    Registriert seit
    May 2007
    Beiträge
    47
    Mal an alle Suse User: auf der Downloadseite bei Nvidia gibt es einen Hinweis/Link der da heißt "SuSE NVIDIA Installer HOWTO". Vielleicht solltet ihr den mal lesen

    http://www.suse.de/~sndirsch/nvidia-...ler-HOWTO.html
    SELECT kaffee FROM kaffeekanne
    INSERT kaffee INTO burli

  7. #142
    PhanX
    Gast
    @burli70
    Okay, das dürfte SuSE-Usern einige Fragen beantworten... hast auch was für mein Problem?

  8. #143
    Registrierter Benutzer
    Registriert seit
    May 2007
    Beiträge
    47
    @PhanX: Ich habe vor ner Weile auch mal Ubuntu Feisty gehabt und den Treiber für eine GF7900 installiert. Ich musste da eigentlich gar nix machen. Hab nur in der Konsole sh NVIDIA-xxxxxxx.run eingegeben und den Rest dem Installer überlassen. Nach dem Neustart hatte ich weiterhin die gleiche Auflösung und zusätzlich 3d.

    Mir fallen nur zwei Punkte ein:
    1. NVIDIA Vanta kenn ich nicht. Wird der unterstützt?
    2. ich hatte bei mir den Root freigeschaltet und hab das ohne sudo gemacht
    SELECT kaffee FROM kaffeekanne
    INSERT kaffee INTO burli

  9. #144
    PhanX
    Gast
    Zitat Zitat von burli70 Beitrag anzeigen
    1. NVIDIA Vanta kenn ich nicht. Wird der unterstützt?
    Laut der NVidia-Seite: Ja, aber nur mit dem Legacy-Treiber, weil der Chipsatz der Vanta wohl älter ist. Hab aber definitiv den richtigen Treiber.
    2. ich hatte bei mir den Root freigeschaltet und hab das ohne sudo gemacht
    Hmm, das wäre natürlich noch ne Idee... wie schalte ich den Root-Account frei? Hab ich noch nie gemacht/gebraucht. Aber einen Versuch ist das allemal wert.

    //EDIT
    Hab das mit dem freischalten des Root-Accounts selber rausgefunden und auch direkt mal so getestet. Wieder nur 800x600, kein GLX.

    Hab mal glxgears laufen lassen, hilft das?
    Xlib: extension "GLX" missing on display ":0.0".
    Error: couldn't get an RGB, Double-buffered visual
    Besonders der letzte Satz scheint mir interessant... meine, entsprechende Optionen mal in xorg.conf's im Netz gesehen zu haben. Jemand ne Idee?
    Geändert von PhanX (27.08.07 um 10:18 Uhr)

  10. #145
    PhanX
    Gast
    Sorry für Doppelpost, aber:
    Ich habe mir hier einige Zeilen für meine xorg.conf "ausgeborgt". Jetzt startet Ubuntu in einer recht hohen Auflösung (tippe mal 1600x1200), schaltet nach dem Login dann aber auf 1024x768 runter. An sich okay, ist ja auch die Auflösung, die ich will.

    GLX fehlt allerdings nach wie vor, Meldung ist die gleiche wie im letzten Post angegeben. DAS scheint also das einzige zu sein, was noch irgendwie da erkannt werden muss...

    //EDIT
    Hier mal meine Xorg.0.log, vielleicht hilft das ja irgendwie...
    http://nopaste.info/04abf9b54d.html

    Zeile 494 scheint interessant zu sein: (EE) GLX is not supported with the Composite extension - was heisst das für mich nun konkret?
    Geändert von PhanX (27.08.07 um 11:43 Uhr)

  11. #146
    Pinguinzüchter Avatar von Der Papst
    Registriert seit
    Nov 2006
    Beiträge
    405
    Zitat Zitat von burli70 Beitrag anzeigen
    Mal an alle Suse User: auf der Downloadseite bei Nvidia gibt es einen Hinweis/Link der da heißt "SuSE NVIDIA Installer HOWTO". Vielleicht solltet ihr den mal lesen

    http://www.suse.de/~sndirsch/nvidia-...ler-HOWTO.html
    Ich hab auf 2 Arbeitsstationen nVidia unter openSUSE 10.2 laufen.
    Sofern die Kernelsourcen und GCC installiert sind, reicht das pseudo-grafische Menü des Treibers aus, er trägt sich zum Schluss sogar selbst in xorg ein...

  12. #147
    Registrierter Benutzer
    Registriert seit
    May 2007
    Beiträge
    47
    Zitat Zitat von Der Papst Beitrag anzeigen
    Ich hab auf 2 Arbeitsstationen nVidia unter openSUSE 10.2 laufen.
    Sofern die Kernelsourcen und GCC installiert sind, reicht das pseudo-grafische Menü des Treibers aus, er trägt sich zum Schluss sogar selbst in xorg ein...
    Mag sein, aber ich hatte den Eindruck das überdurchschnittlich viele Suse User danach fragen obwohl die Antwort schon beim Treiber Download gegeben wird.
    SELECT kaffee FROM kaffeekanne
    INSERT kaffee INTO burli

  13. #148
    Registrierter Benutzer
    Registriert seit
    Jan 2005
    Beiträge
    109
    hallo leute,

    ich hab noch n alten laptop mit einer geforce 4 400 go (mx). was mach ich denn, wenn der neueste treiber gerad mal so toll is um mit nem kernel 2.4 zu laufen??

    für kernel 2.6.xx........... gibs ja von offizieller seite auch keinen treiber. Ich kann zwar wunderbar den neuesten treiber für den ganz normalen desktop pc installieren aber der funzt ja nich bei laptops...............

  14. #149
    Registrierter Benutzer
    Registriert seit
    Oct 2002
    Ort
    Rathjensdorf
    Beiträge
    20
    Laut nvidia müsste der Legacy-Treiber 100.14.11 auch bei deiner go funktionieren. Eigentlich macht nur das Legacy-Treiber-rpm-Paket 96.43.05_2.6 aus dem nvidia-Suse Repository Probleme, aber über den Weg des Installers mit der100 Version sollte es eigentlich funktionieren.

  15. #150
    Registrierter Benutzer
    Registriert seit
    Jan 2005
    Beiträge
    109
    hallo

    hab gerade mal den http://www.nvidia.com/object/linux_d..._71.86.06.html treiber probiert.

    hat alles wie von selbst einwandfrei geklappt.

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •