PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : [B]WPA_Supplicant unter FC4 x86_64[/B]



berndg_FC4
18.04.06, 10:40
Hallo zusammen,

ich hab endlich WLAN unter FC4 x86_64 (2.6.16) zum Laufen gebracht und es kann sogar WPA.... meine Frage:

Kann ich als stinknormaler User irgendwie den WPA_Supplicant starten??

Ich habs schon mehrere Male versucht und er spuckt nur folgendes aus:

[bernd@localhost ~]$ wpa_supplicant -ieth1 -c/home/bernd/wpa_supplicant.conf
ioctl[SIOCSIWPMKSA]: Operation not permitted
ioctl[SIOCSIWMODE]: Operation not permitted
Could not configure driver to use managed mode
SIOCSIFFLAGS: Permission denied
Could not set interface 'eth1' UP
socket(PF_PACKET): Operation not permitted
ioctl[PRISM2_IOCTL_HOSTAPD]: Operation not permitted
Failed to set encryption.
ioctl[PRISM2_IOCTL_HOSTAPD]: Operation not permitted
Failed to set encryption.
ioctl[PRISM2_IOCTL_HOSTAPD]: Operation not permitted
Failed to set encryption.
ioctl[PRISM2_IOCTL_HOSTAPD]: Operation not permitted
Failed to set encryption.
ioctl[PRISM2_IOCTL_HOSTAPD]: Operation not permitted
ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Operation not permitted
ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Operation not permitted
Failed to disable WPA in the driver.
ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Operation not permitted
ioctl[PRISM2_IOCTL_PRISM2_PARAM]: Operation not permitted
ioctl[SIOCSIWAP]: Operation not permitted
SIOCSIFFLAGS: Permission denied