PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : WineX-CVS Debian - Probleme mit der Auflösung



Mr.Floppy33
12.06.04, 18:53
Hallo,

wie im Titel beschrieben benutze ich Debian (Sarge) und die CVS-Version von WineX.
Kompiliert habe ich mit --with-x --enable-opengl --enable-pthreads --disable-trace --disable-debug mittels gcc3.3.

Die Emulation der Spiele (derzeit MotoRacer 1 *g*, Diablo2, MonkeyIsland3 und Broodwar) läuft auch problemlos, ausser, dass wenn ich das Spiel verlasse, unter X eine Auflösung von 640x480 statt 1024x768 habe.
Hinzu kommt, dass unter Diablo2 800x600 auch nicht funktioniert, nur 640x480. Wenn ichs auf 800x600 stelle, ist ein Teil des Bildes ausserhalb des sichtbaren Bereichs. Dasselbe ist, wenn ich unter X mit <strg>+<alt>+<+> bzw <-> die Auflösung umstelle.

Ich muss vielleicht dazusagen, dass es sich bei dem Rechner um ein Notebook handelt(?)

Hier ist meine XF86Config4:


Section "Files"
FontPath "unix/:7100" # local font server
# if the local font server has problems, we can fall back on these
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/Speedo"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
EndSection
Section "Module"
Load "GLcore"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "speedo"
Load "type1"
Load "vbe"
EndSection
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "de"
EndSection
Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/psaux"
Option "Protocol" "PS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
Option "Resolution" "300"
EndSection

Section "InputDevice"
Identifier "Generic Mouse"
Driver "mouse"
Option "SendCoreEvents" "true"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
Option "Resolution" "300"
EndSection
Section "Device"
Identifier "Standardgrafikkarte"
Driver "i810"
VideoRam 16384
EndSection
Section "Monitor"
Identifier "Standardbildschirm"
HorizSync 28-75
VertRefresh 43-75
Option "DPMS"
EndSection
Section "Screen"
Identifier "Default Screen"
Device "Standardgrafikkarte"
Monitor "Standardbildschirm"
DefaultDepth 16
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection
Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Generic Mouse"
EndSection
Section "DRI"
Mode 0666
EndSection

Das Auskommentieren der Sektion DRI hilft auch nichts weiter, ich weiss auch gar nicht in welchen Fällen das empfohlen wird(?)

Vielen Dank fürs Lesen!