PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : erschlagt mich nicht... XRender



oUN>I<TYo
12.06.04, 09:56
Hi erstmal,
hab da ein prob mit WineX unter Suse 9.1
hatte die ganze zeit schon probleme das prog zu starten. hab die meisten probs dank suchfunktion und google selber lösen können, aber halt nicht alle. Sollte ich was im forum übersehen haben schonmal SORRY hab nix über das folgende thema gefunden....

Wenn ich Winex start mit "winex2 /windows/programme/et/et.exe (is nur ein bspl)
bekomme ich folgende fehlermeldung :
XRender could not be loaded
...
error: 21

Xrender ist aber 100% installiert!
Wäre cool wenn mir da jemand nen tip geben könnte woran es liegt!
THX
oUNITYo

Fatty
12.06.04, 12:47
Ähm, also du versuchst nicht wirklich ET mit WineX zu starten oder? :ugly:

Gib mal "glxinfo | grep render" in die Konsole ein, dann solltest du sowas ähnliches bekommen:

$ glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: GeForce FX Go5600/AGP/SSE2

Sollte bei "direct rendering" ein "No" stehen, hast du bei deinem X-Server keine 3D-Beschleunigung aktiviert...

oUN>I<TYo
12.06.04, 13:41
LOL Natürlich spiel ich ET abe wenn dan schon die TUX version ;) ;) Sollte nur als beispiel dienen da ich es noch auf der windows platte hatte.
Hab wie du beschrieben hast alles einegegeben:

glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: GeForce FX 5700/AGP/3DNOW!

daran scheint es wohl nicht zu liegen

Fals es dir/euch weiter hilft hab ich hier mal den gesammten text geposted:

winex3 /windows/c/Programme/VirtualDJ/virtualdj.exe
XRender could not be loaded
This is not necessarily a fatal error, however some
applications require XRender to be installed and
may not function or display text correctly otherwise.
Please consult the WineX Font FAQ for more details
about this problemwine: Unhandled exception, starting debugger...
using wine_path: /usr/lib/transgaming_winex3//winex/bin/wine
0806e1d8:08073160: create process 'G:\windows\C\Programme\VirtualDJ\virtualdj.exe'/0x400f7ca0 @00000000 (0<0>)
0806e1d8:08073160: create thread I @00000000
GNU gdb 6.1
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB. Type "show warranty" for details.
This GDB was configured as "i586-suse-linux".
(no debugging symbols found)...Using host libthread_db library "/lib/tls/libthread_db.so.1".
0806e1d8:08073160: loads DLL ntdll.dll @40054000 (0<0>)
0806e1d8:08073160: loads DLL kernel32.dll @40706000 (0<0>)
0806e1d8:08073160: loads DLL advapi32.dll @40902000 (0<0>)
0806e1d8:08073160: loads DLL gdi32.dll @4089a000 (0<0>)
0806e1d8:08073160: loads DLL user32.dll @4078a000 (0<0>)
0806e1d8:08073160: loads DLL x11drv.dll @409b1000 (0<0>)
0806e1d8:08073160: loads DLL rpcrt4.dll @414c7000 (0<0>)
0806e1d8:08073160: loads DLL ole32.dll @4145e000 (0<0>)
0806e1d8:08073160: exception code=80000003
[New Thread 134689120]
0xffffe415 in ?? ()
(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...trace: 18 => 0
Wine-gdb>

Hoffe das hilft euch weiter. THX schonmal für die schnellen antworten...

Greetz oUNITYo

gladiac
12.06.04, 18:39
installier mal die X packete neu...

oUN>I<TYo
13.06.04, 10:06
Na geil, es funzt!!!! Hab die xfree86-libs neu drauf gemacht jetzt klappt es. Naja was heist klappt? Das Programm was ich mit wineX ausführen will startet zwar noch nicht. aber das dürfte ich ab jetzt wohl allein in den griff bekommen. THX nochmal an gladiac und Fatty für die hilfe....

Greetz
oUNITYo