PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : WineX && Fedora Core 2 ... Möglich?



shawn|
11.06.04, 19:45
Guten Abend Gemeinde!

Also, wie viele andere plagt auch mich das Problem "WineX will nicht laufen!".

Ich weiß, das es genug Threads mit diesem Problem gibt,
doch meines bezieht sich jetzt mal ganz spezifisch auf die Distribution Fedora Core 2.

Bisherige Erfahrung:
Winex lässt sich fehlerfrei kompilieren und installieren (inclusive dem --enable-pthreads/--with-pthreads)
und ebenso installieren.

Nach dem ersten Start kommt ebenso die Fehlermeldung /home/shawn/.wine/launcher-sonstwas ist kein Verzeichnis...
Diesen Fehler konnte ich ebenso beheben.

Desweiteren habe ich auch schon prelink durch geführt und die "echo 0 > ..." Zeile eingetragen.

Denoch, sagt er mir beim Starten einer Applikation: "can't open display ... "
Naja, ich kann mich nicht mehr genau an die Fehlermeldung mehr erinnern, da ich wieder das default "Wine" drüber gezogen habe.

Meine Frage wäre nun eigentlich simpelst.

Hat jemand Erfahrung mit der Installation von WineX unter Fedora Core 2?

Hoffe auf Hilfe .. und im Voraus natürlich Danke für jede die ich bekommen kann.

-shawn

ps: Achja, wenns ein Tutorial geben sollte, das jemandem bei selbigem half, wäre das auch schonmal super!!

- Suchfunktion genutzt [Check]
- Tutorials gewälzt [Check]
- Um Hilfe gebettelt [Wird durch geführt]

Mr.Floppy33
11.06.04, 23:54
Hallo,

ich glaube irgendwo gelesen zu haben, dass dies an den glibc-Versionen zu liegen scheint und die CVS-Version (statt der 3,2?) diesen Bug bereits beheben würde...

Korrigiert mich, wenn ich falsch liege...

Alex_K
12.06.04, 14:51
http://www.fedorafaq.org/#wine

maltin
12.06.04, 18:34
vielleicht musst du auch noch exec-shield ausschalten:

echo 0 > /proc/sys/kernel/exec-shield

so hats bei mir letztendlich geklappt

edit: wurd ja schon gesagt ;)

shawn|
12.06.04, 19:21
Das tat ich bereits,
werde aber heute noch mal die CVS Version neu laden versuchen.

bin nach holarse.de vorgegangen, habe jedoch statt

"[...]co winex-3-2[...]" -> co winex-3-3, sowie -3-3-2 ausprobiert.

Musste bei beidem jedoch hinterher die Datei /DLLs/oleaut32/oaidl.p (oder so?!) vom transgaming CVS Tree neu laden und austauschen, damit der Compile funktioniert.

Welche winex Version empfiehlt ihr zur Nutzung mit FC2
und hattet ihr selbige Probleme?

Oder habt ihr ggf das /winex/tools/wineinstall <-- script mal benutzt?
ist dieses zu empfehlen? oder eher das manuelle kompilieren?

Danke denoch für die Replies!!

-shawn

maltin
13.06.04, 22:50
ich bin nach dem how-to auf linux-gamers.net vorgegangen.. da gabs die pthreads version zum downloaden. dann musst du das garnicht selbst kompilieren weil der das alles automatisch macht :)

shawn|
14.06.04, 22:49
Jau, habs eben mal durch laufen lassen..

wie zuvor, keine Fehler im kompilieren und installieren.. erst beim Ausführen gabs wieder Problem.
Diesmal diesen hier:


[shawn@Evil] ~/ $ cvswinex

FuddFeatures:
Reinsert default registry: cvswinex --reregister
Install .reg with regapi: cvswinex regapi <regfilename.reg>
Install .reg with regedit: cvswinex regedit <regfilename.reg>
Log to file: cvswinex log <normal params>
eg: cvswinex log -debugmsg=+ddraw,+err -- hl.exe -console

/usr/bin/cvswinex: line 285: 24869 Speicherzugriffsfehler /usr/lib/cvswinex/bin/wine "$@"
[shawn@Evil] ~/ $ atexit destroy of semaphore
atexit destroy of shared_memory

[shawn@Evil] ~/ $

Hab vorher extra das alte "wine" per "make uninstall" raus genommen.
Naja und Speicherzugriffsfehler und die Aussagen wirken auf mich irgendwie... verwirrend :-)
als ob da probs mit der alten wine zusammen hängen, oder ähnlich.

jemand ideen?

danke im vorraus
-shawn

Xypherspiral
14.06.04, 23:50
also bei mir keine fehler wine+winex3 (cvs) rennen flott :)
greetz nec

4x!0n
15.06.04, 10:54
also bei mir keine fehler wine+winex3 (cvs) rennen flott :)
greetz nec


hast du das ganze nach einem HOWTO gemacht ? wenn ja könntest du das mal posten ?

greetz

shawn|
15.06.04, 16:34
Wäre schön, wenn ihr mir sagt, was ihr gemacht habt und nicht sagt, das es bei euch funktioniert.

Es wird wohl an meinem System liegen, das es sich nicht korrekt installen lässt.
Aber genau deswegen hoff ich ja auf Hilfe :-)

-shawn




*hüstelt* ok, ein wenig selber probieren schadet echt ned...
Also:
das Speicherzugriffsproblem hab ich gefunden,
lag am /mnt/cdrom1 , welches ich in .cvswinex/config
deklariert habe. das habe ich raus genommen, funzt.
das libntdll.so problem, lag höchstwahrscheinlich daran, das ich versuchte die cvswinex registries auf meine wine registries zu legen (oder so ähnlich)
fazit, beides getrennt halten!

nun bin ich nur noch bei einem kleenen problem:

fixme:keyboard:X11DRV_KEYBOARD_DetectLayout Your keyboard layout was not found!
Using closest match instead (German keyboard layout without dead keys) for scancode mapping.
Please define your layout in windows/x11drv/keyboard.c and submit them
to us for inclusion into future Wine releases.
See the Wine User Guide, chapter "Keyboard" for more information.
fixme:xrender:X11DRV_XRender_Finalize Free cached glyphsets
[/i]atexit destroy of semaphore
atexit destroy of shared_memory[/i]

die letzten beiden Zeilen kommen immer, auch bei anderen angeblich.. aber schaden ja ned, solangs geht.. problem ist eher, das etwas an meiner tastatur nicht stimmt...
hab auch schon probiert andere layouts festzulegen.
Will nicht.
Gibts da irgend eine gescheite lösung? :-)

thx in advance!

-shawn